




 To get context-sensitive Help

You can jump directly to Help information about any command or dialog box by doing the following.

1. From the Help menu, choose Menu Help.

The mouse cursor changes to a question mark.

2. Select a command from a menu.

Ecco Help displays information on that command.

Or
Click the question button or press the F1 key while you are in a dialog box.

Ecco Help displays information on the options in that dialog box.



Glossary
This window lists the words and phrases that are in the glossary.

Choose any green-colored word to display its glossary entry.
While you are viewing a glossary popup box

Click once to dismiss it.
Choose any green-colored word within an entry to jump to its glossary entry.

To return to the main window:

Choose Go Back to close this window and return to the topic you were viewing in the main 
window.

To return to the main window without closing this window, click on the main window or choose it 
from the Windows Task List (press Ctrl+Esc to display this list).    This window will remain open until you 
jump to a different topic in the main window.



A Secondary Window
This is a window created by the User's Guide.

Click on any of the fields, boxes, lists, or significant parts of any picture in this window to display a
popup box that explains the purpose of the item you chose.

Click on 
 to pop up a box that lets you jump to a topic with more information about the sentence that precedes

this text.
Choose Go Back to close this window and return to your previous location.
Choose Windows and Dialogs to close this window and jump to the table of contents for the 

Windows and Dialogs section of the User's Guide.



Main Contents screen
Each icon on this screen represents a chapter of the guide.    

Click on an icon, or press the TAB key to highlight an icon, and then press the ENTER key to jump 
to a chapter of the guide.

Choose the Search button at the top of the window to find topics that concern a particular subject.

More Instructions:
User's Guide basics

Finding what you are looking for

Using the buttons at the top of the window

Moving around in a topic

Jumping out of a topic



User's Guide basics
Each portion of information in the guide is called a topic.    The topic is displayed within the User's Guide 
window.    If there is more text in the topic than will fit on one screen, a scroll bar appears and you can 
move up and down in the topic.

If the information you want is not in the topic you are viewing, you can jump to another topic using the 
buttons at the top of the window, or special pictures and text within the topic.

For more information about jumping, choose another subject in the Instruction window.



Finding what you are looking for
For people who like indexes    Use the Search button it works a lot like an index.    Type the first few 
letters of the subject you are interested in to scroll the list of subjects.    When you find a subject that 
seems correct, choose Show Topics to see a list of the topics in the guide that discuss your subject.    

If none of the topics in the list seems correct, try a different subject word.    When you find a topic that 
interests you, double-click it or highlight it and choose Go To to jump to that topic.
For people who like tables of contents    Always start from the Main Contents screen (choose the 
Contents button).    Everything in the guide is in one of the chapters displayed on this screen.    Choose a 
picture to see the table of contents for a chapter.    
The table of contents for a chapter shows every topic in that chapter.    Read the headings to see if your 
subject is in this chapter.    If it is not, choose Contents to go back to the main screen.    If you see a 
heading that looks correct, choose its folder to see what is in the section.

Any time you feel that you are in the wrong place, choose the Back button to return to the last topic that 
seemed correct, then choose a different jump from there.



Using this table of contents
Choose a closed folder (

) to expand the table under a heading.
Choose an open folder (

) to collapse the table under a heading.
Choose any green-colored title to jump to that topic.



Moving around in a topic
Use the scroll bar, the arrow keys, or the PgUp and PgDn keys to move up and down in the text 

of this topic.
Choose green text with a dotted underline to pop up a box with a glossary definition.    The box 

will remain until you click your mouse or press any key.    (To display the glossary table of contents, 
choose the icon in the upper left corner.)

Choose a Note, Tip, or Illustration button to pop up a box with more information or an example.    
The box will remain until you click your mouse or press any key.



Jumping out of a topic
Click on 

 to pop up a box that lets you jump to a topic with more information about the sentence that precedes 
this text.

Choose any green text with a solid underline to jump to a topic with more information (green text 
with a dotted underline pops up a box but doesn't jump you out of the topic you are reading).

Choose one of the buttons at the top of the window.



Using the buttons at the top of the window
Contents jumps you to the Main Contents screen.
Search displays a dialog box that works like an index to the guide.
Back jumps you back to the topic you were last reading.
History shows you a list of the topics you have displayed since you opened the User's Guide.    

Choose any topic in the list to jump back to it.
Glossary displays a list of Ecco terms.    To view a term's definition, choose the term from the list.
Instructions shows you how to move around and jump from the topic you are reading.    It also 

shows you general information about using the User's Guide.
>> (Next) and << (Previous) jump you to the next or previous topic in the Guide.



OK button    Performs the action.
Click the Go Back button at the top of this window to return to your previous location.



Add button    Performs the action.
Click the Go Back button at the top of this window to return to your previous location.



Cancel button    Cancels the dialog box without performing the action.
Click the Go Back button at the top of this window to return to your previous location.



Continue button    Performs the action and returns you to the previous dialog box.
Click the Go Back button at the top of this window to return to your previous location.



Close button    Closes the dialog box.
Click the Go Back button at the top of this window to return to your previous location.



Done button    Closes the dialog box.
Click the Go Back button at the top of this window to return to your previous location.



Reference
Commands
Windows and Dialog Boxes
Keyboard Shortcuts



Click the button below to view the Ecco Quick Tour slide show.

Click the Contents button at the top of the Quick Tour window to return to the User's Guide.



Click the button below to view the Ecco Quick Tour slide show.

Click the Contents button at the top of the Quick Tour window to return to the User's Guide.



Ecco Quick Tour

To view the Ecco Quick Tour slide show, the file SLIDES.HLP must be in your Ecco program directory.    
This file was installed on your system when you installed Ecco.    You can view the same information in 
the printed Quick Tour booklet.
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About Ecco

Ecco is a Personal Information Manager that provides all the tools you need to simplify your life an 
intuitive, easy-to-use Calendar and PhoneBook for keeping track of the appointments and people you 
deal with daily, as well as a new way to organize your information that, in many ways, will seem very 
familiar.    Ecco outlines give you an easy-to-use and powerful way to structure the tremendous variety of 
information in your day.

Ecco doesn't force someone else's idea of predefined categories on you.    Instead, Ecco gives you the 
tools to create your own personalized structure, as you need it, that best fits the way you work.

Ecco's short command menus provide full capabilities for recording and viewing information in the
three Ecco

 views: PhoneBook, Calendar, and outlining.
The advanced features of Ecco Professional extend these capabilities, allowing you to cross-

reference, collect, and associate values with items of information.    Ecco's workgroup capabilities make it 
easy for individuals to share information in a workgroup environment.



Increase Your Productivity with Ecco

Even if you have never before used a computer to manage your daily information, you'll be surprised at 
how quickly Ecco can save you time and help you work more effectively.    Ecco provides you with three 
primary tools, each displayed in a different "view," to organize your work: a phonebook, a calendar, and 
any number of named outlines.

The Calendar View
With Ecco's calendar, you'll always have an answer to the question "What do I have to do next?" All your 
scheduled appointments and events are displayed for quick reference.    A Busybar shows you at a glance
when you are busy and when you have a free time slot.    "Tickler" reminder notes and customizable 
alarms for your appointments take the pressure off your memory skills.    Recurring events such as 
monthly staff meetings, a weekly lunch, or an annual physical are automatically scheduled for you with a 
simple menu selection.    And because no one's schedule is immune to changes, Ecco makes it easy to 
rearrange your appointments by using the mouse to drag them to a new time or date.    

The Calendar view provides you with day, week, and month views for recording and viewing your 
appointments and a tickler section for recording and viewing to-do's and reminders.    

In the Calendar view you can:
Include outline notes for any appointment or to-do item, letting you create a full record of 

agendas.
Set alarms that notify you of appointments and events.    You can create multiple alarms for each 

appointment or to-do.
Create recurring appointments and to-do's automatically, at the time interval you choose.    

The PhoneBook View
Need a phone number fast? Can you remember only the person's first name and the fact that you met at 
the Dallas convention? Don't bother fumbling through a pile of business cards with notes scrawled on the 
back.    Ecco's PhoneBook gives you instant access to names, phone numbers, and personal notes for 
the people important to you.    

The PhoneBook view provides you with an entry form for entering new names and a phone list for viewing
them.    
In the PhoneBook view you can:

Display, in spreadsheet-like columns, information such as phone numbers, addresses, records, 
and phone conversations.

Keep a full record of your conversations by adding outline notes to your PhoneBook entries.
Quickly find the information you need by searching on first name, last name, and company.
Dial and log phone calls automatically.    

Outline Views
If you think back on your typical day, you'll probably realize that most of the information you deal with 
doesn't easily fall into neat categories.    Ecco's outlines are the ideal place to record your information 
using any structure you find appropriate.    Use an outline to keep lists of major and minor points.    Create 
an outline for a new business plan, for example, listing with each step the people involved and the 
deadlines for each.    Or use an outline to simply record the highlights from a recent seminar that will be 
helpful in next year's budget-planning process.    

Outline views provide you with a way to record and display, in hierarchical format, information about any 
subject.    Outlining is a basic feature available in all Ecco views (Calendar, PhoneBook, and outlines).    
Outlines aid you in thinking and planning and in putting information in context.    Finally, outlines make it 
possible to relate items to each other in a meaningful way and to place information in order of importance.

Other Ecco Features



In addition to the three Ecco views, you can use many other features to help you find, organize, and view 
the information you use every day.

You can:

Use the Ecco Shooter to move information easily between Ecco and other programs.    

Search any Ecco view or an entire Ecco file for a group of text items and place them in a separate
outline view.    

Customize the tool bar for instant access to any Ecco command.    

Format text using outline styles, character formatting, and text touch-ups. 



Using the Full Menus of Ecco Professional

The full menus of Ecco Professional provide you with additional capabilities for collecting, cross-
referencing, and manipulating your information.    These capabilities are available when you choose Show
Full Menus from the Tools Menu.    With full menus you can:

Place the same item in any number of Ecco folders at once, using the folders in the Folder 
window. You can then view those items, along with other related items, from many perspectives.    

Add additional information (such as dates or numbers) to items in a view, using columns in the 
Column pane. 

Limit and order the display of items in a view, using filters and sorting.    

Add items and their associated values to multiple folders at one time, using forms. 

Share information with others in your workgroup, using public files. 



Customer Support

Ecco provides several options to find technical and feature-related information:

The README.TXT file contains last minute information about the program that was not included 
in the printed documentation.    It is a good idea to print this file, read it, and save the copy for future 
reference.

The Ecco Quick Tour booklet provides an ideal overview of Ecco.
The online Help is available in its entirety in the Ecco User's Guide.    Online Help's extensive use 

of cross references and pop-up glossary terms provide advantages beyond the printed documentation.
Context-sensitive help is available for menus, tool bar buttons, and dialog boxes.    
When you are ready to explore the advanced features of Ecco Professional, you should read the 

Advanced Features Tutorial booklet.
If you need additional information or cannot find the answer you need in the printed or online 
documentation, please call Arabesque Customer Support at (206) 885-0559.    Telephone support is 
available Monday through Friday from 7 AM to 5 PM (Pacific Time).    An Ecco Product Specialist will be 
happy to assist you.

When you call Arabesque Customer Support, please be at your computer, if possible.    You may be asked
to provide the following information:

A list of the computer hardware you are using, including network hardware.
The exact wording of any message that you received.
A detailed description of any questions or problems and any relevant steps you have taken.



Electronic Customer Support

Arabesque has its own support forum on CompuServe.    From any command prompt in CompuServe, just
type "GO ECCO" or "GO ARABESQUE" to receive direct online support from Arabesque Customer 
Support representatives.

To sign up for CompuServe, see the CompuServe information insert included in your Ecco package.

Arabesque maintains a 24 hour BBS where you can download files, have TechNotes faxed to you at a 
designated hour, or leave questions for Arabesque Customer Support representatives.    Dial 206-881-
0905.    Communication parameters are 8-N-1, 1200 to 14,400 Baud.
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For more information, see The Calendar View Window.



For more information, see About the Calendar View.



For more information, see The PhoneBook View Window.



For more information, see About the PhoneBook View.



For more information, see The Outline View Window.



For more information, see About Outlining.



For more information, see The Shooter: Sending Information to and from Ecco.



For more information, see Finding Items.



For more information, see Tool Bar.



For more information, see Formatting Items.



For more information, see About Folders.



For more information about columns, see Columns and Values.



For more information, see Filters and Sorting.



For more information, see Forms.



For more information, see Using Ecco in Workgroups.



Setting Up an Ecco File

Click a book to expand or collapse the outline.
            Opening a File  
            The Ecco Program Window  
            Navigating in Ecco  
            Saving an Ecco File  
            Closing Files and Exiting Ecco  



Setting Up an Ecco File

Click a book to expand or collapse the outline.
            Opening a File  
            The Ecco Program Window  

The Ecco Program Window
The Ecco Program Window (with Full Menus)
The Tool Bar

            Navigating in Ecco  
            Saving an Ecco File  
            Closing Files and Exiting Ecco  



Setting Up an Ecco File

Click a book to expand or collapse the outline.
            Opening a File  
            The Ecco Program Window  
            Navigating in Ecco  

Ecco Views
Managing Multiple Windows

            Saving an Ecco File  
            Closing Files and Exiting Ecco  



The following illustration shows the command buttons as they are typically displayed on the Ecco program
window tool bar. You can also display tool bars in the view windows.    

You can customize the tool bar by dragging command buttons from the Repeat box onto the tool bar 
using the right mouse button.    The arrows to the right of the Repeat box move you forward and backward
through the commands you have chosen since you last saved your work.    



The following illustration shows the command buttons as they are typically displayed on the Ecco program
window tool bar. You can also display tool bars in the view windows.    

You can customize the tool bar by dragging command buttons from the Repeat box onto the tool bar 
using the right mouse button.    The arrows to the right of the Repeat box move you forward and backward
through the commands you have chosen since you last saved your work.    



If you choose Show Full Menus from the Tools menu, you can use the advanced features of Ecco 
Professional.    Click green text to view more information.



If you choose Show Full Menus from the Tools menu, you can use the advanced features of Ecco 
Professional.    Click green text to view more information.



Column pane    If you are using the advanced features of Ecco Professional, you can display the Column 
pane.    The Column pane is an area of each view in which you can display spreadsheet-type columns to 
enter and display values such as dates, numbers, and text.



Folder window    If you are using the advanced features of Ecco Professional, you can display the Folder 
window.    You create and organize folders in the Ecco Folder window.    You also use the Folder window to
edit existing folders, view folder types, change folder preferences, add items to folders, and remove items 
from folders.



Zoom button    Click a zoom button to instantly expand a section to its maximum size while collapsing the
adjacent section.    Click it again to restore the sections to their original state.



The main elements of the windows for the Calendar view, the PhoneBook view, and named outline views 
are identical.    The following illustrations show the key features of the Ecco Program window.    Click 
green text to view more information.



The main elements of the windows for the Calendar view, the PhoneBook view, and named outline views 
are identical.    The following illustrations show the key features of the Ecco Program window.    Click 
green text to view more information.



Menu bar    The menu bar contains the main Ecco menu names.    Choose a menu to display a drop-down
list of commands that you use to tell Ecco what to do.    The menu bar remains the same regardless of 
your Ecco view. If you are using the advanced features of Ecco Professional, the menu bar contains an 
additional menu, the Advanced menu. 



Tool bar    If you use a mouse, you can speed up your work by using command buttons located on the 
tool bar.    You can customize the tool bar so that it contains the Ecco command buttons you use most 
often.    



Repeat box    Choose the repeat box to repeat the command last chosen, or customize the tool bar by 
dragging command buttons from the repeat box onto the tool bar, using the right mouse button.    



Secondary menu    Views in Ecco have secondary menus.    These menus work just like the menus on 
the menu bar.



Margin line    Using the mouse, drag the margin line handle to change the right margin of the main 
section of the window in each view.



Status bar    The status bar displays the current date and time as well as information about the selected 
command and whether a filter has been applied to the active view. Use the Show/Hide tool bar button to 
display and hide the tool bar.



Scroll bars    Scroll bars indicate your location in a file.    Click a scroll arrow to move horizontally or 
vertically in the direction of the arrow, or drag a scroll box to move quickly through the active window of 
your file.



Maximize and minimize buttons    Click the maximize button to expand a window, or click the minimize 
button to reduce the window to an icon.



Opening a File

You can open a new file as soon as you start Ecco or at any time while you use Ecco.    You can create a 
new file from scratch, or you can base a new file on an Ecco template. If you are new to Ecco, you will 
probably want to create your first few files using a template.    Ecco files have a .ECO extension, and Ecco
templates have a .ECT extension.

An Ecco template is a file that you can use as a model to create other files of the same type.    Templates 
help you get productive quickly.    For more information about the templates provided with Ecco, read the 
file README.TXT located in your Ecco directory.    Each Ecco template includes a view titled "How to use 
this Template."

You can open an existing file at any time while running Ecco.    Ecco allows you to have multiple files open
at one time.

To create a new file
Use this procedure to create a new file from scratch.

From the File menu, choose New.

Ecco opens a new, untitled file based on the template DEFAULT.ECT.    To open a blank file without 
any template information, press the CTRL or SHIFT key while you choose New.

To create a new file based on a template
Use this procedure to create a new file using a template.

1. From the File menu, choose Open.

The File Open dialog box appears.

2. In the List Files of Type box, select the "Ecco Templates (*.ECT)" option.

In the File Name box, Ecco displays a list of all available templates.

3. In the File Name box, select a template.

4. Choose the OK button.

Ecco opens a new, untitled file based on the template you selected.

To create a new template
You can create a template based on any Ecco file.

1. Open the file on which you want to base the new template.

2. From the File menu, choose Save As.

The Save As dialog box appears.

3. In the File Name box, type a name for the template.

4. In the Save File Type As box, select the Ecco Templates (*.ECT) format.

Ecco saves the file as a template.

To open an existing file
Use this procedure to open a file you previously created.

1. From the File menu, choose Open.



2. In the File Name box, type or select the name of the file you want to open.    

3. If the file you want to open is not listed, do one or more of the following.

In the Drives box, select the disk drive to which you saved your file.
In the Directories box, select the directory to which you saved your file.

4. Select the name of the file you want to open, and then choose the OK button.

Ecco opens the file.



Ecco Views

Ecco has three main views: the Calendar view, the PhoneBook view, and any number of named outline 
views in a single file.    

To switch between Ecco views
Use this procedure to quickly move between Ecco views.

From the View menu, do one of the following:

To switch to the Calendar view, choose Calendar.    
To switch to the PhoneBook view, choose PhoneBook.
To switch to an outline view, choose Outlines, and then choose an outline view.

Note    You can also switch between views by using the Window menu or the tool bar. 



Managing Multiple Windows

Each Ecco view has its own window.    With Ecco, it is possible to have multiple windows open at one 
time, but only one window can be active at a time.    The active view is the window in which you designate 
where the next action will occur.    Commands you choose affect and information you enter goes into the 
active window.    The active view's title bar is highlighted.    

If more than one view window is visible within the Ecco program window, it is easy to identify the active 
one it is the window that has the title bar with a different color.    To make a window active you can:

Click anywhere in the window (if a portion of the window is visible).
Choose the window from the View menu or the Window menu.
Double-click a minimized icon.

When you use Ecco, you will generally have many windows open at one time.    The following procedures 
describe how you move, resize, minimize, maximize, cascade, and tile windows.

To move a window
You can move a view window to any location within the main Ecco window.    This procedure will not work 
if the view window is maximized to fill the entire Ecco program window.

1. Drag the title bar of the window to a new location.

2. Release the mouse button when the outline is at the desired location.

To resize a window
You can change the size or shape of any window by using the mouse.

1. Position the pointer over a border of the window.

The pointer changes to a double-headed arrow.

2. Drag the border until the window is the desired size, and then release the mouse button.

To maximize or minimize a window
You can maximize a view window to fill the entire Ecco program window, or you can minimize it to an icon.

1. Select the window you want to maximize or minimize.

2. Click one of the following buttons in the upper right corner of the window:

To maximize the window, click the maximize button.
To minimize the window, click the minimize button.
To tile or cascade a window

Use this procedure to make all your open windows visible.

From the Window menu, do one of the following:

To arrange your windows in an overlapping fashion, choose Cascade.
To arrange your windows side by side, like tiles, choose Tile.



Saving an Ecco File

An Ecco file can contain calendar, phonebook, and outline information.    Many "integrated" products 
combine several software tools into one program but save information in separate files.    Ecco lets you 
save all related information in one completely integrated file.    When you choose Save from the File 
menu, you save all changes you have made in any view in the active file.

Ecco lets you specify save options in the Ecco Preferences dialog box.    You can save a backup copy of 
your file.    You can have Ecco save your work automatically at regular intervals or when you close your 
file.    You can also specify how many rotating backup copies of your file you want Ecco to save.

To set save options
1. From the Tools menu, choose Preferences.

The Ecco Preferences dialog box appears.

2. Under Save Options, select one or more of the following:

To create one or more backup copies of your file, select the "Always create backup copy" option.
To save more than one backup copy, in the box next to "Number of rotating backups," type the 

number of backup copies you want Ecco to save.
Each time you exit, Ecco creates a new backup copy (with the extension .BK1, .BK2, and so 

forth), up to the number specified.    Once it reaches the specified number of backup copies, Ecco starts 
the sequence over again.

To save your file automatically at a regular interval, select the "Autosave every" option, and then 
select a time interval from the list.

To save automatically on closing without a prompt, select the "Autosave on file close" option.
3. Choose the OK button.

To save an Ecco file
You can save a new, unnamed file or an existing file.

1. From the File menu, choose Save.

When you save an existing (previously saved) file, Ecco saves the file to the same drive and directory
and with the same name.    If you are saving a new, unnamed file, Ecco displays the Save As dialog 
box.

2. In the File Name box, type a name for your file.

3. If you want to save the file to a different drive, in the Drives box, select a new drive.

4. If you want to save the file to a different directory, in the Directories box, select a directory.

5. Choose the OK button.



Closing Files and Exiting Ecco

When you are finished working with an Ecco file you have two options: You can quit Ecco, or you can 
close the file you are working on without quitting Ecco.

To close the active file
Use this procedure to close the active file without leaving Ecco.

From the File menu, choose Close File.

If you have not saved changes, Ecco asks whether you want to save them.

To exit Ecco
Use this procedure to close all open files and quit Ecco.

From the File menu, choose Exit.

If you have not saved changes, Ecco asks whether you want to save them.



Note    You can save any Ecco file as a template with the name DEFAULT.ECT.    This file will then be the 
basis for any new file.    DEFAULT.ECT is located in your Ecco directory.



For more information, see Using the Tool Bar.



For more information, see The Ecco Program Window.



For more information, see Adding Buttons to the Tool Bar on the Fly.



For more information, see The Ecco Program Window.



Note    Alternatively, from the Control menu, choose Move, and then use the arrow keys to move the 
window to the desired location.



Note    Alternatively, if the window you want to resize is not maximized, you can position the cursor over 
the gray box that forms the lower right corner of the window, and then drag until the window is the desired
size.



Note    If you have multiple Ecco files open and you want to close them all, from the Window menu, 
choose Close All.



For more information, see The Tool Bar.



For more information about the Ecco tool bar, see Tool Bar Features.
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The Date Settings dialog box is a compact tool for setting appointment dates and times.    You can also 
use it to add tickler items to the Tickler section, set alarms, schedule recurring events, and change the 
color of the Busybar block.

To display the Date Settings dialog box when the Calendar view is active, click an existing appointment 
time.    Or, select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.    

If you are using the advanced features of Ecco Professional, you can display the Date Settings dialog box
by clicking in any column cell that accepts date values.    Simply select the down arrow in the value edit 
box.     Click an area of the dialog box to view more information.

When you open the Date Settings dialog box, the appointment date is shown in black and the current date
is shown in blue.    If the appointment date is today's date, then it is shown in red.    

Note    If you display the Date Settings dialog box with an item not associated with a time (for example, in 
the Tickler section), the Hours, Minutes, A, P, and Help buttons do not appear.    Instead, Ecco displays a 
Time button that you can choose if you want to associate a time with the item.



The Date Settings dialog box is a compact tool for setting appointment dates and times.    You can also 
use it to add tickler items to the Tickler section, set alarms, schedule recurring events, and change the 
color of the Busybar block.

To display the Date Settings dialog box when the Calendar view is active, click an existing appointment 
time.    Or, select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.    

If you are using the advanced features of Ecco Professional, you can display the Date Settings dialog box
by clicking in any column cell that accepts date values.    Simply select the down arrow in the value edit 
box.     Click an area of the dialog box to view more information.

When you open the Date Settings dialog box, the appointment date is shown in black and the current date
is shown in blue.    If the appointment date is today's date, then it is shown in red.    

Note    If you display the Date Settings dialog box with an item not associated with a time (for example, in 
the Tickler section), the Hours, Minutes, A, P, and Help buttons do not appear.    Instead, Ecco displays a 
Time button that you can choose if you want to associate a time with the item.



OK    Enters any options selected and closes the dialog box.



Cancel    Cancels any changes made and closes the dialog box.



Tickler    Sets tickler item options, such as beginning and ending dates.



Alarms    Creates new custom alarms and edits existing ones.



Recur    Makes the selected item recur at the time interval you specify.



Color    Changes the color of the Busybar block for the selected appointment.



Date grid    Changes the date for the selected appointment.



Mini-Navigator    Moves the date grid forward or backward by month or year.



Hours and minutes buttons    Change the beginning or end time of the selected appointment.



A or P button    Toggles the selected appointment between AM and PM.



Help button    Displays help information about the Date Settings dialog box.



Group button    Allows you to schedule group appointments.    Group scheduling is available in the 
workgroup version of Ecco (Ecco for Workgroups).



The Calendar view window appears inside the Ecco program window.    To switch to the Calendar view, 
choose Calendar from the View menu.     Click green text to view more information.



The Calendar view window appears inside the Ecco program window.    To switch to the Calendar view, 
choose Calendar from the View menu.     Click green text to view more information.



Appointment section    Create and modify your appointments here.    You can also add information in 
outline form for each appointment (item) you schedule.    



Tickler section    Displays reminders that "tickle" your memory about things you need to do or upcoming 
appointments you need to prepare for.    



Navigator    Lets you travel backward and forward through your calendar.    Ecco immediately displays the
appointments and tickler items for the dates you specify.    



Status column    Shows you at a glance the items with associated alarms and items that are recurring 
events.



Busybar    Displays your scheduled appointments in timeline form.    The block in the Busybar that shows 
the time and length of each scheduled appointment is called the Busybar block.



Show/Hide Columns button    If you are using a template that contains default columns, displays or 
hides the columns from view.

If you are using the advanced features of Ecco Professional, the Show/Hide Column button is replaced by
the Column menu.    



Calendar/PhoneBook button    Displays the Calendar and PhoneBook views side by side.    You can 
drag names from the PhoneBook view to the Calendar view to schedule an appointment in the 
Appointment section. 



Introduction to the Calendar View

You can use the Calendar view to record appointments on your computer just as you use a paper 
organizer or other paper calendar.    

Once you've recorded your appointments, Ecco gives you a number of ways to save yourself time and 
keep your schedule on track ways that a paper calendar doesn't provide.

View your schedule a day, a week, or a month at a time for any day, month, or year, using the 
Navigator. 

Create recurring appointments and events automatically, at the time interval you choose.    

Set alarms that notify you of appointments and events.    

Remind yourself of to-do's and upcoming appointments with a list of tickler items. 

Move appointments to any or several different dates and times.    

Schedule an appointment by dragging a name from your PhoneBook to the Calendar view.    

Store important information about your appointments with outline notes. 

You can set appointment dates and times, add tickler items to the Tickler section, set alarms, and so on, 
by using the Date Settings dialog box. 



Introduction to Appointments

Ecco makes it easy to manage your appointments.    You can use the Calendar view to:

Schedule a new appointment.    

Change the time, date, or duration of an appointment.    

Delete an appointment.    

Add outline notes to an appointment description.    



Scheduling New Appointments

You can schedule an appointment in the Calendar view by selecting a time slot and typing an 
appointment description.    

You can also schedule an appointment by dragging a name from the PhoneBook view to a time slot in the
Calendar view.

By default, new appointments are scheduled on the hour, for a default duration of one hour.    You can 
change the starting time and duration of an appointment by dragging the Busybar block or using the Date 
Settings dialog box. 

To schedule an appointment
You can schedule any appointment with the Ecco Calendar view.    

1. Use the Navigator to switch to the appointment's date.

If necessary, click the Day button to view appointments by day.

2. In the Appointment section (the bottom half of the Calendar view window), click to the right of the 
number describing the hour on which you want to schedule the appointment.    If necessary, use the 
Appointment section's scroll bar to scroll to the time you want.

Or
From the Calendar menu, choose Add Appt.    Item.

3. Type a description for the appointment.

The appointment is scheduled, and a Busybar block for the appointment appears in the Busybar.    If 
the appointment conflicts with another appointment, a red-and-white stripe pattern in the Busybar 
block indicates the overlapping appointments.

You can create a multilevel outline as part of an appointment's description.    



Scheduling Appointments Using the PhoneBook

You can use the PhoneBook view and the Calendar view side by side to schedule an appointment with 
anyone in your PhoneBook.

To schedule an appointment using the PhoneBook
You can schedule an    with anyone listed in your PhoneBook by dragging the person's name into the 
Calendar view.

1. Choose the Calendar/PhoneBook button located to the right of the Navigator.

Or
From the Calendar menu, choose Use with PhoneBook.    

Ecco displays the Calendar and PhoneBook views side by side.

2. Click on the PhoneBook view to make it the active view.

3. In the PhoneBook list, point to the blue item bullet next to the name you want, and hold down the 
mouse button.

The pointer changes to a four-headed arrow.

4. Drag the name to the time slot you want.

The appointment is scheduled in the Calendar view, and a Busybar block for the appointment appears
in the Busybar.    If the appointment conflicts with another appointment, a red-and-white stripe pattern 
in the Busybar block indicates the time overlap.

You can create a multilevel outline as part of an appointment's description.    

Ecco also creates a sub-item for the appointment in the PhoneBook view.    If you have an Appointments 
column in the PhoneBook view, Ecco displays the appointment date there.

Note    You can also drag an item from any outline view into the Calendar view.    For example, you could 
drag an item from a Task List outline to your calendar to schedule it as an appointment.



Scheduling Multi-Day Appointments

You can schedule an appointment or event that spans more than one day, using the Calendar view.    For 
example, you could schedule a three-day seminar or a two-week vacation.

To schedule a multi-day appointment
You use the Add Multi-Day Appointment dialog box to schedule beginning and end dates for your 
appointment or event.

1. From the Calendar menu, choose Add Multi-Day Appt.

Ecco displays the Add Multi-Day Appointment dialog box.

2. In the Beginning text box, select the date on which the appointment or event will begin.

3. In the Ending text box, select the date on which the appointment or event will end.

4. Choose the OK button.

Multiday appointments appear in the Tickler section and at the top of the Busybar in solid red.



Changing an Appointment Time

You can change the scheduled time or date of an appointment by:

Dragging the Busybar block to another time or date.
Dragging the appointment to another time or date.
Selecting the item, opening the Date Settings dialog box, and then selecting another time, 

duration, or date.
To change an appointment's description, select the description and edit the text.

To move an appointment to another time or date
You can drag appointments to any other time or date that appears in the Appointment section of the 
Calendar, using either the Busybar block or the item bullet. For example, if you are displaying all the 
appointments for a week, you can drag an appointment to any day in that week.    You can drag the 
Busybar when the day or week view is displayed.

1. Point to the middle portion of the Busybar block and hold down the mouse button.

Or
Point to the item bullet (to the left of the appointment text) and hold down the mouse button.

The pointer changes to a four-headed arrow.    If you're dragging the Busybar block, a box displays 
the appointment time as you drag.

2. Drag the appointment to a new time or date.

If you move the appointment in the Busybar or the Appointment section, Ecco indicates any conflicts 
with a red-and-white stripe pattern in the Busybar block.

You can use the Date Settings dialog box to change an appointment's date to a date not currently 
displayed in the Calendar.    In the dialog box, click a different day in the date grid, or use the Mini-
Navigator to select a date.    (The Mini-Navigator is similar to the Navigator displayed at the top of the 
Calendar view window.)

Change the appointment time, if necessary, using the Hours and Minutes buttons at the bottom of the 
dialog box.



Changing an Appointment's Duration

You can change the beginning time or duration of an appointment with the Busybar block. When you 
select an appointment, arrows appear at the top and bottom of the Busybar block.    You can drag the 
upper arrow to change the beginning time or drag the lower arrow to change the appointment's duration.

To change an appointment's description, select the description and edit the text.

To change an appointment's beginning time or duration
You can use the Busybar block to change the duration of any appointment in the Calendar day or week 
view.

1. Select the Busybar block for the appointment whose duration you want to change.

Ecco displays an arrow at either end of the bar.

2. Select either arrow and, holding down the left mouse button, drag the arrow to the appropriate 
beginning or ending time.

Ecco displays the new appointment time in 15 minute increments as you drag.

3. Release the mouse button when the appropriate time is displayed.

To change the color of the Busybar block for the appointment, click the Color button at the right side of the
Date Settings dialog box, and then select a new color.



Deleting Appointments

Ecco preserves appointments indefinitely unless you delete them.    You can delete an appointment from 
just the Appointment section or delete all occurrences of the item (for example, if an appointment appears
in the Tickler section or if you have dragged a name from the PhoneBook view to the Calendar view).

To delete an appointment
You can delete appointments to remove them from Ecco.

1. Select the appointment you want to delete.

2. From the Edit menu, choose Delete Items.

If the appointment appears only in the Appointment section, it is removed from the Calendar.    If the 
appointment appears in other Ecco views, the Delete Items dialog box appears.    

3. If the Delete Items dialog box appears, take one of the following actions:

To delete the appointment only from the Calendar Appointment section, select the "From 
Calendar and Date Folder" option.

To delete the appointment entirely, select the "Delete entirely from file (all Views)" option.
4. Choose the OK button.



Adding Outline Notes to an Appointment

For some appointments, a description of just a few words might be adequate.    For others, you might 
want to include additional background information, directions to a location, or a list of points to be 
discussed at a meeting.    With Ecco, you can include a detailed outline as part of the description of any 
appointment.

Note    You can create outline notes in any Ecco view.    This section introduces you to some of the basic 
Ecco outlining functions.    

To add an outline to an appointment
You can add an outline to an existing or newly created appointment.

1. Select the appointment.

2. Press the ENTER key.

Or
From the Calendar menu, choose Add Outline Note.

Ecco inserts a sub-item below the appointment description.

3. Type any additional descriptive information in the sub-item.

Each time you press ENTER, another sub-item is added at the same heading level.

4. To promote or demote an item in the outline, drag the item bullet, located at the left of the item, to the 
desired location in the outline.

Or
Select the item, and then press the TAB key or SHIFT+TAB.

5. You can expand or collapse the outline by double-clicking the item bullet to the left of an item.



Introduction to Viewing Your Schedule

Every day, as you add and change appointments and check your schedule, you will need to look at 
various Calendar view dates and appointments.    You can view dates and appointments in any of three 
main ways.

You can move through the calendar a month, day, or year at a time using the Navigator on the 
Calendar view tool bar.    

You can view all the time slots for a particular day or all the dates and appointments for a 
particular week or month using the Day, Week, and Month buttons.    

You can quickly move to today's date by choosing the Go to Today button.    



Using the Navigator to Move to a Date

The Navigator shows your location and offers a convenient set of tools that move you quickly to any day, 
month, or year of your choosing.

The Date buttons display the date of the active Calendar view.
Click the text of the Date buttons to display lists of months, days, and years from which you can 

choose.
Click the arrow buttons to move forward and backward by month, day, or year.    These buttons 

will either move you directly to a different date or will display a set of days, months, or years from which to
choose.    



Displaying Your Schedule by Day, Week, or Month

With simple clicks of the Day, Week, and Month buttons (at the far left of the Navigator) you can display 
daily, weekly, and monthly views of your schedule.    The day, week, or month Ecco displays reflects the 
date displayed on the Navigator.

The Day button displays your appointments for the selected day.

The Week button displays your appointments for the selected week.

The Month button displays your appointments for the selected month.

Tip    Use these shortcuts when you display your appointments by week or by month.

Display or collapse the appointments for a day by double-clicking the folder icon to the left of the 
day.

Jump to a particular day by clicking that day in the Busybar.
Display only the appointments for a particular day by double-clicking the name of the day (for 

example, "Monday").



Introduction to Ticklers

For many businesspeople, a simple list of calendar appointments isn't enough of a memory aid.    You 
might also want to create a list of tasks to do each day.    Or you might want to keep track of upcoming 
events so you can prepare for them.    With Ecco, you can display to-do's and reminders of upcoming 
appointments or events in the Tickler section of the Calendar view.    These tickler items help you organize
tasks that aren't scheduled for a specific time but still need your attention.

The Tickler section shows all the tickler items and appointments related to the day, week, or month 
displayed in the Calendar view.

You can create and view two types of tickler items in the Tickler section:

Tickler items (to-do's)    Type reminders directly into the Tickler section.    For example, put 
shopping reminders or a list of phone calls onto your daily to-do list without assigning a specific time to 
them.    

Tickler appointments (to-comes)    Put a scheduled appointment into the Tickler section to 
display a reminder for several days in advance (you set the number of days).    For example, you could 
remind yourself to prepare a status report several days before the meeting at which you're scheduled to 
present it.    Because you can display a tickler item over several days or weeks, the Tickler section can 
serve as a catch-all for reminders of upcoming tasks.    You can even continue to display an appointment 
in the Tickler section after it is over, to remind you to follow up on it.    

Tip    If you have a large number of tickler items or appointments, you might want to adjust the size of the 
Tickler section so that you can view them more easily.    To resize the Tickler section, point to the bar that 
separates the Tickler section from the Appointment section, and drag it up or down.    You might also want 
to expand or collapse the folders that contain tickler items.    You can do so by double-clicking the folder 
icons.



Creating a To-Do List

You can create lists of tasks to do on any day by entering them in the Tickler section. When you add a 
task, you have the option of displaying it in the Tickler section over several days.

You can organize your to-do list by adding tickler items to different locations or folders.    For example, you
can add a tickler item to a Start Date or To-Do's folder.    Each item you add to a folder appears under that 
folder name in the Tickler section.

If you are using the advanced features of Ecco Professional, you can add Ticker items to any folder 
displayed in the Folder window.    The items then appear in any view in which the folder is displayed.    

To add a to-do item to the Tickler section
You can add a tickler item for any day.    Before you begin the following procedure, use the Navigator to 
switch to the Calendar view of the day you want to display the tickler item.

1. From the Calendar menu, choose Add Tickler Item.

Ecco displays the Add Tickler Item dialog box.    The default settings add the item to the date selected 
in the Navigator and to the To-Do's folder.    

2. If you want, select the number of days you want the item to appear in the Tickler section before and 
after the current date.

Selecting the "Until marked Done" option in the Ending box will keep the item in the Tickler until you 
choose Mark as Done from the Item menu.    If you have a Done column in any view, you can also 
click on any cell in the column to mark an item as done.

If you are using the advanced features of Ecco Professional, you can add tickler items to the Done 
folder to mark them as done.    

3. If you want, select a folder in which to include the tickler item.    

4. Choose the OK button.

A new item appears in the Tickler section.

5. Type the text of the tickler item.

The tickler item appears in the Tickler section for each day in the range of days you specified.



Creating Advance Reminders for Your Appointments

Suppose you have an important meeting or presentation coming up.    It's not enough to have the event 
itself on your schedule; you might need reminders for a few days in advance so you can prepare for the 
event.    Tickler appointments give you advance warning as many days ahead of time as you need.

To add an appointment to the Tickler section
When you create an appointment, you can add it to the Tickler section.    You can also add an existing 
appointment to the Tickler section.

1. Select the appointment you want to add to the Tickler section.

2. Click the time to the left of the appointment to display the Date Settings dialog box.

Or
Select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.

3. Click the Tickler button (at the right side of the Date Settings dialog box).

Ecco displays the Item's Calendar Tickler Options dialog box.

4. Select the "Show in Tickler Section" option.

5. If you want, select the number of days before and after the current date that you want the item to 
appear in the Tickler section.

Selecting the "Until marked Done" option in the Ending box will keep the item in the Tickler until you 
mark it as done.    

From the Item menu, choose Mark as Done to remove an item from the Tickler section.
If you have a Done column in the Calendar view, click the column cell on the same line as the 

item to mark it as done.    It is then removed from the Tickler section.
If you are using the advanced features of Ecco Professional, you can also mark an item as done by 
adding it to the Done folder in the Folder window.    

6. When your changes are complete, choose OK, and then choose the OK button in the Date Settings 
dialog box.

The appointment appears in the Tickler section for each day in the range of days you specified.



Changing a Tickler Item

You can change the date settings for any tickler item in the Tickler section.

For example, suppose you add an appointment to the Tickler section and realize later that the 
appointment date should be changed.    You can open the Date Settings dialog box from the Tickler 
section and change the appointment without navigating to the appointment's actual date.

To change a tickler item
You use the Date Settings dialog box to change a tickler item's settings.

1. Click the date to the left of an existing tickler item to display the Date Settings dialog box.

Or
Select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.

When you select an item that does not have a time associated with it and display the Date Settings 
dialog box, a Time button appears in the lower right corner of the dialog box.    If you choose this 
button, Ecco displays the Group, Help, Hours, and Minutes boxes.    

2. Make any changes to the tickler item's date settings.

You can click the Tickler button to change the range of dates for the tickler item, or you can use the 
Date Settings dialog box to change any other date settings.

3. When your changes are complete, choose the OK button.



Removing an Item from the Tickler Section

You can leave tickler items in the Tickler section and let them disappear from view naturally after you 
move past the range of dates you specified for them.    However, if you decide you don't want an item to 
be in the Tickler section any more, you can remove it from the Tickler section only or from the entire 
calendar.    

If you are using the advanced features of Ecco Professional and you have added a tickler item to other 
views or folders, you can choose to delete it from them also.

To remove an item from the Tickler section only
You use the Date Settings dialog box to remove tickler items from the Tickler section only.

1. Click the date to the left of an existing tickler item to display the Date Settings dialog box.

Or
Select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.

2. Choose the Tickler button.

The Item's Calendar Tickler Options dialog box appears.

3. Select the "Don't Show" option.

4. Choose the OK button, and then choose the OK button in the Date Settings dialog box.

To remove a tickler item from the calendar or from all Ecco folders and 
views
If you are using the advanced features of Ecco Professional, you can add tickler items to other folders.    
You can also remove tickler items when you no longer need them.

1. Select the tickler item.

2. From the Edit menu, choose Delete Items.

If the tickler item has been added to another Ecco view, Ecco asks whether you want to delete the 
item from the Calendar and Date folder only or from the entire file (all views).



Introduction to Alarms

In Ecco, you can set simple alarms that go off once or multiple alarms that go off minutes, hours, days, 
and even weeks before or after an event. Alarms before an event might remind you to start preparing 
early for an important presentation or to buy your sister a birthday gift.    Alarms after an event might 
remind you to finish a follow-up report or mark an item as Done.

An alarm can display a message, generate a sound, or launch a document, an application, or a batch file. 
For example, you could set an alarm to launch your presentation program every morning for a week 
before the presentation is due.    You decide which messages Ecco will display, what sounds it will make, 
what document or application it will launch, and how often the alarm will occur.

Alarms will go off at the times set.

If Ecco is currently running, Ecco displays the alarm message, generates a sound, or launches 
the application.    

If an alarm occurs while Ecco is not running, the Alarms Occurred dialog appears when you 
restart Ecco.    You can set additional alarms for any of the events listed.    The alarms will occur at the 
selected time interval from the current time.    



Setting Simple Alarms

When setting simple alarms in Ecco, you have two options.    

You can set a simple alarm that is not associated with any item and that displays a message of 
your choice.    For example, if you need to remind yourself to pick up your dry cleaning on the way home 
from the office, you can set an alarm and type a reminder message for that specific task.

You can set a simple alarm that displays a message with the text of any item, from any view, 
including appointments and tickler items.    

To set a simple alarm that is not associated with an item
You use the Create an Alarm dialog box to set a simple alarm without associating it with any item.    (This 
method is not available in the Calendar view.)

1. From the Tools menu, choose Alarms, and then choose Create New Alarm.

The Create An Alarm Dialog Box appears.    

2. If the "Attach alarm to selected Item" checkbox is selected, cancel the selection.

3. In the Alarm Text box, type a message.

4. In the Date box, select a date.

5. Next to Time, choose the buttons to select a time.

6. Choose the OK button.

When the alarm occurs, Ecco displays a dialog box with the text you specified.

To set a simple alarm for an appointment or tickler item
You use the Date Settings dialog box to set a simple alarm associated with any appointment or tickler 
item, displaying the text of the item.

1. Click the date or time to the left of an existing appointment or tickler item to display the Date Settings 
dialog box.

Or
Select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.

2. Choose the Alarms button in the Date Settings dialog box, and then choose Simple Alarm.

When the alarm occurs, Ecco displays a dialog box with the text you specified.

To set a simple alarm for any item
You use the Create an Alarm dialog box to set a simple alarm associated with any item in the PhoneBook 
or any outline view.    (This method is not available in the Calendar view.)

1. Select the item for which you want to set the alarm.

2. From the Tools menu, choose Alarms, and then choose Create New Alarm.

The Create an Alarm dialog box appears.

3. In the Date box, select a date.

4. Next to Time, choose the buttons to select a time.

5. Select the "Attach alarm to selected Item" option.

Ecco displays the text of the selected item in the Text box.

6. Choose the OK button.

When the alarm occurs, Ecco displays a dialog box with the text you specified.





Setting Custom Alarms in the Calendar View

In addition to setting simple alarms, you can set custom alarms that go off multiple times, minutes, hours, 
days, and weeks before or after an event.    You can also name any custom alarm you create, add it to the
Alarms menu, and use it again to signal another item.    

When setting custom alarms in Ecco you have two options.    

You can set custom alarms for an appointment or tickler item in the Calendar view.
You can set custom alarms for any item in any view. 

To set a custom alarm for an appointment or tickler item
You can set custom alarms for appointment or tickler items from the Date Settings dialog box.

1. Click the time or date to the left of an existing appointment or tickler item to display the Date Settings 
dialog box.

Or
Select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.

2. Choose the Alarms button in the Date Settings dialog box, and then choose Custom.

The Alarms dialog box appears.

3. Take one or more of the following actions:

If you want the alarm to go off at the time of the event, select the "Invoke Alarm at time of 
appointment" option.

If you want, choose additional alarms before and after the event by clicking or dragging in the 
drop-down number menu.    Selecting multiple numbers will cause alarms to occur at multiple times before
or after the event.    You can select any number of minutes, hours, days, or weeks (up to six weeks) before
or after the event.

To reuse the same alarm settings in the future, select the "Add to Menu" option, and then type in 
the Rename box a name for your new alarm.

Your named alarm will appear at the bottom of the Alarms menu (displayed from the Date 
Settings dialog box) and can be applied to any other appointment or event.

To display more alarm options, choose the Options button.    

4. Choose the OK button, and then choose the OK button in the Date Settings dialog box.

The default alarm is a message with the text of the appointment or tickler item.



Setting Custom Alarms for Any Item

You can set custom alarms for any item in the PhoneBook or in an outline view.    You can also name any 
custom alarm you create, add it to the Alarms menu, and use it again to signal another item.    Note that in
the Calendar view, custom alarms are available from the Date Settings dialog box.    

To set a custom alarm for any item
You can set custom alarms for items in the PhoneBook or in an outline view from the Create an Alarm 
dialog box.

1. Select the item you want to set the alarm for.

2. From the Tools menu, choose Alarms, and then choose Create New Alarm.

The Create an Alarm dialog box appears.

3. In the Date box, select a date.

4. Next to Time, choose the buttons to select a time.

If you don't select a specific time, the alarm will go off at the beginning of the day.    You can specify 
the beginning of the day using the Preferences command.    

5. Select the "Attach alarm to selected Item" option.

Ecco displays the text of the selected item in the Alarm Text box.

6. In the Type box, select Custom.

The Custom Alarm dialog box appears.    

7. Take one or more of the following actions:

Select the "Invoke Alarm at time of event" option if you want the alarm to go off at the time of the 
event.

If you want, choose additional alarms before and after the event by clicking or dragging in the 
drop-down number menu.    Selecting multiple numbers will cause alarms to occur at multiple times before
or after the event.    You can select any number of minutes, hours, days, or weeks (up to six weeks) before
or after the event.

To reuse the same alarm settings in the future, select the "Add to Menu" option, and then type in 
the Rename box a name for your new alarm.

Your named alarm will appear at the bottom of the Alarms menu (displayed from the Date 
Settings dialog box) and can be applied to any other appointment or event.

To display more alarm options, choose the Options button.    

8. Choose the OK button, and then choose the OK button in the Create an Alarm dialog box.

The default alarm is a dialog box displaying the text of the item.    



Specifying Alarm Actions

In addition to displaying a message with the text of the item, custom alarms in Ecco can also play any 
sound stored on your system (sound files have the file extension .WAV) or display any dialog message 
you type.    For example, if you need to remind yourself to pick up brochures the day before a sales 
presentation, you can set an alarm and type yourself a reminder message for that specific task.

You can also set alarms that launch files, programs, or batch files.    For example, you can set an alarm 
that will launch your word-processing program to remind you that you need to send a memo to your staff.  
Or set an alarm to launch a batch file that backs up your files at a certain time every day.    

To specify alarm actions
Alarms can play sound files, display messages, or launch files or programs.

1. In the Calendar view, open the Date Settings dialog box, choose the Alarms button, and then choose 
Custom.    The Alarms dialog box appears.

Or
In the PhoneBook view or an outline view, from the Tools menu, choose Alarms, and then choose 
Create New Alarm.    In the Create an Alarm dialog box, in the Type box, select Custom.    The Custom
Alarm dialog box appears.

The Alarms dialog box and Custom Alarm dialog box are very similar.

2. Choose the Options button.

The dialog box expands, displaying options for setting alarm actions.

3. Take one or more of the following actions:

To display a custom message instead of the item's text, select the "Dialog Message" option and 
then type your message.

To play a sound, select the "Play Sound" option, and then choose the Browse button to search for
the .WAV file you want.

Or
Type the path, including the filename, of the sound you want to play.    For example, c:\windows\
chimes.wav might be the path for a sound file that sounds a chime.

To launch a document or a batch file, select the "Launch Document/.Bat File" option, and then 
choose the Browse button to search for the file you want.

Or 
Type the path, including the filename, of the file you want to launch.    For example, c:\bat\
backup.bat might be the path for a batch file that backs up your hard disk.

To display a dialog box that lets you confirm before launching, select the "Confirm Before Launch"
option.
4. Choose the OK button.

Note    Document files must be associated with a program before Ecco can launch them.    If an alarm 
occurs while Ecco is not running, the Alarms Occurred dialog box appears when you next start Ecco.    If 
you set an alarm to launch a document or batch file, you can launch the file from this dialog box.    



Canceling an Alarm

When you no longer need an alarm, you can:

Delete the alarm from the Review Alarms dialog box.
Cancel the alarm and keep the item.
Delete the item with which the alarm is associated.
To delete an alarm

You use the Review Alarms dialog box to delete an alarm.

1. From the Tools menu, choose Alarms, and then choose Review Alarms.

The Review Alarms dialog box appears.

2. From the list of alarms, select the alarms you want to delete.

3. Choose the Delete button.

Ecco asks whether you want to delete all alarms associated with the selected appointment.

4. Choose the Yes button.

5. Choose the OK button.

To cancel an alarm from the Calendar view
You use the Date Settings dialog box to cancel an alarm.

1. Position the mouse pointer at the left of the appointment or tickler item so that the Options cursor 
appears, and then click.

Or
Select the item with an associated alarm and, from the Calendar menu, choose Time, Date, Alarm, 
etc.

The Date Settings dialog box appears.

2. Choose the Alarms button in the Date Settings dialog box, and then choose None.

3. Choose the OK button.

Note    Deleting an item also deletes the alarm associated with it.



Reviewing Alarms

To see what alarms you have set for any week or to delete an alarm you no longer need, use the Review 
Alarms command.

To review alarms
You use the Review Alarms dialog box to review or delete an alarm.

1. From the Tools menu, choose Alarms, and then choose Review Alarms.

The Review Alarms dialog box appears.

2. Take one or more of the following actions:

View the alarms for the current week.
To see alarms occurring in a week other than the current week, choose the down arrow next to 

"Alarms occurring the week of" and select a different date.
To delete an alarm, select the alarm you want to delete and then choose the Delete button.

3. When you are through, choose the OK button.



Managing Named Alarms

In addition to creating and reviewing alarms, Ecco lets you edit or rename existing named alarms, delete 
named alarms, or reorder named alarms on the Alarms menu.    You can perform all these tasks from the 
Manage Named Alarms dialog box.

To manage named alarms
You use the Manage Named Alarms dialog box to edit, rename, delete or reorder named alarms.

1. From the Tools menu, choose Alarms, and then choose Manage Named Alarms.

The Manage Named Alarms dialog box appears.

2. Take one or more of the following actions:

To rename an alarm, select the alarm you want to rename, and then type in the Rename box the 
new name you want to give the alarm.

To create a new named alarm, choose the New button.
To edit a named alarm, select the alarm you want to edit, and then choose the Edit button.
To delete a named alarm, select the alarm you want to delete, and then choose the Delete button.
To reorder named alarms on the Alarms menu, select the alarm you want to move, and then 

choose either the Up or Dn reorder button.
3. When you are through, choose the OK button.



Introduction to Recurring Events

In Ecco, recurring events are activities that happen at regular intervals events such as Monday morning 
staff meetings or bimonthly conference calls.

When you specify an event as recurring, Ecco automatically displays the event at the dates and times of 
your choice in your calendar.
By using recurring events, you can:

Save time.
Be certain that you'll remember events that happen regularly.
Avoid scheduling conflicts.    If you schedule another meeting that coincides with the recurring 

event, a red-and-white stripe pattern in the Busybar block alerts you to the conflict.
Ecco lets you specify events that recur as frequently as every day or as far apart as every 20 years.    
Here are examples of recurring events you can create.

Staff meetings (same day and time every week)
Payroll (1st and 15th of every month)
Board meetings (first Tuesday of every month)
Estimated taxes (four times a year)
Annual reports (yearly)



Creating Recurring Events

You can create two types of recurring events:

Standard recurring events are based on the current date in the Calendar view.    For example, if 
the current date is Thursday, October 1, Ecco gives you the following choices:    every day, every Mon thru
Fri, every Thursday, the 1st of every month, the first Thursday of every month, and every October 1st.

Custom recurring events can be set for almost any time period.    For example, you could set 
events to recur every third Tuesday, or you could set events to recur on the 11th, 12th, and 13th of each 
month.
Once you've created a recurring event, a recurring event icon is displayed in the status column to the left 
of the item with which it's associated.    In addition, when you display the Date Settings dialog box for an 
item with an associated recurring event, the upper left corner of the Recur button is red.

If you create a recurring event that conflicts with existing appointments or holidays, Ecco displays a dialog
box that alerts you to the conflict.

You can make appointments or tickler items into recurring events.    

If you are using the advanced features of Ecco Professional, you can make any item that is in a date 
folder into a recurring event.    

To create a standard recurring event
You create standard recurring events from the Date Settings dialog box.

1. If the Calendar view is active, click the time to the left of an existing appointment to display the Date 
Settings dialog box.

Or
Select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.

2. In the Date Settings dialog box, click the Recur button to display the Recur menu.    The commands 
on this menu change depending on the current calendar date.

3. Choose the interval of recurrence you want.

4. In the Date Settings dialog box, choose OK.

To create a custom recurring event
If the standard events on the Recur menu don't meet your needs, you can create a custom recurring 
event.

1. If the Calendar view is active, click the time to the left of an existing appointment to display the Date 
Settings dialog box.    

Or
Select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.

2. In the Date Settings dialog box, click the Recur button to display the Recur menu.

3. From the Recur menu, choose Custom.

Ecco displays the Recurring Event dialog box.    

4. In the Type box, select the time increment you want for the recurring event (daily, weekly, monthly, or 
yearly).

5. In the On box, select as many options as you want.

6. In the Repeating box, select the frequency with which you want the event to recur.    For example, if 
you selected "Weekly" in the Type box, you could choose the "Every 2 Weeks" option in the 
Repeating box to have the recurring event scheduled at two-week intervals.



If you selected the "Monthly" option in the Type box, a "Specific Months option" is available.    This 
option lets you select multiple months, such as January, April, July, and September.

7. In the Until box, select the date on which you want the event to stop recurring.

8. Choose the OK button, and then choose the OK button in the Date Settings box.

Ecco adds the recurring event to your calendar.



Changing Recurring Events

When schedule changes affect recurring events, you'll need to modify the recurring events to reflect those
changes.    If a recurring event conflicts with existing appointments or holidays, Ecco displays a dialog box
that alerts you to the conflict.

To change a recurring event
Changes you make to recurring events are reflected throughout your calendar.

1. If the Calendar view is active, click the time to the left of an existing appointment time to display the 
Date Settings dialog box.

Or
Select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.

2. Choose the Recur button.

3. Choose one of the standard recurring event commands, and then choose the OK button in the Date 
Settings dialog box.

Or
Choose Custom to display the Recurring Event dialog box, make the changes you want, and then 
choose the OK button in the Date Settings dialog box.



Canceling Recurring Events

You can cancel a recurring event in any of several ways.

You can delete the item with which a recurring event is associated.    This removes the event from
every calendar location.

You can specify an earlier expiration date for the event in the Recurring Event dialog box.
You can cancel the recurring event without deleting the item.
To cancel a recurring event

This procedure removes the item's recurring status but retains the original item.

1. If the Calendar view is active, click the time to the left of the appointment to display the Date Settings 
dialog box.

Or
Select the item and, from the Calendar menu, choose Time, Date, Alarm, etc.

2. Choose the Recur button.

The Recur menu appears.

3. From the Recur menu, choose Non-Recurring.

4. In the Date Settings dialog box, choose the OK button.

The selected appointment item remains, but any associated recurring events are removed from your 
calendar.



Printing Your Schedule

In Ecco, you can print your Calendar view in a format that meets your needs or preferences.    You can 
print a specified day, week, month, or range of dates, or you can print only selected items and their sub-
items. You can also specify the page size, margins, and number of copies to print.

When printing your Calendar, you have a number of options.    You can print:

Summary pages only.    Summary pages do not include sub-items.
Detail pages.    When you print detail pages, you can print all items, exclude hidden sub-items, 

and specify the levels of sub-items to include.    You can also print any columns associated with your 
Calendar.    

Both summary pages and detail pages.
The Appointment section, Tickler section or both.
Selected items in any font you specify.
To print Calendar information

You can print your schedule according to options you select.

1. To print selected items only, select the items you want to print.    

2. From the File menu, choose Print.
The Print Calendar View dialog box appears.    

3. Select one of the Format options to select the items to print.

4. In the Date Range boxes, select a starting and ending date to print.

5. In the Page Size box, select the page size you want.

You can choose from page sizes that fit common organizer-style notebooks.    If you select "Custom," 
Ecco displays the Custom Page Size dialog box, in which you specify the height and width of the 
page.

6. Under Margins in Inches, type the measurement for each margin you want to change: left, top, 
bottom, and right.

Ecco always prints the Calendar month view with preset margins.    Ecco also restricts your input to 
the limits of the Windows printer driver you are using.

7. In the Copies box, type the number of copies you want to print.

8. If you want to specify additional printing options, choose the Options button.

Ecco displays the Calendar Print Options dialog box.

9. Take one or more of the following actions:

Select "Summary Pages (no sub-items)" or "Detail Pages" or both.    Summary pages in month 
format print in a grid, like a page of a monthly wall calendar.

Select the Appointment section, Tickler section, or both for printing.
If you selected the "Detail Pages" option, select the items and columns you want to print.    For 

example, you can exclude hidden items and minimized columns, or you can specify the level of items to 
include.    

Select the fonts to use to print your calendar.
10. Choose the OK button.



Looking Ahead: Integrating the Calendar with Other Views

Here are some ways in which you can integrate the Calendar view with other Ecco views and features
and thereby manage your information more productively.    You can:

View information from other views in the Appointment section and Tickler section. Simply select 
any item from any view and, from the Tools menu, choose Ticklers.    

Drag PhoneBook items into Calendar to create appointments.    

Format outline notes using outline styles, character formatting, and text touch-ups.    

Add columns of information to your appointments.    

View and schedule appointments in other views.    

Apply filters to your appointments.    

Schedule appointments along with other information, using forms.    



For more information, see The Calendar View Window.



For more information, see Viewing Dates and Appointments.



For more information, see Using Recurring Events.



For more information, see Using Alarms.



For more information, see Ticklers: To-Do's and What's Ahead.



For more information, see Changing an Appointment Time.



For more information , see Scheduling Appointments Using the PhoneBook.



For more information, see Adding Outline Notes to an Appointment.



For more information, see The Date Settings Dialog Box.



For more information, see Scheduling New Appointments.



For more information, see Changing an Appointment Time and Changing an Appointment's Duration.



For more information, see Deleting Appointments.



For more information, see Adding Outline Notes to an Appointment.



Schedule an appointment in the Calendar view.



For more information, see Changing an Appointment's Duration.



Note    You can change the default duration of an Ecco appointment (for example, to 30 minutes or two 
hours).    From the Tools menu, choose Preferences, and then change the Default Appointment Duration 
setting in the Ecco Preferences dialog box.    



For more information, see Tools: Preferences.



For more information, see Adding Outline Notes to an Appointment.



Drag a name from the PhoneBook to schedule an appointment.



For more information, see Adding Outline Notes to an Appointment.



Use outline notes to describe an appointment.



For more information, see Creating Outlines.



For more information, see Using the Navigator to Move to a Date.



For more information, see Displaying Your Schedule by Day, Week, or Month.



Use the Navigator to move forward and backward through the Calendar view.



Use the Navigator's drop-down lists to move to a specific month, day, or year.    For example, to go
from December 20, 1994, to August 1, 1995, you would make selections that result in this screen 
display.



Day view



Week view



Month view



Use the Tickler section to display to-do lists and reminders of upcoming events.



For more information, see Creating a To-Do List.



For more information, see Creating Advance Warning for Your Appointments.



Organize your to-do list by adding tickler items to different folders.



For more information, see Understanding Folders.



Note    When the PhoneBook view or an outline view is active, you can add items to the Tickler section by 
choosing Ticklers from the Tools menu.



For more information, see Ecco Default Folders.



Note    If you press F2 (the keyboard shortcut for the Time, Date, Alarm, etc.    command), the appointment
edit box appears.    This box lets you quickly enter or change dates and times from the keyboard.    Click 
the down arrow or press the INSERT key to display the Date Settings dialog box.



For more information, see Understanding Folders.



For more information, see Setting Custom Alarms for Any Item.



For more information, see Specifying Alarm Actions.



For more information, see Setting Custom Alarms in the Calendar View.



For more information, see Tools: Preferences.



For more information, see Specifying Alarm Actions.



Note    Deleting a named alarm from the Manage Named Alarms dialog box also cancels an alarm.    



For more information, see Managing Named Alarms.



For more information, see Ecco Default Folders.



Note    You can make an exception to one or more instances of a recurring event.    For example, if your 
weekly staff meeting falls on a holiday, you could change that instance of the recurring event to another 
day.    You make an exception to a recurring event in the same way you change any appointment.    



For more information, see Changing an Appointment Time.



For more information, see Introduction to Columns.



For more information, see Selecting Multiple Items.



For more information, see Ticklers: To-Do's and What's Ahead.



For more information, see Scheduling Appointments Using the PhoneBook.



For more information, see About Formatting.



For more information, see Introduction to Columns.



For more information, see Date Columns.



For more information, see Applying Filters in the Calendar View.



For more information, see Forms.



For more information, see Creating and Managing Appointments.



For more information, see Ticklers: To-Do's and What's Ahead.



For more information, see Using the Navigator to Move to a Date.



For more information, see Scheduling Appointments Using the PhoneBook.



For more information, see Changing an Appointment Time.



For more information, see Entering Values in Columns.



For more information, see About the Calendar View.



For more information, see Introduction to Columns.



The PhoneBook View

Click a book to expand or collapse the outline.
            About the PhoneBook View  
            Entering PhoneBook View Information  
            Finding PhoneBook Information  
            Viewing PhoneBook Information  
            Displaying All PhoneBook Entries  
            Dialing and Logging Calls  
            Printing Your PhoneBook Entries  
            Importing, Exporting, and Mail Merge  
            Using the PhoneBook with the Calendar  
            Looking Ahead: Integrating the PhoneBook with Other Views  



The PhoneBook View

Click a book to expand or collapse the outline.
            About the PhoneBook View  

Introduction to the PhoneBook View
The PhoneBook View Window

            Entering PhoneBook View Information  
            Finding PhoneBook Information  
            Viewing PhoneBook Information  
            Displaying All PhoneBook Entries  
            Dialing and Logging Calls  
            Printing Your PhoneBook Entries  
            Importing, Exporting, and Mail Merge  
            Using the PhoneBook with the Calendar  
            Looking Ahead: Integrating the PhoneBook with Other Views  



The PhoneBook View

Click a book to expand or collapse the outline.
            About the PhoneBook View  
            Entering PhoneBook View Information  

Introduction to Entering Information
Using the PhoneBook View Entry Form
Editing and Deleting Entries
Adding Outline Notes to an Entry

            Finding PhoneBook Information  
            Viewing PhoneBook Information  
            Displaying All PhoneBook Entries  
            Dialing and Logging Calls  
            Printing Your PhoneBook Entries  
            Importing, Exporting, and Mail Merge  
            Using the PhoneBook with the Calendar  
            Looking Ahead: Integrating the PhoneBook with Other Views  



The PhoneBook View

Click a book to expand or collapse the outline.
            About the PhoneBook View  
            Entering PhoneBook View Information  
            Finding PhoneBook Information  
            Viewing PhoneBook Information  

Viewing Information in the PhoneBook View
            Displaying All PhoneBook Entries  
            Dialing and Logging Calls  
            Printing Your PhoneBook Entries  
            Importing, Exporting, and Mail Merge  
            Using the PhoneBook with the Calendar  
            Looking Ahead: Integrating the PhoneBook with Other Views  



The PhoneBook View

Click a book to expand or collapse the outline.
            About the PhoneBook View  
            Entering PhoneBook View Information  
            Finding PhoneBook Information  
            Viewing PhoneBook Information  
            Displaying All PhoneBook Entries  
            Dialing and Logging Calls  

Introduction to Dialing and Logging Calls
Dialing
Logging Calls

            Printing Your PhoneBook Entries  
            Importing, Exporting, and Mail Merge  
            Using the PhoneBook with the Calendar  
            Looking Ahead: Integrating the PhoneBook with Other Views  



You can use the scroll bars, zoom button, entry form, and close box button to view only the information 
you want to see.    Click green text to view more information.



You can use the scroll bars, zoom button, entry form, and close box button to view only the information 
you want to see.    Click green text to view more information.



Scroll bars    Click the scroll arrows to move horizontally or vertically in the direction of the arrow, or drag 
the scroll box to move quickly through your entries or columns.



Minimized column    If you are using a template that contains default columns, double-click the column 
heading to minimize a column.    Minimized columns let you display a greater number of columns on-
screen at one time.    To return a minimized column to its pre-minimized width, double-click the column 
heading.    

If you are using the advanced features of Ecco Professional, the Column menu appears in the upper right 
corner of the PhoneBook view.    



Column pane border    If you are using a template that contains default columns, drag the Column pane 
border to resize the PhoneBook list and the Column pane.    



Close box button    Click the Close Box button in the upper left corner of the PhoneBook entry form to 
hide the entry form.



Use this Business address for Print & Display    Select this option to display the business address in 
the entry form for the selected name.    Cancel this option to display the home addresses in the entry form.
Note that you can enter both a business and home address for each name.    This option determines 
which address is used when printing your PhoneBook or when sending a name to another program using 
the Shooter.



Hidden outline    Double-click the blue item bullet to the left of an item to expand or collapse the outline.



The PhoneBook view window appears within the Ecco program window.    To display the PhoneBook view,
from the View menu, choose PhoneBook.        Click green text to view more information.



The PhoneBook view window appears within the Ecco program window.    To display the PhoneBook view,
from the View menu, choose PhoneBook.        Click green text to view more information.



PhoneBook view tool bar    Using the PhoneBook view tool bar buttons, you can search for and collect 
PhoneBook entries, find the next instance of specified search text, dial and log phone calls, and make an 
appointment in your Calendar.



PhoneBook menu    The PhoneBook menu commands let you perform basic PhoneBook view actions, 
such as entering new and editing existing PhoneBook entries.



PhoneBook list    The PhoneBook list displays PhoneBook items.    When you enter a name in the 
PhoneBook view, Ecco converts it into an item. Each item has a blue item bullet to its left.    



Entry form    You enter names, numbers, addresses, and other information into the fields in the entry 
form.    You can also use this form to view or make changes to existing entries.



Column pane    The Column pane provides an alternate display of the information, other than the name, 
that you entered using the entry form.



Search button    Search for any text in the PhoneBook view (names, outline notes, or column information)
by typing text in the search edit box and then choosing the Search button.    Choose the Search button 
with the search edit box empty to collect all names in the PhoneBook.



Next button    Choose this button to highlight the next instance of the search text in the displayed 
PhoneBook items.    You can use this button without previously choosing the Search button.



Introduction to the PhoneBook View

You can use the PhoneBook view to record names, numbers, and addresses in your computer files just 
as you would in any address book.    However, the Ecco PhoneBook offers you much more than a paper 
address book does.    

Enter information into the PhoneBook view using the straightforward text-entry form. 

Add outline notes using the Ecco outlining features.    Enter any number of outline notes for 
each name in the PhoneBook.    

Search for an entry that matches a specified single character, multiple characters, a word, or a 
phrase.    You can search for a person's name, a company's name, or outline notes.    

Create and track any number of Calendar appointments for any name in your PhoneBook.    

Dial any number saved in the PhoneBook view.    Let Ecco search for it and do the dialing for 
you.    

Automatically log the time, date, and duration of every call you make.    

Import from another software program the file that you currently use as your online phone or 
address book.    You can import any file that can be saved as a CSV (comma-separated value) or as a 
tab-separated text file.    

If you are using the advanced features of Ecco Professional, the following options are available:

Organize names in the PhoneBook view by collecting them in Ecco folders. 

Display columns of custom information about the names in the PhoneBook view.    

Apply filters to the PhoneBook view to display only those names that meet search criteria, based
on any field or column.    



Introduction to Entering Information

To enter and update PhoneBook view information, you use an entry form similar to a paper form.    To 
enter new information, simply fill in the blanks.    You can use the entry form to:

Add new entries.    

Edit or update existing entries.    

Delete PhoneBook entries.    

When you add an entry to the PhoneBook view, the name (or item) is displayed in the PhoneBook list, 
and the rest of the information is displayed in the Column pane. The name plus its associated information 
(address, phone number, and so on) is called an entry.



Using the PhoneBook View Entry Form

Simply type the information into the spaces provided and then choose the Add button.    Your new 
PhoneBook entry appears in the PhoneBook list.

To add a new entry
Use the PhoneBook entry form to enter information into the PhoneBook view.

1. In the entry form, choose the New button.

Or
If the entry form is not displayed, from the PhoneBook menu, choose New PhoneBook Item.

2. In the Name field, type the name you want to add, last name first.

3. Press the TAB key to move to the next field.

Or
Click the next field.

4. Type information in all applicable fields.

5. To add a home address, next to "Address showing," select the "Home" option, and then type the 
home address into the address fields.

6. When you have finished filling in the fields, choose the Add button.

The name (or item) is displayed in the PhoneBook list.    The remainder of the information is displayed
in the Column pane. If the Column pane is not displayed, choose the Show Columns button.    If you 
want, you can enter additional information about PhoneBook items in the columns that don't have 
headings.

If you are using the advanced features of Ecco Professional, you can add more columns to the 
PhoneBook view and use columns to filter the entries displayed in the view.    

Tip    To quickly add similar entries to the PhoneBook, choose the Based On Last button in the 
PhoneBook entry form.    Ecco displays the last entry displayed in the form.    Change the fields that are 
different, and then choose the Add button.



Editing and Deleting Entries

Suppose a client moved to a new address or you discover a duplicate entry for a supplier.    You can use 
the PhoneBook view entry form to edit and delete PhoneBook view information.

To edit an existing entry
Use the entry form to edit entries.

1. In the PhoneBook list, select a name.    All the information associated with the name appears in the 
form.    

2. If the entry form is not displayed, from the PhoneBook menu, choose Use PhoneBook 
Form.

3. Type new information in any field or fields.
Press the TAB key or SHIFT+TAB to move forward or backward through the fields.

4. When you have finished making changes, choose the Apply button.

The entry is modified to include your changes.

To delete an entry
To delete a PhoneBook entry, you select the entry's item and then delete it.    The associated information 
is deleted along with it.

1. Select the item you want to delete.

2. From the Edit menu, choose Delete Items.

Or
On the entry form, choose the Delete button.

The entry is deleted.

Note    You can also select and delete multiple items.    



Adding Outline Notes to an Entry

For some entries, a name, an address, and a phone number might be adequate.    With Ecco, you can 
also include a detailed outline as part of the description of any entry.    Your outline could include any or all
of the following:

A full log of all conversations.
A log of all appointments and outline notes for those appointments.
Additional information about the person or company, for example, directions to a home or 

business, or a list of topics to discuss the next time you talk on the phone.

To add an outline to an entry
You can add an outline to any entry.

1. Select the entry to which you want to add outline notes.

2. Press the ENTER key.

Or
From the PhoneBook menu, choose Add Outline Note.

Ecco inserts a blank line for a sub-item below the entry item.

3. Type any information in the sub-item line.

Each time you press ENTER, an additional blank line for a sub-item is added at the same heading 
level.

4. To move an item up or down in the outline, or to promote or demote an item in the outline, drag the 
blue item bullet, located at the left of the item, to the desired location in the outline.

Or
Select the item and then press ALT+an arrow key.

5. You can expand or hide the outline levels by double-clicking the item bullet.



Finding PhoneBook Information

You can find and display PhoneBook entries in either of two ways.    

Click a letter tab to display all entries whose first or last name begins with that letter.    The letter 
tabs are located along the left side of the PhoneBook view window.    For example, to display Bob 
Anderson's entry, you could click either "B" or "A."

Search for entries that begin with or contain certain text.
Before clicking a letter tab or searching for a string of text, you can specify whether you want to search by
first and last name or by company name.    If you choose the Search 1st and Last Name command on the 
PhoneBook menu, Ecco searches through the items (names) in the PhoneBook list.    If you choose the 
Enable Company Search command on the PhoneBook menu, Ecco lets you choose whether you want to 
search through items (names), through the Company column, or through any other column in the 
PhoneBook view.    

To find an entry by searching for specific text
You search for entries in the PhoneBook view using a single letter, multiple letters, a word, or a phrase.    
You can search for entries by first name, last name, or company name.    If you search for entries that 
contain a letter or string of letters, Ecco includes sub-items in the search.

1. From the PhoneBook menu:

To search by first or last name, choose Search 1st and Last Name.
To search by name or company name, choose Enable Company Search.

2. In the PhoneBook tool bar:

To search for a name that begins with certain text, beside "Search for Items that," select the 
"Begin With" option.

To search for a name that contains certain text, beside "Search for Items that," select the 
"Contain" option.
3. In the Search box, type the text you want Ecco to search for.

4. Choose the Search button.

If you chose the Search 1st and Last Name command on the PhoneBook menu, Ecco searches 
for all items (names) that match the specified text.

If you chose the Enable Company Search command on the PhoneBook menu and the "Begin 
With" option, you can specify whether Ecco searches for names or for companies that match the specified
text.

If you chose the Enable Company Search command on the PhoneBook menu and the "Contain" 
option, you can specify whether Ecco searches for names and notes (sub-items) or for companies that 
match the specified text.

Ecco searches for, and collects in the PhoneBook list, all entries that match the specified text.    If you 
have a large number of PhoneBook entries, this option takes longer than the "Begin With" option.

5. Choose the Next button in the PhoneBook view tool bar to highlight the first instance of the search 
text in the entries collected in the PhoneBook list.

6. Continue choosing the Next button to move to each subsequent instance of the search text.

Note    When searching by first and last name, Ecco looks at the first two words in the item text, ignoring 
middle initials and additional words.



Displaying All PhoneBook Entries

When you search for entries in the PhoneBook view using the letter tabs or PhoneBook tool bar, Ecco 
displays only the entries that match your search text.    Using the following procedure, you can display 
your entire PhoneBook.

To view all PhoneBook entries
1. In the PhoneBook tool bar, delete any text that appears in the search text box in the PhoneBook tool 

bar.

2. Choose the Search button.

Ecco displays all the items in your PhoneBook.    



Introduction to Dialing and Logging Calls

Whenever you make a call, Ecco can dial the number for you and log, or keep a record of, the date, time, 
and duration of the call.    To have Ecco dial a number for you, all you need is a modem that is on the 
same line as your telephone.    Even if you dial a number yourself, you can still log the call.

You dial and log calls using the Dialer/Call Logger dialog box.    To display the Dialer/Call Logger dialog 
box, choose the Telephone button in the PhoneBook tool bar or choose the Dial phone command on the 
PhoneBook menu.    



Dialing

If you have a modem, you can use Ecco to dial your calls for you.    You can also log each call you make.   

To have Ecco dial a phone number
You dial using the Dialer/Call Logger dialog box.

1. Select the name of the person or business you want to call.

2. In the PhoneBook view tool bar, choose the Telephone button.

Or
From the PhoneBook menu, choose Dial phone.

The Dialer/Call Logger dialog box appears.

3. In the Prefix box, enter a dialing prefix (for example, 9 for an outside line).

4. In the Phone # Choice box, select the type of phone number you want to dial (for example, Work #, 
Home #, or Fax #).

The phone number appears in the Number to Dial box.

5. Choose the Dial button.

Ecco dials the number for you.

6. When the ring sounds, pick up the phone receiver.

7. When you are through with the call, hang up, and then choose the Close button.



Logging Calls

With Ecco, you can keep a record of every call you make.    Ecco will record the time, date, and duration 
of the call for you; you specify the text of the log entry.    For example, if you were discussing a quote with 
a customer, you could enter "Project quote" as the log entry.    This log entry appears as a sub-item of the 
person you are calling.    The default log entry is "Logged Call." You can even add additional notes to the 
log entry by using outline notes.

You can log your calls when you use Ecco to dial for you, or you can log calls when you're not using Ecco 
to dial.

To log a call
You can log any call you make to record its time, date, and duration.

1. Select the name of the person or business you want to call.

2. In the PhoneBook view tool bar, choose the Telephone button.

Or
From the PhoneBook menu, choose Dial phone.

The Dialer/Call Logger dialog box appears.

3. If you want the log entry to appear as something other than "Logged Call," in the Phone Log Text box,
type a new entry.

4. Choose the Begin Logging button.

Or
Choose the "Begin Logging upon dialing" option, and then choose the Dial button to have Ecco dial 
the number.

Ecco begins logging the duration of your call.

5. Choose the Close button when the call is over.

Or
Choose the End Logging button when you want to stop logging your call.

The log entry appears as a sub-item under the name of the person called.    

To view a phone log entry
You can view the date, time, and duration of a call in the PhoneBook view.

1. To view the date of the call, select the log entry, and then scroll through the Column pane until the 
"Phone Log" column is displayed.    

2. To view the time and duration of the call, click the cell with the date in the "Phone Log" column.

A date value edit box displaying the date, time, and duration of the call appears.    When you have 
finished viewing the information, choose the ENT (checkmark) button or the ESC button.



Printing Your PhoneBook Entries

When printing your PhoneBook you have many options.    You can print:

The entire PhoneBook.
Only selected items and their sub-items.
Only those items currently displayed in the PhoneBook list.    
Names, sub-items (or outline notes), and all information in columns.
Only names, addresses, and phone numbers.
Only names and addresses.

You can also specify the margins of the printed page; the number of copies you want; and whether you 
want a page break between entries beginning with a different letter.

To print PhoneBook information
You can print your entire PhoneBook, selected items, or currently displayed items only.

1. If you want to print selected items, select the items you want to print.    

2. From the File menu, choose Print.
The Print PhoneBook View dialog box appears.    

3. Select one of the Print options to specify the entries to print.

To print entries in the order currently displayed, select the "All Items Currently in this View" option.    
(You can sort your PhoneBook entries before printing.    First, display all entries in the PhoneBook 
view by choosing the Search button when the search edit box is empty.    Then, from the Advanced 
menu, choose Sort to sort the entries by field or column.)

4. Select one of the Format options to specify the parts of each entry to print.

5. In the Page/Labels box, select the page size you want.

If you are printing name and address only, you can choose standard page sizes, or you can choose 
Avery® label sizes (if you're printing names and addresses only).    If you select "Custom," Ecco 
displays the Custom Page Size dialog box, in which you specify the height and width of the page.

6. Under Margins in Inches, type the measurement for each margin you want to change: left, top, 
bottom, and right.

Ecco restricts your input to the limits of the Windows printer driver you are using.

7. In the Copies box, type the number of copies you want to print.

8. If you want to specify additional printing options, choose the Options button.

Ecco displays the PhoneBook Print Options dialog box.    

9. Take one or more of the following actions:

To specify what items to print, select one or more of the Name & Sub-Item Options.
To specify what columns to print, select one or more of the Column Options.
To print entries in "firstname lastname" format, select the "Name Order" checkbox.
To insert a page break between entries beginning with a different letter, select the "Page Breaks" 

checkbox.
Select the fonts to use to print your PhoneBook.
Choose the OK button to close the PhoneBook Print Options dialog box.

10. Choose OK to print.

Ecco prints your PhoneBook selection.

Note    If you want to print a single page to check your printing selections, choose the Test button in the 
Print PhoneBook View dialog box.    Generating this page for proofreading is useful before you print 



mailing labels or a large number of entries.



Importing, Exporting, and Mail Merge

You can import into the PhoneBook view an existing database or text file of names, addresses, and 
numbers.    You can import these files in either of two formats, .TXT (text) or .CSV (comma-separated 
values), using the Import command on the File menu.    

You can also export PhoneBook information to other programs, using the Export command on the File 
menu.    For example, you can export PhoneBook entries to a word-processing program and use the 
program's mail merge feature to print form letters.    



Using the PhoneBook with the Calendar

You can display the PhoneBook and Calendar views side by side by choosing the Calendar/PhoneBook 
button. You can then schedule an appointment with anyone in your PhoneBook list by dragging a name 
from the PhoneBook view to a time slot in the Calendar view.

To schedule an appointment using the PhoneBook
You can use the PhoneBook to schedule an appointment by dragging the name from the PhoneBook list 
into the Calendar view.    

1. Choose the Calendar/PhoneBook button on the right side of the PhoneBook view tool bar.

Or
From the PhoneBook menu, choose Use with Calendar.    

2. Click the PhoneBook view to make it the active view.

3. In the PhoneBook list, point to the item bullet next to the name you want and hold down the mouse 
button.

The pointer changes to a four-headed arrow.

4. Drag the name to the time slot you want.

The appointment is scheduled in the Calendar view.    Ecco creates a sub-item for the appointment in 
the PhoneBook view.    If you have an Appointments column in the PhoneBook view, Ecco also 
displays the appointment date there.

Note    To view the time and duration of the appointment, click the cell containing the date in the 
Appointments column.    An appointment edit box displaying the date, time, and duration of the 
appointment appears.    



Looking Ahead: Integrating the PhoneBook with Other Views

Here are some ways in which you can integrate the PhoneBook view with other Ecco views and features 
to manage your information more productively.    You can:

Drag PhoneBook items into the Calendar to create appointments.    

Add or change PhoneBook view information in columns.    

Update multiple PhoneBook entries quickly and easily using forms.    

View information from other Ecco views using columns.    

Format outline notes using outline styles, character formatting, and text touch-ups.    

If you are using the advanced features of Ecco Professional, you can:

Apply filters to your PhoneBook.    For example, you might create a filter to display all entries that 
have the same zip code.    

Add your names or their associated notes to Ecco folders to view that information in other 
contexts with related items.    



For more information, see The PhoneBook View Window.



For more information, see Using the PhoneBook View Entry Form.



For more information, see Adding Outline Notes to an Entry.



For more information, see Finding PhoneBook Information.



For more information, see Using the PhoneBook with the Calendar.



For more information, see Dialing.



For more information, see Logging Calls.



For more information, see Importing, Exporting, and Mail Merge.



For more information, see Understanding Folders.



For more information, see Introduction to Columns.



For more information, see Introduction to Filters.



For more information, see Using the PhoneBook View Entry Form.



For more information, see Editing and Deleting Entries.



For more information, see Editing and Deleting Entries.



Note    You can import into the PhoneBook view an existing database or text file of names, addresses, 
and numbers.    



For more information, see Importing to the PhoneBook.



For more information, see Introduction to Columns.



For more information, see Finding PhoneBook Information.



For more information, see Selecting Multiple Items.



Note    You can create outlines in any Ecco view.    This section introduces you to some of the basic Ecco 
outlining functions.    



For more information, see Creating Outlines.



Note    If you are using the advanced features of Ecco Professional, you can search for entries by their 
column values (for example, by city or by ZIP code).    You can also display only selected entries by 
applying a filter. 



For more information, see About Filters.



Use this menu to search for entries.



For more information, see Viewing Information in the PhoneBook View Window.



For more information, see Logging Calls.



You can add notes to any logged call entry.



Note    You can choose an item and start taking notes while the Dialer/Call Logger is logging time.



Click a cell in the Phone Log column to view the date, time, and duration of a call.



For more information, see Selecting Multiple Items.



For more information, see Importing to the PhoneBook.



For more information, see Exporting from the PhoneBook View.



For more information, see About the Calendar View.



Ecco displays the PhoneBook and Calendar views side by side.



For more information, see Editing and Deleting Values in Columns.



For more information, see Using the PhoneBook with the Calendar.



For more information, see Entering Values in Columns.



For more information, see Forms.



For more information, see Using the Same Column in Multiple Views.



For more information, see Formatting Items.



For more information, see About Filters.



For more information, see Understanding Folders.



For more information, see About the PhoneBook View.



For more information, see Introduction to Columns.



Outlining

Click a book to expand or collapse the outline.
            About Outlining  
            Creating Outlines  
            Viewing an Outline  
            Labeling an Outline  
            Managing Outlines  
            Printing an Outline  
            Looking Ahead: Integrating Outlines with Other Views  



Outlining

Click a book to expand or collapse the outline.
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Outlining

Click a book to expand or collapse the outline.
            About Outlining  
            Creating Outlines  

Creating New Outlines
Adding Items to an Outline
Selecting Single Items
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Deleting Items
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            Managing Outlines  
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Outlining

Click a book to expand or collapse the outline.
            About Outlining  
            Creating Outlines  
            Viewing an Outline  
            Labeling an Outline  

About Outline Labels
Creating Outline Labels
Displaying Outline Labels

            Managing Outlines  
            Printing an Outline  
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Outline views let you outline any kind of information.

Click green text to view more information.



Outline views let you outline any kind of information.

Click green text to view more information.



Item bullets    These blue rectangles appear next to each item in any outline.    You can rearrange 
selected items by dragging a bullet or by using the Move command on the Item menu.



Folder    When you create a new outline view, the name you give the view becomes the name of the 
folder under which items are added.    You can rename this folder at any time by selecting the text and 
typing a new name.

If you are using the advanced features of Ecco Professional, you can add other folders to an outline view. 



Parent item    A term describing an item that has one or more items subordinate to it.    Double-click a 
parent item bullet to display or hide its sub-items.    A parent item with hidden sub-items has a black 
triangle beside its item bullet.



Sub-item    A term describing an item that is subordinate to a parent item.



Show Columns button    Depending on the template you have used to create your file, Ecco might 
display a Show Columns button in the right-most corner of the outline view. If you choose this button, 
Ecco displays the Column pane. 



Introduction to Outlining

An outline is simply a list with major and minor points.    Outlines are a familiar tool for organizing complex 
information.    Outlining is a fundamental part of information management in every Ecco view. You can 
create outlines to help you organize the information associated with all the tasks you do.    For example, 
you might use an outline to organize your notes for a sales presentation, research project, or legal brief.

To keep track of meeting notes, participants, or action items for your appointments, create 
outlines in the Calendar view.    

To record background information or notes on phone conversations, add outlines to PhoneBook 
entries.    

To organize and keep track of virtually any task you do, create outlines in an outline view.    

If you are using the advanced features of Ecco Professional, outlining is also your key to advanced 
information management.    Using folders, you can cross-reference outline information, making it possible 
for you to view segments of one or more outlines in different contexts, for different purposes.    

When you create any outline in Ecco, you can:
Create and rearrange the outline structure.    

Expand or collapse the outline to see more or less detail.    

Create styles for outline levels.    

Print part or all of the outline.    

When you create an outline in an outline view, you can also label the levels of the outline to clarify the 
outline's structure.



Using an Outline View

Outline views let you outline any kind of information.    Unlike the PhoneBook view (with its alphabetical 
organization) and the Calendar view (with its chronological organization), outline views do not give you a 
predefined structure for the information you put into them.

You can create multiple outlines in separate outline view windows.    

Outline view windows appear within the Ecco application window.    To switch to an outline view, from the 
View menu choose Outlines, and then choose either New Outline or the name of any previously created 
outline.    



Outlining and Word Processing

Ecco is a powerful tool for organizing all the information you need.    Outlining in Ecco doesn't work quite 
the same way as outlining in a word-processing program.    In word processing, an outline is simply a 
series of paragraphs indented to various levels.    In a word-processing outline, you can move or 
rearrange any paragraph, regardless of its place in the outline structure.

Ecco outlines consist of individual units of information called items.    These items have a consistent 
hierarchical relationship with the items around them.    This means that individual items you add to an 
outline are part of a larger information structure, and you can use those items in many different ways (for 
example, by cross-referencing).

Ecco gives you great flexibility in rearranging and organizing items.    Because items are the basis of a 
structured information system, however, they do not behave the way paragraphs in a word processor do.

In Ecco, an item can be only one level subordinate to the previous item.
When you move an item that has subordinate items (sub-items), the sub-items must move with it.
In Ecco, pressing the ENTER key creates a new item below the current item

even if the insertion point is at the beginning or in the middle of the current item.
Ecco outlines also give you several features not available in word-processing outlines, including the ability
to select multiple noncontiguous items and to expand and collapse selected parts of an outline.



Creating New Outlines

To organize information for different purposes, you can create a separate, named outline view for each 
purpose.    For example, to organize information for a presentation, a weekly staff meeting, and a research
project, you could create a "Presentation" view, a "Staff Meeting" view, and a "Research" view.    Each 
view could contain information specific to its subject.

When you create a new outline:

The information in the view is saved whenever you save your Ecco file.
You can open the outline from the View menu by choosing the outline's name from the list 

displayed when you choose the Outlines command.
You can add, move, delete, and view the outline information.

If you are using the advanced features of Ecco Professional, you can also use outline views to cross-
reference outline information.    

To create a new outline view
Create a new outline view to organize information for different purposes.

1. From the View menu, choose Outlines, and then choose New Outline.

Ecco displays the Create a New Outline View dialog box.

2. In the Name box, type a name that describes the information you will add to the view.

The name of the outline view will appear in the menu when you choose the Outlines command.

The name of the outline will also appear as the folder name at the top of the new outline.    

If you are using the advanced features of Ecco Professional, the folder name is useful when you want
to cross-reference the information in the outline.    

3. Choose the OK button.

Ecco displays a new outline view.    The name you gave the outline appears as the folder name at the 
top of the outline as well as in the title bar.    The next time you choose Outlines from the View menu, 
you will see the name of your outline at the end of the menu.    You can switch between outlines by 
choosing their names from this menu.    

4. Create an outline by adding items.    

Note    To rename or delete outlines or change their order in the menu, choose Outlines from the View 
menu, and then choose Manage.    



Adding Items to an Outline

You can quickly add items to any outline by pressing the ENTER key.

In a new outline in an outline view, press ENTER to add a new item below the folder icon at the top
of the outline view.

In an existing outline, press ENTER to add a new item below the selected item.
If the selected item has sub-items that are expanded, the new item is also subordinate to the 

selected item.
If the selected item has no sub-items or if the sub-items are hidden, the new item is at the same 

level as the selected item.
If you press ENTER when a Calendar appointment or PhoneBook entry is selected, you start an 

outline by creating a new item subordinate to the selected item.
You can also add items to an outline using the following key or Item menu commands.    Any of these 
methods adds a new item below the selected item, regardless of the location of the insertion point in the 
item.

Result
Item Menu 
Command Key Command

Adds item at 
same level as 
selected item

Add Item CTRL+ENTER

Adds sub-item 
one level below 
selected item

Add Item Right CTRL+R

Adds item one 
level above 
selected item

Add Item Left CTRL+L

If you add an item by mistake, select the item and choose either the Cut command or the Delete Items 
command from the Edit menu.

You can insert carriage returns or tabs within the selected item using the following key and Edit menu 
commands.

Result
Edit Menu 
Command Key Command

Adds carriage return 
within the selected 
item, at the insertion 
point

Insert New Line SHIFT+ENTER

Adds tab to the end 
of the selected item

Insert Tab CTRL+T

You can import items from other programs into an outline.    



Selecting Single Items

To move, delete, format, or otherwise act upon an item, you must first select it.

To select a single item
You can use any of three methods to select an item.

Click the item's bullet.

Or
Click anywhere in the item's text.

Or
Move through an outline using the UP ARROW and DOWN ARROW keys.

When you select a single item, a black selection bar appears to the left of its item bullet, and a box 
appears around its text.

You use these same item selection methods in all Ecco views.

Note    Selection of a parent item does not automatically result in selection of the parent's sub-items.    
However, most tasks you perform on parent items will affect their sub-items as well.    For example, when 
you move a parent item, its sub-items move with it.    

If you are using the advanced features of Ecco Professional, there are some exceptions to this rule.    



Selecting Multiple Items

To move, delete, format, or otherwise act upon more than one item at a time, you can select multiple 
items.    You can select items in sequence, out of sequence, or at one or more outline levels only.    You 
use the following item selection methods in all Ecco views.

To select sequential items using the mouse
1. Point to the left of the item bullet of the first or last item you want to select.

The pointer changes to a dotted selection box.

2. Drag a dotted outline around the item bullets of all the items you want to select.

Or 
Select the first item in the group you want to select, hold down the SHIFT key, and select the item 
bullet of the last item in the group.

To select sequential items using the keyboard
1. Select the first or last item in the group you want to select.

2. Hold down the SHIFT key, and use the UP ARROW or DOWN ARROW key to extend the selection to the 
other items you want to include.

To select nonsequential items
1. Select a single item or a group of items.

2. While you hold down the CTRL key, click the item bullet corresponding to each of the additional items 
you want to select.

Or 
Point to the left of the item bullets, hold down the SHIFT key, and drag a dotted outline around the 
bullets corresponding to the group of additional items you want to select.



Promoting, Demoting, and Moving One Or More Items

You can promote or demote any item or group of items in an outline from one outline level to another.    
You can also move items within an outline.    You can promote, demote, and move outline items in all Ecco
views.

Ecco uses the following rules to control promoting, demoting, and moving items.

When you promote, demote, or move a parent item, all its sub-items are relocated along with it.
You can demote an item to no more than one level below the preceding item in the outline.
You can promote an item to no more than one level above the following item in the outline.
When you promote, demote, or move multiple nonsequential items, all the items move to the 

same level and location.    Relationships between parent items and sub-items that are part of the selection
are preserved.

If you are using the advanced features of Ecco Professional, promoting, demoting, or moving a top-level 
item might affect its folder assignment.    

To promote, demote, or move items using the mouse
You can promote, demote, or move an item by dragging its item bullet with the mouse.

1. Select the item or items you want to promote, demote, or move.    

2. Drag the item bullet of one of the selected items.
As you drag, a horizontal black marker shows you the location to which the selection will move when 
you release the mouse button.

Drag left to promote the selected items.
Drag right to demote the selected items.
Drag up or down to move the selected items.

3. When the horizontal black marker is in the location you want, release the mouse button.

You can promote, demote, or move the selected items using the following key and Item menu commands.

Result
Item Menu 
Command Key Command

Moves selection 
up one item

Move: Up ALT+UP ARROW

Moves selection 
down one item

Move: Down ALT+DOWN ARROW

Promotes 
selection (moves
it up) one level

Move: Left SHIFT+TAB or 
ALT+LEFT ARROW

Demotes 
selection (moves
it down) one 
level

Move: Right TAB or ALT+RIGHT 
ARROW

You can also move items using the Cut and Paste commands on the Edit menu.

Tip    If you want to move a parent item independently of its sub-items, promote the sub-items so they are 
on the same level as the parent.    Then you can move the original parent item without affecting its former 
sub-items.



Deleting Items

You can delete one or more outline items from any Ecco view.

To delete one or more items
You can delete items when you no longer need them.

1. Select the item or items you want to delete.    

2. From the Edit menu, choose either the Cut command or the Delete Items command.
Or 
Press CTRL+D.

If you are using the advanced features of Ecco Professional and if a top-level item has been added to 
more than one folder, Ecco asks you whether you want to delete the item from the active folder or from all
folders.

If a sub-item has been added to any folder, Ecco asks you whether you want to delete the sub-item from 
all folders.    

Tip    If you want to delete a parent item independently of its sub-items, promote the sub-items so they are
on the same level as the parent.    Then you can delete the original parent item without affecting its former
sub-items.



Entering Information in Columns

Depending on the template you use to create your file, a Show/Hide Columns button might appear in the 
right-most corner of your outline view. Choose this button to display or hide the Column pane on the right 
side of your outline view.    Use the cells in the Column pane to enter additional information for items.    For
example, you might use columns to add notes concerning each of the items in your task list.    

If you are using the advanced features of Ecco Professional, you can take advantage of columns to add 
dates, pop-up lists, numbers, and Gantt charts, as well as supply headings for columns.    

To enter information in a column
The columns displayed when you choose the Show Columns button depend on the template you are 
using.    One or more columns will have headings, and the remaining columns will be displayed without 
headings.    

1. Choose the Show Columns button.

The Column pane appears at the right side of the window.

2. To enter additional information about an item in the outline, click a cell in a column on the same line 
as the item.

Or
Press the F11 key to move the selection to the Column pane, and then press the ENTER key.

Ecco displays a value edit box in which you can enter information.    

3. Enter your information in the value edit box.

If you have selected a cell in a column without a heading, you can type any text in the value edit box.  
If you type more characters than will fit in the box, the text scrolls up so you can continue to enter 
information.

If you have selected a cell in a column with a heading, Ecco might display a value edit box requiring a
type of information other than text, such as a date or number.

4. When you have entered the information, press the ENTER key or choose the ENT (Enter) button.

The value edit box disappears, and Ecco displays only the amount of text that fits into the displayed 
column cell.

Whenever you show columns in this outline view, the information you have entered in the column will be 
displayed along with the item.



Viewing an Outline

To make it easy to display summary or detailed outline information, Ecco lets you expand and collapse 
items in an outline to display your desired level of detail.    Items for which there are hidden sub-items 
appear with a triangle next to the item bullet.

Using the mouse, you can expand and hide the sub-items under a specific parent item.

Result
Item Menu 
Command

Mouse 
Technique

Key 
Comman
d

Hides all sub-
items

Show Sub-
Items: Hide

Double-click 
item bullet of 
expanded 
item

CTRL+H

Expands 
hidden sub-
items

Show Sub-
Items: 
Expand

Double-click 
item bullet of 
collapsed 
item

CTRL+E

Expands all 
sub-items

Show Sub-
Items: All 
Subs

ALT+double-
click

Expands only 
the sub-items 
one level 
below the 
selected item

Show Sub-
Items: 1 
Level Only

CTRL+double-
click

To control the level of detail displayed throughout an outline, you can display the Show Levels dialog box 
on your screen.

To use the Show Levels dialog box
The Show Levels dialog box gives you an easy way to expand or collapse all or part of an Ecco outline.

1. From the Item menu, choose the Show Levels command.

Or 
Press CTRL+W.

The Show Levels dialog box appears.    

2. Select one of the following options in the Show Levels dialog box:

"All" to display the entire outline to the level you specify.
"Selected" to display the selected parts of the outline to the level you specify.    This option lets 

you view items expanded to this level in a specific part of the outline.
"Unselected Only" to display the parts of the outline not selected, to the level you specify.    This 

option lets you view detail on one part of the outline while hiding detail for the rest.
3. Choose one of the numbered level buttons to expand or collapse items in the outline based on the 

option you selected.

The Show Levels dialog box remains displayed on your screen until you close it.    You close it by 
double-clicking its system menu (the horizontal bar in the upper left corner of the box) or by pressing 



the ESC key.



About Outline Labels

By default, each item in an Ecco outline in an outline view is labeled with a numeral.

You can define a set of custom labels to identify the levels of any outline view outline.    For example, you 
could use uppercase letters for level 1 items, lowercase letters for level 2 items, and so on.

You can give each outline a distinctive set of labels, or you can give a name to a set of labels, save the 
set, and apply it to many outlines.

If you are using the advanced features of Ecco Professional, you can apply outline labels to the folders in 
the Folder window.    By default, outline labels for folders are not displayed.

Use the Outline Labels command on the Format menu to:

Create a set of custom labels that you can apply to any outline.
Display or hide outline labels, omit a label, or restart the labeling sequence.
Rename, delete, or reorder named labels.



Creating Outline Labels

When you create a set of outline labels, you can:

Use Roman or Arabic numerals and uppercase or lowercase numbers.
Add prefix or suffix characters (such as brackets, periods, or any characters you want to use).
Make labels cumulative, so each item includes the labels of all the levels above it.    For example, 

the second third-level item in an outline might be labeled 1.1.2.
Give a name to a set of labels, so you can easily reapply it to any outline.
Base a new set of labels on an existing set.
To create a set of outline labels

You can create labels to identify the levels of an outline.

1. From the Format menu, choose Outline Labels, and then choose New.

The Outline Labels dialog box appears.

2. In the Rename box, type a name for the set of labels.

Ecco adds this name to the Outline Labels menu.

3. Select one or more outline levels.

4. Make any of the following changes.

Select a label from the Label box.
Select or type a prefix or suffix in the Prefix or Suffix box.
Select the "Cumulative" checkbox to make each item in the selected levels include the labels of 

all the levels above it.
Choose the Based On button to use an existing set of labels as the basis for part or all of the new

set.
5. When you have finished specifying your outline labels, choose the OK button.



Displaying Outline Labels

In some situations you might want to change the way outline labels are displayed.    For example, in a 
simple, one-level outline you might find labels distracting.    You might want to include unlabeled, blank 
items in your outline to create space between sections.    Or you might want to restart the numbering 
sequence in the middle of the outline.

Choose Outline Labels from the Format menu, and then use the following commands to change the way 
labels are displayed.

Result
Format: Outline Labels 
Command

Displays or hides all 
outline labels

Show Labels

Hides or displays the 
label for the selected 
item or items

Skip Label

Restarts the alphabetical
or numerical label 
sequence at the selected
item

Restart Sequence

Managing Outlines

In addition to creating multiple outline views, Ecco lets you edit or rename existing outlines, delete 
outlines, and reorder outlines on the Outlines menu.    You can perform all these tasks from the Manage 
Named Outlines dialog box.

To manage outline views
1. From the View menu, choose Outlines, and then choose Manage.

The Manage Named Outlines dialog box appears.

2. Take one or more of the following actions.

To rename an outline, select the outline you want to rename, and then type in the Rename box 
the new name you want to give the outline.

To delete an outline, select the outline you want to delete, and then choose the Delete button.
To reorder outlines on the menu, select the outline or outlines you want to move, and then choose

either the Up or Dn reorder button.
3. When you are through, choose the OK button.



Printing an Outline

When you print an outline in an outline view, you can control the amount of information printed as well as 
the way the printed output looks.    You have the following options.

Print all items in the outline.
Print only the selected items in the outline.
Print only items from specified outline levels.
Omit or print sub-items that are not displayed.
Omit or print item bullets.

You can specify whether and how to print columns associated with the outline.    Ecco also lets you add 
headers and footers to an outline, set margins, and specify the number of copies to print.

To print an outline from an outline view
You can print an outline and choose a variety of options.

1. If you want to print selected items only, select the items.    

2. If you want to omit sub-items, collapse the items in the outline so the sub-items are not 
displayed.

3. From the File menu, choose Print.
The Print Outline View dialog box appears.    This dialog box displays the settings used the last time 
an outline was printed.    

4. Select the "Print All Items" checkbox or the "Print Selected & Subs Only" checkbox.

5. Select or deselect the "Print Items to Level," "Skip Hidden Subs," and "Print Item Icons" checkboxes 
as desired.

6. Change the settings in the Columns area as needed.    

7. If you want to print a title for the outline, type the text for the title in the Title Text box.

The title appears centered at the top of the first page and as part of the footer on subsequent pages.

8. If you want to print the date or page numbers in the footer for each page, select "Print Date" and 
"Print Page Numbers."

The date appears in the lower right corner of each page, and the page number appears in the lower 
left corner.

9. If you want, specify margin sizes in the Margin in Inches area, and specify a number of copies in the 
Copies box.

The margins refer to the outline text.    Headers and footers fall inside the margins specified.    Ecco 
restricts your input to the limits of the Windows printer driver you are using.

10. Choose the OK button to print the outline using the settings you specified.



Looking Ahead: Integrating Outlines with Other Views

Here are some ways in which you can integrate your outline views with other Ecco views and features to 
manage your information more productively.    You can:

Format text using outline styles, character formatting, and text touch-ups.    

Associate values with items using columns.    You can use columns to add database-type fields to 
every item in a view.    

Add an item to multiple outlines using folders.    You can place the same information item in any 
number of Ecco folders at once.    Use folders to collect and cross-reference similar items.    

View information from other views in an outline.    

Share outlines with others over a network.    

Use the Shooter to move information between an outline view and other programs without leaving
Ecco.    

Import (and export) information from other programs into an outline view.    



For more information, see Adding Outline Notes to an Appointment.



An outline in the Calendar view



For more information, see Adding Outline Notes to an Entry.



An outline in the PhoneBook view



For more information, see Creating New Outlines.



An outline in an outline view



For more information, see About Folders in Outline Views.



For more information, see Promoting, Demoting, and Moving One Or More Items.



For more information, see Viewing an Outline.



For more information, see Outline Styles.



For more information, see Printing an Outline.



For more information, see The Outline View Window.



For more information, see Understanding Folders.



For more information, see Adding Folders to an Outline View.



For more information, see Adding Items to an Outline.



For more information, see Managing Outlines.



For more information, see Importing to Other Ecco Views.



A selected outline item



For more information, see Removing Items from an Outline View.



Note    You can cancel selection of multiple items by clicking on the text of any item or to the left of any 
item.



When you point to the left of an item bullet, the pointer changes to a dotted selection box.



Note    If an outline in an outline view includes more than one folder, you can move items between folders.



For more information, see About Item Levels.



For more information, see Selecting Single Items and Selecting Multiple Items. 



For more information, see Selecting Single Items and Selecting Multiple Items. 



For more informationabout adding items to and removing them from folders, see About Adding Items to 
Folders or Introduction to Removing Items from Folders.



For more information, see Introduction to Columns.



In columns, enter additional information about items.



An outline with collapsed items



Default outline labels



Custom outline labels



Note    You can also perform these actions on named outline labels from the Manage Outline Labels 
dialog box.    To display this dialog box, from the Format menu choose Outline Labels, and then choose 
Manage.



For more information about selecting    multiple items, see Selecting Multiple Items.



For more information, see About Formatting.



For more information, see Introduction to Columns.



For more information, see Understanding Folders.



For more information, see About Folders in Outline Views.



For more information, see About Workgroup Computing.



For more information, see The Shooter: Sending Information to and from Ecco.



For more information, see Importing and Exporting.



For more information, see Adding Folders to an Outline View.



For more information, see Entering Values in Columns.



Using the Tool Bar

Click a book to expand or collapse the outline.
            Tool Bar Features  
            Displaying or Hiding the Tool Bar  
            Adding Buttons to the Tool Bar on the Fly  
            Adding Drop-Down Menus to the Tool Bar  
            Rearranging the Tool Bar on the Fly  



Tool Bar Features

Use the Ecco tool bar for quick access to commands. 

Ecco's tool bar provides the following features.
Any command from any of Ecco's menus has a predefined button that can be used on the tool 

bar.
The last accessed menu command is always displayed in the repeat box at the far right of the tool

bar.
At any time, you can drag the button in the repeat box to any position on the tool bar using the 

right mouse button.
At any time, you can simply click the repeat box to repeat the last command.
Every one of Ecco's cascading menus has a corresponding button that you can add to the tool 

bar as a drop-down menu.
All user-defined menu items, such as named outline views, named text-touch ups, named outline 

labels, etc., also have predefined buttons that can be added to the tool bar displaying the user-defined 
name.

Up to three rows of tool bars are supported for the Ecco application window in addition to up to 
three rows for each individual view.

You can display or hide tool bars instantly with a single click of the mouse on the status bar 
button.

You can instantly remove or rearrange tool bar buttons using the right mouse button.
You can insert spaces between buttons to visually organize related groups using SHIFT+the right 

mouse button.
You can drag a group of buttons to a new position using CTRL+the right mouse button.

Buttons give you easy access to commands for common tasks like the following.

Quickly move from one view to another by adding buttons that represent the PhoneBook view,
the Calendar view, or any outline view. You can choose multiple views from one button; for instance, you 
could use a drop-down menu button that corresponds to the Outlines command to choose any of the 
outline views you have created.

Instantly apply text styles to outline text by adding buttons for specific fonts and point sizes to 
your outline view tool bar. You can choose multiple styles from one button; for instance, you could add a 
drop-down button that corresponds to the Font command and then use it to choose any of the available 
fonts.

Display only the information you need by adding buttons for a Filters or Forms menu or for 
individual filters or forms (available only if you are using the advanced features of Ecco Professional). 



Displaying or Hiding the Tool Bar

You can display a tool bar at the top of the Ecco program window. You can also display tool bars at the 
top of the view windows. Each tool bar can contain up to three rows of buttons.

You can also display a tool bar in the Shooter. The Shooter tool bar, which appears at the top of the 
screen when other software programs are active, can also contain up to three rows. 

You can toggle the display of the tool bar on and off using the Show/Hide tool bar button located on the 
right side of the Status bar.

To display or hide the tool bar
Click the Show/Hide tool bar button in the status line.

The tool bar will be displayed (or hidden if it was previously displayed).

To change the number of tool bar rows
You can increase the number of rows displayed in a tool bar or remove a tool bar from a view altogether, 
depending upon your preferences.

1. From the Tools menu, choose Tool Bar.

The Tool Bar dialog box appears. 

2. In the Row box, select the number of rows you want displayed in the tool bar.

3. Choose the OK button.



Adding Buttons to the Tool Bar on the Fly

When you begin using Ecco, you see some of the most commonly used buttons in the Ecco program 
window tool bar. These include buttons for the views, for saving the file, and for often-used editing 
commands. 

You can:
Add buttons to the tool bar by using the right mouse button to drag the commands from the 

repeat box onto the tool bar. The repeat box is located in the right-most position on the tool bar of your 
Ecco program window.

Copy buttons by using the right mouse button to drag them from one tool bar to another. 
Delete buttons from the tool bar by using the right mouse button to drag them off the tool bar.

Choose the repeat box to instantly repeat previous commands. When you choose a command in Ecco, 
notice that the button displayed in the repeat box reflects your choice. 

To add a button to the tool bar
You can add buttons directly to a view's tool bar as well as to the tool bar for the Ecco program window. 
Be sure the appropriate view is displayed before you begin.

1. Choose a command from any of Ecco's menus. A corresponding button appears in the repeat box on 
the far right of the tool bar.

To display a button in the repeat box without executing the corresponding command, choose the 
command from the appropriate menu so that the command button is displayed in the repeat box. 
Then drag the mouse off the menu before you release the mouse button.

2. Use the right mouse button to drag the command button from the repeat box to the desired position 
on the tool bar.

The command button appears where you have positioned it on the tool bar.

Note    Alternatively, you can add a button by choosing menu commands. From the Tools menu, choose 
Tool Bar, and then choose the Add/Arrange Icons button. Then follow the instructions in the Description 
box. (You cannot use this method for adding buttons to the Shooter toolbar).



Adding Drop-Down Menus to the Tool Bar

You can directly add any cascading (or hierarchical) menu accessible from anywhere within Ecco to the 
tool bar as a drop-down menu. For example, rather than choosing the Format menu, and then the Font 
menu, and then Helvetica, you could add the cascading Font menu to the tool bar and simply choose 
Helvetica directly from that drop-down menu.

Similarly, if you're using the advanced features of Ecco Professional, you could add the cascading Filter 
menu directly to the tool bar and have instant access to all the filter commands and named filters. 

Also note that Ecco has many user-defined names that appear on its cascading menus, such as named 
outline views, named text touch-ups, and named outline labels. You can directly add any of these 
individual named menu commands to the tool bar, giving you instant access to that command. For 
example, you could add a button to your tool bar for any particular named outline view; clicking on that 
button would open the view.
You can add these user-defined menu commands to the tool bar just as you would add any other 
command by choosing the menu command and then dragging the command button from the repeat box 
with the right mouse button. The first several characters of the user-defined name will appear in the 
button to identify the command.

To add a cascading menu to the tool bar
1. From any main Ecco menu, choose the menu command that brings up the cascading menu.

The button for the first menu item in the cascading menu appears in the repeat box at the far right of 
the tool bar.

2. Click outside the menus to dismiss them.

3. Click the up arrow attached to the repeat box.

The button for the cascading menu appears in the repeat box (note that buttons for cascading menus 
have a white triangle in their lower right corner).

4. Use the right mouse button to drag the menu button from the repeat box onto the tool bar.



Rearranging the Tool Bar on the Fly

Ecco makes rearranging the buttons on a tool bar simple. You can:

Rearrange command buttons by dragging them, using the right mouse button.
Arrange command buttons into groups, and then move these groups as single objects by 

dragging them while pressing CTRL+ the right mouse button.
Add or delete spaces between command buttons by pressing SHIFT+ the right mouse button when

the mouse cursor is positioned between the command buttons.
Note    Alternatively, you can add and delete spaces or rearrange groups using menu commands. From 
the Tools menu, choose Tool Bar, and then choose the Add/Del Spaces button or the Arrange Groups 
button. Then follow the instructions displayed in the Description box.



For more information, see The Tool Bar.



For more information, see Displaying the Shooter.





For more information, see The Tool Bar.



A drop-down menu from a tool bar button



For more information about filters, see About Filters.



Formatting Items

Click a book to expand or collapse the outline.
            About Formatting  
            Outline Styles  
            Character Formatting  
            Text Touch-Ups  



Formatting Items

Click a book to expand or collapse the outline.
            About Formatting  
            Outline Styles  
            Character Formatting  
            Text Touch-Ups  

About Text Touch-Ups
Creating Text Touch-Ups
Applying Text Touch-Ups
Managing Text Touch-Ups



About Formatting

To control the way the text in your Ecco file looks, you use formatting.    You can format text in every Ecco 
view.    You can apply formatting attributes such as bold, underline, color, or italics to add emphasis or call 
attention to special points.    You can change the font and the point size to enhance readability or create 
special effects.    You can create outline styles that differentiate between levels in an outline.

There are three ways to format information in Ecco.    The method you use depends on what you're trying 
to accomplish.

Outline styles let you apply distinctive formatting to each outline level quickly and consistently.    
Outline styles help you differentiate between the levels in your outlines.    The outline styles you create 
apply only to the active view.    

Character formatting is useful for formatting a single item, sentence, or word.    If you format an 
item that appears in more than one place, the formatting will appear wherever the item does.    For 
example, if you format an item as bold, then wherever the item shows up in an Ecco view, it will be 
displayed as bold.    

Text touch-ups are groups of character-formatting attributes that are named and stored.    Text 
touch-ups let you apply multiple formats quickly and repeatedly.    

Tip    To speed up your work, you can customize the tool bar so that it contains the formatting commands 
you use most frequently.    



Outline Styles

An outline style is a set of character-formatting attributes that apply to a particular outline level.    Using 
different outline styles for each level makes it easier to visually distinguish between outline levels.    For 
instance, you could format every first-level item as 10-point, bold, and Helvetica.    You could format every 
second-level item as 10-point, italic, and Times New Roman.    The outline styles you create apply to the 
active view only.

To format using outline styles
You can define an outline style for each level in your outline.    Once you define the outline style, Ecco 
applies the style to all items of the same level in your outline.

1. Select an item or items that represent the outline level or levels you want to format.

2. From the Format menu, choose Outline Styles.

The Outline Styles dialog box appears.    

3. Select the formatting attributes you want.

4. Choose the Apply button.

Ecco applies the style to all items of the same hierarchical level in your outline.

To reapply an outline style
You can reapply an outline style to an item or word that has already been formatted with a character 
format.

1. Highlight the text to which you want to reapply the outline style.

2. From the Format menu, choose Character.

The Character dialog box appears.

3. Choose the Reapply button.



Character Formatting

You use character formatting to change the font, point size, style, or color of text without affecting the 
outline style.    You can apply one or more of the attributes you want at a time.

To format characters
1. Highlight the word or item you want to format.

2. From the Format menu, choose Character.

The Character dialog box appears.    

3. Select the formatting attributes you want.

4. Choose the Apply button.

Note    To apply a single format, you can simply highlight the text you want to format and choose from the 
Format menu the attributes you want.



About Text Touch-Ups

A text touch-up is a group of character-formatting attributes that you name and store.    Use text touch-ups
to override, without changing, your outline styles.    Text touch-ups can streamline your work.    You can 
apply text touch-ups in every Ecco view.

Suppose you want to make particular items that appear throughout your file stand out.    You could create 
a text touch-up that applies bold and italic formatting simultaneously, and you could apply the text touch-
up to highlighted text wherever you need it.    Because you name text touch-ups and add them to the Text 
Touch-Ups menu, you can use them again and again.    Ecco saves your named text touch-ups when you 
save a file.    



Creating Text Touch-Ups

You can create a new text touch-up by specifying in the New Named Text Touch-Up dialog box the 
formatting attributes you want.

To create a text touch-up
1. From the Format menu, choose Text Touch-Ups, and then choose New.

The New Named Text Touch-Up dialog box appears.    

2. In the Name box, type the name you want to give the text touch-up.

3. Select the formatting attributes you want.

If you want Ecco to ignore font, size, or color when applying the text touch-up, do not select an option 
in the corresponding list boxes.    If you want Ecco to ignore any of the style attributes, do not select 
the corresponding checkboxes.

4. Choose the Apply Button.



Applying Text Touch-Ups

Once you create a text touch-up, you can apply it to text anywhere in Ecco.

To apply a text touch-up
1. Highlight the text to which you want to apply a text touch-up.

2. From the Format menu, choose Text Touch-Ups, and then choose the named text touch-up you want 
to apply.

Ecco applies the text touch-up to the selected text.



Managing Text Touch-Ups

In addition to creating and applying text touch-ups, Ecco lets you edit or rename existing text touch-ups, 
delete text touch-ups, or reorder text touch-ups on the Text Touch-Ups menu.    You can perform all these 
tasks from the Manage Text Touch-Ups dialog box.

To manage named text touch-ups
1. From the Format menu, choose Text Touch-Ups, and then choose Manage.

The Manage Text Touch-Ups dialog box appears.    

2. Take one or more of the following actions:

To rename a text touch-up, select the touch-up you want to rename, and type in the Rename box 
the new name you want.

To create a new text touch-up, choose the New button.
To edit a text touch-up, select the touch-up you want to edit, and then choose the Edit button.
To delete text touch-ups, select the touch-ups you want to delete, and then choose the Delete 

button.    
To reorder text touch-ups on the menu, select the touch-ups you want to move, and then choose 

either the Up or Dn reorder button.
3. When you are through, choose the OK button.



For more information, see Outline Styles.



For more information, see Character Formatting.



For more information, see Text Touch-Ups.



For more information, see Adding Buttons to the Tool Bar on the Fly.



You can use different outline styles for each level of your outline.



Note    To bypass the Outline Styles dialog box, select an item or items that represents the outline level or 
levels you want to format, and then hold down the CTRL key while you choose from the Format menu the 
attributes you want.



Use character formatting to change selections of text.



Finding Items

Click a book to expand or collapse the outline.
            About Finding Items  
            Searching the Active View for Items  
            Searching the Entire File for Items   
            Using the Search Results View  
            Finding and Replacing  



About Finding Items

When you need to find a specific word or string of text anywhere in your Ecco file, you can use the Find, 
Find Next, and Find/Replace commands. To quickly find a specific word or string of text, use the Find 
command.  To replace all instances of a specific word or string of text with other text, use the 
Find/Replace command. 

 Using the Find and Find/Replace commands, you can:
Find a specified string of text in order to reformat, edit, delete, promote, or demote it.
Update all instances of the specified string of text with a different string of text.
Add to the Search Results view all items that contain the text.
If you are using the advanced features of Ecco Professional, you can apply a filter to find only 

items that match the filter criteria you specify. 

Ecco will find the string of text for which you are searching even if the searched items are located in a 
hidden outline level.

Note    While the Find dialog box is open, you can promote and demote items, apply formats, edit text, 
and perform other tasks using menu commands. For example, you could select all items containing the 
word "urgent" and format them as red-colored text or promote them to the leftmost level.



Searching the Active View for Items

Using the Find command to search for items in the active view, you can:

Highlight the next instance of the specified text.
Select all items in the active view that contain the specified text.
Add all instances of the specified text to the Search Results view.
To highlight the next instance of specified text

You can use the Find command to search for text in the Calendar view, the PhoneBook view, and outline 
views. Use this procedure to quickly find and highlight the next instance of specified text in the active 
view.

1. From the Edit menu, choose Find.

The Find dialog box appears.

2. In the Find box, type the text you want to find.

Or
Click the down arrow and select from the list of previous searches.

3. Choose the Find button to highlight the next occurrence of the specified text.

4. Continue choosing the Find button to highlight the next occurrences.

5. When you are through using the Find dialog box, from the Control menu, choose Close.

Or
Press ESC or ALT+F4.

To search the active view for text
You can use the Find command to search for text in the Calendar view, the PhoneBook view, and outline 
views. Use this procedure to specify options for controlling your search.

1. From the Edit menu, choose Find.

The Find dialog box appears.

2. In the Find box, type the text you want to find.

Or
Click the down arrow and select from the list of previous searches.

3. Choose the Unfold button (>>) to expand the Find dialog box.

The Find dialog box expands, displaying additional options.

4. To highlight all items in the view that contain the specified text, beside Actions, select the "Select All in
View" option.

5. To copy all occurrences of the specified text to the Search Results view, select the "Copy to 'Search 
Results' view" option. Then select one of the following options:

To replace the contents of the Search Results view with the newly found items, select Replace.
To append the newly found items to the end of the Search Results view, select Append. 

6. Choose the Find button.

Ecco highlights all items in the active view that contain the specified text, or Ecco displays the Search 
Results view, which contains the results of your search.



7. When you are through using the Find dialog box, from the Control menu, choose Close.

Or
Press ESC or ALT+F4.



Searching the Entire File for Items 

You can use the Find command to search for, and collect in the Search Results view, all items that 
contain a specified string of text. This lets you gather similar items together into one view.

To search an entire file for items 
Ecco searches all views and displays the results of the search in the Search Results view.

1. From the Edit menu, choose Find.

The Find dialog box appears.

2. In the Find box, type the text you want to find.

Or
Click the down arrow and select from the list of previous searches.

3. Choose the Unfold button (>>) to expand the Find dialog box.

The Find dialog box expands, displaying additional options.

4. Beside "Scope," select the "Entire File" option.

5. Beside "Copy to 'Search Results' view," select one of the following options:

To replace the contents of the Search Results view with the newly found items, select "Replace."
To append the newly found items to the end of the Search Results view, select "Append."

6. Choose the Collect All button.

Ecco displays the Search Results view, which contains the results of your search. 

7. When you are through using the Find dialog box, from the Control menu, choose Close.

Or
Press ESC or ALT+F4.



Using the Search Results View

The Search Results view allows you to collect and work with similar items, all in one place. For example, 
you could use the Find command to collect all items having do with an employee. Once you collected 
them, you could review them, edit them, or copy them to an outline view if you wanted to preserve the 
results of the search.

The Search Results view is an outline view. You can add items to the Search Results view just as you can
in any outline view. 

When you add a new item to an Ecco view other than the Search results view, that new item will not 
automatically appear in the Search Results view, even if it matches the search criteria. To update the 
Search Results view to include the new item, you would need to use the Find command again.



Finding and Replacing

When you need to change specific text, you can search for it and replace it. You can automatically replace
all matching text, or you can selectively replace text, on a case-by-case basis. You can search the active 
view only, or you can search an entire file.

To replace text
Use this procedure to find specified text and replace it with different text.

1. From the Edit menu, choose Find/Replace.

The Find and Replace dialog box appears. 

2. In the Find box, type the text for which you want to search.

Or
Click the down arrow and select from the list of previous searches.

3. In the Replace box, type the text with which you want Ecco to replace the found text.

Or
Click the down arrow to select from the list.

4. Beside "Scope," select one of the following:

To search and replace in the active view only, select the "Current View" option.
To search and replace throughout the entire file, select the "Entire File" option.

5. Choose the Find button.

Ecco highlights the first occurrence of the text.

6. To replace the text, choose the Replace button.

Or
To leave the text unchanged and search for the next occurrence, choose Find.

7. Repeat steps 5 and 6 to search for and replace subsequent occurrences of the text.

Or
Choose the Replace All button to replace all occurrences of the text without confirmation (rather than 
conducting one search at a time).

8. When you are through using the Find and Replace dialog box, from the Control menu, choose Close.

Or
Press ESC or ALT+F4.



For more information, see Finding and Replacing.



For more information, see Searching the Active View for Items and Searching the Entire File for Items.



For more information, see Finding Column Information with Filters.



Note    Alternatively, to highlight the next occurrence of the text last searched for without opening the Find 
dialog box, from the Edit menu, choose Find Next.



For more information, see Using the Search Results View.



The green-shaded items are context parents items that do not meet the search criteria but appear
in the Search Results view to provide context.



Using Ecco with Other Programs

Click a book to expand or collapse the outline.
            About Using Ecco with Other Programs  
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            Linking and Embedding OLE Objects  
            Working with Disk Files  



Using Ecco with Other Programs
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Using Ecco with Other Programs

Click a book to expand or collapse the outline.
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Importing to Other Ecco Views
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Using Ecco with Other Programs
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Using Ecco with Other Programs

Click a book to expand or collapse the outline.
            About Using Ecco with Other Programs  
          
 The Shooter: Sending Information to and from Ecco
            Importing and Exporting  
            Linking and Embedding OLE Objects  
            Working with Disk Files  

Introduction to Working with Disk Files
Inserting Files and Directory References into Ecco
Launching Other Programs from Ecco



About Using Ecco with Other Programs

You can use Ecco to create and organize a vast amount of information for almost any purpose.    But you 
can do more than this.    You can use Ecco to create powerful connections with the other programs and 
documents you use.    Ecco lets you move information between programs with ease and use other 
programs without leaving Ecco.    This enables you to use Ecco as the control center for all the work you 
do on your computer.    

Moving Information Between Programs
You can move information between Ecco and other programs using the import and export features and 
the Shooter, which is a tool that lets you move information between programs with one easy step.    Using 
the Shooter, you can copy individual items from another program directly into Ecco views, copy 
information from Ecco into other programs, and copy information between any two programs that are 
running while Ecco is running.    The Shooter provides a quick way to get information from electronic-mail, 
word-processing, or spreadsheet programs into the right location in your Ecco file.    

If you are using the advanced features of Ecco Professional, you can copy information directly into Ecco 
folders. 
Using the import and export features, you can move large quantities of information into or out of Ecco.    

Using Other Programs from Within Ecco
You can directly access other programs while you are using Ecco.    You can:

Embed OLE objects (graphics, charts, spreadsheets, and so forth) within Ecco items, or link 
objects to items.    OLE is a dynamic link between the data in an Ecco file and a file that contains the 
same data in another program.    Changes to the file in the program are reflected in the data linked to it in 
the Ecco file.    OLE lets you take advantage of the functionality of any program without forcing you to first 
leave Ecco.    

Insert references to program or document files within Ecco items, and launch programs or 
documents from those items.    

Any information from other programs that you add to Ecco behaves like any other Ecco item.    For 
example, you can promote and demote the imported information in an outline.

If you are using the advanced features of Ecco Professional, you can add imported items to any number 
of folders and apply forms and filters to them.    



Introduction to the Shooter

The Shooter is a tool that lets you place information from other programs into Ecco, or from Ecco into 
other programs, with one easy step.    You can also use the Shooter to send information between two 
other programs.    The arrow-shaped Shooter icon appears by default in the upper left corner of the active 
program window at all times while Ecco is running.

You can send information to or from word-processing, database, spreadsheet, drawing, mailing, painting, 
and other types of programs.    You can send almost any type of information using the Shooter.    For 
example, you might send a picture created in your painting program to illustrate a section of an Ecco 
outline, or you might send information from an internal electronic-mail memo straight to a new 
appointment item in your calendar.

Using the Shooter, you can copy information between programs, create links between Ecco and other 
programs, and embed objects from other programs into Ecco.

Copying information with the Shooter produces the same results you would get if you copied 
using the Windows Clipboard.    The Shooter is simply a faster and more efficient way to copy.    For 
example, you can send selected information from your current program to any Ecco view without 
choosing the Copy and Paste commands and without leaving your program.

When you embed into an Ecco file information from another program, you can edit and format the
information in the program you used to create it.    Information that you embed is called an embedded 
object.    For example, by embedding a graphic in Ecco, you can open the painting program in which you 
created the graphic and make changes to the graphic from within an Ecco view.    

When you link an Ecco file to source information that is located in a file in another program, any 
changes you make to the source information are immediately reflected in the linked Ecco file.    For 
example, you might link a spreadsheet file to Ecco so that when the spreadsheet changes you see the 
new information in Ecco.    



Displaying the Shooter

By default, the Shooter icon appears on your screen at all times while Ecco is running.

The Shooter has a tool bar that can help speed up your work.    You can customize the tool bar to include 
the commands you most frequently use.    

If you are using the advanced features of Ecco Professional, you can display the Folder window in the 
Shooter so that you can add information from other programs to your Ecco folders. You can display or 
hide the tool bar and the Folder window, resize the Shooter display, or move or hide the Shooter icon.

To change the Shooter display
1. Switch to any program running while Ecco is running.    If the Shooter icon is not visible, from the 

Tools menu in Ecco, choose Show Shooter.

2. Click the Shooter icon.

The Shooter menu appears.

3. From the Shooter menu, choose Show.

4. Choose one of the following commands:

To display the Shooter tool bar, choose Tools.
To display the Shooter icon only, choose Icon.
If you are using the advanced features of Ecco Professional, to display the Shooter tool bar and 

the Ecco Folder window, choose the Tools and Folders command.

To hide or display the Shooter icon
From the Tools menu in Ecco, choose Show Shooter.

The Shooter icon is displayed or removed from display.

Note    Alternatively, you can hide the Shooter icon by doing the following: From the Shooter menu, 
choose Show, and then choose Hide Shooter.



Sending Information to Ecco

Using the Shooter, you can move information from other programs into Ecco without switching to Ecco.    

You can send information to any Ecco file and to any Ecco view.
You can send information relative to the last piece of information you sent to Ecco.    You can send

information subordinate to, superior to, or to the same level as the last piece of information sent.    This 
feature makes it easy to build an outline or to show the relationship between selections as you're sending 
information to Ecco.

If you are using the advanced features of Ecco Professional, you can send information to any 
Ecco folder. You can also send information to several folders at one time, while associating numbers, 
other text, or dates with it, by using Ecco forms. 
You send information to Ecco in one of three formats as editable text, as an OLE object, or as an OLE 
link. When you send information to Ecco as editable text, you can format it, edit it, and manipulate it just 
as you would text created in Ecco.    You can also send text or graphics as OLE objects or OLE links.    

To send information to Ecco
1. If the Shooter icon is not visible, from the Tools menu in Ecco, choose Show Shooter.

2. In any other program, select the source information (text or a graphic) that you want to send to Ecco.

3. Click the Shooter icon.

The Shooter menu appears.

4. Choose one of the following commands from the Shooter menu:

To send the selected information to the active view or the Calendar view in Ecco, choose the 
corresponding command.

To send the selected information to Ecco relative to the last information you sent, do the following:
Choose Relative to Last, and then choose the option you want.

If you are using the advanced features of Ecco Professional, to send the selected information to a
folder, choose Folders, and then click a folder name in the Folder window. 

If you are using the advanced features of Ecco Professional, to add the selected information by 
form, choose Add By Form, and then choose the named form you want.    

If you chose Ask Before Sending, Ecco displays either the Send Text Selection As or the Send 
Graphics Selection As dialog box.    



Sending Information from Ecco

Ecco makes it easy to copy information created in Ecco to other programs.    For example, you might 
create notes in the PhoneBook view while talking to a client on the phone.    You could then send those 
notes directly to your word-processing program to form the basis of a letter addressing your client's 
concerns.

To send information to another program from Ecco
1. Select the items you want to send.

2. Click the Shooter icon.

The Shooter menu appears.

3. From the Shooter menu, choose Other Program.

Ecco lists only those programs that are currently active and that can have text or graphics pasted into 
them from the Windows Clipboard.

4. Choose the name of the program to which you want Ecco to send the information.

Ecco inserts the information into the selected program's active file at the insertion point.



Sending Information Between Non-Ecco Programs

You can send text and graphics between almost any two programs that are running while Ecco is running.
For example, you could send text created in your word-processing program to your electronic-mail 
program to avoid retyping information.

Sending text from one program to another works like copying and pasting but in one easy step.    When 
you click the Shooter icon, the Shooter copies the selected text to the Windows Clipboard, switches to the
destination program, and then pastes the copied text into the active file.

Sending a graphic embeds the graphic in the destination file if the destination program supports OLE 
objects. Otherwise, sending a graphic pastes the graphic into the destination file.    When you embed into 
a destination file a graphic from another program, you can edit and format the graphic in the program you 
used to create it.    When you paste into a destination file text from another program, you can work with it 
only in the destination program.

To send information between other programs
1. Select the text or graphic you want to send.

2. Click the Shooter icon.

The Shooter menu appears.

3. From the Shooter menu, choose Other Program, and then choose the name of the program to which 
you want Ecco to send the information.

Ecco switches you to the destination program and inserts the information at the insertion point.



Setting Shooter Preferences

You can change the settings of the Shooter using the Preferences command on the Shooter menu.    
Under Preferences, you can switch to or open another Ecco file to which you want to send information.    
You can specify how you want text and graphics sent and whether you want Ecco to confirm before 
sending.    For example, if you want to send all information to Ecco as editable text and you don't want 
Ecco to display the Send Text As dialog box each time you send, you can specify these settings on the 
Shooter menu.

To set Shooter preferences
You can set your Shooter preferences from within any program other than Ecco.

1. Click the Shooter icon.

The Shooter menu appears.

2. From the Shooter menu, choose Preferences, and then choose one of the following commands from 
the Shooter menu.

To switch to another open Ecco file, select Choose Ecco File, and then choose the Ecco file to 
which you want to switch.    To open an Ecco file that isn't currently open, choose Open Another.

To send all text as editable text or as linked or embedded OLE objects, choose Send Text As, and
then choose the appropriate option.

To send all graphics as linked or embedded OLE objects, choose Send Graphics As, and then 
choose the appropriate option.

To display or hide the Send Text Selection As dialog box when sending text, choose Send Text 
As, and then choose Ask Before Sending.



Introduction to Importing and Exporting

You use importing and exporting to move database, spreadsheet, or text information between Ecco and 
any file.    For example:

If you are converting information from another personal information manager, you can export your
entire phonebook from that program and import it into Ecco.    

To do a mail merge, you can export selected records from Ecco in a mail-merge format to your 
word-processing program.    

To move information into or out of your spreadsheet, you can import or export information in a 
columnar format.    

To move information into the PhoneBook view or an outline view, you can import an entire file.    You can 
import files in either of two formats, tab-delimited text or (comma-separated values). (CSV).    A tab 
delimited file contains fields or categories of information separated by tabs.    A CSV file contains fields 
enclosed in quotation marks and separated by commas.    Most personal information manager, database, 
and spreadsheet programs allow you to save files in these formats.

You can export your work in Ecco for use in other programs by using the Export command on the File 
menu.    You can export information in any of several formats: Ecco to Ecco, tab-indented, CSV, tab-
delimited, and mail-merge.    You can export information for a mail merge to the following word-processing
programs: Microsoft Word for Windows, Lotus® AmiPro®, WordPerfect® for Windows, and any other 
program that uses standard mail-merge formats.



Importing to the PhoneBook

When you import a file into the PhoneBook view, you can specify the fields in the original file you want to 
include in the PhoneBook view as well as where to include them.

Normally, names and other identifying information will appear as items in the PhoneBook view.    
Addresses, phone numbers, and most other typical information will appear in the PhoneBook entry form.   
New fields you create will appear in columns in the PhoneBook view.

To import a file into the PhoneBook view
1. Switch to the PhoneBook view.    

2. From the File menu, choose Import.

The File Import dialog box appears.    

3. In the List Files of Type box, select the file type you want to import.

4. In the File Name box, type or select the name of the file you want to import.

5. Choose the OK button.

Ecco displays the Choose Fields for Import into PhoneBook dialog box, which displays the field 
names located in the file you want to import.    You use this dialog box to select the fields you want to 
import into the Ecco PhoneBook view.

6. If you want, click the Sample buttons to move through the file one record at a time.

7. In the Field Name box, select a field you want to import into the Ecco PhoneBook view.

8. In the Choose a Destination box, select a destination for the field.

If you do not want to import the information in the selected field, select <Ignore>.
If you want the information in the selected field to appear as part of the item for this PhoneBook 

name, select <Full Name>, <Last Name>, <First Name>, or <Middle Name>.
If you want the information in the selected field to appear as a particular field in the PhoneBook 

form, or if you want the information in the selected field to appear in an existing PhoneBook column or in 
another existing Ecco text column, select a field name without angle brackets.    

If you want to create in the PhoneBook view a new column that displays the information in the 
selected field, select <New Field> and then type a name in the Rename New Field box.
9. Repeat steps 7 and 8 for each additional field you want to import.

10. When you have specified a destination for each field you want to import, choose OK.

Ecco imports the information in the file to the destinations you specified.



Importing to Other Ecco Views

When you import a file into an outline view, you can import both item text and column information.    Ecco 
lets you specify which columns in the view you want to import to.    If the file you are importing has a mail 
merge header (if the first row of the file contains field names), you can use the header to create new 
columns to import to.    If the file does not have a mail merge header and you'd like to import information 
into columns, you can choose the fields you want to import and the columns you want to import them to.   

Although you can't import directly into the Calendar view, you can import information into an Ecco outline 
view that contains date columns. By default, any information you import into a date column will appear in 
the Calendar view.    

To import a file into an outline view
1. Switch to an outline view.    

2. From the File menu, choose Import.

The File Import dialog box appears.    

3. In the List Files of Type box, select the file type you want to import.

4. In the File Name box, type or select the file you want to import.

5. Choose the OK button.

Ecco displays the Import into Current View dialog box.    

6. Under "Insert imported items" select an option.

To place the imported information at the bottom of the outline, select the "At bottom of outline" 
option.

To place the imported information after and at the same level as the currently selected item, first 
select the "after currently selected item" option, and then select the "Same as selected item" option.

To place the imported information after and subordinate to the currently selected item, first select 
the "after currently selected item" option, and then select the "Subordinate to selected item" option.
7. If you are importing information into columns, select the "Import file has columnar data" option.

You will probably use this option if you are importing a file from a spreadsheet or database.    

8. If the file you are importing has a mail merge header that you want to use to create new columns, 
select the "Create new columns using mail merge header" option.    

If you want to use existing Ecco columns if they match the fields in the file, select the "Use existing 
columns if matching names found" option.

9. To choose the columns you want to import to, select the "Choose column for each field" option, and 
then choose the Choose button.    

Ecco displays the Choose Columns for Import Fields dialog box, which displays the field names in the
file you want to import.    You use this dialog box to select the fields you want to import into the Ecco 
outline view.

10. If you want, click the Sample buttons to move through the file one record at a time.

11. In the Import Field list, select an import field you want to import into the Ecco outline view.

12. In the Choose a Column box, select a destination for the import field.    The first import field is 
automatically designated as item text.

If you do not want to import the information in the selected import field, select <Ignore>.
If you want the information in the selected import field to appear in a particular column in the 

outline view, select that column.



If you want to create a new column in the outline view to import the selected import field to, select
a field name with angle brackets and then type a name in the Rename Column box.    For example, to 
create a new text column, select <New Text Field> and then type a name for the text field in the box.    

 
13. Repeat steps 11 and 12 for each additional field you want to import.

14. When you have specified a destination for each field you want to import, choose the Continue button.

15. Choose the OK button.

Ecco imports the information in the file to the destinations you specified.



Exporting from the PhoneBook View

You can use the Export command on the File menu to export PhoneBook entries to another program.    
For example, you might export your PhoneBook to a database, or you might export PhoneBook entries to 
a word-processing program and use the program's mail-merge feature to print form letters.

To export from the PhoneBook
1. Switch to the PhoneBook view.

2. From the File menu, choose Export.

The Export PhoneBook dialog box appears.

3. Under "Items To Export" select an option:

To export all entries in your PhoneBook, select the "Entire PhoneBook" option.
To export only those entries collected in the PhoneBook list, select the "Items currently in View" 

option.
To export only selected items, select the "Selected Items Only" option.    

4. Select one of the format options:

To export information to a word-processing program in a format that you can use to do a mail 
merge, select one of the mail-merge options.

To export the PhoneBook to a spreadsheet or database, select the "CSV (comma-separated)" 
format.

To export only names and outline notes to a word-processing program, select the "Outline Only 
(tab indented)" format.

To export names, column information, and outline notes, select CSV (+ tab indented notes).
To export to another Ecco file, select the "Ecco to Ecco" format.

5. If you are doing a mail merge or if you plan to import your PhoneBook information back into Ecco at a 
later time, select the "Mail Merge Header" option if it is not already selected.

6. In the "Export to file" box, type a name for the file you want to export.

Or
Choose the Browse button and then select a file to export to.

7. Under "Choose Field Set," select "<Create Set...>." 

The Choose Field Set dialog box appears.    You use this dialog box to select the PhoneBook fields 
you want to export.

8. In the Choose Fields list, select a field you want to export.

When exporting the address fields, Ecco will export either the business or home address for each 
entry based on which option is selected in the PhoneBook entry form.

9. Choose the Add button.

The field appears in the Fields Chosen list.

10. Repeat steps 8 and 9 for each additional field you want to export.

11. When you are through specifying fields, choose the OK button.

12. Choose the OK button.

The PhoneBook is exported to the file you specified.

Note    To add the field set to the menu, in the Choose Field Set dialog box, select the "Add Field Set to 
Menu" option and then type a name in the Name box.    The field set will appear under Choose Field Set 



in the Export PhoneBook dialog box.



Exporting from an Outline View

When exporting from an outline view, you can export all items in the view, selected items only, or items 
plus information in columns.

To export from an outline view
1. Switch to the outline view you want to export.

2. From the File menu, choose Export.

The Export Outline dialog box appears.

3. Under Items To Export select an option:

To export all items, including sub-items, in your outline, select the "All Items in View" option.
To export only selected items, select the "Selected Items" option.    

To export selected items plus their sub-items, select the "Selected Items and Subs" option.
4. Select one of the format options:

To do a mail merge, select one of the mail-merge options.
To export the outline, including information in columns, to a spreadsheet or database, select the 

"CSV (comma-separated)" format.
To export only outline items to a word-processing program, select the "Outline Only (tab 

indented)" format.
To export to another Ecco file, select the "Ecco to Ecco" format.

5. In the "Export to file" box, type a name for the file you want to export.

Or
Choose the Browse button and select a file to export to.

6. Choose the OK button to export your outline.

Or
To export information in columns, follow the instructions described in the following procedure.

To export an outline view with columns
Before beginning this procedure, follow the steps described in the preceding procedure.

1. In the Export Outline dialog box, choose the Columns button.

The Export Outline and Columns dialog box appears.

2. Under Choose Column Set, select <Create Set...>.

The Choose Column Set dialog box appears.    You use this dialog box to choose the columns you 
want to export.

3. In the Choose Columns list, select a column you want to export.

4. Choose the Add button.

The column appears in the Columns Chosen list.

5. Repeat steps 3 and 4 for each additional column you want to export.

6. When you are through selecting columns, choose the OK button.

7. Choose OK again.

The outline is exported to the file you specified.



Note    To add the column set to the menu, in the Choose Column Set dialog box, select the "Add Column 
Set to Menu" option and then type a name in the Name box.    The column set name will appear under 
Choose Column Set in the Export Outline and Columns dialog box.



Exporting from the Calendar View

To export Calendar view information, place the Appointments folder or a date folder into an outline view 
and then export the outline.     



Connecting with Other Information Managers and Hand-held 
Devices

Arabesque has teamed up with IntelliLink Corporation to provide a powerful connectivity program that 
allows Ecco and your palmtop to share information quickly, conveniently, and intelligently.    Far more than 
a simple file transfer utility, IntelliLink actually recognizes and understands the file formats of Ecco and the
supported palmtops, and can thus translate data directly from one to the other.

By providing personal information portability, IntelliLink dramatically increases the usefulness of both your 
palmtop and your personal computer.    For example, IntelliLink allows you to:

Translate data back and forth between Ecco and your palmtop, freeing you from the drudgery of 
having to re-enter data.

Transfer your Calendar, PhoneBook, or outline information from Ecco to your palmtop prior to a 
meeting or a business trip.    While on the road, enter or update the information.    When you return home, 
IntelliLink will automatically transfer the updated information directly into Ecco.

Back up palmtop files directly to your personal computer.
Simple data transfer capabilities between palmtops and personal computers are commonly available.    
IntelliLink, on the other hand, is an intelligent data sharing system that provides not only data transfer 
capability, but data translation, data reconciliation, data filtering, and various data mapping options as 
well.    Collectively, these data sharing capabilities are referred to as SmartMerge  technology.    It is this 
SmartMerge technology that makes IntelliLink such an effective data sharing tool.

The combination of Ecco and IntelliLink is an even more powerful information sharing technology.    
Arabesque has done substantial work to optimize the links between Ecco and IntelliLink.    For example, 
changes to appointment dates, times, or text in your palmtop are automatically reconciled with your Ecco 
Calendar.    No other Personal Information Manager or Windows application provides such tight 
integration with IntelliLink.    This is in keeping with Arabesque's goal to enhance the quality and 
productivity of our customers' lives by keeping their information management tasks simple and powerful.

How to Obtain IntelliLink
Send in your Ecco registration card today and call the toll-free Arabesque Customer Inquiry number at 1-
800-457-4243 to ask for your free copy of the IntelliLink software for Ecco.    With this software, you'll be 
able to communicate between your personal computer and the following palmtops:

HP 95LX
Sharp Wizard

For information on how to obtain the appropriate cables as well as how to purchase additional 
functionality (for example, communication between Ecco and other palmtops, other Personal Information 
managers, or other Windows applications), contact IntelliLink directly at the following address:

IntelliLink Corporation
98 Spit Brook Road
Suite 12
Nashua, NH 03062

(603)888-0666
(603)888-9817 (fax)



Introduction to Linking and Embedding

OLE is a Windows term that stands for object linking and embedding.    An OLE object is a piece of 
information from one program that is used by another program.    OLE objects can be text, spreadsheet 
figures, graphics, charts, or other types of information.    You can link and embed OLE objects in any of 
several ways.

Create a link or embed an object quickly and easily using the Shooter. 

Copy information in another program and use the Paste Special command on the Edit menu to 
link or embed it.    To embed any graphic as an OLE object, you can choose the Paste command on the 
Edit menu.

Create an embedded object "from scratch" by using the Insert command on the Edit menu.    For 
example, to create a simple graphic and embed it in Ecco, you can choose Insert from the Edit menu, and
then choose your graphics program from the menu.    Your graphics program opens, allowing you to 
create the graphic without leaving Ecco.
When you embed an object in Ecco, you place information created in another program into Ecco.    
Embedding is similar to copying, but with an important distinction if you need to change the embedded 
object, you can double-click the object, and the original program will open allowing you to change the 
information.    You don't need to switch back and forth between programs to finish your work.

When you link an object, you make not a copy, but a reference, or link, to the source file in which the 
object is located.    When you edit an embedded object, you make changes to the object in the program it 
was created in but not in the source file, because the embedded object is just a copy.    However, when 
you edit a linked object, you make changes to the source file.
If you want an object to appear in several documents and if you want changes made to the object in one 
place to be reflected every place the objects exists, you should link it.    If you don't want changes made 
reflected everywhere an object exists, then you should embed the object.    
For example, you might move a spreadsheet chart into your Ecco file but later add new figures to the 
spreadsheet figures that affect the chart.    If you want all such changes to the spreadsheet reflected in 
the chart you've inserted into Ecco, you should insert the chart as an OLE link.    If you don't want the 
chart to change after you place it in Ecco, you should insert the chart as an OLE object.

Embedding an object into your Ecco file or linking an object to your file has many benefits.    By using OLE
you can:

Extend Ecco's performance
you can work in programs that support OLE from within Ecco.    

Concentrate on a task by collecting in one location
an Ecco file
all the tools you need to complete the task.    You can open the program from within Ecco, make your 

changes, and continue working without interruption.
Update all linked objects in your Ecco file.    

Note    If you make changes to a linked object from Ecco, the changes appear in the source file.



Embedding OLE Objects

You can embed an object in Ecco any of three ways.

Embed existing information from another program into Ecco using the Shooter. 
Embed an object into Ecco using the Paste Special Command on the Edit menu.    (For graphics, 

you can use the Paste command on the Edit menu.) 
Start from Ecco and create an embedded object "from scratch" by using the Insert command on 

the Edit menu.

Note    The program you want to embed information from must be capable of treating information as OLE 
objects.    Ecco's OLE options are not available when you use a program that is not an OLE server.

To embed an existing object in Ecco using the Shooter
1. Select the information (object) you want to embed in Ecco.

2. From the Shooter menu, choose Preferences, and then choose Send Graphics As.

3. Choose OLE object.

Or
Choose Ask Before Sending.

4. Using the Shooter, send the object to Ecco.

If you chose Ask Before Sending, Ecco displays either the Send Text Selection As or the Send 
Graphics Selection As dialog box, in which you should select the "OLE Object" option.    

To create and embed an object from within Ecco
You can use this procedure to create an embedded object "from scratch" while Ecco is the active window.

1. Move the insertion point to the position in the Ecco file at which you want to embed the new object.

2. From the Edit menu, choose Insert, and then choose the program with which you want to create the 
embedded object.

The program opens.

3. Create the object.

4. When you have created the object, quit the program.

Ecco asks you whether you want to update the embedded object or save changes before proceeding.

5. Choose the Yes button.

The program window closes and the Ecco window, containing the new embedded object, reappears.



Editing Embedded Objects

You edit an embedded object from within the program it was created in, without affecting the source file.

To edit an embedded object
1. Double-click the embedded object.

Or
Select the object and, from the Edit menu, choose Objects, and then choose Edit.

The program with which you created the object opens, displaying the object.

2. Make any changes you want.

3. When you have made all your desired changes, quit the program.

Ecco asks you whether you want to update the embedded object in your Ecco file before proceeding.  

4. Choose the Yes button.

The program window closes and the Ecco window, containing the edited embedded object, 
reappears.

Note    If you embed an existing object and then edit it from Ecco, those changes are not saved in the 
original source file.



Linking OLE Objects

You can link an object from another program to Ecco in either of two ways: using the Shooter, or by using 
the Paste Special command.    

To create an OLE link using the Shooter
1. Select the information you want to link to Ecco.

2. From the Shooter menu, choose Preferences, and then choose Send Graphics As.

3. Choose OLE Link.

Or
Choose Ask Before Sending.

4. Using the Shooter, send the object to Ecco.

If you selected Ask Before Sending, Ecco displays either the Send Text Selection As or the Send 
Graphics Selection As dialog box, in which you can select the "OLE Link" option.    

Note    Alternatively, you can copy information in another program, switch to Ecco, and then link the 
information to Ecco by using the Paste Special command on the Edit menu.



Editing OLE Links

You edit a linked object from within the file in which it was originally created (the source file).    

To edit a linked object
1. Double-click the linked object.

Or
Select the object and, from the Edit menu, choose OLE Links to display the Links dialog box.    Select 
the link you want to edit, and then choose the Edit button.

The source file opens.

2. Make any changes you want.

3. When you have made all your changes, quit the program.

The program asks whether you want to save changes before proceeding.

4. Choose the Yes button.

The program closes and the Ecco window reappears, displaying the updated linked object.



Updating Links

Once a link has been created, you have two options for updating it.    Ecco can update links automatically, 
or you can update links manually.

Normally, Ecco updates links automatically.    If Ecco is running and the file is open, changes in 
the linked file are reflected immediately in Ecco.    If Ecco is not running when changes are made, Ecco 
asks whether you want to update the links when you open an Ecco file.

You can set any link so that you must update it manually.    Use this option to control the updating 
of information more carefully.

To set links to update manually
1. From the Edit menu, choose OLE Links.

The Links dialog box appears.

2. From the "Link" list, select a link you want to update manually.

3. Change the Update option to "Manual."

4. Choose the OK button.

To update links manually
1. From the Edit menu, choose OLE Links.

The Links dialog box appears.

2. From the Link list, select the links you want to update.

3. Choose the Update Now button.

Ecco updates the selected links.



Changing Links

Once you've linked an OLE object to Ecco, you can change the link so the object is linked to a different 
file.    For example, suppose you link a spreadsheet to Ecco and then save the updated spreadsheet 
under a different name.    You can change the linked item in Ecco so it continues to reflect the most 
current information.

To change a link
1. From the Edit menu, choose OLE Links.

The Links dialog box appears.

2. From the Link list, select the link you want to change.

3. Choose the Change Link button.

The Change Link dialog box appears.

4. From the File Name list, choose a new file to which to link.

5. Choose the OK button, and then choose the OK button again to close the Links dialog box.



Resizing Linked or Embedded Objects

You can change the size of a linked or embedded object by dragging the handle on its bottom border.

Alternatively, you can use menu commands to maximize the object, minimize it, or restore it to a previous 
size.

To resize a linked or embedded object
1. Select the object you want to resize.

2. Drag the handle in the lower right corner of the object.

Or
Click the button in the upper left corner of the object, and then take one of the following actions:

To reduce the selected object to a minimized size, choose Minimize.
To return an object to its previous resized state, choose Adjusted Size.
To return an object to its original size, choose Original Size.



Deleting Linked or Embedded Objects

You delete linked and embedded objects just as you delete any other item in Ecco.

To delete an OLE object
1. Select the object you want to delete.

2. From the Edit menu, choose Delete Items.

The object is deleted from the file.

Or
If the Delete Items dialog box appears, choose OK to delete the object entirely from the file.    



Introduction to Working with Disk Files

You can create items representing files on your disk and treat them as you would any other item.    You 
can also launch these files and their associated programs from within Ecco.    For example, you might 
insert into your outline for this week's meeting a reference to a word-processing file that contains an 
important report you'll be presenting.    When you view the meeting outline, you can launch that report file 
in your word-processing program directly from Ecco.    

If you are using the advanced features of Ecco Professional, an item that contains a file reference can be 
added to other Ecco folders, making the file available to you in many other contexts.

Because you can make references to files in items, Ecco can function as a file and program manager.    
Using the Get Disk Files command on the Tools menu, you can insert filenames, executable programs, 
and even entire directories into Ecco.

When you insert a reference to a file into Ecco using the Get Disk Files command, you are pasting the 
path, including the name, of that file or directory into Ecco.    Each file or directory reference you insert 
becomes an item with all the capabilities of any other Ecco item.

Once you have inserted a file reference, you can use the Launch command to run any file or executable 
program from within Ecco.    When you have inserted a directory reference, you can use the Launch 
command to open the directory and then launch any of that directory's files.



Inserting Files and Directory References into Ecco

You can insert references to individual files or groups of files into Ecco in either of two ways.

You can browse through your directory structure from within Ecco and select a file to insert.
You can open the File Manager and select one or more files or directories to insert into Ecco.

You can launch any file from its file reference in Ecco by choosing the Launch command on the Tools 
menu.    

To insert a reference to one file into Ecco using Browse
1. Select the item below which you want to insert the item with a file reference.

2. From the Tools menu, choose Get Disk Files, and then choose Browse.

3. In the Choose File Name to Paste dialog box, select the name of the file you want to reference, and 
then choose OK.

Ecco inserts an item with a file reference below the selected item.

To insert a reference to multiple files or directories into Ecco using the File 
Manager
1. Select the item below which you want to insert the item that contains references to a group of files.

2. From the Tools menu, choose Get Disk Files, and then choose From File Manager.

3. If Ecco displays a message, choose OK.

If you want, you can avoid viewing this message in the future by selecting the "Don't show this 
message again" option.

The File Manager window opens.

4. Select the files or directories for which you want to insert references.

For information on navigating in the File Manager and selecting files and directories, refer to your 
Microsoft Windows User's Guide.

5. Click the Shooter icon.

The Shooter menu appears.

6. From the Shooter menu, choose the view to which you want to send the files.

If you are using the advanced features of Ecco Professional, you can also select a folder to which you
want to send the files.

Ecco inserts references to the selected files or directories.



Launching Other Programs from Ecco

Once you have inserted a reference to a file into Ecco, you can launch it.    When you launch a document 
file, Ecco starts the program and then opens the file.    

To launch a file
1. Select the reference to the file you want to launch.

2. From the Tools menu, choose Launch.

Ecco launches the file.    If the file no longer exists, Ecco gives you the option of searching for an 
existing file and updating the reference with the new filename.

To launch a file within a directory
1. Select the reference to the directory that contains the file you want to launch.

2. From the Tools menu, choose Launch.

The Choose File To Run dialog box appears, open to the proper directory.

3. From the File Name box, select the name of the file you want to launch.

4. Choose the OK button.

Ecco launches the file.



For more information, see The Shooter: Sending Information to and from Ecco.



For more information, see Understanding Folders.



For more information, see Importing and Exporting.



For more information, see Linking and Embedding OLE Objects.



For more information, see Working with Disk Files.



For more information about forms, see Forms. For more information about filters, see Filters and Sorting.



The Shooter icon displayed in the File Manager title bar



For more information, see Embedding OLE Objects.



For more information, see Linking OLE Objects.



Tip    To hide or display the Shooter icon, from the Tools menu, choose Show Shooter.



For more informationabout customizing the tool bar, see Adding Buttons to the Tool Bar on the Fly.



Note    You can drag the Shooter to any location on your screen.    The Shooter will be displayed in this 
location every time you open Ecco until you change the location.    If you drag the Shooter to the active 
program's title bar, it will always maintain the same position relative to the current active program.



Tip    Double-click the Shooter icon to return the Shooter display to its former state.    For example, if the 
tool bar and the Folder window were displayed before you chose Icon Only, double-click the Shooter icon 
to redisplay them.

To resize the Shooter display, position the pointer over the border in the lower right corner of the Shooter 
display.    When the pointer changes to a double-headed arrow, drag the border until the display is the size
you want.



For more information, see Linking and Embedding OLE Objects.



For more information, see About Forms.



For more information about Shooter preferences, see Setting Shooter Preferences.



Sending PhoneBook information from Ecco to another program



For more information, see Importing to the PhoneBook.



For more information, see Exporting from the PhoneBook View.



For more information, see Exporting from an Outline View.



For more information, see Introduction to Columns.



For more information, see Introduction to Columns.



For more information, see Date Columns.



For more information, see Introduction to Columns.



For more information about column types, see Using Column Types (and Folder Types).



For more information about selecting items, see Selecting Multiple Items.



For more information about selecting items, see Selecting Multiple Items.



For more information about adding folders to a view, see Adding Folders to an Outline View. For more 
information about exporting an outline, see Exporting from an Outline View.



For more information, see The Shooter: Sending Information to and from Ecco.



A graph embedded in an Ecco outline



For more information about sending information with the Shooter, see Sending Information to Ecco.



Note    Alternatively, you can copy information from another program, switch to Ecco, and then embed the 
information in Ecco by using the Paste Special command on the Edit menu.



Note    The program you want to link information from must be capable of treating information as OLE 
objects.    Ecco's OLE options are not available when you use a program that is not an OLE server.



For more information about sending information with the Shooter, see Sending Information to Ecco.



Note    If a file contains manually updated links, when you save or close the file, Ecco asks you whether 
you want to update the links.



For more detailed information on deleting items, see Deleting Items.



An item containing a filename and a path



For more information, see Launching Other Programs from Ecco.



Note    When you insert references to multiple files or a directory into Ecco from the File Manager, each 
reference appears as a separate item.



Note    Document files must be associated with a program before Ecco can launch them.    You can 
associate files with programs in the File Manager.



Folders
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Folders  
            Adding Items to Folders  
            Viewing Items in Folders  
            Understanding an Item's Context  
            Removing Items from Folders  
            Setting Up Folders  
            Folder Values and Folder Types  
            Under the Hood: Item Levels  
            Looking Ahead: Organizing and Accessing Information  



Folders
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Folders  

Understanding Folders
Examples of Ways to Use Folders
The Folder Window
Using Folders: An Overview
Using Folders, Slide Show (Interruptible)

            Adding Items to Folders  
            Viewing Items in Folders  
            Understanding an Item's Context  
            Removing Items from Folders  
            Setting Up Folders  
            Folder Values and Folder Types  
            Under the Hood: Item Levels  
            Looking Ahead: Organizing and Accessing Information  



Folders

These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Folders  
            Adding Items to Folders  

About Adding Items to Folders
Typing Items
Adding an Item to Additional Folders

            Viewing Items in Folders  
            Understanding an Item's Context  
            Removing Items from Folders  
            Setting Up Folders  
            Folder Values and Folder Types  
            Under the Hood: Item Levels  
            Looking Ahead: Organizing and Accessing Information  



Folders
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Folders  
            Adding Items to Folders  
            Viewing Items in Folders  

About Folders in Outline Views
Creating a New Outline View
Adding Folders to an Outline View
Removing Folders from an Outline View

            Understanding an Item's Context  
            Removing Items from Folders  
            Setting Up Folders  
            Folder Values and Folder Types  
            Under the Hood: Item Levels  
            Looking Ahead: Organizing and Accessing Information  



Folders
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Folders  
            Adding Items to Folders  
            Viewing Items in Folders  
            Understanding an Item's Context  

Viewing an Item's Context
Understanding Context Parents
Viewing an Item's Folders

            Removing Items from Folders  
            Setting Up Folders  
            Folder Values and Folder Types  
            Under the Hood: Item Levels  
            Looking Ahead: Organizing and Accessing Information  



Folders
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Folders  
            Adding Items to Folders  
            Viewing Items in Folders  
            Understanding an Item's Context  
            Removing Items from Folders  

Introduction to Removing Items from Folders
Removing Items Using the Folder Window
Removing Items from an Outline View

            Setting Up Folders  
            Folder Values and Folder Types  
            Under the Hood: Item Levels  
            Looking Ahead: Organizing and Accessing Information  



Folders
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Folders  
            Adding Items to Folders  
            Viewing Items in Folders  
            Understanding an Item's Context  
            Removing Items from Folders  
            Setting Up Folders  

Introduction to Setting Up Folders
Ecco Default Folders
Ecco Templates

Creating Folders
Organizing the Folders in the Folder Window
Renaming Folders
Deleting Folders

            Folder Values and Folder Types  
            Under the Hood: Item Levels  
            Looking Ahead: Organizing and Accessing Information  



Folders
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Folders  
            Adding Items to Folders  
            Viewing Items in Folders  
            Understanding an Item's Context  
            Removing Items from Folders  
            Setting Up Folders  
            Folder Values and Folder Types  
            Under the Hood: Item Levels  

About Item Levels
Item Levels and Folders
Using Context Parents

            Looking Ahead: Organizing and Accessing Information  



These advanced features of Ecco Professional are available with full menus only.

If you are using the advanced features of Ecco Professional (Full Menus), you can display the Folder 
window at the right side of the Ecco program window.    To view the Folder window, from the Advanced 
menu, choose Show Folder Window.    (To hide the Folder window, choose the Close button, located in 
the upper left corner of the Folder window.) Click green text to view more information.



If you are using the advanced features of Ecco Professional (Full Menus), you can display the Folder 
window at the right side of the Ecco program window.    To view the Folder window, from the Advanced 
menu, choose Show Folder Window.    (To hide the Folder window, choose the Close button, located in 
the upper left corner of the Folder window.)

Click green text to view more information.



Folders    In the Folder window, you can add new folders and edit, rearrange, or select existing folders.   



Folder menu    Choose commands from this menu to switch between Assign and Edit modes, to add or 
delete folders, to change folder types or properties, to assign by keys, or to make folders public. 



Folder buttons    Checkmarks on these buttons indicate that the selected items in the active view have 
been added to these folders.    



Zoom button    Click this button to display, hide, or resize the Folder window.



Close button    Click this button to close the Folder window.



Understanding Folders
These advanced features of Ecco Professional are available with full menus only.

Ecco folders are like the paper folders in your file drawers: They allow you to collect related items of 
information so that you can look at or change those items in one place.    Just as you'd collect all papers 
and receipts related to insurance in a paper folder labeled "Insurance," with Ecco you could also create a 
folder, name it "Insurance," and then use it to collect information related to insurance.    Then, at any time, 
you could look at the contents of that "Insurance" folder and see all the information you've collected 
related to insurance.

One unique feature of Ecco's folders is that you can place the same information item in any number of 
Ecco folders at once, just as though you were placing a live, dynamic, photocopy of a receipt into many 
paper folders.    Folders are the ideal tool for managing the large volume of diverse information that 
confronts you every day.

Definitions: Items, Folders, and Views
Before you begin to work with Ecco folders, it's important that you understand more precisely three simple
Ecco concepts:    Items, folders, and views.

Items are the basic element of information in Ecco.    Every line in an outline, every name in the 
PhoneBook, and every appointment in the Calendar is an item.    Put another way, every line of text or 
graphics with a blue bullet (an item bullet) to its left is an item.

Folders are containers of items used to collect and cross-reference related items.    Whenever 
you create items in any of Ecco's views, you are actually adding them to a folder.    For example, when 
you create an appointment in the Calendar, Ecco automatically adds that appointment item to a folder 
named Appointments.    Similarly, whenever you add a name to your PhoneBook, Ecco automatically adds
that name to the PhoneBook folder.    You can also add any item (or items) to any number of additional 
folders.

Views are windows showing one or more folders and the items in those folders.    The PhoneBook
view, for example, displays the PhoneBook folder and all of the items (names) in that folder.    Outline 
views can display the items in one or more folders of your choice.
The following illustration shows items in a folder in an outline view.

Classifying and Cross-Referencing Diverse Information
As you manage information, you often confront two major problems:

You need to classify your information by type.
You need to put the same information in several places.

Ecco provides solutions to both of these problems.

Problem 1: The need to segregate or classify your information
As you're confronted with new information every day, you need many different places to put the many 
different kinds of information, just as you use many different paper folders in your file drawers.    Consider 
the following ways of segregating your information.

Action items
Each individual project (or even each project phase)
Each of your coworkers
Things to discuss with Bob
Things to discuss with your boss
Information sources (periodicals, consulting firms, wire services)
Major outstanding issues
Geographical locations (for example, regional offices)
Features of competitive products



Solution: Ecco folders
Ecco allows you to create a large number of folders that you can use at will to collect items of information 
that you determine to be related.    Putting an item into a folder is as easy as typing it into an outline view 
or dragging it into a folder.    You can arrange folders hierarchically so you have access to any particular 
folder, and you can easily move, delete, or add new folders as necessary.    You can name folders any 
way you want.

If you are using the advanced features of Ecco Professional (Full Menus), you can create and organize 
folders in the Folder window by choosing Show Folder Window from the Advanced menu.    

Problem 2: Putting the same piece of information into several folders
Consider the following example: As you're working on your July report, you realize you need western 
region sales figures from Frank.    You'd like to be reminded of this need when you're reviewing the 
following:

Pending issues in the "Pending With Frank" folder.
Uncompleted tasks in the "July Report" folder.
Open issues in the "Western Region" folder.
Action items in the "Action Items" folder.

Solution: Ecco folders
This is an ideal task to represent the strength and flexibility of Ecco folders.    Suppose you are working in 
an outline that has a "July Report" folder.    As you type new items into your outline, these items are added
automatically to the July Report folder.    When you realize that you need the western region sales figures 
from Frank, you do the following:

1. In the current outline, you type the item "Get western region sales figures from Frank."
2. You drag this item into each of the following three folders in the Folder window: Pending With Frank, 

Western Region, and Action Items.
Note that when you drag an item from an outline into a folder in the Folder window, it remains in the 
outline as well.

When you look at the contents of the "Pending With Frank" folder, you see all the items you need to 
discuss with Frank, including this new item.    Similarly, when you look at the contents of the "Western 
Region," "Action Items," and "July Report" folders, you see the item from those perspectives as well.

Any changes to this item (or any of its sub-items) in any of the folders will be reflected in all the folders in 
which it appears.    It's easy to view the items in any folder at any time by simply dragging that folder from 
the Folder window into any outline view.    



Examples of Ways to Use Folders
These advanced features of Ecco Professional are available with full menus only.

Ecco allows you to create new folders as easily as you would add items to an outline.    Like items, you 
can arrange folders in an outline to create a logical and visible structure.

Consider the following three typical users and their information management needs.

Bob, an administrative assistant for a large corporation, creates an outline of tasks to be done.    Items in 
the outline need to be collected together in the following groups: items that need to be reviewed by a 
coworker; items related to a particular project; and items that need an immediate resolution.    

Bob sets up his Ecco folders so that he can view items in any of these contexts, together with the other 
items of that type, without delay.

Stephanie, a lawyer, puts together an outline that shows the logical flow of a case.    When she interviews 
a witness, Stephanie wants to easily review all the points that pertain to that witness.    She needs to be 
able to view the outline information from two perspectives: according to its degree of value to the case 
and as a set of problematic points, drawing information from other cases.

Pat, a research chemist, gathers information for each type of experimental procedure, chemical 
compound, and institution she works with.    As she creates outline notes on journal articles, she records 
the important points in each article in several places.    When she wants a summary of her reading on a 
specific compound, all the relevant information is available in one place.

Each of these people needs to cross-reference items in order to view the information contained in the 
items in multiple contexts.



Using Folders: An Overview
These advanced features of Ecco Professional are available with full menus only.

The basic steps for using folders are described in the following procedures.

To display the folder window
1. To display the Advanced menu, from the Tools menu, choose Show Full Menus.

The Advanced menu appears.

2. From the Advanced menu, choose Show Folder Window.

The Folder window appears.    

To create and name folders
Select the folder preceding the position in which you want to insert the folder.

1. From the Folder menu, choose Edit Folders.

2. Press the ENTER key to create a new folder.

3. Type a name for the folder.

4. Reorganize the folders as you would any outline item.

To add items to folders
Drag any item with a blue item bullet to any folder in the Folder window.

The item is added to the folder and remains in the view as well.

To view a folder's items
Drag any folder from the Folder window into any outline view  .  
The folder and its items appear in the outline view.

To remove a folder from an outline view
Drag the folder into the Folder window.

The folder and its items are removed from the view.

Click here to see the Quick Tour slides on using folders.



About Adding Items to Folders
These advanced features of Ecco Professional are available with full menus only.

You add items to folders in Ecco in any of the following ways.

Type new items into any Ecco view to automatically add them to a folder.    

Drag items from a view into a folder in the Folder window. The items are added to the folder and 
remain in the view as well.    

Select an item and choose a folder button in the Folder window.    

Note    Alternatively, you can add items to folders by adding checkmarks or values to folder columns in the
Column pane.    



Typing Items
These advanced features of Ecco Professional are available with full menus only.

You can add items to folders by typing them into a view. As you type, Ecco adds the items to folders as 
described in the following table.

Type of Item Folder
Calendar appointment Appointments

Calendar tickler item 
(created in the Tickler 
section)

Date folder of your choice

PhoneBook name PhoneBook

Outline view item Folder above the item in the 
outline view

Adding an Item to Additional Folders
These advanced features of Ecco Professional are available with full menus only.

To cross-reference an item, you can add it to additional folders. For example, you might want to put the 
item "Get manager's approval for first draft of ad copy" into your "Manager" folder, your "First Drafts" 
folder, and your "Ad Copy" folder.

You can add one or more items to one or more folders at the same time.

To add items to folders
You can add items to folders by dragging the items into the Folder window or by using the folder options 
pop-up menu. To display the Folder window, you must be using the advanced features of Ecco 
Professional (Full Menus).

1. If the Folder window is not displayed, from the Advanced menu, choose Show Folder Window.

2. Switch to the view that contains the items you want to add to folders.

You can add items from any view to any folder or group of folders.

3. Select the item you want to add by clicking it.

You can select a single item, multiple items in sequence, or nonsequential multiple items.    

4. Drag the items into a folder in the Folder window.

Or 
Click a folder name to select a folder, or drag through several folder names to select multiple folders, 
and then choose Add Items to Folder(s) from the folder options pop-up menu, as shown in the 
following illustration.

5. If Ecco displays an edit box, enter a value in the box and then choose the checkmark button.

The edit box appears if the folder has a value type assigned to it (for example, date, text, or number).     
For the selected item, Ecco displays a checkmark in the folder button for each folder to which the item 
has been added.



Note    Ecco provides three alternative methods for adding items to folders:
Select the item in the outline view. From the Folder menu, choose Assign by Keys, and use the 

arrow keys to highlight the appropriate folder.    Press the SPACEBAR or the ENTER key to display the folder 
options pop-up menu.

You can create a form that allows you to add items to a set of folders at one time.    

You can add a folder column to any view.    You can then add any item to the folder associated 
with the column by selecting the column cell on the corresponding line.    



About Folders in Outline Views
These advanced features of Ecco Professional are available with full menus only.

In an outline view, you can display the items in one or more folders, allowing you to easily compare, 
contrast, and cross-reference items between folders.    For example, you might create an outline view that 
displays the items in all folders relating to a single project, account, or client.    

To prepare for a presentation to a client, you might create an outline view titled "Presentation" that 
includes all the folders relating to that client.    And you might also place some of the same folders into an 
outline view titled "Fiscal Report '93," along with folders containing budget information.

Ecco outline views allow you to do the following.

Create a new outline view.    You can add any folder to the view and see all the items in that 
folder.    

Add folders to an existing outline view.    You can add the same folders to multiple outline views, 
allowing you to view the same information in different contexts.    

Remove folders from an outline view at any time.    



Creating a New Outline View
These advanced features of Ecco Professional are available with full menus only.

When you create a new outline, the information in the view is saved whenever you save your Ecco file.    
You can open the outline from the View menu by choosing the Outlines command and then choosing the 
outline's name from the list.

To create a new outline view
Create a new outline view to organize information for different purposes.

1. From the View menu, choose Outlines, and then choose New Outline.

Ecco displays the Create a New Outline View dialog box.

2. In the Name box, type a name that describes the information you will add to the view.

This name appears in the menu when you choose the Outlines command.

3. Choose the Folders button.

The Choose Outline Folders dialog box apppears.

4. To add folders to the outline view, click the folder names in the Folder window displayed in the dialog 
box.

You can use the mouse to drag through multiple folders to select them at one time.    As you add them
to the view, the folder names appear in the list box.

5. To remove a folder, highlight the folder in the list on the left, and then choose the Remove button.

6. When you are through adding folders, choose the OK button.

7. Choose the OK button again.

Ecco displays a new outline view that shows the items in the folders you added.    The name you gave
the view appears in the title bar.    The next time you choose Outlines from the View menu, you will 
see the name of your outline at the end of the menu.    You can switch between outlines by choosing 
their names from this menu.    

Note    Once you have created an outline view, you can filter and sort it.    Use filters and sorts to view 
items in a variety of ways without changing the basic information.    



Adding Folders to an Outline View
These advanced features of Ecco Professional are available with full menus only.

You can add additional folders to an outline view at any time.    You can add a new folder to the existing 
folders in the view, or you can replace the contents of the outline view with the new folder.    When you do,
you see the items contained in those folders.

To add folders to an outline view
Use this procedure to add additional folders to an existing outline view.

1. Switch to the outline view to which you want to add additional folders.

2. If the Folder window is not already open, from the Advanced menu, choose Show Folder Window.

The Folder window is displayed.    

3. Drag into the outline view the folders you want to add.

Note    Alternatively, from the Advanced menu, choose Outline Folders.    In the Choose Outline Folders 
dialog box, click folders to add them to the view.    Or, you can use the folder options pop-up menu to add 
folders to the active outline view.    In the Folder window, select the folder you want to add.    From the 
folder options pop-up menu, choose Show Folder's Items, and then choose Add Folder to View.

To replace an outline view's contents with the items in a folder
Use this procedure to replace all the folders in the active outline view with one or more different folders.

1. Switch to the outline view to which you want to add additional folders.

2. If the Folder window is not already open, from the Advanced menu, choose Show Folder Window.

The Folder window is displayed.    

3. Select the folders whose items you want to view.

The folder options pop-up menu appears.

4. From the folder options pop-up menu, choose Show Folder's Items, and then choose Replace View's 
Folders.

The contents of the outline view are replaced with the folder's items.



Removing Folders from an Outline View
These advanced features of Ecco Professional are available with full menus only.

You can remove folders from an outline view at any time.    When you remove a folder from a view, you 
are removing it from the view only you are not deleting it or its items from the file.

To remove folders from an outline view
You can remove a folder from a view by dragging it or by using the Remove Folders command.

1. Select the folder you want to remove from the outline view.

2. Using the mouse, drag the folders out of the outline view window.

Or
From the Edit menu, choose Remove Folders.

Note    Alternatively, you can use the Choose Outline Folders dialog box to remove folders from an outline
view.    From the Advanced menu, choose Outline Folders.    In the Choose Outline Folders dialog box, 
highlight the folders you want to remove, and then choose the Remove button.    Then choose the OK 
button.



Viewing an Item's Context
These advanced features of Ecco Professional are available with full menus only.

Ecco gives you two easy ways to view an item's context.    You can:

View a folder's items.    When you view a folder's contents in an outline view, Ecco displays all the
items that have been placed in that folder.    Some of these items might not be meaningful without their 
parent items displayed for context.    To give meaning to such items, Ecco displays the parent items in 
green text to indicate that these green items were not explicitly placed in the folder.    

View the folders to which an item has been added.    Using the Show Item Info command on the 
Advanced menu, you can look at all of an item's folders and values from anywhere in Ecco.    



Understanding Context Parents
These advanced features of Ecco Professional are available with full menus only.

Problem: Viewing Only the Information You Need
Too much information is as much of a problem as too little.    Once you've collected a large body of 
information, the problem is no longer "How do I find and view this information" but "How do I view only the
most relevant information and still understand it?"

Solution: Context Parents
Consider the following example.    Suppose you've just logged a phone conversation in your PhoneBook.   
In this conversation, your friend Pat made a co-marketing proposal.    You'd like to track this proposal 
under your "Co-marketing Issues" folder, so you drag this conversation into the "Co-marketing Issues" 
folder in the Folder window.

"Logged call - co-marketing proposal" is dragged to the Co-marketing Issues folder.
When you next look at your "Marketing" outline view (which contains this folder), it might look like this:

Context parents appear in green.
Because the item logging the conversation was explicitly added to the folder, it appears in black.    All of its
sub-items have been brought in and are hidden (as indicated by the black triangle).    The name "Redline 
Cruises," from the PhoneBook, was not added to the folder and appears in this outline view solely to 
provide meaning and context.    It appears in green    to indicate that it has not been explicitly placed in the
folder.    In Ecco, this item is called a "context parent."
If the name "Redline Cruises" had been explicitly placed in the "Co-marketing Issues" folder, all the other 
appointments, conversations, etc., appearing under that name in the PhoneBook would appear here as 
well.    This would obscure the co-marketing proposal that you wanted to track.

The ability to add a subordinate item to a folder without adding its parent allows you to exclude 
extraneous information, while the appearance of the context parent provides the necessary context to 



understand the item.

Note      If a filter is applied in an outline view, context parents not meeting the criteria are displayed in 
green.    



Viewing an Item's Folders
These advanced features of Ecco Professional are available with full menus only.

Another way to view an item's context is to view the folder names to which an item has been added. You 
can view an item's folders in either of two ways.

Select the item and open the Folder window. A checkmark on a Folder button indicates that the 
selected item has been added to that folder.

Use the Show Item Info command on the Advanced menu to quickly see which folders an item 
has been added to and what values have been associated with the item for each column.
Using the Show Item Info dialog box, you can move quickly through the items in a view, getting a broader 
view of the item's context, viewing an item's folders, and even changing the values associated with a 
given item.

To view an item's folders
Use this procedure to view an item's folders and edit the values associated with the item.

1. Select the item whose folders you want to view.

Select the first item in the view if you want to step through all the items in a view, looking at each 
item's folders in turn.

2. From the Advanced menu, choose Show Item Info.

The Show Item Info dialog box appears.    The text of the selected item is displayed in the Item text 
box.    The folders to which the item has been added (or the columns in which the items have been 
given values) are listed below Folder Name.    The values associated with the selected item for each 
folder or column are listed below Item's Folder Values.

3. To edit a value, select it, and then change the value in the value edit box.    To clear a value, select the
item and then choose the Clear Value button.    

4. To view the folders for the next item in the view, choose one of the Next Item buttons.
The Next Item buttons let you move through the items in the active view without closing the dialog 
box.    You can move up or down the outline at the same level, or you can move from one level to 
another.

5. When you are through viewing items' folders, choose the Done button.

If you have made any changes in the dialog box, the Done button changes to an OK button.    Choose
the OK button when you are through viewing and making changes in the dialog box.



Introduction to Removing Items from Folders
These advanced features of Ecco Professional are available with full menus only.

You can remove items from folders in either of the following ways.

Use the folder options pop-up menu to remove the selected items from one or more folders that 
you select in the Folder window. 

Delete an item from an outline view, thereby removing that item from the folder under which it 
appears or from all folders.    

Note    You can also use alternative ways to remove items from folders.    

You can remove checkmarks or values from folder columns in the Column pane.    

From the Advanced menu, you can choose Show Item Info and then remove the selected item 
from any folders to which it has been added.    



Removing Items Using the Folder Window
These advanced features of Ecco Professional are available with full menus only.

Use the folder options pop-up menu in the Folder window to remove selected items from any folder.

To remove items from folders using the Folder window
When you remove an item from a folder using the Folder window, the item remains in all other folders to 
which it has been added.

1. In the active view, select the item you want to remove.

You can select a single item, multiple items in sequence, or nonsequential multiple items.    

2. In the Folder window, click the name of the folder from which you want to remove the items.

Or 
Drag through several folder names to select multiple folders.    The items will be removed from all the 
folders you select.

Ecco displays the folder options pop-up menu.

3. From the folder options menu, choose Remove Items from Folder(s).

The selected items are removed from the folder or folders.



Removing Items from an Outline View
These advanced features of Ecco Professional are available with full menus only.

When you delete a top-level item from an outline view, you can choose to remove it from the folder in 
which it appears or from all folders.    Top-level items are located at the highest (left-most) level of an 
outline view.    Deleting a top-level item also deletes its sub-items. When you delete a sub-item, it is 
removed from all folders and deleted from the Ecco file.

To remove items from folders in an outline view
You can easily delete an item either from a single folder or from all folders to which it has been added.

1. In an outline view, select the items you want to remove.

2. From the Edit menu, choose Delete Items, or on the keyboard, press CTRL+D.

Depending on the items you selected, one of the following events happens:

If you selected items that were assigned to only one folder, the items are removed from the folder.
If you selected top-level items that are currently in multiple views, Ecco asks you whether you 

want to remove the items from the current folder or from the entire Ecco file.
If you selected sub-items that were added to more than one folder, Ecco asks you to confirm that 

you want to remove the items from all folders to which they have been added.



Introduction to Setting Up Folders
These advanced features of Ecco Professional are available with full menus only.

Whenever you deal with a complex task, one of the first challenges you face is organizing the information.
Ecco folders provide you with the structural tools you need.

The default Ecco folders described in the following paragraphs give you categories for storing 
basic information such as phone numbers and appointments.

Ecco templates give you additional folders in an outline structure.    For example, some templates 
include folders structured to reflect the different levels of an organization.    

You can create additional folders yourself for any other categories you need.    For example, you 
can add folders for new projects as they arise.    

Ecco Default Folders
To get you started, Ecco provides you with the following default folders: 

PhoneBook contains items created in the PhoneBook view. The PhoneBook folder has several 
subfolders containing related information entered in PhoneBook view, such as telephone numbers and 
addresses.    

Appointments contains items created in the Appointment section of the Calendar View.
Done, Start Dates, and Due Dates are folders you can use to organize scheduled items.    

To Do's contains items created in the Tickler section of the Calendar View.    

Search Results contains items found when you search the entire Ecco file.    

New Columns contains subfolders based on any scratch columns to which titles have been 
added.    

These default folders cannot be deleted from the Folder window.

Depending on the template you are using, you will see additional folders in the Folder window.    New 
Ecco files are based on the template DEFAULT.ECT in your Ecco directory.

You can replace the default template with your own file.    To replace the default template with a template 
of your choosing, save any file with the filename and extension DEFAULT.ECT.

Ecco Templates
Several templates, which you can use to start a new Ecco file, are included with the program.    The 
templates provide folder structures for some typical types of projects or applications.    Take the time to 
investigate the folder setup in these templates you will find that Ecco has already done much of the setup
work for you.    Each Ecco template includes a view titled "How to use this Template."



Creating Folders
These advanced features of Ecco Professional are available with full menus only.

When you need to create a new information category, you can create a new folder in the Folder window. 
Creating a folder is as simple as adding items to an outline.

To create a folder
Create a folder when you are first organizing information in your Ecco file or when you discover you need 
to add another type of information.

1. Open the Folder window, if necessary, by choosing Show Folder Window from the Advanced menu. 

2. From the Folder menu, choose Edit Folders.

Or 
Double-click in the Folder window.

3. Select the folder under which you want to place the new folder.

4. Press the ENTER key.

5. Type a name for the folder.

Note    Alternatively, you can create a folder by choosing New Folder from the Folder menu.    When you 
create a new outline view, Ecco creates a new folder with the name of the outline.    You can edit the name
at any time.    This folder is added below the New Columns folder in the Folder window.



Organizing the Folders in the Folder Window
These advanced features of Ecco Professional are available with full menus only.

You can structure folders in much the same way that you structure items in an outline.    The same 
benefits apply: You can more easily understand the relationship between the folders, and you can expand
and collapse folders to view them more easily.    In addition, arranging folders in an outline structure 
allows you to create multiple-folder columns to view multiple values in one cell.    

In folder outlines, you can:
Move a folder up, down, right, or left in the outline by dragging its folder icon or by pressing 

ALT+an arrow key.    
Expand and collapse a folder that contains subfolders by double-clicking its folder icon.    Or, from 

the keyboard, choose Assign by Keys from the Folder menu.    Press CTRL+H to hide subfolders and 
CTRL+E to expand subfolders.

Create a new folder at a lower or higher level than the selected folder by pressing CTRL+R (to 
create a subfolder) or CTRL+L (to create a folder one level higher).
In general, folder outlines behave the same as any other Ecco outline.     In addition, you can apply 
formatting to folder outlines as you would to any other outline.    

When you add a folder to an outline view, the folder always appears at the highest level of the outline, no 
matter what level it occupies in the Folder window. 



Renaming Folders
These advanced features of Ecco Professional are available with full menus only.

You can edit the name of a folder at any time: in the Folder window, in an outline view, or in a dialog box 
that includes a list of folders (such as the Choose Outline Folders dialog box).

To change the name of a folder
When you change a folder's name, the name changes wherever the folder appears.

1. Select the folder in an outline view, or double-click the folder name in the Folder window or in a dialog
box that lists folders.

2. Edit the folder name.



Deleting Folders
These advanced features of Ecco Professional are available with full menus only.

When you no longer need a folder, you can delete it from an Ecco file using the Folder window. When you
delete a folder, all its subfolders are deleted as well.    You cannot delete a default Ecco folder, such as 
PhoneBook or Appointments.

Note    When you delete a folder from the Folder window, any items in only that folder no longer appear in 
any Ecco view. If you want to continue to view items in only the folder you want to delete, move the items 
to another folder before you delete the folder.    

To find an item that is not displayed in any view, search the entire file for the item using the Find 
command and place the item in the Search Results view.    

To delete a folder
You can easily delete any folder except default folders from the Folder window.

1. In the Folder window, select the folder that you want to delete.

You can delete multiple folders using any of the methods for multiple selections.    

2.  From the Folder menu, choose Delete Folder.

Or
From the Edit menu, choose Cut or, from the keyboard, press CTRL+X.

The folder name disappears from the Folder window.    If the folder contains items, Ecco displays the 
Delete Folder dialog box, which includes a warning that the folders will be removed from all views and
columns.

3. Choose the OK button.

The folder is deleted from the Ecco file.



Folder Values and Folder Types
These advanced features of Ecco Professional are available with full menus only.

A folder can store a value with each item it contains.    A folder value gives you a way to associate an 
additional piece of information with each item.    Because an item can be added to many different folders, 
each item can have many different values associated with it.    This is analogous to the many different 
column values that can be associated with each item in a view. 



About Item Levels
These advanced features of Ecco Professional are available with full menus only.

When you add an item to a folder, Ecco treats the item differently depending on whether it is a top-level 
item or a sub-item.    Ecco automatically adds top-level items to the folder in which they are typed, 
whereas you must explicitly add sub-items to a folder before they are added to it.    When you add an 
existing sub-item to a second folder, Ecco displays the parent item in green in any views displaying the 
second folder, to allow you to see the context of the item without viewing a lot of information you don't 
need.

When you promote or demote an item to or from the first level in an outline view, Ecco adds it to 
or removes it from the folder under which it appears.    

 
When you promote or demote an item or its context parents in an outline view, Ecco changes the 

context information as well.    



Item Levels and Folders
These advanced features of Ecco Professional are available with full menus only.

When you type and rearrange items in a folder that appears in an outline view, those items are added to 
and removed from that folder in different ways, depending on their level.

When you type a top-level item under a folder name in an outline view, it is automatically added to
that folder.    If you select the item, you will see a checkmark in the folder button next to the folder name in 
the Folder window. 

Because an outline view shows all the sub-items of an item included in a folder, Ecco does not 
explicitly add sub-items to a folder when you type them.    This makes it easier to remove items from 
folders.

By promoting or demoting an item to or from the first level in an outline view, you can add it to or remove it
from a folder.    

When you demote a top-level item to a lower level, it is removed from the folder, and a checkmark
no longer appears next to the folder name.    As long as the top-level item above it is in the folder, the item
will continue to appear in the outline after you demote it.    

When you promote a sub-item to the top level, it is added to the folder under which it appears in 
the outline view.



Using Context Parents
These advanced features of Ecco Professional are available with full menus only.

When you type new items into or rearrange existing items in an outline view that contains context parents,
note the following:

When you type a new item under a folder name in an outline view, the item is added to the folder 
if (and only if) the parent, if one exists, hasn't been added to the folder.

When you add a sub-item below a context parent in a view, it will be added to the folder above it 
in the view.
Following these principles, notice that when you promote a second-level context parent, the first-level 
context parent disappears because it is no longer needed to show context; the second-level context 
parent is added to the folder and therefore appears black; and the promoted item is removed from its 
original folder.    

When you promote a black item that has two or more levels of context parents, the context parent that the
item was directly subordinate to disappears because it is no longer needed to show context.

If you are applying a filter in an outline view, note the following:

When you enter an item or assign a sub-item to a folder and it does not match the filter criteria, 
the item appears green.    When you reapply the filter after choosing Ignore Filter, the item disappears 
from view.    

If you have canceled the option labeled "Subs of items matching the criteria are considered to 
match" in the Create a New Filter dialog box, all new sub-items typed in the outline will appear green.    



Looking Ahead: Organizing and Accessing Information
These advanced features of Ecco Professional are available with full menus only.

When you have items entered into views and categorized into folders, Ecco provides you with several 
additional features for organizing and accessing your information.

Record additional information about items by associating values with the items when you add 
them to a folder.    For example, you might want to associate a date with each item you add to a Project 
Completion Date folder.    Or you might want to type a comment describing the resolution of each issue 
that you add to a Resolved folder.    

Set up a Column pane in your views so that you can easily add and display values for each item.  

Create forms so that you can quickly add items to multiple folders and apply values to those 
items.    

Create filters that display subsets of information based on criteria you specify.    

Make the information in your file available to others in your workgroup. 



Items in a folder in an outline view



A folder outline in the Folder window



For more information about , see Setting Up Folders.



You can drag an item into a folder.    The item remains in the view as well.



For more information, see Adding Folders to an Outline View.



Sample folder setup for task notes



Sample folder setup for case notes



Sample folder setup for research notes



For more information, see Typing Items.



For more information, see Adding an Item to Additional Folders.



For more information, see Adding an Item to Additional Folders.



For more information, see Entering Values in Columns.



For more information, see Selecting Single Items or Selecting Multiple Items.



The folder options pop-up menu



For more information, see About Folder Values.



For more information, see About Folder Columns.



For more information, see About Forms.



For more information, see Creating a New Outline View.



For more information, see Adding Folders to an Outline View.



For more information, see Removing Folders from an Outline View.



For more information, see Introduction to Filters and Sorting.



For more information, see The Folder Window.



For more information, see Understanding Context Parents.



For more information, see Viewing an Item's Folders.



For more information, see Applying Filters.



For more information, see About Folder Values.



For more information, see Removing Items Using the Folder Window.



For more information, see Removing Items from an Outline View.



For more information, see Viewing an Item's Folders.



For more information, see Editing and Deleting Values in Columns.



For more information, see Selecting Single Items or Selecting Multiple Items.



For more information, see Opening a File.



For more information , see Creating Folders.



For more information, see About Date Columns (and Folders).



For more information, see Ticklers: To-Do's and What's Ahead.



For more information, see Using the Search Results View.



For more information, see Adding or Changing Column Headings.



For more information, see Displaying Multiple Folders in a Column.



For more information, see Promoting, Demoting, and Moving One Or More Items.



For more information, see About Formatting.



For more information, see Adding Folders to an Outline View.



For more information, see Adding an Item to Additional Folders.



For more information, see Searching the Entire File for Items.



For more information, see Sorting Items in a View.



For more information, see Selecting Multiple Items.



For a better understanding of folder values, see About Folder Values.



For more information, see Item Levels and Folders.



For more information, see Using Context Parents.



Top-level items are added automatically to the folder.



For more information, see Promoting, Demoting, and Moving One or More Items.



For more information, see Applying Filters.



For more information, see Advanced Filters.



For more information, see Viewing, Editing, and Deleting Values in Folders.



For more information, see The Column Pane.



For more information, see About Forms.



For more information, see Introduction to Filters.



For more information, see About Workgroup Computing.



For more information, see Folders.



For more information, see Adding Items to Folders.



For more information, see Folders.



Columns and Values
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            Introduction  
            Setting Up and Using Columns  
            Entering Values in Columns  
            Editing and Deleting Values in Columns  
            Using the Same Column in Multiple Views  
            Printing Values in Columns  
            Folder Columns and Folder Values  
            Using Column Types (and Folder Types)  
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Columns and Values
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            Introduction  
            Setting Up and Using Columns  
            Entering Values in Columns  
            Editing and Deleting Values in Columns  
            Using the Same Column in Multiple Views  
            Printing Values in Columns  
            Folder Columns and Folder Values  
            Using Column Types (and Folder Types)  

About Column Types
Text Columns
Number Columns
Date Columns
Pop-up List Columns
Checkmark Columns

About Date Columns (and Folders)
Using Date Folders in a New File
Assigning Date Properties
Specifying Pop-up List Values
Using Gantt Columns
Creating a Gantt Column
Changing Gantt Columns



You can display the Column pane on the right side of every Ecco view.    To view the Column pane, from 
the Column menu, choose the Show Columns command.

The Column menu is available only if you are using the advanced features of Ecco Professional.    If you 
are not using the advanced features, the Column menu is replaced by the Show/Hide Columns button.    
Click green text to view more information.



You can display the Column pane on the right side of every Ecco view.    To view the Column pane, from 
the Column menu, choose the Show Columns command.

The Column menu is available only if you are using the advanced features of Ecco Professional.    If you 
are not using the advanced features, the Column menu is replaced by the Show/Hide Columns button.    
Click green text to view more information.



Cell    In the cells of the Column pane, you can type values to associate with items, and you can edit or 
delete values.



Column headings    Supply a heading for a column by simply choosing the Heading command from the 
Column menu.    



Column menu    This menu includes commands for hiding, displaying, inserting, or deleting columns; 
modifying column properties; naming, aligning, moving, or sizing columns; and make the contents of a 
column public.



Zoom button    Click this button to expand or hide the column display.



Pane border    Drag this border to resize the Column pane.



Introduction to Columns and Values
These advanced features of Ecco Professional are available with full menus only.

Ecco provides you with the flexibility you need to organize and collect related items of information in the 
way most useful for you.    You use Ecco views, outlines, and folders to organize and collect items of 
information.    You can use columns to add database-type fields to every item in a view.

In this chapter you'll learn about:

Understanding values in columns.    

Using the Column pane.    

Associating values with items.    

Using different types of columns.    

Working with folder columns.    

The first part of this chapter deals exclusively with columns and column values.     The second part of the
chapter, "Folder Columns and Folder Values," describes folder columns and the relationship of folders to 
columns.    

 The third part of the chapter, "Using Column Types (and Folder Types)," provides detailed information 
about value types in both columns and folders.    

The Column menu and Folder window are available only if you are using the advanced features of Ecco 
Professsional.    If you are not using the advanced features, the Column menu is replaced by the 
Show/Hide Columns button.



Example: Tracking Information in Columns
These advanced features of Ecco Professional are available with full menus only.

As marketing assistant for Romantic Travel Agency, Edna has been using an Ecco file to enter items of 
information regarding all aspects of her job, and she has been organizing those items into folders. One of 
those folders is a "Task List" folder, to which she adds items for each of the major tasks she must 
accomplish in the coming week.

Edna decides she would like to track additional information, such as priority and cost, for each item.    
Columns are the perfect answer to her need.

Entering Values in Columns
The first thing Edna wants to do is prioritize the tasks for the week.    In an outline view displaying the Task
List folder, she displays the Column pane (by choosing Show Columns from the Column menu) and types
a "High," "Medium," or "Low" priority for each item in one of the columns.    While she's at it, she decides 
to enter, in another column, some budget figures associated with those same items.

Edna's tracking technique works but, as you'll see in a moment, she could track costs and priorities even 
more effectively by using distinct column types.

Naming the Columns
To ensure she remembers the significance of the values she's entered, Edna gives the headings "Priority"
and "Budget" to her columns.

Date Columns and Other Column Types
Column types provide a way to simplify entry and formatting of different types of values, such as dates, 
numbers, text, and pop-up lists.

For example, using the Insert Column command, Edna could insert a date column for storing the due 
dates of each task.    Entering dates in a date column is simple using the Date Settings dialog box.    When
Edna enters dates for her tasks, those tasks will also appear on the appropriate dates of her Calendar.    

Other column types include text, number, checkmark, and pop-up list, the last of which let you define a list
of values and then associate values from that list with items.



Adjusting the Column Pane Display
These advanced features of Ecco Professional are available with full menus only.

Ecco allows you to quickly adjust the Column pane display so you can see the information you need.    

To display or hide the Column pane, from the Column menu, choose the Show Columns 
command.

To instantly expand and contract the Column pane, use the zoom buttons located in the lower 
scroll bar.

To adjust the width of the Column pane, use the mouse to drag the left border of the pane.
You can adjust the display of the individual columns as described in the following table.

Adjustment
Column Menu 
Command

Mouse Procedure

Resize a column Width Drag border of 
column heading

Minimize or 
restore a column

Width (Minimize 
checkbox in the 
Column Width 
dialog box)

Double-click 
column heading

Move a column Move Column Drag column 
heading

Note    A minimized column displays a triangle in the lower right corner of its heading.    Minimize columns 
to increase the number of columns you can view at one time.    You can choose to omit minimized 
columns when you print.



Customizing a Column's Display
These advanced features of Ecco Professional are available with full menus only.

Ecco allows you to adjust the appearance of your columns and the way you display values in them.

You can customize columns by modifying their properties or by formatting text using the Format menu on 
the main menu bar.

To customize column display from the Column menu, choose the Properties command.    The Column 
Properties dialog box appears.    The specific properties you can change in this dialog box depend on the 
column type.

Column heading    You can create a heading for any column.    Once you give a heading to a column, that
heading appears both at the top of the column and as the name of a folder in the Folder window.    You 
can continue to use the column as you would any other column.    The appearance of the column's name 
in the Folder window provides an easy way to add the column to multiple views.    You can use this folder 
just as you would any other folder, with some additional benefits.    

Column width    You can adjust the width of any column, accept the standard width, or change the 
standard width.    You can also specify whether the column should be displayed minimized.

Value format    You can choose a format to be used for the entry and display of dates and numbers in 
date and number columns, or you can choose the style of checkmark you want displayed in checkmark 
columns.

Alignment  You can specify whether values are displayed aligned left, right, or centered in the cells of the
selected column.

Fonts and styles    Use the Format menu on the main menu bar to change fonts and styles in a column.   
You can select a cell or click on a column heading and, from the Format menu, choose a font or a style to 
apply to the entire column.    Fonts and styles applied to a column override outline styles.    To remove a 
column style, choose the "Reapply Outline Style to Selected Text" option in the Character dialog box.    



Inserting Columns
These advanced features of Ecco Professional are available with full menus only.

When you want to include values of a particular type in a column, you can insert a new column.    You can 
insert a column of any type into the Column pane in an Ecco view.    Each view can include up to 50 
columns (and your Ecco file can include a combination of up to 250 folders and columns).    

To insert a column
The new column will appear to the left of the column you select.

1. Select any cell in any column or click any column heading in the Column pane.

You can select a cell using either the mouse or the arrow keys.

2. From the Column menu, choose Insert Column.

3. Choose one of the column types listed.

When you insert a date column, Ecco displays a dialog box in which you can specify a date 
column heading.    

When you insert a Gantt column, Ecco displays a dialog box in which you can specify a date 
range and other options.    

When you insert a pop-up list column, Ecco displays the Insert Pop-up List Column dialog box, in 
which you can specify the values to be included in the pop-up list.    

When you insert a folder column, Ecco displays a dialog box in which you can select a folder or a 
column from other views to display in the column.    Included in the list of folders are all columns in the 
active file that have been given a heading. 

Notes    Alternatively, you can insert a folder column by dragging a folder from the Folder window into the 
Column pane.    

When you add a folder to a view, a column for that folder is also inserted in the Column pane (for all 
folders except checkmark folders).



Deleting or Removing Columns
These advanced features of Ecco Professional are available with full menus only.

To remove any column from the Column pane, select a heading or cell in the column, and then choose 
Delete Column or Remove Column from the Column menu.    Ecco removes the column from the Column 
pane in that view.

If the column is a scratch column (one for which no heading has been supplied) the Column menu 
contains the Delete Column command.    Deleting the column also removes from the file the values 
included in the column.

If the column has a heading, then that heading appears as a name in the Folder window.    In that case, 
choosing Remove Column from the Column menu removes the column and its values from the view 
without deleting them from the file.    You can redisplay the column and its values by dragging that same 
folder from the Folder window into the Column pane.    



Adding or Changing Column Headings
These advanced features of Ecco Professional are available with full menus only.

If you've entered a certain type of value in a scratch column, you might want to give the column a 
heading.    For example, you might give the heading "Priority" to a column that shows the priorities of 
items in the view.

When you give a column a heading, Ecco creates a folder with that name, and the column becomes a 
folder column.    The name of the column appears in the list in the Folder window.    Essentially, a column 
with a heading and a folder are the same thing.    This means the items and values in the column are 
added to the new folder, and you can view and edit them in other Ecco views.    To view a column in 
another view, simply drag the folder of the same name into the view's Column pane.

To add or change a column heading
The heading will appear at the top of the column you select.

1. Select any cell in any column, or click any column heading.

(You can select a cell using either the mouse or the arrow keys.)

2. From the Column menu, choose Heading.

3. In the Column Heading dialog box, type the heading.

The heading appears at the top of the selected column.    If the column did not previously have a 
heading, that heading now appears as a folder in the Folder window.    If you change an existing 
heading, the change will be reflected in the Folder window and in any other views in which that 
column appears.    

4. Choose the OK button.



Changing a Column's Type
These advanced features of Ecco Professional are available with full menus only.

Before you enter values in a column, you might want to change the column's type.    A column's type 
determines the kind of information you can add to it.    Ordinarily, empty Ecco columns are text columns by
default.    If you want to associate number, date, pop-up list, or Gantt values with a scratch column, you 
first need to change its type.    

For example, you might want to type budget information in one column and due dates in another.    To do 
this, you would make the first column a number column and the second column a date column.    

To change a column's type
Once a column contains values, you cannot change its type.    This is true even if a column has no values 
in the current view but does have values in other views.

1. Select any cell in the column for which you want to assign a column type (or click its heading).

You can select a cell using either the mouse or the arrow keys.

2. From the Column menu, choose Column Type.

3. Choose one of the types listed.

When you create a folder column, Ecco displays a dialog box in which you can select a folder to 
display in the column.    

When you create a date column, Ecco displays a dialog box in which you can specify a date 
column heading. 

When you create a Gantt column, Ecco displays a dialog box in which you can specify folders, 
range, and other options.    

When you create a pop-up list column, Ecco displays the Insert Pop-up List Column dialog box in 
which you can specify the values to be included in the pop-up list.    



Entering Values in Columns
These advanced features of Ecco Professional are available with full menus only.

You can most quickly associate values with items by entering the values in the Column pane. When you 
enter a value in a column that has a letter for a heading ("A" or "B," for example) the value is saved and 
displayed only in that view.    When you enter a value in a column that has a heading, the value and the 
item are added to a folder with that name, and you can display the value for that item in other views and 
from the Folder window. 

In columns, you can enter text, numbers, dates, or values that you select from a pop-up list that you 
define.    

To enter a value in a column
You can easily enter values in columns.

1. If the Column pane is not displayed, from the Column menu, choose the Show Columns command.

Or
Select an item and, from the Window menu, choose Go To Pane.    Then press the F11 key or choose 
Left <{bmc endash.bmp}>Right.

2. If necessary, use the scroll bar to scroll horizontally to find the column to which you want to add the 
value.

You might also want to scroll vertically to find the item with which you want to associate the value.

3. Using the mouse or the arrow keys, select a column cell that is on the same line as the item with 
which you want to associate the value.

4. Enter a value in the value edit box. 

5. When you have entered the value, choose the ENT (checkmark) button or press the 
ENTER key.



Editing and Deleting Values in Columns
These advanced features of Ecco Professional are available with full menus only.

You can change an item's value, or you can delete specific values entirely.

To edit or delete a column value
1. In a column, select the cell with the value you want to change, either by using the arrow keys or by 

clicking the cell with the mouse, and then press the ENTER key.

2. In the value edit box that appears, make changes to the value, or press the DELETE key to delete the 
value.

3. When you are finished, choose the ENT (checkmark) button.

When you delete a value from a folder column (that is, from a column with a heading), you also 
remove the associated item from the folder of that name.    



Using the Same Column in Multiple Views
These advanced features of Ecco Professional are available with full menus only.

Since the same item can appear in multiple views, there will be many times when you'll want to display 
the same column values in each of the other views.    If you created a priority column and entered priority 
values for some of those items, you'd want to see those same priority values wherever those items 
appeared.

To insert a column from another view
Before you can insert a column from another view, the column in that other view must already have a 
column heading.    Every column with a heading is represented as a folder in the Folder window and is 
called a folder column. 

1. If the Folder window is not displayed, from the Advanced menu, choose Show Folder Window.

2. Drag the folder based on the column from the Folder window to the Column pane in any view.

The column and its values are displayed in the view.

Note that new columns you've created will be found in the Folder window under the New Columns folder.  
PhoneBook columns will appear under the PhoneBook folder (or in some templates under the extended 
PhoneBook folder).



Printing Values in Columns
These advanced features of Ecco Professional are available with full menus only.

You can specify how Ecco prints the values that appear in a view's columns by changing the settings in 
the Columns section of the dialog box that appears when you print.    (The name of this dialog box reflects
the view you are printing.) 

To print values in columns
You can print the displayed columns for any Ecco view.

1. Minimize any columns you do not want to print.

(You can minimize a column by double-clicking its heading.)

2. From the File menu, choose Print.

If you are in the PhoneBook view, select the "Name, Sub-Items & Columns" format option and choose
the Options button.

If you are in the Calendar, choose the Options button.

3. In the Columns section, select the "Print Columns" option.

4. If you want Ecco to print only the columns that are not minimized, select the "Skip Minimized 
Columns" option.

5. In the No.    of Cols.    on 1st Page box, type the number of columns you want to print on the same 
page as the items in the view.    

6. Select any other options and settings you want.    

7. Choose the OK button to print the items and columns in the view according to your specifications.



About Folder Columns
These advanced features of Ecco Professional are available with full menus only.

Note    Before reading this section, you should familiarize yourself with the use of both folders and 
columns.    

A folder column combines the benefits of both columns and folders.    It lets you organize your items and 
add values to those items.    In addition, a folder column provides you with a simple way to use the same 
column in multiple views.
When you drag a folder from the Folder window into the Column pane of a view, you get a folder column 
whose heading is the name of that folder.
Alternatively, when you supply a heading for any column in a view, the column is represented as a folder 
in the Folder window and the column becomes a folder column.

Example:    Cross-Referencing Information in Folder Columns
Edna has set up and is using her folders and columns in every aspect of her job as the marketing 
assistant for Romantic Travel.    Now she will realize the full power of Ecco, using folder columns.    

Folder Columns with Checkmarks
As Edna works her way through her tasks, she can mark tasks as important by dragging them into the 
Important folder.    Edna would like to see at a glance which items are important, so she simply drags the 
Important folder from the Folder window into the Column pane of her Task List view.    The result is a 
folder column with the heading "Important." Each checkmark in that column indicates that the task (item) 
on that line is in the Important folder.

By clicking any cell in the Important column, Edna can easily add the item on that line to the Important 
folder.

Edna adds items to the Important folder by clicking in the Important column.
The preceding example illustrates how easily you can use a folder column to see at a glance which items 
are in a folder or to add items to a folder.

Folder Columns with Column Values
Edna wants to keep a record of the number of days she expects to allocate to each task, so she inserts a 
number column using the Column menu and gives the column the heading "Days." When she gives the 
column a heading, it becomes a folder column, and the folder "Days" appears in her Folder window 
(underneath the "New Columns" folder).

As she enters her estimate for each task in the "Days" column, that task is added to the "Days" folder.    
The value she enters for each task is also added to the folder along with that task.    In the "Days" folder, 
each value that was added in the column is associated with the item (task) on the same line.



Edna adds number values in the Days folder.
Important      Notice that entering a value in a folder column causes the item and its associated value to 
be added to the folder.

Using the Same Column in Multiple Views
Edna has created a "Needs Approval" view to list all of the items in the file that need approval from her 
supervisor.    She's added some of the items in her Tasks view to the Needs Approval folder.

She'd like to see the day estimates for each of the items in the view.    She has already created a "Days" 
folder in which she has entered the day estimates.    Now she drags the Days folder from the Folder 
window to the Column pane of this view, and the "Days" column appears.    The day estimates she's 
already entered for any of the items in this view are now displayed in the column.    If she now changes 
any of the values in this column or supplies new ones, those changes are also reflected in the "Days" 
column of any other view.

Edna drags the Days folder into the Column pane.
Combining the Benefits of a Folder and a Column
Edna now wants to review at a glance all of her time commitments throughout her file.    In other words, 
she wants to see all the items in her file for which she has supplied a "Days" value.    To do so, she simply 
drags the Days folder from the Folder window into the outline area of any outline view.

Now the Days folder and all the items for which she has entered a "Days" value appear in the outline.

Also, Ecco automatically adds the Days column to the Column pane, so Edna can easily view and edit the
"Days" value for each of these items.



Edna drags the Days folder into a view.



Using Folder Columns
These advanced features of Ecco Professional are available with full menus only.

You can add folder columns to a view in any of the following three ways.

Drag a folder from the Folder window into the Column pane.
From the Column menu, choose Insert Column, and then choose Folder.    In the Insert Folder 

Columns dialog box, select the folders you want to add.
In the Folder window, choose the button or buttons for the folders to be included in the Column 

pane.    In the folder options pop-up menu, choose Show Folder's Items and then, in the menu, choose 
Insert Folder Column.
When you insert a folder column, several things happen.

A new column appears in the view.    Its heading is identical to the folder name.
If the folder is a checkmark folder, checkmarks appear in the column on the same line as any 

items in the view that have been added to the folder.
If the folder is a text, number, date, appointment, or pop-up list folder, values appear in the 

column on the same line as any items in the view that have been added to the folder.
You can add, edit, and delete the values in the folder column as you would in any other column.     
Adding a value to the column also adds the item on that line to the folder.    Conversely, deleting a value 
from the column also removes the item on that line from the folder.



Displaying Multiple Folders in a Column
These advanced features of Ecco Professional are available with full menus only.

Normally, each folder column displays the values for a single folder.    If you want, you can set up a 
column to show values from a group of folders, however.    This can be very useful when only a few of a 
large number of folders are likely to be used with each item in an outline.    Setting up columns for multiple
folders is also useful for working with items that have a number of values or folder assignments that you 
want to view and edit in one place.

For example, suppose that you have a folder for each of your coworkers.    It's likely that each item in your
marketing plan outline would be added to only one or two of these folders.    You'd like to see at a glance 
which items are in which folders without having to dedicate a column to each member of your staff.

In the Folder window, you could create a folder called "Coworkers" and make the folder for each coworker
subordinate to that folder.

You could then create a multiple-folder column with the heading "Coworkers." For each item in the outline,
those subordinate coworker folders that contain the item will be displayed in the corresponding cell of this 
column.

Note the following about multiple-folder columns.

If an item in the view has been added to one of the subfolders, the folder's name appears in the 
multifolder column cell to its right.

If the folder contains a value, the value appears along with the folder name.
You can add, delete, or edit the values in each subfolder by clicking the column cell.
You can include folders without values in a multiple-folder column, and you can use the column to

view folder assignments, add items to folders, and remove items from folders quickly, in a single location.
To display multiple folders in a column

You can display the subfolders of a folder in a single cell of a folder column.

1. In the Folder window, arrange a group of folders as subfolders of a single folder.    

For example, you might make "Date 1," "Date 2," and "Date 3" subfolders of a "Project Dates" folder.

2. In the Column pane, insert a folder column for the folder to which the group of folders is subordinate.

To extend the preceding example, you would insert a folder column based on the Project Dates folder.

3. With the column selected, from the Column menu, choose Properties.

Ecco displays the Column Properties dialog box.

4. In the "For each item, cell displays:" area of the Properties dialog box, select the "Subfolders of 
<folder name> that contain item" option.

5. Choose the OK button.

When you add an item in the view to one of the subfolders, the folder's name appears in the column 
cell on the same line as the item.



Editing Multiple Folders in a Column
These advanced features of Ecco Professional are available with full menus only.

You can change values and folder assignments in a multiple-folder column by clicking on a column cell 
and making changes in the box that appears.

To edit the cells of a multifolder column
You can easily change values entered in multiple folder cells.

1. Click a column cell, or select the cell and then press the ENTER key.

Ecco displays a box listing all the folders subordinate to the folder heading the column, together with 
the value assigned to the item for each folder.    Ecco displays "<excluded>" for the subfolders to 
which the item has not been added.

2. Click the subfolder you want to edit, or select the folder and then press ALT+S.

Ecco displays a value edit box appropriate for the folder type.     If the folder is a checkmark folder, 
click the folder name to "check" or "exclude" it.

3. Enter a value or edit the existing value.

If you want to remove the item from that folder, delete the value.    If the folder is a checkmark folder, 
click the folder name to add or remove the item from that folder.    

4. In the edit box, choose the ENT (checkmark) button.

5. When you have finished editing folder values, choose the checkmark in the box that lists the folders.



About Folder Values
These advanced features of Ecco Professional are available with full menus only.

Folders are the basic organizational containers for collecting and cross-referencing the items you enter 
into Ecco.    

As described earlier in the chapter in "About Folder Columns," a folder can store a value with each item it 
contains.    A folder value gives you a way to associate an additional piece of information with each item.    
Because an item can be added to many different folders, each item can have many different pieces of 
information associated with it.    This is analogous to the many different columns of information that can be
associated with each item in a view.    
Like the values you type into columns, folder values can be text, numbers, dates, appointments, or pop-
up lists (that is, predefined values, such as "high," "medium," and "low" priorities, that appear in a list).    
You can add a value to a folder, associating it with an item, in either of two ways:    

By entering values into a folder column.
By adding the item to a folder (by dragging, for example) and then supplying a value when 

prompted.    

Using folders you can:

Make a folder a value folder by assigning a type of value to it.    From the Folder menu, choose 
Folder Type and then choose from the list of folder types.    

Add items and their associated values to the folder in the Folder window.    When you add an item
to a folder, Ecco displays a value edit box in which you enter the item's value.    

View and edit the folder values associated with any selected item.    Choose the folder button for 
the selected item, and then choose Show/Edit Values from the menu.    Edit the value displayed in the 
value edit box.    

View and edit the values associated with items in a view, using a folder column.    



Assigning a Type to a Folder
These advanced features of Ecco Professional are available with full menus only.

By default, a new folder is a checkmark folder that you can use to collect items. Before you can associate 
values with items when you add them to a folder, you must assign a type of value to the folder.    The 
available folder value types are text, number, date, and pop-up list. 

In the Folder window, you can use the Folder Type command from the Folder menu to change the type of 
a folder.    You can only change the type of a new folder or of a folder containing no items.

To assign a folder type in the Folder window
Once you've assigned a type of value to a folder and put items in it, you can't change the folder's type.

1. In the Folder window, choose Edit Folders from the Folder menu.

2. Select a folder that contains no items.

3. From the Folder menu, choose Folder Type.

4. Choose a folder type from the menu.

If you choose a pop-up list folder type, the Pop-up List Column Values dialog box appears, in which 
you can define a set of values for the folder.    

Note    When you set up date folders, you can define default properties for the folder (such as ticklers, 
alarms, and recurrence options) by choosing Properties from the Folder or Column menu and making 
selections in the Date Properties dialog box.    



Adding Items and Values to Folders
These advanced features of Ecco Professional are available with full menus only.

You can add an item and an associated value to a folder in either of two ways.

Add items to the folder by dragging them into the folder in the Folder window, if the folder type is 
other than checkmark.    Ecco then prompts you to enter a value for the items.    

You can display a column that shows the folder values in the Column pane and then type a value 
in the column for each item, just as you would for any other column.    When you type a value into a folder 
column, the item on that line is also added to that folder.    



Viewing, Editing, and Deleting Values in Folders
These advanced features of Ecco Professional are available with full menus only.

You can view, edit, and delete item values most easily from the Column pane, though you can also use 
the Folder window to perform these tasks.    

Use the Folder window if you want to view, edit, or delete a particular value for a folder you don't use very 
often.

To view or edit an item's values in the Folder window
You can display an item's values in the Folder window by choosing Show/Edit Values from the folder 
options pop-up menu. Once the value is displayed, you can select it and then edit or delete the value.

1. Select the item whose values you want to view.

2. In the Folder window, select one or more folders.

Ecco displays the folder options pop-up menu.

3. Choose Show/Edit Values.    This command is unavailable if the folder is a checkmark folder or if no 
value has previously been assigned.

The value assigned to the item is displayed in a value edit box. If you want, you can edit or delete the 
value at this time.    If you delete the value, the item is removed from the folder.

If you selected multiple folders, Ecco displays the Show/Edit Folder Values dialog box, which lists the 
item's value in each of the selected folders.    If you want to edit or delete any of the values displayed, 
select the value and make the necessary changes in the value edit box that appears.

Note    If values are associated with an item in folders, Ecco provides two additional ways in which you 
can edit or delete the values.

From the Advanced menu, choose Show Item Info.    In the Show Item Info dialog box, select a 
value listed in the Item's Value column, and edit or delete the value displayed in the value edit box.    

You can create a form and then use that form to edit or delete the item's values for the folders in a
form, using the View Item by Form command on the Advanced menu. 



About Column Types
These advanced features of Ecco Professional are available with full menus only.

Note    Unless otherwise indicated, the information in this section applies to folder values as well as 
columns.

Column values give items an added dimension of information.    You can associate four main types of 
values with items in Ecco.

Text columns associate comments, descriptions, or any combination of miscellaneous texts with 
items.    

Number columns associate numerical information with items.    

Date columns associate date and time information with items and automatically show items in 
the Calendar.    

Pop-up list columns associate with items values from a list that you define.    

In addition, you can assign a checkmark type to a folder or column, which allows you to include or 
exclude an item without associating a value with it.    

In the Column pane, you can also create a Gantt column, which displays two date values in a single 
column as a Gantt bar.    

Text Columns
Text columns let you associate any text with items. You can associate text of up to 32,000 characters in 
length with a single item.    Text columns give items an added dimension.

Here are some examples of ways you might use text values.

Suppose a set of items describes each part of a problem.    As you resolve each item, you might 
type a text value that describes the solution to that part of the problem.

For a set of items describing proposed marketing plans or business strategies, you might create 
several text columns, one for each manager, and enter a text value describing each manager's response 
to each proposal.

You might create a list of outside consultants with whom you work, create text columns for each 
project, and type a brief summary of each consultant's involvement with a project.
If you select a column that is a text type, Ecco displays an empty, sizable value edit box.

In this box you can type up to 32,000 characters of text.    If you type more characters than will fit 
in the box, the text scrolls up so you can continue to enter your value.    Press SHIFT+ENTER to insert 
carriage returns in the text.

You can expand the borders of the value edit box by dragging them.
When you finish entering text, press the ENTER key.    The edit box disappears, and Ecco displays only the 
amount of text that can fit into the on-screen column cell.

Number Columns
Number columns let you associate numbers with items. Use number columns to take advantage of a 
large variety of number display formats and to limit data entry in the column to numbers only.

Here are some examples of ways you might use number columns.

Associate a budget amount with each of the tasks that constitute a project.
In a list of equipment, associate an inventory number or a quantity with each item.
In an outline that describes courier deliveries, associate a confirmation number with each 

delivery.
If you select a column that is a number type, Ecco displays an empty value edit box. Type any number in 



this box.    (Ecco does not accept nonnumeric values in this box.)    Press the ENTER key when you finish 
entering text.

Date Columns
Date columns let you associate dates with items. When you enter a value in a date column for an item, 
you can give the date all the attributes you give to dates in the Calendar view, including a date and time, 
an alarm, a recurring date, and a range of dates during which the item will appear in the Calendar's 
Tickler section.

Unless you specify otherwise, all items with date values appear in the Tickler section of the Calendar 
view.    If you associate a time as well as a date with the item, the item also appears in the Appointment 
section of the Calendar view.    This means that giving an item a date value in the Column pane or the 
Folder window integrates that item with the rest of your schedule.

When you create a date column, Ecco requires a heading so that items displayed in the Tickler section 
can be properly identified.

Use date columns for a wide variety of scheduling and project management purposes, including:

Setting up due dates for project milestones (for example, with "First Draft" and "Review" date 
folders).

Assigning dates of initiation and resolution to problems and issues.    For example, you might 
have a "Date Initiated" folder in which you record when the problem began, a "Description" text folder in 
which you enter a description of the problem resolution, and a "Date Resolved" date folder in which you 
record the resolution date.
If you select a column that is a date type, Ecco displays an empty value edit box in which you can type 
the date.    Alternatively, choose the down arrow to display the Date Settings dialog box. Use the dialog 
box to set the date, together with any other date attributes.    

Ecco includes several default date folders, which you can use to associate date values with items.    
In addition, you can change the properties of a date folder or column in any of several ways.    

Pop-up List Columns
Pop-up list columns let you define a list of values and then associate values from that list with items.

Using pop-up list columns, you can:

Quickly associate with an item values from a user-definable list
without retyping.

Standardize the entry of values so that filters and sorts can be applied to them.
Add or edit the values in the pop-up list "on the fly."

For example, if you use a "Priority" column to associate a "High," "Medium," or "Low" priority with items, 
you can save typing time and ensure accuracy by creating a pop-up list column with these three values in 
the list.

If you select a column or folder that is a pop-up list type, Ecco displays a value edit box. In this box you 
can:

Choose the down arrow to display a list of existing values, and then select a value from the list.
Type a new or existing value.
Select "<Edit Values>" to display the Pop-up List Column Values dialog box.    In this dialog box, 

you can add, modify, or delete the values in the pop-up list column.    

Checkmark Columns
Checkmark columns and folders have no values associated with them.    In the Column pane, selecting a 
cell in a checkmark column simply adds a checkmark to the cell.    (You can customize the appearance of 
the checkmark by choosing Properties from the Column menu.) No value edit box is displayed.    In the 



Folder window, adding an item to a checkmark folder simply adds the item to the folder without 
associating any value with it.    

Use checkmark columns and folders to categorize items.    For example, you might set up "Billable," 
"Overhead," and "Personal" checkmark columns in your Calendar view and categorize your tasks by 
checking the appropriate column for each item.



About Date Columns (and Folders)
These advanced features of Ecco Professional are available with full menus only.

Note    Unless otherwise indicated, the information in this section applies to folder values as well as 
columns.

The management and scheduling of tasks is integrally associated with dates.    By allowing you to 
associate date values with items, Ecco provides you with a powerful capability for tracking and organizing 
your tasks.

You can associate dates with items by:

Creating appointments and tickler items in the Calendar view.    
Entering dates in date columns.
Adding items to date folders in the Folder window.
Making any selected item a tickler when you choose Ticklers from the Tools menu.

When you add an item to the Tickler section, Ecco places the item in a date folder of your choice.    Unless
you specify otherwise by changing the date properties, when you give an item a date, the item appears in 
the Calendar view.    

You attach dates and times to items in the Appointment section. When you enter an appointment, Ecco 
places the item in the Appointments folder.    You can place the item in any other date folder as well.    Any 
item assigned directly to a date folder with a time as well as a date attached to it is automatically 
displayed in the Appointment section, at the appropriate date and time.



Using Date Folders in a New File
These advanced features of Ecco Professional are available with full menus only.

When you open a new file, Ecco provides you with several default date folders to which items with dates 
are added.    Ecco places appointment and tickler items into folders automatically when you enter the 
items in the Calendar view. Ecco provides other default folders (described in the following paragraphs) to 
which you can add items with dates.    Of course, you can create as many additional date folders as you 
want.    

You can display date folders as columns in your Column pane for a view so that you can easily view date 
values for multiple items in multiple folders.    This is a convenient way to, for example, display your 
appointments or your due dates in a single column.

Ecco provides you with the following date folders.

Phone Log    This folder is subordinate to the PhoneBook folder.    Each time you log a call using the Call 
Logger in the PhoneBook, the date and duration of the call are recorded in this folder.    You can view this 
information in the Phone Log column in the PhoneBook Column pane, or you can add the column or view 
values in the Folder window as you would for any other date folder.

Appointment    Ecco places into this folder all items you enter in the Appointment section of the Calendar 
view.    Any items with associated times as well as dates are considered appointments.    If you add an 
item directly to this folder, including a time as well as a date, Ecco displays the item in the Calendar view 
as well.    (If you add a date only, the item appears in the Tickler.) This means you can set up 
appointments from the Folder window, from Columns or from just about anywhere in Ecco that you 
choose to work.

To-Do's    You can use this folder to keep track of your "action items." Action items typically describe tasks
you need to do on a specific date or over a period of time.    When you add an item to the Tickler section, 
it is automatically placed in the To-Do's folder, and when you add an item to the To-Do's folder, it is 
automatically placed in the Tickler section.
Start Dates    You can use this folder to store items with start date values.    The dates in this folder are 
the default dates used to specify the beginning of bars in a Gantt chart.
Due Dates    You can use this folder to store items with ending date values.    The dates in this folder are 
the default dates used to specify the ending of bars in a Gantt chart.



Assigning Date Properties
These advanced features of Ecco Professional are available with full menus only.

When you choose Properties from the Folder menu and a date folder is currently selected in the Folder 
window, Ecco displays the Date Properties dialog box.

In this dialog box, you can select from the following options.    
Default Settings for new Items    Specify the default settings.    You can override these default settings 
for individual items using the Date Settings dialog box.    

Note    These settings affect items that will subsequently be placed in the folder as well as any items 
currently in the folder that match the pre-existing defaults.

Show Item in Calendar's Tickler Section    Choose whether to show the items added to the 
folder in the Calendar's Tickler section. If you choose to display the items in the Tickler section, you can 
select the default lead time and follow-up time during which you'd like the items to be displayed.

Default Recurrence    Ecco allows you to specify an appointment item recurrence at a time 
interval you specify.    You can select an option from the list to change the default setting for the 
recurrence pattern you use most often for items using this date column.

Default Alarms    Select an alarm from the list to change the default setting for the alarm you use 
most often for this date column.

Calendar Busybar Color    Select a color from the list to change the default color for the Busybar
displayed at the left side of the Calendar view.
Entering Dates    In this portion of the Date Folder Properties dialog box, you can specify the default 
display of the value edit box that appears when you add a date value to an item in a column or in Folder 
view.

You can choose whether the value edit box initially displays a box, allowing you to type the date 
from the keyboard, or the Date Settings dialog box, allowing you to select a date and other properties 
using the mouse.

You can choose whether the value edit box always includes fields for entering time in addition to a
date or whether the time fields are displayed only for appointments.



Specifying Pop-up List Values
These advanced features of Ecco Professional are available with full menus only.

Note    Unless otherwise indicated, the information in this section applies to folder values as well as 
columns.

When you create a new pop-up list column or folder or when you choose "<Edit Values>" in an existing 
pop-up list, Ecco displays a Pop-up List dialog box in which you can create and change pop-up list 
values.    In this dialog box, you can:

Add new values to the list by choosing the New button.
Choose a value and edit it in the value edit box.
Delete values from the list by choosing the Delete button.
Reorder the values in the list.

To add values to a new pop-up list column or folder
1. Create a new pop-up list column or folder.    

Ecco displays the Insert Pop-up List Column Values dialog box.

2. Choose the New button.

"Value 1" is highlighted in the value edit box.

3. Type the first value, overtyping "Value 1."

4. Choose the New button (without choosing OK) and continue to add the values you want to include.

Each time you choose New, the previously entered value appears in the list box.

5. When you have typed the last value, choose the OK button.



Using Gantt Columns
These advanced features of Ecco Professional are available with full menus only.

You can use the Column pane to automatically display Gantt charts.    Gantt charts consist of bars 
representing lengths of time and are helpful as a quick way to compare time frames.    A Gantt chart can 
be used, for example, to show the start and completion dates for different tasks involved in building a 
house.    Ecco allows you to display a Gantt chart, with bars in the color of your choice, right on the 
screen.    You can print the chart, too, to create a permanent record of the information.

Because the starting and ending dates displayed in Gantt columns are contained in date folders, creating 
the chart requires little more than identifying a column as a Gantt column.    You can enter dates in the 
Gantt column itself or in the date folders on which it is based.    



Creating a Gantt Column
These advanced features of Ecco Professional are available with full menus only.

A Gantt chart is displayed in a single column in the Column pane. Gantt charts are created from values in 
date folders. The starting date value and ending date value associated with each item in the view define 
the length of one bar on the chart.

You can use any items with date values, stored in any date folders in your Ecco file.    If you want to create
a new Gantt chart based on date folders that do not yet exist, create the date folders first.    

To create a Gantt chart
You can choose the width of your chart by dragging the column boundary.

1. Select a cell in a scratch column.

2. From the Column menu, choose Column Type.

3. Choose Gantt from the column types listed.

Ecco displays the Create New Gantt Column dialog box.

4. In the Chart Range boxes, specify the date range for the chart.

By default, Ecco displays today's date for the starting date and 90 days from today's date for the 
ending date.    In either value edit box, you can choose the down arrow to select a date from the 
calendar.

5. For both the starting and the ending date, in the drop-down lists, select the folders that best describe 
the beginning and end of each bar.

Ecco lists all the date folders currently in the active file.

6. From the Bar Color list, choose the color in which you want to display the bars of the chart.

7. Choose the OK button.

Ecco displays the column without a heading.    If you drag the right column boundary to the right, Ecco
displays dates, in the date range you specified, across the top of the column.    Ecco spaces the dates
proportionate to the total space you have allotted to the column.

To add bars to the Gantt chart
You can create a Gantt bar by adding a pair of date values to any item displayed in the view.

1. In the Gantt column, choose the cell corresponding to the item you want to include in the chart.

If you have not added date values to this item in the date folders specified for the chart, Ecco displays
a value edit box in which you can enter the starting and ending dates.

2. Type the dates, or choose the down arrow button to display the Date Settings dialog box and select 
the dates.

3. Press the ENTER key.

Ecco displays the Gantt bar in the column cell.    

4. Continue to add bars to the chart as desired.

You can minimize a Gantt chart to conserve room.    The minimized column displays a colored bar instead 
of a column heading.    



Changing Gantt Columns
These advanced features of Ecco Professional are available with full menus only.

Once you've created a Gantt chart, you can easily change the range of the chart, the values of the items, 
or the colors of the bars.

You can change the date values of an item displayed in a Gantt bar by simply choosing the cell 
displaying the bar and changing the date in the value edit box. If you change the value in one of the date 
folders elsewhere in Ecco (for example, in the Folder window or in the Calendar view), that change will 
also be reflected in the Gantt bar.    If the new value does not fall within the range specified for the Gantt 
chart, the bar will not appear in the chart.

You can change the date range for the chart, the folders from which the values are taken, or the 
color of the bars at any time.    Select a column cell, from the Column menu choose Properties, and then 
make the necessary changes.

You can change the width of the chart by resizing the column.    All bars will be lengthened or 
shortened proportionately.    You can resize a column by dragging it to the desired width or by choosing 
Width from the Column menu.    



For more information, see Example:    Tracking Information in Columns.



For more information, see The Column Pane.



For more information, see Entering Values in Columns.



For more information, see Using Column Types (and Folder Types).



For more information, see Folder Columns and Folder Values.



For more information, see Introduction to Columns and Values.



For more information, see Using Column Types (and Folder Types).



For more information, see Folder Columns and Folder Values.



Items in Edna's folder



Items with associated information entered in columns



Columns with headings



You can insert a column to display dates.



For a description of the Column pane, see The Column Pane.



For more information, see About Folder Columns.



For more information, see About Formatting.



For more information about the types of values that you can enter into columns, see About Column 
Types.



For more information, see Date Columns.



For more information, see Using Gantt Columns.



For more information, see Pop-up List Columns.



For more information about inserting folder columns, see Using Folder Columns.



For more information, see About Folder Columns.



For more information, see Using Folder Columns.



For more informationabout column value types, see About Column Types.



For more information, see About Folder Columns.



For more information, see Date Columns.



For more information, see Using Gantt Columns.



For more information, see Pop-up List Columns.



For more information, see About Folder Columns.



For more information, see About Column Types.



Entering a pop-up list value



For detailed information about value types, see About Column Types.



For more information, see Introduction to Removing Items from Folders.



For a better understanding of folder columns, see About Folder Columns.



For more information, see The Print Outline View Dialog Box, The PhoneBook Print Options Dialog Box, 
or The Calendar Print Options Dialog Box.



For more information about folders, see Understanding Folders. For more information, see Introduction to 
Columns.



For more information, see Entering Values in Columns.



To create a multiple folder column, first select a folder with subordinate folders.



A multiple-folder column



For more information, see Organizing the Folders in the Folder Window.



For more information, see Using Folder Columns.



For more information, see About Column Types.



For more information, see Understanding Folders.



For more information, see Entering Values in Columns.



For more information, see About Column Types.



For more information, see Adding Items and Values to Folders.



For more information, see About Folder Columns.



For more information, see Adding Items and Values to Folders.



For more information, see Viewing, Editing, and Deleting Values in Folders.



For more information, see About Folder Columns.



For more information, see About Column Types.



Note    Alternatively, you can assign a type to a folder by creating a new column of a certain type in the 
Column pane and then giving the column a heading. 



For more information, see Inserting Columns or About Folder Columns.



For more information, see Pop-up List Columns.



For more information, see Assigning Date Properties.



For more information, see About Folder Columns.



For more information, see Editing and Deleting Values in Columns.



For more information, see Viewing an Item's Folders.



For more information, see About Forms.



For more information, see Text Columns.



For more information, see Number Columns.



For more information, see Date Columns.



For more information, see Pop-up List Columns.



For more information, see Checkmark Columns.



For more information, see Using Gantt Columns.



Note      If you want to print lengthy text values, use outline notes instead of columns, since only the 
amount of text that fits into a cell will appear when you print columns.



Note    Use number values to record numbers for viewing, sorting, or filtering.    You can export column 
values into a spreadsheet program to perform calculations on them.

If you need to include calculations as part of an Ecco file, you can insert a spreadsheet into an Ecco 
outline as an OLE object or link.    



For more information, see Linking and Embedding OLE Objects.



For more information, see The Date Settings Dialog Box.



For more information, see Ecco Default Folders.



For more information, see Assigning Date Properties.



A pop-up list allows you to choose a value from a user-defined, editable list.



For more information, see Specifying Pop-up List Values.



Note      When you sort items using a pop-up list column, the items are sorted based on the position of the 
values in the list.    You can modify this order at any time by choosing Edit Values from the list.



Note    You could produce a similar result by creating a single pop-up list column with "Billable," 
"Overhead,"    and "Personal" listed as values in the pop-up list.



For more information, see The Date Settings Dialog Box.



Note    When you type a new value in an existing pop-up list, the value is added to the end of the pop-up 
list.



For more information, see Inserting Columns, Changing a Column's Type, and Assigning a Type to a 
Folder.



A Gantt chart column



For more information, see Creating a Gantt Column.



For more information, see About Date Columns (and Folders).



For more information, see Adjusting the Column Pane Display.



For more information, see Adjusting the Column Pane Display.



For more information, see Adding or Changing Column Headings.



Filters and Sorting
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            Introduction  
            About Filters  
            Using Filters  
            Advanced Filters  
            Finding Column Information with Filters  
            Sorting Items in a View  



Filters and Sorting
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            Introduction  
            About Filters  
            Using Filters  

Introduction to Using Filters
Creating Filters
Applying Filters

Applying Filters in the Calendar View
Applying Filters in the PhoneBook View
Applying Filters in an Outline View

Using Named Filters
Managing Filters

            Advanced Filters  
            Finding Column Information with Filters  
            Sorting Items in a View  



Introduction
These advanced features of Ecco Professional are available with full menus only.

At this point, you know how to make full use of Ecco to collect items of information, cross-reference them, 
and associate values with them.    Perhaps you're worried that you have too much of a good thing.    You 
need a way to narrow and order the information you're viewing a way to focus on a particular situation or 
set of circumstances.    

You need a filter, which is a search function that displays only those items meeting certain criteria.    You 
can use Ecco filters to limit the display of items in a view to those items whose values meet the criteria 
you specify.    
You can also sort the information displayed in a view so that it is ordered in the way most meaningful to 
you.    By applying both a filter and a sort in a view, you can both limit the items displayed and display 
them in the order you want.    
Filters and sorting are available only if you are using the advanced features of Ecco Professional.



About Filters
These advanced features of Ecco Professional are available with full menus only.

You can use filters in a variety of ways, as shown in the following examples.

You're planning your work week and want to know which outstanding issues you need to tackle first.    In 
your Priority column you've added values indicating the priority of the task items. 

You create a filter to display only those items with a priority of "High."

You're taking a trip to San Francisco and want to print a list of the telephone numbers of your clients living
there.

In the PhoneBook view, you could apply a filter to display only those names with a city value of "San 
Francisco." 

You're cleaning up your list of tasks and want to know which ones are completed.    As you've completed 
tasks, you check them off in your Completed column.    

You can create a filter to display only those items in the Task List folder that are included in the Completed
column.

You can create a filter based on any column displayed in a view. The column must have a heading or 
must have at least one value displayed in it.    For example, you could create a filter based on the 
Company column in the PhoneBook view.    You can create an advanced filter based on one or more of 
your Ecco folders or columns.    For example, you could create a filter based on the Company and the ZIP
code columns in the PhoneBook view.    For the advanced filter, you can specify that the values meet all or
only some of the criteria specified.    

Note    Ecco allows you to use filters in conjunction with the Find command, which allows you to find items
based on database-type criteria.    



Introduction to Using Filters
These advanced features of Ecco Professional are available with full menus only.

If you are using the advanced features of Ecco Professional, you can create as many filters as you want 
and apply any one of them to any Ecco view. Create a filter by choosing the New command from the 
Filters menu and, in the dialog box, selecting a column and entering a value.    You can create an 
advanced filter based on multiple criteria.    

You apply a filter automatically when you create it, or you can choose the Filters command from the 
Advanced menu and select the filter name.     If you create and name a filter in one view, it is available 
from every view.    

You can edit named filters or create new filters by choosing the Filters command, and then choosing 
Manage.    If you create a new filter by choosing the Manage command, the filter will not be applied 
automatically to the view.    



Creating Filters
These advanced features of Ecco Professional are available with full menus only.

You can create a filter based on any column displayed in a view. The column must have a heading or 
must have at least one value displayed in it.

You create a filter by specifying a column on which to apply the filter and a value for that column, if 
applicable.    You can also select an operator, such as "Contains item" or "Equals," that specifies the type 
of comparison to be made.    For example, if you want a Priority column to display only those project tasks
of high priority, in the dialog box you would select Priority from the list of columns, select Equals from the 
list of operators, and type High as the value.

To create a simple filter
Be sure that a heading or some values or checkmarks have already been entered in the column for which
you are creating the filter.

1. From the Advanced menu, choose Filters.

Ecco displays a menu of filter commands.

2. Choose New.

Ecco displays the Filter Current View dialog box.

3. From the list of columns, select a column on which you want to base the filter.

Ecco includes in the list all columns containing headings, values, or checkmarks in the active view.

4. If you want to apply an operator to the value, select one from the list of operators.

Ecco displays a list of available operators.    This list of operators changes according to the column 
type.

5. Type the value on which the filter is to be based.

The value must be appropriate for the column type.    For example, if the column type is Number then 
the value you enter must be a number.

6. If you want to add the filter name to the Filters menu and save it for future use, choose the "Add to 
menu" option and type a name for the filter.

Ecco displays the new filter name in the Filters menu.    The filter is then available in any Ecco view in 
the file as well as from the Find command.    

7. Choose the OK button.

Ecco immediately applies the filter to the view.    Only the items whose values meet the specified 
criteria are displayed (in addition to those parent items necessary to provide context).    The status bar
displays the message "FILTER ON." 



Applying Filters
These advanced features of Ecco Professional are available with full menus only.

When you create a new filter using the New command, that filter is applied immediately to the items in the
active view. Ecco displays only the items whose values meet the specified criteria, along with their sub-
items. In an outline view, parent items necessary to show the context also appear, displayed in green.

The filter remains in effect for a view until you choose Ignore Filter from the Filters menu or until you apply
another filter, either by choosing New and creating a filter or by choosing a named filter.

When a filter is in effect for a particular view, the status bar displays the message "FILTER ON." When 
you choose Ignore Filter, the message disappears and all the items in the view are redisplayed.

When a filter is in effect in any view and you add to the view a new item that does not meet the criteria, 
the item is displayed in green to indicate that it does not meet the criteria.    If the filter is removed, the 
item is displayed in black.

Applying Filters in the Calendar View
The Calendar view acts as a kind of date filter in that it displays tickler items and appointments for only 
the date, week, or month you choose.    However, you might want to further limit the items displayed in 
your Calendar view, for example, by filtering out all but the "Priority 1" items in a Status column.

Filters applied to the Calendar view affect the entire view, not just the date or date range currently 
displayed.    In the Calendar view, only tickler items and appointments that meet the filter criteria are 
shown, regardless of whether their sub-items meet the criteria.

Applying Filters in the PhoneBook View
When you initially apply a filter to the PhoneBook, Ecco displays any item in the PhoneBook that meets 
the filter criteria.    If you click a letter tab, only items that meet the filter criteria and begin with that letter 
are displayed.    When you search for text, the filter is applied to that search as well.    If a name is 
displayed in the entry form, that name also disappears if it does not meet the criteria of the filter (if you 
have not yet applied the new information, you will be prompted to do so before the name disappears).    

In the PhoneBook view, only names that meet the criteria are shown, regardless of whether their sub-
items meet the criteria.

When a filter is in effect in the PhoneBook view and you add a new name to the PhoneBook, that name 
appears in the PhoneBook list only if it meets the filter criteria.

Applying Filters in an Outline View
When you apply a filter to an outline view, only those items meeting the filter criteria are displayed in the 
view, along with their sub-items. If the items are subordinate to items that do not meet the criteria, the 
parent items appear as well and are displayed in green (that is, they appear as context parents).    

If you want each sub-item to be evaluated on its own, choose the Advanced button in the Filter Current 
View dialog box.    In the Create a New Filter dialog box, cancel the option labeled "Subs of items 
matching the criteria are considered to match." When this option is canceled, the sub-item is not 
displayed if the parent item matches the criteria but the sub-item does not.    This option is unavailable if 
you are basing the filter on a column without a heading. 



Using Named Filters
These advanced features of Ecco Professional are available with full menus only.

You can name and save for later use any Ecco filter you create, with the exception of a filter based on a 
column without a heading. To name a filter, choose the "Add to menu" option in the Filter Current View 
dialog box (or in the Create a New Filter dialog box) and type a name for the filter.    The filter name 
appears in the Filters menu, where it is available at any time, from any view.

If you name and save a filter you can:

Retain the specifications of the filter for future use.
Add the filter name to the Filters menu, from where you can choose it from any view.
Apply the filter to items in any view.
Add a tool bar button for the filter.    

If you create a filter but do not name and save it:

You cannot use the filter in any view other than the current one.
You can toggle the filter on and off using the Ignore Filter command.    If you switch to or create 

another filter, however, the specifications of an unnamed filter are not saved.



Managing Filters
These advanced features of Ecco Professional are available with full menus only.

Ecco lets you edit or rename existing named filters, delete named filters, or reorder named filters on the 
Filters menu.    You can perform all these tasks from the Manage Named Filters dialog box.

To manage named filters
You use the Manage Named Filters dialog box to edit, rename, delete, or reorder named filters.

1. From the Advanced menu, choose Filters, and then choose Manage.

Ecco displays the Manage Named Filters dialog box.

2. Take one or more of the following actions:

To rename a filter, select the name of the filter in the list box and then change the name in the 
Rename text box.

To create a new filter, choose the New button.    Ecco displays the Create a New Filter dialog box, 
in which you can specify a new filter.    

To edit a filter, select the name of the filter in the list box and then choose the Edit button.    Ecco 
displays the Edit a Named Filter dialog box, in which you can make the desired changes.

To delete a named filter, select the name of the filter in the list box and then choose the Delete 
button.    This action deletes the filter from all views.

To reorder named filters on the Filters menu, select the names of the filter or filters you want to 
move and then choose either the Up or Dn reorder button.
3. When you are through, choose the OK button.



Advanced Filters
These advanced features of Ecco Professional are available with full menus only.

Ecco allows you to create an advanced filter that specifies more than one set of criteria.    Of the multiple 
sets of criteria, you can decide whether all must be true (AND) or only one must be true (OR) before the 
items are displayed in the filtered view. You can also create multiple sets of criteria that combine AND and
OR operators.    The folders and columns specified in the criteria needn't be displayed in the columns for 
the active view in order for the criteria to be applied.    Filters can help you sieve out only the information 
you need.    Consider the following examples.

You're supervising a team of consultants and want to ensure that Bob, the new hire, is working on his 
most important assignments.    You could show the team's task list in an outline view and create a filter to 
display those items that meet two sets of criteria: items that are in Bob's folder and that have been 
assigned a value of High.

Because Bob doesn't have many assignments of high priority, you decide you want to see those 
assignments of medium priority also.    You could create a filter to display those items that are in Bob's 
folder and have been assigned a value of High or Medium.

Ecco allows you to use multiple folder and column criteria by choosing the Advanced button in the Filter 
Current View dialog box.    In the Create a New Filter dialog box, you specify each set of criteria for a 
multiple folder filter.    You do this in the same way that you specify criteria for a single column filter.    

By default, Ecco treats sub-items of an item that matches a specific line of criteria as though the sub-
items meet the criteria (the checkbox "Sub-items matching this criteria are considered to match" is 
selected).    You can select or cancel this option for each line of criteria.    
For example, you might want to know which of your daily tasks are still uncompleted.    You have created 
a Task List folder and a Done folder, and as you complete tasks you add them to your Done folder.    In 
your Done folder, you can see that so far today you have reserved a location for the photo shoot.

In the Create a New Filter dialog box, you could create a filter specifying that the items displayed are 
included in the Task List folder and not included in the Done folder.    You would specify that the sub-items 
are evaluated separately from their parent items in the Done folder but not in the Task List folder.

When you apply the filter, only the uncompleted tasks (sub-items) are displayed in the Task List folder.

Note    If you used the Create a New Filter dialog box to create the current filter, then when you 
subsequently choose New from the Filters menu, Ecco displays the current filter in the same dialog box.

To create an advanced filter
You can create an advanced filter using the Advanced button in the Filter Current View dialog box.

1. From the Advanced menu, choose Filters.

2. From the Filters menu, choose New.

Ecco displays the Filter Current View dialog box.

3. Choose the Advanced button.

Ecco displays the Create a New Filter dialog box.

4. From the Folder window in the dialog box, select the folders to be included in the criteria.

First decide whether you want the items to meet all the sets of criteria you list (AND) or only one 
of them (OR).    You can have a combination of both in the same filter.    If this is an OR list, choose the 
Begin button under the Folder window display to begin a list in which only one line of the criteria is 
required.    The button display changes to End and, in the Criteria list box, the message "<click a folder to 



add criteria>" is displayed.    
Select a folder to be included in the criteria by choosing a folder button.    Ecco displays the name 

of the folder in the criteria list.    If this is an OR list, the folder name is displayed under the heading "Any 1
of the following:" When Ecco adds a folder to the list, it displays the value "Contains Item" by default, next 
to the folder name.

When you want to end the OR list, choose the End button.    
5. For each criterion you have included in the list box, you can select the folder name and specify the 

following in the lower part of the dialog box:

An operator, if desired, appropriate for the folder type.    Select one from the list of operators.
A value appropriate for the operator and folder type.    Type a value and then select the criteria to 

add it to the Criteria list box.
Whether or not the sub-items of the items matching the criteria are also considered to match and 

are displayed in the view.    Under the folder list box, select "Sub-items matching this criteria are 
considered to match."
6. To add the filter to the Filters menu, select the "Add to menu" checkbox and then type a filter name.

7. When you have specified the filter to your satisfaction, choose the OK button.

Ecco immediately applies the filter to the view.    Only the items meeting the value criteria specified 
are displayed.    The status bar displays the message "FILTER ON."

Tip    When creating a filter, you might discover that you would like to collect items in a new folder.    From 
the Folder window displayed in the Create a New Filter dialog box, you can add new folders and change 
the names of existing folders.    To do so, you use the same procedure that you use to add or rename 
folders in the Folder window.    



Finding Column Information with Filters
These advanced features of Ecco Professional are available with full menus only.

In addition to using a filter to limit the amount of information displayed, you can use a filter to find items, 
whether you specify search text or not.    

To find items using a filter
Use this procedure to find items in the file that match a filter.    

1. From the Edit menu, choose Find.

The Find dialog box appears.

2. In the Find box, type the text you want to find.

Or
To use a filter without specifying search text, press the DEL key to clear the highlighted text.

3. Choose the Unfold button (>>) to expand the Find dialog box.

The Find dialog box expands, displaying additional options.    

4. Beside "Find Items Matching Filter," select an existing filter.

Or
Select the "Custom" option and create a filter.    

5. If you want, select one or more of the following to control your search:

To highlight the next instance of the specified text, beside Actions, select the "Find Next" option.
To select all items in the view that contain the specified text, beside Actions, select the "Select All 

in View" option.
To copy all occurrences of the specified text in the file to the Search Results view, select the 

"Copy to Search Results' view" option.    To replace the contents of the Search Results view with the 
newly found items, select Replace from the list box.    To append the newly found items to the end of the 
Search Results view, select Append from the list box.    

6. Choose the Find button or the Collect All button.



Sorting Items in a View
These advanced features of Ecco Professional are available with full menus only.

Sorting means rearranging items. Using Ecco, you can arrange items:

In alphabetical order.
In ascending or descending order (in descending order, Ecco sorts 9

0 or Z
A).

By associated value.
In alphanumerical order.
By a combination of the above methods.

Using a simple sort, you can arrange items alphanumerically by their text.    Using a more powerful sort, 
you can arrange items by value, using the values displayed in columns. For example, you might sort 
items by date or by order of priority.    Suppose you wanted to sort items in a project outline by due date.    
If you have a Due Dates column, you can easily arrange the items in the project outline in chronological 
order.

Ecco lets you sort items using two sorting criteria, or keys.    Choose the more significant criteria for the 
first sort key and the less significant for the second sort key.    For example, to sort by due date and to 
arrange all items with the same due date in alphabetical order, first sort on the Due Dates folder column 
and then sort by item text.    

You can sort all top-level items or the sub-items of any selected items or folders. If you choose to sort 
sub-items, only the items one level subordinate to the selected items or folders are sorted.    For example,

Selecting a folder sorts only the first-level items below it.
Selecting a first-level item sorts only the second-level items below it.
Selecting first and second-level items sorts the second and third-level items.

To sort items
You can sort all top-level items in a folder or you can sort an item's sub-items.    

1. Select the folders or items whose sub-items you want to sort.

2. From the Advanced menu, choose Sort.

The Sort Items dialog box appears.

3. To sort all top-level items, select the "Entire view" option.

Or
To sort sub-items of selected items or folders, select the "Sub-items of selected items or folders" 
option.

4. To sort by item text, in the Sort key 1 drop-down list, select <item text>.

Or
To sort by a value, select a column to sort by the values in that column.    

5. If you want to list items in descending order, select the "Descending" option.

6. If you want, specify a second sort criteria, or key.

7. Choose the OK button.

Ecco sorts the selected items according to your specifications.



For more information, see About Filters.



For more information, see Sorting Items in a View.



Text values indicate the priority of your tasks.



A filtered view, based on the Priority column



A PhoneBook view, before applying a filter



A filtered view, based on the City column



A Completed column, indicating completed tasks



A filtered view, based on the Completed column



For more information, see Advanced Filters.



For more information, see Finding Column Information with Filters.



For more information, see Creating Filters.



For more information, see Applying Filters.



For more information, see Using Named Filters.



For more information, see Managing Filters.



Create a single column filter.



For more information, see Using Named Filters.



For more information, see Applying Filters.



Note    You can apply only one filter to the items displayed in one view.    Use advanced filters to specify 
multiple criteria.



For more information, see Understanding Context Parents.



For more information, see Advanced Filters.



For more information, see Adding Buttons to the Tool Bar on the Fly.



For more information, see Creating Filters.



A filter based on multiple criteria



A filter based on AND and OR criteria



For more information, see Creating Filters.



Items in the Task List and Done folders



Creating a filter based on the Task List and Done folders



The outline view with the filter applied



In the Create a New Filter dialog box, you can specify operators and values for each folder.



For more information, see Creating Folders.



For more information on using the Find command, see About Finding Items.



For more information, see Creating Filters.



For more information, see Using the Search Results View.



Note    You can select and sort multiple folders or multiple items.    You cannot select and sort a 
combination of both folders and items, however.



For more information, see Introduction to Columns.



Forms
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Forms  
            Creating Forms  
            Adding Items by Form  
            Applying Forms to Items  
            Viewing Items by Form  
            Managing Multiple Forms  



About Forms
These advanced features of Ecco Professional are available with full menus only.

Forms make use of both folders and columns, using them interchangeably.    

Perhaps you've found yourself adding certain kinds of items to the same folders again and again.    For 
example, you might be adding all items related to a specific project to each of three folders: the project 
folder, the "Bob Smith" folder, and the "Pete Jones" folder.    Or you might have found yourself repeatedly 
updating the same column values for a large number of items.    For example, at the start of the day, you 
might prioritize your tasks by assigning all high-priority items a value of "high" in your Status column.    If 
these scenarios sound familiar, Ecco forms can help you automate your work.
Forms automate the work of adding items to folders and of associating column values or folder values 
with those items.    Instead of adding items to folders one by one, you can create forms that will add items 
to multiple folders at one time and supply column values at the same time.    Forms help you to categorize
and cross-reference information quickly and easily.
The names of both columns and folders appear in the Folder window. When creating a form, you decide 
which folders to include as well as the default column values that any item will receive.    For example, 
suppose you created a form titled "Expansion Issues." This form could include:

Checkmark folders for the individuals working on the expansion project.
A number column titled "Cost" for estimated budget amounts.
A text column titled "Region."
A Priority column that contains pop-up list values of High, Medium, and Low.

Once you have created the form "Expansion Issues," you can apply it to one or more items.    When you 
apply this form to an item:

The item is placed in the checkmark folders listed on the form with the value <checked>.
You give the item a Cost column dollar value.
The item is given a default Priority column value of "High."
The item is given a default Region column value of "West."

You can use the following form commands on the Advanced menu to work with forms:

Add Item by Form lets you create a new item and add it directly to multiple folders without 
requiring you to first type the item into a particular view.    

Apply Form to Items adds any number of selected items to multiple columns or folders at one 
time while simultaneously associating column values with the items.    

View Item by Form steps through each item in a view, displaying each item's folder or column 
values and allowing you to change those values.    



Creating Forms
These advanced features of Ecco Professional are available with full menus only.

A form consists of folders, or columns, and values. You can create forms to quickly add items and their 
associated values to several columns at once.    For example, you could create a form that adds an item 
to a specific project column, a "Budget" column, and a "Priority" column all at once.    

You can create a new form in either of two ways.

In the Create New Form dialog box, supply values for all columns on the form and select the "Put 
Items in Folder; don't display Form" checkbox.    When you subsequently choose the Apply Form to Items 
command, the items and their associated values are automatically added to the specified columns without
displaying the form.

In the Create New Form dialog box, add columns to the form, optionally specifying values.    
When you choose the Apply Form to Items command, the Apply Form dialog box appears.    You can add 
the item to selected columns, or you can change the default values for any column on the form.    For 
example, you might associate a different number or date with a particular item.
If you don't supply a value for a column in the form, Ecco will ignore that column when you apply the form 
to an item.

To create a new form
Once you create a form, you can use it with the Add Item by Form, View Item by Form, and Apply Form to
Items commands.

1. From the Advanced menu, choose Add Item by Form, and then choose New Form.

The Create New Form dialog box appears.

2. In the Rename box, type the name you want to give the form.

This name will be listed in a cascading menu whenever you choose any of the form commands.

3. Select the folders or columns you want to add to the form.

The folder and column names appear in the Folder list as you add them.

4. To enter a default column value for items that will be added or modified using this form, select the 
column and then enter a value in the value edit box. 

When you add checkmark folders, the default item value is <checked>.    You can supply default 
values for all other column types.    For example, if you add a Date column to the form, you can enter 
a default date that will be assigned automatically to each item added or modified by the form.

You can enter a value when you use any of the form commands, even if you do not supply a default 
value in the form.

5. If you don't want Ecco to display the form when you choose the Apply Form to Items command, select
the "Put Items in Folders; don't display Form" checkbox.

If the list contains columns for which no default value has been specified, you cannot select this 
checkbox.

6. Choose the OK button.

Note    To edit a folder name from within the Create New Form dialog box, double-click the folder name.



Adding Items by Form
These advanced features of Ecco Professional are available with full menus only.

You can use your forms to create new items, adding them to folders and supplying column values, from 
anywhere within Ecco.    You can also add items by form from other programs, using the Shooter.    

When you add an item by form, you don't have to type it into a view. You can add it directly to several 
folders at once, using a form.    You won't see the item displayed unless the folders on the form are 
displayed in views or you've chosen to add it to the active view.
You can use the default column values you set up when you created the form, or you can change the 
values.    You can also add an item to the active view as well as to the folders on the form.

To add a new item by form
Use the Add Item by Form command to add new items to folders one at a time.    You can continue adding
items without closing the dialog box.

1. From the Advanced menu, choose Add Item by Form, and then choose from the menu the form you 
want.

The Add by Form dialog box appears, listing the folders, columns, and the associated values set up 
on this form.

2. In the Item Text box, type the item you want to add.

3. To set or change a column value, select the column, and then enter a value in the value edit box.

For checkmark folders and columns, the item's value is either <checked>, if it is to be added to the 
column or folder, or <excluded>, if the item is not to be added to the column or folder.    Items whose 
value indicates <excluded> will not be added to folders .

4. If you don't want to include an item in one of the form's folders, select the folder, and then choose the 
Clear Value button.

Ecco changes the item's folder value to <excluded>.

5. If you want to add this item below the selected item in the active view, select the "Add to active View" 
checkbox.

6. To add the item, do one of the following:

To add the item and close the dialog box, choose the Add button.
To add the item and continue adding other items, choose one of the Add & Continue buttons.    

You can then add subsequent items at the same level as or subordinate to the previous item added.
Note    If you changed any of the item's values and you want to reset all of them, choose the All Defaults 
button.



Applying Forms to Items
These advanced features of Ecco Professional are available with full menus only.

The Apply Form to Items command provides a quick way to add any number of items to several folders 
and supply several column values at once.    For example, suppose you have added several new items to 
a task outline.    You could apply a form to add all these items to your Project folder and assign a priority 
number and a due date with items added to them.

You can also use the Apply Form to Items command to update values for items items that already have 
values for columns on the form.    For example, suppose you applied a form that assigned a specific due 
date to several items.    If the due date changes, you can apply the form again and change the value for all
the items at once.    

To apply a form to existing items
When you apply a form to existing items, you can select the folders or columns to which you want to add 
the items.    You can also modify the values to be associated with the item for each of the columns.

1. Select the items to which you want to apply the form.

2. From the Advanced menu, choose Apply Form to Items, and then choose the form you want to apply.

The Apply Form dialog box appears unless you selected the "Don't display Form" checkbox when you
created the form.

If you selected the "Don't display Form" checkbox, the selected items are added to the form's folders and 
assigned the default values you specified.
3. If you don't want to add the selected items to a folder or column, select the folder or column name 

and then choose the Ignore button.

Ecco changes the item's folder value to <ignore>.

4. To change a value, select it, and then change the value in the value edit box.

For checkmark folders or columns, you can select either the <checked> or the <ignore> value.    For 
other column types, Ecco displays a value edit box in which you can enter an appropriate value.

If a value is indicated as <ignore>, Ecco does not add the item to the folder or change its column 
value when you apply the form.

5. Choose the OK button.



Viewing Items by Form
These advanced features of Ecco Professional are available with full menus only.

Using the View Item by Form command on the Advanced menu, you can quickly see which folders on a 
form an item has been added to and the value associated with that item in each column. You can then 
add the item to or remove the item from any folder on the form and change the values associated with the
item for each column.

From the View by Form dialog box, you can step through the items in the active view, displaying all the 
folders containing the item and all the columns for which the item has been given a value, and make 
changes to any of those values.    For example, if priorities change, you could update the value in the 
Priority column for each item in a view.

To view an item's folders
Use this procedure to view an item's folder or column assignments by form and edit the value associated 
with the item for each column.

1. Select the item whose folders and columns you want to view.

Select the first item in the view if you want to step through all the items in a view, looking at each 
item's folders and columns in turn.

2. From the Advanced menu, choose View Item by Form, and then choose the form by which you want 
to view the item.

The View by Form dialog box appears.    The text of the selected item is displayed in the Item Text 
box.    The folders and columns included on the form are listed below Column or Folder Name.    For 
each column on the form, the values associated with the selected item are listed below "Item's Value 
(editable)."

3. To remove an item from a folder, select the folder from which you want to remove the item, and then 
choose the Clear Value button.

4. To add an item to a folder or to enter a column value, select the folder or column to which you want to 
add the item, and then choose the <checked> option or supply a value in the value edit box.

5. To edit a value, select it, and then change the value in the value edit box.

If you don't add or delete a value, Ecco does not add or remove the item from the column.

6. To view the folders and columns for the next item in the view, choose one of the Next Item buttons.

The Next Item buttons let you move through the items in the active view without closing the dialog 
box.    You can move up or down the outline's items at the same level, or you can move from one level
to another.

7. When you are through viewing items' folders, choose the OK button if you have made changes you 
want to save.

Or 
Choose the Close button if you do not want to save your changes for the current item.

Tip    If you want to delete an item from all folders, choose the Delete Item button in the View by Form 
dialog box.



Managing Multiple Forms
These advanced features of Ecco Professional are available with full menus only.

Ecco lets you edit or rename existing forms, delete forms, reorder forms on the menu, or make forms 
public. You can perform all these tasks from the Manage Forms dialog box.

To manage forms
You use the Manage Forms dialog box to edit, rename, delete, or reorder forms and to make forms public.

1. From the Advanced menu, choose Add Item by Form, and then choose Manage Forms.

The Manage Forms dialog box appears.

2. Take one or more of the following actions:

To rename a form, select the form you want to rename, and then type in the Rename box the new
name you want to give the form.    

To create a new form, choose the New button.
To edit a form, select the form you want to edit, and then choose the Edit button.
To delete a form, select the form you want to delete, and then choose the Delete button.
To reorder forms on the various Form menus, select the forms you want to move, and then 

choose either the Up button or the Dn button.
To make a form public, select the form you want to make public, and then select the "Make 

Public" checkbox, in the lower right corner of the dialog box.    

3. When you are through making changes, choose the OK button.



For a better understanding of the basic relationship between folders and columns, see About Folder 
Columns.



The Expansion Issues form specifies the folders and values that are assigned when you apply the 
form to an item.



For more information, see Adding Items by Form.



For more information, see Applying Forms to Items.



For more information, see Viewing Items by Form and About Folder Values.



For more information, see Sending Information to Ecco.



You can change the default column values when you add a new item by form.



For more information, see Sharing Forms.



Using Ecco in Workgroups
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Workgroup Computing  
            Using a Public File  
            Sharing Views, Columns, Folders, and Forms  
            Using Shared Items  
            Scheduling Meetings and Sharing Calendars  
            Disconnecting from a Public File  
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Using Ecco in Workgroups
These advanced features of Ecco Professional are available with full menus only.

Click a book to expand or collapse the outline.
            About Workgroup Computing  
            Using a Public File  
            Sharing Views, Columns, Folders, and Forms  
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About Workgroup Computing
These advanced features of Ecco Professional are available with full menus only.

If you are part of a networked workgroup, you can use public files to share information with others.    A 
public file is an Ecco file shared by two or more users on a network.    When you connect a private file to a
public file, you can share any part of your file with others in a workgroup.    Any information you make 
public is stored in the public file as well as in your own file.

To share information over a network, you must first:

Create a new public file using the Connect to Public command.    

If a public file already exists, you can:

Use the Connect To Public command to connect any private file to a public file.
View public information in that file.
Share parts of your Ecco file

folders, outline views, columns, or forms
so that others in your workgroup can view and work with the information.

All the information you share is saved in the public file and is available to anyone who connects to the 
public file.    All other information in your file remains private; that is, only you can view or change it.

As long as each user in your workgroup is connected to the same public file, you can use Ecco for 
multiuser tasks such as outlining, assigning project tasks, scheduling projects, tracking project or task 
progress, posting announcements or meeting outlines, and more.    

Multiple users (up to 250) in a workgroup can view and edit the public information simultaneously.    
Record locking ensures the integrity of the data.

The following examples illustrate ways in which you might use Ecco in a workgroup.

Example:    Project Team
Create public folders, one for each team member.    Assign tasks by adding the tasks to folders.
Enter team meeting notes into a public outline view.    Post action items to team members' folder 

columns. 

Create a project schedule in a public outline view.    Insert columns that show the start and due 
dates for each project task as well as the resources (for example, personnel and equipment) needed to 
complete each task.    Include project milestones.

Summarize the week's activity, posting end-of-week reports in a public outline view.
Dedicate an outline view to project brainstorming.



What is a Public File?
These advanced features of Ecco Professional are available with full menus only.

A public file is an Ecco file shared by two or more users on a network.    You must connect a private file to 
a public file in order to share information with others in a workgroup. Any information you make public is 
stored in the public file as well as in your own file.

Where a public file resides depends upon your network.    If you have a network server, you might want to 
store the public file on the server.    Alternatively, you can store the file on your own PC's hard disk, 
provided you are running Windows for Workgroups and the disk is accessible to others over the network.  
If you are not sure where to find a particular public file, ask your network administrator for help.



Creating a Public File
These advanced features of Ecco Professional are available with full menus only.

When you create a public file, your private file is automatically connected to it.    If another user creates a 
public file, you must connect your own private file to it in order to view and work with the shared 
information.

To create a public file
Before you create a public file, you must open your own private file.

1. From the File menu, choose Connect to Public.

Ecco displays the Connect to Public File dialog box.

2. Choose the New Public File button.

3. Choose the OK button.

Ecco displays the Create Ecco Group File dialog box.

4. In the File Name box, type the name you want to give this public file.

All public files have a .ECG file extension.    When you create a public file, Ecco also creates a file of 
the same name with a .ECB file extension.    This .ECB file holds all OLE objects embedded in the 
public file.    

5. Choose OK.

You can now share any views, folders, columns, and forms in your file with members of your 
workgroup.



Connecting to a Public File
These advanced features of Ecco Professional are available with full menus only.

To use an existing public file, you first need to connect your private file to it.    Once you've connected to a 
public file, you can make views, folders, and columns in your private file available to others in your 
workgroup. You can also view any information that others have made public.

You can disconnect from a public file that you no longer need to be connected to.    

To connect to a public file
Before you connect to a public file, you must first open your own private file.

1. From the File menu, choose Connect to Public.

Ecco displays the Connect to Public File dialog box.

2. Select the "Existing Public File" option.

3. Choose the OK button.

Ecco displays the Connect to Ecco Group File dialog box.

4. In the "File Name" box, select the public file to which you want to connect.

All public files have a .ECG file extension.

5. Choose OK.

You can now share any views, folders, forms, and columns in your file with members of your 
workgroup.



Introduction to Sharing
These advanced features of Ecco Professional are available with full menus only.

After you connect to a public file, you can make public any of the outline views, folders, columns, and 
forms in your private file.    For example, you could share an outline view that contains information the 
entire workgroup needs, such as a project meeting outline.    Any folders or items you later add to that 
view would also become public.

Once you have shared an outline view, any existing columns in the view are also shared.    You can share 
any columns that you later add to the view.    Sharing a folder column also shares the folder.    In other 
words, making a folder column public is the same thing as making the entire folder public.

When you make an outline view public, a share bar, a blue horizontal line, appears above every item 
bullet in that view.    When you share a folder, a share bar appears inside the folder icon.



Sharing Views
These advanced features of Ecco Professional are available with full menus only.

You should share an outline view when you want to give your workgroup access to everything in that 
view.    When you share a view, all items, folders, and columns contained in the view become public. Any 
items or folders (or, optionally, columns) you add to the view also become public.    For example, you 
might make public a project view that contains folders, items, and forms that relate to a project that 
involves several people.    

To share an outline view
1. Display the new or existing outline view you want to share.

2. From the View menu, choose Make Public.

A share bar appears above each item bullet and inside each folder icon.    All the items and folders in 
the view can now be shared by anyone connected to the public file.    



Displaying a Shared View
These advanced features of Ecco Professional are available with full menus only.

You display a shared view just as you display any other view in your file.    You can then add to the view 
the items and folders that you want to share with the rest of your workgroup.

To display a shared view 
Shared views are listed on the view menu with the other views contained in your file.

From the View menu, choose Outlines, and then choose the view you want displayed.



Sharing Folders
These advanced features of Ecco Professional are available with full menus only.

When you share a folder, the items in the folder become available to other members of your workgroup. 
Any item you add to a folder also becomes public. 

To share folders
You can share a folder by adding it to a public view.    Alternatively, you can make a folder public in the 
Folder window.

1. From the Folder menu, choose Edit Folders.

2. Select the folder you want to share.

3. From the Folder menu, choose Make Public.

A share bar appears inside the folder icon.    All items in the folder or added to this folder will be public.



Viewing the Contents of a Shared Folder
These advanced features of Ecco Professional are available with full menus only.

You can display a shared folder's contents in any outline view, public or private.    You add a public folder 
to a view the same way you add a private folder.

To view the contents of a shared folder
You can view the contents of a public folder in any outline view.

1. From the View menu, choose the view in which you want to display the folder.

2. Drag a public folder icon from the Folder window into the outline view.



Sharing Columns
These advanced features of Ecco Professional are available with full menus only.

When you share a view, any columns already inserted in the view become public. Once the view has 
been made public, any user can add private columns without altering the view as seen by other users.    
Additionally, a user can share a private column in a public view with others on the network by using the 
Make Public command on the Column menu. 

For example, you might share two date columns in a "Milestones" outline view: a "Start Dates" column 
and a "Due Dates" column.    Or you might share columns that show which members of the workgroup 
have been assigned to particular tasks.    Members of the workgroup can then see their individual tasks, 
start dates, and due dates as well as those assigned to others.

To share a column
Before you can share a column, you must first make public the view in which it appears.

1. Select a cell in the column you want to share.

2. From the Column menu, choose Make Public.



Sharing Forms
These advanced features of Ecco Professional are available with full menus only.

You can share forms that you want to make available to the workgroup. This can help ensure that users 
add new items to the appropriate folders throughout the public file. 

To share a form
Once you have created a form, you can share it with the workgroup.

1. From the Advanced menu, choose Add Item By Form.

Ecco displays a second menu.

2. From the menu, choose Manage Forms.

Ecco displays the Manage Forms dialog box.

3. In the list of forms, select the form you want to share.

4. Select the Make Public checkbox.

5. Choose the OK button.

This form will appear on the various forms menus of all workgroup users.



What is a Shared Item?
These advanced features of Ecco Professional are available with full menus only.

A shared item is an item in any public view or folder. Shared items are distinguished in an outline view by 
a share bar, a blue horizontal line, above the item bullet. You work with shared items just as you do with 
any items.    You can edit, delete, add to folders, filter, and sort shared items.    With the exception of 
results of filters, any changes made to shared items are reflected throughout the workgroup. When you 
apply a filter to a view, you do not alter the view as seen by others; only you see the results.



Sharing Items
These advanced features of Ecco Professional are available with full menus only.

A shared item is an item in any public outline view or folder. You share an item by adding it to a public 
view or folder.    You can make an item nonpublic by deleting it or by removing it from all public views and 
folders.

To share an item
Anyone in the workgroup can view, edit, or delete items.

Type an item into any public view.

Or
Add an item to any public folder using the Folders window.    

To make an item nonpublic
1. Expand the entire outline so all the item's parent and sub-items are displayed.

2. Select the item and any of its parent and sub-items that have a long, blue share bar above them.    
(These items have been added explicitly to public folders.)

3. Remove the selected items from any public folders that contain them by clicking the folder name in 
the Folder window and then choosing Remove Items from Folder(s).

The blue bar inside a folder's icon indicates that the folder is public.    A checkmark next to a folder 
name indicates that one or more of the selected items are in that folder.

Note    Alternatively, you can use the Show Item Info command on the Advanced menu to move through 
the items in a view and remove them from any public folders.



Changing Shared Items
These advanced features of Ecco Professional are available with full menus only.

Once items have been shared, anyone in the workgroup can change those items.    However, workgroup 
members cannot change an item that another user is currently working with.    As long as one user has an 
item selected, that item is unavailable to all other workgroup users.

To change shared items
You can edit any shared item as long as no other user has that item selected.

1. Select the item you want to change.

2. Make the changes you want.

3. Press the ENTER key, or select another item.

The change appears immediately throughout the public file.



Shared Items and Share Bars
These advanced features of Ecco Professional are available with full menus only.

A shared item can be identified by the share bar that appears above its item bullet. An item will have 
either a long or short share bar, depending on whether or not it has been explicitly added to a public 
folder.

Because an outline view shows all the sub-items of an item included in a folder, Ecco does not explicitly 
add sub-items to a folder when you type them.    These shared sub-items are identified by a short share 
bar.    Items that have been explicitly added to a public folder are identified by a long share bar.

Therefore,

When you add an item to a public folder, its bullet has a long share bar.    Its sub-item's bullets, 
unless they have been explicitly added to a public folder, have short share bars.

When you type a top-level item under a folder name in a public outline view, it is automatically 
added to that folder.    Because it has been added to a public folder, its share bar is long.

When you demote a top-level item to a lower level, it is removed from the folder, and its share bar
is shortened unless the item has been explicitly added to another public folder.

When you promote a sub-item to the top level of a public outline view, it is added to the public 
folder under which it appears in the outline view, and its share bar is lengthened.



Shared Items and Context Parents
These advanced features of Ecco Professional are available with full menus only.

You can share items in a private view by adding them to a public folder.    When you add a sub-item to a 
public folder, only that sub-item goes into the folder.    However, the items directly above the sub-item, the 
context parents, appear in the files of all workgroup users to provide the necessary context.    These 
context parents are shaded to indicate that they have not been added to the public folder.

In your file, the share bars of the parent items will be shaded to remind you that the parents have not 
been added to the public folder but have been shared only to provide context.    



Scheduling Meetings and Sharing Calendars
These advanced features of Ecco Professional are available with full menus only.

Group scheduling and shared Calendar views are available in the workgroup version of Ecco (Ecco for 
Workgroups).



Disconnecting from a Public File
These advanced features of Ecco Professional are available with full menus only.

If you no longer want your private file connected to a public file (for example, if you want to connect your 
private file to a different public file) you can disconnect it.    When disconnecting your private file from a 
public file, you have two options.    You can:

Disconnect, removing all public information from your private file.    This includes all information 
that you have made public.

Disconnect, keeping a copy of all public information in your private file.    If you later reconnect to 
the same public file, a duplicate of the public information will appear in your private file.

To disconnect from a public file
To disconnect from a public file, the private file from which you want to disconnect it must be active.

1. From the File menu, choose Connection Status.

The Connection Status & Options dialog box appears.

2. Select the "Completely disconnect from public file" option.

3. Do one of the following:

To disconnect and remove all public information from your file, select the "Disconnect, removing 
all public information from public file" option.

To disconnect and retain a copy of all public information, select the "Disconnect, keeping local 
copies of public information" option.
4. Choose the OK button.

Your private file is now disconnected.

Note    In addition to allowing you to disconnect from a public file, the Connection Status & Options dialog 
box displays two other pieces of helpful information.    It displays the full pathname of the public file to 
which you are connected, and it tells you whether the public file to which you are connected is currently 
available.



For more information, see Creating a Public File.



For more information, see Using Folder Columns.



For more information, see Linking and Embedding OLE Objects.



For more information, see Disconnecting from a Public File.



Share bars indicate which items and folders have been made public.



For more information, see Understanding Folders.



For more information, see Introduction to Columns.



For more information, see About Forms.



For more information, see About Adding Items to Folders.



For more information, see Understanding Context Parents.



Windows and Dialog Boxes
Windows

The Ecco Program Window
The Ecco Program Window (with Full Menus)
The Tool Bar
The Calendar View Window
The PhoneBook View Window
Viewing Information in the PhoneBook View Window
The Outline View Window
The Folder Window
The Column Pane

File Menu Dialog Boxes
The Connect to Public File Dialog Box
The Connection Status & Options Dialog Box
The File Import Dialog Box
The Choose Fields for Import into PhoneBook Dialog Box
The Import into Current View Dialog Box
The Choose Columns for Import Fields Dialog Box
The Export Outline Dialog Box
The Export Outline and Columns Dialog Box
The Choose Column Set Dialog Box
The Export PhoneBook Dialog Box
The Choose Field Set Dialog Box
The Print Outline View Dialog Box
The Print Calendar View Dialog Box
The Calendar Print Options Dialog Box
The Print PhoneBook View Dialog Box
The PhoneBook Print Options Dialog Box

Edit Menu Dialog Boxes
The Find Dialog Box
The Find and Replace Dialog Box
The Links Dialog Box

View Menu Dialog Boxes
The Create A New Outline View Dialog Box
The Manage Named Outlines Dialog Box 

Item Menu Dialog Boxes
The Show Levels Dialog Box

Format Menu Dialog Boxes
The Character Dialog Box
The New Named Text Touch-Up Dialog Box



The Manage Text Touch-Ups Dialog Box 
The Outline Styles Dialog Box
The Outline Labels Dialog Box
The Manage Outline Labels Dialog Box

Tools Menu Dialog Boxes
The Create An Alarm Dialog Box
The Review Alarms Dialog Box
The Manage Named Alarms Dialog Box
The Show Item in Calendar Tickler Section Dialog Box
The Tool Bar Dialog Box 
The Ecco Preferences Dialog Box

Advanced Menu Dialog Boxes
The Sort Items Dialog Box
The Filter Current View Dialog Box
The Create a New Filter Dialog Box
The Manage Named Filters Dialog Box
The Choose Outline Folders Dialog Box
The Show Item Info Dialog Box
The Create New Form Dialog Box
The Manage Forms Dialog Box 
The Add By Form Dialog Box
The View By Form Dialog Box
The Apply Form Dialog Box

Calendar Dialog Boxes
The Date Settings Dialog Box
The Add Tickler Item Dialog Box
The Dialer/Call Logger Dialog Box
The Alarms Dialog Box
The Recurring Event Dialog Box

PhoneBook Dialog Boxes
The Dialer/Call Logger Dialog Box

Column and Folder Dialog Boxes
The Create New Gantt Column Dialog Box
The Column Width Dialog Box
Pop-Up List Column Values Dialog Box
The Date Properties Dialog Box
The Specify Folders and Column Values Dialog Box

Shooter Dialog Boxes
The Send Text Selection As Dialog Box



Windows and Dialog Boxes 
Add By Form Dialog Box
Add Tickler Item Dialog Box
Alarms Dialog Box
Apply Form Dialog Box
Calendar Print Options Dialog Box
Character Dialog Box
Choose Column Set Dialog Box
Choose Columns for Import Fields Dialog Box
Choose Field Set Dialog Box
Choose Fields for Import into PhoneBook Dialog Box
Choose Outline Folders Dialog Box
Column Width Dialog Box
Connect to Public File Dialog Box
Connection Status & Options Dialog Box
Create a New Filter Dialog Box
Create A New Outline View Dialog Box
Create An Alarm Dialog Box
Create New Form Dialog Box
Create New Gantt Column Dialog Box
Date Properties Dialog Box
Date Settings Dialog Box
Dialer/Call Logger Dialog Box
Ecco Preferences Dialog Box
Export Outline and Columns Dialog Box
Export Outline Dialog Box
Export PhoneBook Dialog Box
File Import Dialog Box
Filter Current View Dialog Box
Find and Replace Dialog Box
Find Dialog Box
Import into Current View Dialog Box
Links Dialog Box
Manage Forms Dialog Box 
Manage Named Alarms Dialog Box
Manage Named Filters Dialog Box
Manage Named Outlines Dialog Box 
Manage Outline Labels Dialog Box
Manage Text Touch-Ups Dialog Box 
New Named Text Touch-Up Dialog Box
Outline Labels Dialog Box



Outline Styles Dialog Box
PhoneBook Print Options Dialog Box
Pop-Up List Column Values Dialog Box
Print Calendar View Dialog Box
Print Outline View Dialog Box
Print PhoneBook View Dialog Box
Recurring Event Dialog Box
Review Alarms Dialog Box
Send Text Selection As Dialog Box
Show Item in Calendar Tickler Section Dialog Box
Show Item Info Dialog Box
Show Levels Dialog Box
Sort Items Dialog Box
Specify Folders and Column Values Dialog Box
Tool Bar Dialog Box 
View By Form Dialog Box
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            File Menu Dialog Boxes  
            Edit Menu Dialog Boxes  
            View Menu Dialog Boxes  
            Item Menu Dialog Boxes  
            Format Menu Dialog Boxes  
            Tools Menu Dialog Boxes  
            Advanced Menu Dialog Boxes  

The Sort Items Dialog Box
The Filter Current View Dialog Box
The Create a New Filter Dialog Box
The Manage Named Filters Dialog Box
The Choose Outline Folders Dialog Box
The Show Item Info Dialog Box
The Create New Form Dialog Box
The Manage Forms Dialog Box 
The Add By Form Dialog Box
The View By Form Dialog Box
The Apply Form Dialog Box

            Calendar Dialog Boxes  
            PhoneBook Dialog Boxes  
            Column and Folder Dialog Boxes  
            Shooter Dialog Boxes  



Windows and Dialog Boxes 
Click a folder to expand or contract the outline.

            Windows  
            File Menu Dialog Boxes  
            Edit Menu Dialog Boxes  
            View Menu Dialog Boxes  
            Item Menu Dialog Boxes  
            Format Menu Dialog Boxes  
            Tools Menu Dialog Boxes  
            Advanced Menu Dialog Boxes  
            Calendar Dialog Boxes  

The Date Settings Dialog Box
The Add Tickler Item Dialog Box
The Alarms Dialog Box
The Recurring Event Dialog Box

            PhoneBook Dialog Boxes  
            Column and Folder Dialog Boxes  
            Shooter Dialog Boxes  



Windows and Dialog Boxes 
Click a folder to expand or contract the outline.
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            File Menu Dialog Boxes  
            Edit Menu Dialog Boxes  
            View Menu Dialog Boxes  
            Item Menu Dialog Boxes  
            Format Menu Dialog Boxes  
            Tools Menu Dialog Boxes  
            Advanced Menu Dialog Boxes  
            Calendar Dialog Boxes  
            PhoneBook Dialog Boxes  

The Dialer/Call Logger Dialog Box
            Column and Folder Dialog Boxes  
            Shooter Dialog Boxes  



Windows and Dialog Boxes 
Click a folder to expand or contract the outline.

            Windows  
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            Edit Menu Dialog Boxes  
            View Menu Dialog Boxes  
            Item Menu Dialog Boxes  
            Format Menu Dialog Boxes  
            Tools Menu Dialog Boxes  
            Advanced Menu Dialog Boxes  
            Calendar Dialog Boxes  
            PhoneBook Dialog Boxes  
            Column and Folder Dialog Boxes  

The Create New Gantt Column Dialog Box
The Column Width Dialog Box
Pop-Up List Column Values Dialog Box
The Date Properties Dialog Box
The Specify Folders and Column Values Dialog Box

            Shooter Dialog Boxes  



Windows and Dialog Boxes 
Click a folder to expand or contract the outline.
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            File Menu Dialog Boxes  
            Edit Menu Dialog Boxes  
            View Menu Dialog Boxes  
            Item Menu Dialog Boxes  
            Format Menu Dialog Boxes  
            Tools Menu Dialog Boxes  
            Advanced Menu Dialog Boxes  
            Calendar Dialog Boxes  
            PhoneBook Dialog Boxes  
            Column and Folder Dialog Boxes  
            Shooter Dialog Boxes  

The Send Text Selection As Dialog Box





Command Reference 

About Ecco (Help menu)
Active View (Shooter menu)
Add Appt. Item (Calendar menu)
Add By Form (Shooter menu)
Add Item (View menu)
Add Item By Form (Advanced menu)
Add Item Left (View menu)
Add Item Right (View menu)
Add Items to Folder(s) (Folder options pop-up menu)
Add Multi-Day Appt (Calendar menu)
Add Outline Note (Calendar menu)
Add Outline Note (PhoneBook menu)
Add Tickler Item (Calendar menu)
Alarms (Tools menu)
Alignment (Column menu)
Apply Form to Items (Advanced menu)
Arrange Icons (Window menu)
Assign by Keys (Folder menu)
Assign Folders (Folder menu)
Calendar (Shooter menu)
Calendar (View menu)
Cascade (Window menu)
Character (Format menu)
Checkmark (Column menu)
Close All (Window menu)
Close File (File menu)
Color (Format menu)
Column Type (Column menu)
Connect to Public (File menu)
Connection Status (File menu)
Contents (Help menu)
Copy (Edit menu)
Custom (Alarms menu)
Custom (Recur menu)
Cut (Edit menu)
<Date-Specific Options> (Recur menu)
Delete Folder (Folder menu)
Delete Items (Edit menu)
Dial phone (PhoneBook menu)
Display (Tools menu)



Ecco Shooter Help (Shooter menu)
Edit Folders (Folder menu)
Enable Company Search (PhoneBook menu)
Every Day (Recur menu)
Every Mon thru Fri (Recur menu)
Exit (File menu)
Export (File menu)
Filters (Advanced menu)
Find (Edit menu)
Find Next (Edit menu)
Find/Replace (Edit menu)
Folder Type (Folder menu)
Folders (Shooter menu)
Font (Format menu)
Format (Column menu)
Get Disk Files (Tools menu)
Go To Ecco (Shooter menu)
Go To Pane (Window menu)
Group Scheduling (Calendar menu)
Heading (Column menu)
Help on Ecco Folders (Help menu)
Help on this View (Help menu)
Import (File menu)
Insert (Edit menu)
Insert Column (Column menu)
Launch (Tools menu)
Make Public (Column menu)
Make Public (Folder menu)
Make Public (View menu)
Mark as Done (View menu)
Menu Help (Help menu)
Move (View menu)
Move Column (Column menu)
<Named Alarms> (Alarms menu)
Navigate (Calendar menu)
New (File menu)
New Folder (Folder menu)
New PhoneBook Item (PhoneBook menu)
Non-Recurring (Recur menu)
None (Alarms menu)
Objects (Edit menu)
OLE Links (Edit menu)
Open (File menu)
<Open Windows> (Window menu)



<Other Program> (Shooter menu)
Outline Folders (Advanced menu)
Outline Labels (Format menu)
Outline Styles (Format menu)
Outlines (View menu)
Overview (Help menu)
Paste (Edit menu)
Paste Special (Edit menu)
PhoneBook (View menu)
Preferences (Shooter menu)
Preferences (Tools menu)
Print (File menu)
Printer Setup (File menu)
Properties (Column menu)
Properties (Folder menu)
Relative to Last (Shooter menu)
Remove Column/Delete Column (Column menu)
Remove Folders (Edit menu)
Remove Items from Folder (Folder options pop-up menu)
Save (File menu)
Save As (File menu)
Search (Help menu)
Search 1st and Last Name (PhoneBook menu)
Send Mail (File menu)
Shortcut Keys (Help menu)
Show (Shooter menu)
Show Columns (Column menu)
Show Folder Window (Advanced menu)
Show Folder's Items (Folder options pop-up menu)
Show Full Menus (Tools menu)
Show Home Folder (Column menu)
Show Item Info (Advanced menu)
Show Levels (View menu)
Show Shooter (Tools menu)
Show Sub-Items (View menu)
Show/Edit Values (Folder options pop-up menu)
Size (Format menu)
Sort (Advanced menu)
Style (Format menu)
Text Touch-Ups (Format menu)
Ticklers (Tools menu)
Tile (Window menu)
Time, Date, Alarm, etc. (Calendar menu)
Tool Bar (Tools menu)



Undo (Edit menu)
Use PhoneBook Form (PhoneBook menu)
Use with Calendar (PhoneBook menu)
Use with PhoneBook (Calendar menu)
View Item By Form (Advanced menu)
Width (Column menu)



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            File Menu  
            Edit Menu  
            View Menu  
            Item Menu  
            Format Menu  
            Tools Menu  
            Advanced Menu  
            Window Menu  
            Help Menu  
            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            File Menu  

File Menu Overview
New
Open
Close File
Save
Save As
Send Mail
Connect to Public
Connection Status
Import
Export
Print
Printer Setup
Exit

            Edit Menu  
            View Menu  
            Item Menu  
            Format Menu  
            Tools Menu  
            Advanced Menu  
            Window Menu  
            Help Menu  
            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            File Menu  
            Edit Menu  

Edit Menu Overview
Undo
Cut
Copy
Paste
Paste Special
Delete Items
Remove Folders
Find
Find/Replace
Find Next
Insert
OLE Links
Objects

            View Menu  
            Item Menu  
            Format Menu  
            Tools Menu  
            Advanced Menu  
            Window Menu  
            Help Menu  
            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            File Menu  
            Edit Menu  
            View Menu  

View Menu Overview
Calendar
PhoneBook
Outlines
Make Public

            Item Menu  
            Format Menu  
            Tools Menu  
            Advanced Menu  
            Window Menu  
            Help Menu  
            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            File Menu  
            Edit Menu  
            View Menu  
            Item Menu  

Item Menu Overview
Add Item
Add Item Right
Add Item Left
Show Levels
Show Sub-Items
Move
Mark as Done

            Format Menu  
            Tools Menu  
            Advanced Menu  
            Window Menu  
            Help Menu  
            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            File Menu  
            Edit Menu  
            View Menu  
            Item Menu  
            Format Menu  

Format Menu Overview
Character
Font
Size
Style
Color
Text Touch-Ups
Outline Styles
Outline Labels

            Tools Menu  
            Advanced Menu  
            Window Menu  
            Help Menu  
            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            File Menu  
            Edit Menu  
            View Menu  
            Item Menu  
            Format Menu  
            Tools Menu  

Tools Menu Overview
Show Full Menus
Get Disk Files
Launch
Alarms
Ticklers
Tool Bar
Preferences
Display
Show Shooter

            Advanced Menu  
            Window Menu  
            Help Menu  
            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            File Menu  
            Edit Menu  
            View Menu  
            Item Menu  
            Format Menu  
            Tools Menu  
            Advanced Menu  

Advanced Menu Overview
Show Folder Window
Sort
Filters
Outline Folders
Show Item Info
Add Item By Form
View Item By Form
Apply Form to Items

            Window Menu  
            Help Menu  
            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            File Menu  
            Edit Menu  
            View Menu  
            Item Menu  
            Format Menu  
            Tools Menu  
            Advanced Menu  
            Window Menu  

Window Menu Overview
Tile
Cascade
Arrange Icons
Close All
Go To Pane
<Open Windows>

            Help Menu  
            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            File Menu  
            Edit Menu  
            View Menu  
            Item Menu  
            Format Menu  
            Tools Menu  
            Advanced Menu  
            Window Menu  
            Help Menu  

Help Menu Overview
Overview
Contents
Search
Menu Help
Shortcut Keys
Help on this View
Help on Ecco Folders
About Ecco

            Non-Menu Bar Commands  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  

 Non-Menu Bar Commands Overview
            Column Menu  
            Calendar Menu  
            PhoneBook Menu  
            Folder Menu  
            Folder Options Pop-up Menu  
            Shooter Menu  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  

 Non-Menu Bar Commands Overview
            Column Menu  

Column Menu Overview
Show Columns
Insert Column
Remove Column/Delete Column
Column Type
Properties
Heading
Format
Checkmark
Alignment
Width
Move Column
Show Home Folder
Make Public

            Calendar Menu  
            PhoneBook Menu  
            Folder Menu  
            Folder Options Pop-up Menu  
            Shooter Menu  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  

 Non-Menu Bar Commands Overview
            Column Menu  
            Calendar Menu  

Calendar Menu Overview
Add Tickler Item
Add Appt. Item
Add Multi-Day Appt
Group Scheduling
Time, Date, Alarm, etc.
Add Outline Note
Navigate
Use with PhoneBook

            PhoneBook Menu  
            Folder Menu  
            Folder Options Pop-up Menu  
            Shooter Menu  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  

 Non-Menu Bar Commands Overview
            Column Menu  
            Calendar Menu  
            PhoneBook Menu  

PhoneBook Menu Overview
New PhoneBook Item
Use PhoneBook Form
Add Outline Note
Search 1st and Last Name
Enable Company Search
Dial phone
Use with Calendar

            Folder Menu  
            Folder Options Pop-up Menu  
            Shooter Menu  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  

 Non-Menu Bar Commands Overview
            Column Menu  
            Calendar Menu  
            PhoneBook Menu  
            Folder Menu  

Folder Menu Overview
Assign Folders
Edit Folders
New Folder
Folder Type
Properties
Delete Folder
Assign by Keys
Make Public

            Folder Options Pop-up Menu  
            Shooter Menu  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  

 Non-Menu Bar Commands Overview
            Column Menu  
            Calendar Menu  
            PhoneBook Menu  
            Folder Menu  
            Folder Options Pop-up Menu  

Folder Options Pop-up Menu Overview
Add Items to Folder(s)
Remove Items from Folder
Show/Edit Values
Show Folder's Items

            Shooter Menu  
            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  

 Non-Menu Bar Commands Overview
            Column Menu  
            Calendar Menu  
            PhoneBook Menu  
            Folder Menu  
            Folder Options Pop-up Menu  
            Shooter Menu  

Shooter Menu Overview
Active View
Calendar
Folders
Relative to Last
<Other Program>
Show
Preferences
Add By Form
Go To Ecco
Ecco Shooter Help

            Date Settings Commands  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  
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Date Settings Commands Overview
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            Recur Menu  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  
            Date Settings Commands  

Date Settings Commands Overview
            Alarms Menu  

Alarms Menu Overview
None
Custom
<Named Alarms>

            Recur Menu  



Command Reference 

Click a book to expand or collapse the outline.
            Menu Bar Commands  
            Non-Menu Bar Commands  
            Date Settings Commands  

Date Settings Commands Overview
            Alarms Menu  
            Recur Menu  

Recur Menu Overview
Non-Recurring
Custom
Every Day
Every Mon thru Fri
<Date-Specific Options>



This dialog box is displayed by choosing the Custom command on the Recur menu from the Date 
Settings dialog box.  The Recurring Event dialog box lets you create a custom recurring event.

Click an area of the dialog box to view more information.



Type    Specify the kind of recurrence you want for the recurring event.    The options are: daily, weekly, 
monthly by date, monthly by weekday, monthly by business day, and yearly.



On    Specify the dates on which you want to recurring event to take place, such as the 16th of each 
month.    You can choose as many of these options as you want.



Repeating    Specify the frequency of recurrence.    For example, if you choose the "Monthly by date" 
option, you can specify recurrence ranging from every month to every 20 months, or specific selected 
months to be repeated every year.



Until    Specify the date you want to end the recurring event.



This dialog box is displayed by choosing the Custom command on the Alarms menu from the Date 
Settings dialog box.  The Alarms dialog box lets you specify parameters for a new alarm for the selected 
item. This dialog box is similar to the Custom Alarm dialog box and the New Named Alarms dialog box.

Click an area of the dialog box to view more information.



Invoke Alarm at time of appointment    Specifies whether the alarm will go off at the time of the selected
appointment.



Additional Alarms before appointment    Sets additional alarms to occur minutes, hours, days, weeks, 
or any combination of time increments before the specified date.    Selecting multiple options will cause 
alarms to go off multiple times before the event.



Follow-Up Alarms after appointment    Sets additional alarms to occur minutes, hours, days, weeks, or 
any combination of time increments after the specified date.



Add to Menu    Adds the named alarm to the Alarms menu, so that these same settings can be used for 
other appointments or to-do's.    



Rename    Renames the alarm for the menu display.    



Options button    Expands the dialog box to display the following additional options.    



Dialog Message    Specifies that you want to display a dialog box message; type the text of the message 
in the adjacent box.    By default, an alarm displays a dialog box with the item's text.



Play Sound    Specifies a sound file you want to play at the alarm time.    Choose the Browse button to 
select a file.



Launch Document/.Bat File    Specifies a document or a .BAT file you want to launch at the alarm time.    
Choose the Browse button to select a file.



Confirm Before Launch    Displays a dialog box asking you to confirm that you want to launch the 
specified document or .BAT file.



Ecco displays the Send Text Selection As dialog box before inserting your text in another program using 
the Shooter,  This dialog box is similar to the Send Graphics Selection As dialog box.

Click an area of the dialog box to view more information.



Editable Text    Sends your selection to Ecco as editable text.    Unless you select one of the following 
options, Shooter sends each line as a separate item.



Only One Item    Sends your selection as one item.    Each line in your selection is a separate paragraph 
within that item.



Fewer Paragraphs    Sends your selection as one item.    All lines in your selection become a single 
paragraph in that item.



OLE Link    Sends your selection to Ecco as linked text or graphics.    



OLE Object    Sends your selection to Ecco as an embedded object.    



Always Ask When Sending    Displays the Send Text Selection As dialog box every time before sending. 
Canceling this option prevents the dialog box from appearing when you send selections in the future.    To 
reinstate the dialog box, choose Preferences from the Shooter menu, choose either Send Text As or Send
Graphics As, and then choose Ask Before Sending.    



This dialog box is displayed by the Add Items to Folder(s) command on the folder options pop-up menu. 
The Specify Folders and Column Values dialog box lets you associate values with items added to multiple
folders.

Click an area of the dialog box to view more information.



Item Text    Displays the text of your item.



Column or Folder Name    Displays a list of the folders to which the items will be added and the columns 
for which values will be entered.



Item's Value (editable)    For each folder, displays a value to be associated with the item when it is added
to that folder or when a value is entered for that column.     Displays a list of the values associated with 
each folder or column in the list.    To edit a value, choose it; a value edit box will appear.



This dialog box is displayed by the Properties command on the Folder menu.     The Date Properties 
dialog box lets you specify properties for the selected date folder.

Click an area of the dialog box to view more information.



Default Settings for new Items:    Specifies Tickler, recurrence, alarm, and Busybar settings for items 
you add to date folders.



Show Item in Calendar's Tickler Section    If checked, new items added to the folder are displayed in 
the Calendar's Tickler section by default.



Beginning    Specify the number of days or weeks before a tickler item's date that you want to begin 
displaying it in the Tickler section.    This gives you advance warning for an event on a specific date.



Ending    Specify the number of days or weeks after the tickler item's date that you want to stop 
displaying it in the Tickler section.    Alternatively, you can choose to display the item in the Tickler section 
until it is marked Done.



Default Recurrence    Specify a recurrence option.



Default Alarms    Specify an alarm.



Calendar Busybar Color    Specify a color.



Entering Dates    Specify options for displaying a value edit box or the Date Settings dialog box when you
enter dates.    



Initial Display    Specify keyboard or Date Settings dialog box options for entering dates.



Keyboard Entry    When you edit a date value, displays a value edit box, in which you can enter a date.



Date Settings Dialog    When you edit a date value, displays the Date Settings dialog box, in which you 
can select dates or use other date settings options.



Appt.    Time Fields    Specify display options for the Appointment Time fields.



Always Displayed    Always displays the appointment time fields at the bottom of the Date Settings dialog
box.



Optional    Displays the appointment time fields at the bottom of the Date Settings dialog box only when 
you're setting an appointment.



This dialog box is displayed by choosing the Pop-Up List command from the Folder Type command on 
the Folder menu.     The Pop-Up List Column Values dialog box lets you create a pop-up list of values for
a folder.    For example, the pop-up list values for a folder titled"Priorities"might include the values "High," 
"Medium," and "Low." This dialog box is identical to the Insert Pop-Up List Column dialog box.

Click an area of the dialog box to view more information.



Edit box    Type here to edit the text of a pop-up list value.



New button    Creates a new value.    Displays "Value 1" in the Edit box.    Type in the Edit box to specify 
new value text.    



Delete button    Deletes the selected value.



Reorder buttons    Move the selected value up or down one line at a time.    



This dialog box is displayed by the Dial phone command on the PhoneBook menu.     The Dialer/Call 
Logger dialog box lets you dial and log every call you make.

Click an area of the dialog box to view more information.



Name    Displays the selected name from the PhoneBook list.



Prefix    Specifies a dialing prefix and maintains a history of previously used prefixes.



Dial 1    Dials 1 for a long-distance number.    Ecco automatically turns this option off when you dial local 
calls.



Number to Dial    Displays the phone number to be dialed.    When you open the dialog box, Ecco 
displays the work number corresponding to the selected item.    You can select a different number from 
the Phone # Choice list.



Dial button    Dials the number displayed in the Number to Dial box.    The name of this button changes to
Hangup while your call is in progress.



Phone # Choice    Displays the phone number categories for the selected item (for example, home #, 
work #, and fax #).    If you add a new phone number column, it appears in this list.



Select text for dialing    Specifies the text you want Ecco to dial (for example, the phone number but not 
an extension number).



Don't dial local area code; local code is    Type your local area code if you want Ecco to omit the local 
area code when dialing this number.



Setup button    Displays the Phone Dialer Setup dialog box, in which you can specify your modem's 
prefix, suffix, and port connection.



Call Logging    Specifies options for logging your call.



Begin Logging upon dialing or Start/Stop Logging here    Starts logging as soon as your number is 
dialed.



Begin Logging/End Logging button    Manually begins or ends logging.



Duration    Displays the duration of your call.



Phone Log Text    By default, Ecco inserts the sub-item "Logged Call" below the selected entry.    If you 
want, type here a different log entry.



Close button    Closes the Dialer/Call Logger dialog box.



This dialog box is displayed by the Add Tickler Item command on the Calendar menu.     The Add Tickler 
Item dialog box lets you specify settings for the tickler item you are adding.    

Click an area of the dialog box to view more information.



For    Displays the date associated with the tickler item (the date currently displayed in the Calendar view).



Beginning    Specifies the date you want to begin displaying the tickler item, from the date associated 
with the tickler item to as many as 120 days before.



Ending    Specifies the date you want to stop displaying the tickler item.    Options range from the date 
associated with the tickler item to as many as two weeks after, or until you mark the item as Done.



Put Item into which Folder    Specifies the folder into which you want to put the tickler item.    



This dialog box is displayed by the Width command on the Column menu.     The Column Width dialog 
box allows you to specify the column width, or minimize the column to a narrow width to display a greater 
number of columns at one time.

Click an area of the dialog box to view more information.



Column Width    Specify a width for your column.    The width is measured in number of characters.



Minimize Column    Minimizes your column to a narrow width.    (You can also minimize a column by 
double-clicking the column head.    To return a minimized column to its preminimized width, double-click 
the column head.)



Use Standard Width     Specifies use of the standard column width.



Standard Width     Specifies the column width for all columns that are using the standard width.



This dialog box is displayed by choosing the Gantt command from the Insert Column command on the 
Column menu.  The Create New Gantt Column dialog box allows you to create a Gantt chart based on 
date folders..    This dialog box is identical to the Column Properties: Gantt Column dialog box.

Click an area of the dialog box to view more information.



Chart Range    Select the date range on which you want to base your chart.



Choose folders which best describe start and end of each Gantt bar    Select the date folders on 
which you want to base the start and end date of the bars of your chart.    



Bar Color    Select a color for the bars of your chart.



This dialog box is displayed by the Apply Form to Items command on the Advanced menu.  The Apply 
Form dialog box lets you set folder values and apply the chosen form to the selected items.

Click an area of the dialog box to view more information.



Item Text    Displays the text of the selected item.



Column or Folder Name    Displays a list of the columns or folders associated with the selected form.    
You select the folders to which you want to add the items and the columns for which you want to enter 
values.



Item's Value (editable)    For each column, displays a value to be associated with the items when the 
form is applied to those items.    For each folder, displays whether or not the items will be added to that 
folder when the form is applied to the items.    To edit a value, click it; a value edit box will appear.    



Ignore button    Prevents the item from being given a column value or from being added to the selected 
folder.



All Defaults button    Restores the default values of all columns or folders as defined in the form.



This dialog box is displayed by the View Item By Form command on the Advanced menu.  The View By 
Form dialog box lets you view the selected item's folders and associated folder values by form.

Click an area of the dialog box to view more information.



Item Text    Displays the text of the selected item.



Column or Folder Name    Displays a list of all folders to which the item has been added or columns for 
which a value has been entered.



Item's Value (editable)    For each column, displays the value that has been entered for the item in the 
column.    For each folder, indicates whether or not the item is in the folder.    To edit a value, click it; a 
value edit box will appear.    



Next Item buttons    Step you through the items in the active view, displaying each item's columns and 
associated values by form.    You can move up or down the outline at the same level or move from one 
level to another.



Delete Item button    Deletes the selected item or items.



Clear Value button    Removes the item from the selected column or folder.



All Defaults button    Restores the default values of all columns as defined in the form.



This dialog box is displayed by choosing a named form from the Add Item By Form command on the 
Advanced menu.  The Add By Form dialog box lets you specify options to create a new item and add it 
to Ecco by form, without having to first add them to a view..

Click an area of the dialog box to view more information.



Item Text    Type here the text of your item.



Column or Folder Name    Displays a list of the columns or folders associated with the selected form.    
Select the folders to which you want to add the items or the columns for which you want to enter values.



Item's Value (editable)    For each column, displays a value to be associated with the item when the item 
is added to your file.    For each folder, displays whether or not the item will be added to that folder when 
the item is added to your file.    To edit a value, click it; a value edit box will appear.    



Add & Continue buttons    Enters a value for the form's columns, adds the item to the form's folders, and
lets you continue adding items.    



Add to active View    Adds the item to the active view as well as enters values for the form's columns or 
adds the item to the form's folders.



Clear Value button    Prevents the item from being given a column value or from being added to the 
selected folder.



All Defaults button    Restores the default values of all columns as defined in the form.



This dialog box is displayed by choosing the Manage Forms command from the Add Item By Form 
command on the Advanced menu.  The Manage Forms dialog box lets you rename or delete existing 
forms, or reorder them on the menu.

Click an area of the dialog box to view more information.



Rename    Type here the name you want to give the selected form.



New button    Displays the Create New Form dialog box, in which you can specify options to create a new
form.    



Edit button    Displays the Edit Form dialog box, in which you can edit the settings for the selected form.   
This dialog box is identical to the Create New Form dialog box.



Delete button    Deletes the selected form or forms.



Reorder buttons    Move the selected forms up or down one row at a time on the Forms menu.



Make Public    Makes the selected forms public.    When a form is public, it is available to other workgroup
users.    This option is valid only if you've previously made the Ecco file available by choosing the Connect
to Public command from the File menu.    



This dialog box is displayed by choosing the New Form command from the Add Item By Form command 
on the Advanced menu.     The Create New Form dialog box lets you create a form to quickly add items 
and their associated folder values to several folders at one time.

The options in the following dialog box are also available in the Edit Form dialog box, which appears 
when you choose the Edit button in the Manage Forms dialog box.    
Choose a folder or column to add to your new form.
Click an area of the dialog box to view more information.



Rename    Type here a name for your form.



Column or Folder Name    Displays a list of the columns or folders you've put into your new form.



Item's Value (editable)    For each column, displays a value to be associated with the item when the form 
is applied.    For each folder, displays whether or not the item will be added to that folder by default when 
the form is applied.     To edit a value, click it; a value edit box will appear.



Remove button    Removes the selected column or folder from the list.



Reorder buttons    Move the selected column or folder up or down in the Folder list one row at a time.



Apply form, don't display dialog If this checkbox is selected, when you subsequently choose the Apply 
Form to Items command, the form will be applied using its default settings, without displaying the Apply 
Form dialog box.    This option is available only when all columns have default values.    



Default Value button  Restores the default value for the selected column.



This dialog box is displayed by the Show Item Info command on the Advanced menu.  The Show Item 
Info dialog box lets you view all folders to which the selected item has been added, edit the folder values 
associated with the item, or delete the item.

Click an area of the dialog box to view more information.



Item Text    Displays the text of the selected item.



Column or Folder Name    Displays a list of all folders to which the item has been added and all columns 
containing values for the item.    Columns for which you have not supplied a column heading will not 
appear.



Item's Value (editable)    Indicates whether or not the item is in a folder or displays the item's column 
value.  To edit a value, click it; a value edit box will appear.



Next Item buttons    Let you move through the items in the active view while you are in the dialog box.    
You can move up or down the outline at the same level or move from one level to another.



Delete Item button    Removes the selected item from all views.



Clear Value button    Removes the item from the selected folder or column.



This dialog box is displayed by the Outline Folders command on the Advanced menu.  The Choose 
Outline Folders dialog box lets you choose the folders whose items you want displayed in the view.    To 
include a folder in the view, click the folder name.

Click an area of the dialog box to view more information.



Folder list    Displays the list of folders whose items will be displayed in the view.



Remove button    Removes the selected folder from the view.



This dialog box is displayed by choosing the Manage command from the Filters command on the 
Advanced menu.  The Manage Named Filters dialog box lets you rename or delete existing named 
filters, or reorder them on the menu.

Click an area of the dialog box to view more information.



Rename    Type here the new name you want to give the selected filter.



New button    Displays the Create a New Filter dialog box, in which you can create a new filter.    



Edit button    Displays the Edit Named Filter dialog box, in which you can modify an existing filter.    This 
dialog box is identical to the Create a New Filter dialog box.



Delete button    Removes the selected filter.



Reorder buttons    Move the selected filter up or down one row at a time in the Filters menu.



This dialog box is displayed by choosing the New command from the Filters command on the Advanced 
menu.     The Create a New Filter dialog box lets you select multiple folder columns and sets of criteria to
create an advanced filter.

Click an area of the dialog box to view more information.



Criteria    Displays the list of columns and values and folders and folder values that are the criteria for the 
filter.



Options for Folder <name>    Displays a list of comparison phrases (equals, greater than, less than, and 
so on).



Value text box    Type here a comparison value, if applicable.



Subs of Items matching this criteria are considered to match    Specifies for a selected criterion that, 
if an item matches that criterion, all sub-items will be treated as though they too match that criterion.    For 
example, if there is only one criterion, choosing this option displays all sub-items of any item matching the
criterion, whether or not those sub-items themselves match the criterion.    This option applies only to the 
line of criteria currently selected in the list box above.



Add to menu    Type here a name for your filter to save it and add it to the Filter menu.    These same 
filters are also available to you from the Find, and Find and Replace, dialog boxes.



Remove button    Removes the selected criteria from the Criteria list.



Begin/End buttons    Begins or ends a set of criteria.    Only one criteria of this set needs to be true for 
the items to be shown in the view.



This dialog box is displayed by choosing the New command from the Filters command on the Advanced 
menu.  The Filter Current View dialog box lets you create a filter to extract and display specific 
information from the view.    This dialog box is identical to the Use Custom Filter dialog box.

Click an area of the dialog box to view more information.



Show only Items for which    Specify a column, operator, and value for your filter.    



Choose Column    Displays a list of the columns in your active view. 



Operator    Displays a list of comparison phrases (equals, greater than, less than, and so on).



Value    Type here a comparison value, if applicable.



Add to menu    Type here a name for your filter to save it and add it to the Filter menu for use in other 
views.    Filters added this way are also available to you from the Find, and Find and Replace, dialog 
boxes.    This option is available only if the selected column has a heading other than "A," "B," "C," etc.



Advanced button    Displays the Create a New Filter dialog box, in which you can specify multiple folders
and sets of criteria for your filter.     



This dialog box is displayed by the Sort command on the Advanced menu.     The Sort Items dialog box 
lets you sort items or sub-items subordinate to the selected folders or items in the active view. 

Click an area of the dialog box to view more information.



Entire view    Sorts all top-level items in the active view.



Sub-items of selected items or folders    Sorts the sub-items of the selected items or folders.



Sort key 1    Select a column, or item text, as your primary sort key.



Sort key 2    If appropriate, select a column, or item text, as your secondary sort key.



Ascending    Sorts items in ascending order.    If the selected column is a pop-up list, items whose value 
is first in the list will be sorted first.



Descending    Sorts items in descending order.



This dialog box is displayed by the Preferences command on the Tools menu.     The Ecco Preferences 
dialog box lets you specify the settings you want to use whenever you work in Ecco.

Click an area of the dialog box to view more information.



Calendar    Specify appointment and workday time frames for the current Ecco file.



Default Appointment Duration    Specify the default appointment length.



Start of Day    Specify the time your workday begins.



End of Day    Specify the time your workday ends.



Save Options    Specify the backup and autosave options for your Ecco files.



Always create backup copy    Creates one or more backup copies of your file.



Number of rotating backups    Specify the number of backup copies you want Ecco to save.    Each time 
you save, Ecco creates a new backup copy (with an extension such as .BK1 or .BK2), up to the number 
specified.    The most recent backup will always have the extension .BK1.    If you specify two or more 
backup copies, the highest numbered backup file will preserve the previous day's work.



Autosave every    Select a time interval from the list to save your file automatically at a regular interval.



Autosave on file close    Saves your file automatically on closing, without first displaying a prompt.



Open last file on startup    When you start Ecco, automatically opens the Ecco file last open.    



Public file user name    Specify the name that identifies you to other users.    When another user 
attempts to edit an item in a public file that you are editing, Ecco displays a message with your specified 
name in it.



Maximize current view when Folder window opens    Maximizes the active view when you display the 
Folder window.



Keyboard access to Shooter menu: Ctrl + Alt +    Specify the key you want to use to display the 
Shooter menu using the keyboard.



Show Holidays for    Specify the country whose national holidays you want displayed in the Calendar 
view.



This dialog box is displayed by the Tool bar command on the Tools menu.     The Tool Bar dialog box lets 
you customize the tool bar display.

Click an area of the dialog box to view more information.



Action    Specify the icon action you want to take.



Add/Arrange Icons    Specify that you want to add or arrange the icons.



Arrange Groups    Moves groups of icons as a single unit.



Add/Del Spaces    Lets you add or delete spaces between icons on the tool bar.



Description    Identifies the steps you need to take perform the task you selected in the Action area.



Rows    Specify the number of tool bar rows you want displayed.



Main Window    Specify the number of rows you want displayed in the tool bar of the Ecco program 
window.



Views    Specify the number of rows you want displayed in the tool bar of the Ecco view windows.



Shooter    Specify the number of rows you want displayed in the Shooter tool bar.



This dialog box is displayed by the Ticklers command on the Tools menu.     The Show Item in Calendar 
Tickler Section dialog box lets you specify settings for the item you are displaying as a tickler item in the 
Tickler section of the Calendar.

Click an area of the dialog box to view more information.



Event Date    Specify the event date you want to associate with the item.



Beginning    Specify the date you want to begin displaying the tickler item, from the date associated with 
the tickler item to as many as 120 days before.



Ending    Specify the date you want to stop displaying the tickler item.    Options range from the date 
associated with the tickler item to as many as two weeks after, or until you mark the item as Done.    



Put Item into which Folder    Specify the date folder into which you want to put the tickler item.    Tickler 
items are organized by folder in the Calendar view.

If you are using the advanced features of Ecco Professional, folders will be available for other purposes 
as well.    To use folders, from the Tools menu, choose Show Full Menus.    



This dialog box is displayed by choosing the Manage Named Alarms command from the Alarms 
command on the Tools menu.     The Manage Named Alarms dialog box lets you create or edit named 
alarms, delete existing named alarms, or reorder the named alarms on the Alarms menu.

Click an area of the dialog box to view more information.



Rename    Type here the new name you want to give the selected alarm.



New button    Displays the New Named Alarm dialog box, in which you can specify options to create a 
new named alarm.    This dialog box is similar to the Alarms dialog box.    



Edit button    Displays a dialog box, in which you can modify an existing named alarm.



Delete button    Deletes the selected named alarm.



Reorder buttons    Move the selected named alarm up or down on the menu one row at a time.



This dialog box is displayed by choosing the Review Alarms command from the Alarms command on the 
Tools menu.     The Review Alarms dialog box lets you view upcoming alarms and delete those you no 
longer want.

Click an area of the dialog box to view more information.



Alarms occurring the week of  Select the week for which you want to review your alarms.



Next Alarm    Displays a list of dates for which alarms are set.



Appt.    Date    Displays the dates of the events associated with the upcoming alarms.



Alarm message    Displays the events or messages associated with the upcoming alarms.



Delete button    Deletes the selected alarm.



This dialog box is displayed by choosing the Alarms command on the Tools menu.     The Create an 
Alarm dialog box lets you create a simple alarm or a new named alarm.

Click an area of the dialog box to view more information.



Alarm Text    Type here the text you want the alarm to display when it "goes off." Typing will be disabled if 
the alarm is attached to the selected item.



Date    Select the date on which you want the alarm to go off.



Time    Select the time at which you want the alarm to go off.



Type    If you select the "Simple Alarm" option, the alarm displays a text message at the specified time.

If you select the "Custom" option, the Custom Alarm dialog box (similar to the Alarms dialog box) appears.
Use the Alarms dialog box to set multiple alarms for this event.    

If you select the "Manage" option, the Manage Named Alarms dialog box appears.    
If you select any named alarm, the times and options specified by the named alarm will be invoked 
relative to the date and time of this event.



Attach alarm to selected Item    Attaches the alarm to the selected item and displays the item's text in 
the "Alarm Text" box.    



This dialog box is displayed by choosing the Manage command from the Outline Labels command on the 
Format menu.     The Manage Outline Labels dialog box lets you edit, delete, reorder, and rename 
existing outline labels.    You can also create a new outline label from this dialog box.

Click an area of the dialog box to view more information.



Rename    Type here the new name you want to give the outline label style.



New button    Displays the Outline Labels dialog box, in which you can create a new outline label style.   



Edit button    Displays a dialog box, in which you can edit an existing outline label style.



Delete button    Deletes the selected outline label style.



Reorder buttons    Move the selected outline label style up or down one row at a time on the Outline 
Labels menu.



This dialog box is displayed by choosing the New command from the Outline Labels command on the 
Format menu.     The Outline Labels dialog box lets you create custom label formats (for example, I, II, 
III; 1, 2, 3; A, B, C) for selected outline levels.

Click an area of the dialog box to view more information.



Rename    Type here a name for the outline label you are creating.



Prefix    Choose, or type, the prefix you want displayed in front of the label.    The prefix can be up to two 
characters long.



Label    Choose a numeric or alphabetic format for the label.



Suffix    Enter the suffix you want displayed behind the label.    The suffix can be up to two characters 
long.



Cumulative    For a given level, displays the labels for all levels to its left.    This feature is useful for 
tracking item levels in long documents.



Based On button    Displays a dialog box, in which you can apply attributes of an existing label to all 
levels or to selected levels only.



This dialog box is displayed by the Outline Styles command on the Format menu.     The Outline Styles 
dialog box lets you define a text style (font, size, color, and style) for the selected levels in your outline.

Click an area of the dialog box to view more information.



Font    Displays the outline level in the font you specify.



Size    Displays the outline level in the point size you specify.    



Color    Displays the outline level in the color you specify.



Style    Displays the outline level in the style you specify.    You may select more than one attribute at a 
time.    



Example    Displays text with the attributes you've specified.



Apply button    Applies the specified attributes to the outline level.



This dialog box is displayed by choosing the Manage command from the Text Touch-Ups command on 
the Format menu.     The Manage Text Touch-Ups dialog box lets you create a new touch-up, rename or 
edit an existing touch-up, delete a touch-up, or reorder the list of custom touch-ups.

Click an area of the dialog box to view more information.



Rename    Type here the new name you want to give the text touch-up.



New button    Displays the New Named Text Touch-Up dialog box.    



Edit button  Displays the Edit Named Text Touch-Up dialog box (identical to the New Named Text Touch-
Up dialog box), in which you can modify an existing touch-up.



Delete button    Deletes the selected text touch-up.



Reorder buttons    Moves the selected touch-ups up or down one row at a time on the Text Touch-Ups 
menu.    You might want to move the touch-ups you use most often to the beginning of the list.



This dialog box is displayed by choosing the New command from the Text Touch-Ups command on the 
Format menu.     The New Named Text Touch-Up dialog box lets you create a custom style for the 
selected text.    This dialog box is identical to the Edit Named Text Touch-Ups dialog box.

Click an area of the dialog box to view more information.



Name    Type here a name for your text touch-up.



Font    Displays the selected text in the font you specify.



Size    Displays the selected text in the point size you specify.



Color    Displays the selected text in the color you specify.



Style    Displays the selected text in the style you specify.    You may select more than one attribute at a 
time.



Example    Displays text with the attributes you've specified.



Apply button    Applies the specified style to the selected text.



This dialog box is displayed by the Character command on the Format menu.     The Character dialog 
box lets you specify character formats or apply an outline style to previously formatted text.

Click an area of the dialog box to view more information.



Font  Displays the selected text in the font you specify.



Size    Displays the selected text in the point size you specify.    



Color    Displays the selected text in the color you specify.



Style    Displays the selected text in the style you specify.    You may select more than one attribute at a 
time.    



Example    Displays text with the attributes you've specified.



Reapply button    Reapplies the outline style associated with the outline level of the selected text, 
removing any character formatting you've applied.



Apply button    Applies the specified attributes to the selected text.    If you hold down the CTRL key while 
you choose this button, Ecco applies the specified attributes to the outline style for the levels of the 
selected items.    



This dialog box is displayed by the Show Levels command on the Item menu.     The Show Levels dialog
box lets you collapse and expand your outline level by level by clicking the level number buttons.

Click an area of the dialog box to view more information.



All    Select this checkbox to affect your entire outline.



Selected    Select this checkbox to affect only the selected items and their sub-items.



Unselected Only    Select this checkbox to affect your entire outline with the exception of the selected 
items.    This is useful if you want to collapse every item other than the selected items (to see the context 
of the selected items more clearly).    



Level buttons    Collapse and expand your outline level by level by clicking the level number buttons.



This dialog box is displayed by choosing the Manage command from the Outlines command on the View 
menu.     The Manage Named Outlines dialog box lets you rename or delete existing outline views, or 
reorder them on the menu.

Click an area of the dialog box to view more information.



Rename    Type here the new name you want to give the selected view.



Delete button    Deletes the selected outline view.



Reorder buttons    Move the selected outline view or views up or down one row at a time on the Outline 
Views menu.



This dialog box is displayed by choosing the New Outline command from the Outlines command on the 
View menu.     The Create A New Outline dialog box lets you create a new outline view.

Click an area of the dialog box to view more information.

If you are using the advanced features of Ecco Professional, the lower dialog box appears.    Otherwise 
the upper dialog box appears.



Name    Type here a name for your view.



Folders button    Displays the Choose Outline Folders dialog box, in which you can select folders to 
include in your outline view.    

If you are using the advanced features of Ecco Professional, folders will be available.    To use folders, 
from the Tools menu, choose Show Full Menus.    



This dialog box is displayed by the OLE Links command on the Edit menu.     Displays the Links dialog 
box, in which you specify options that let you change or update existing OLE links in your file.

Click an area of the dialog box to view more information.



Link list    Lists the links in the active file.



Update Now button    Updates the selected link.



Change Link button    Displays the Change Link dialog box, in which you can choose a file for a new link.



Update Options  Lets you specify whether the links are updated automatically, or by you on a case-by-
case basis.



Edit button    Opens the program in which the linked object was originally created, allowing you to make 
changes to the object without leaving Ecco.



This dialog box is displayed by the Find/Replace command on the Edit menu.     The Find and Replace 
dialog box lets you specify the text you want to find and the text with which you want to replace it.

Click an area of the dialog box to view more information.



Find box    Type here the text you want to find.



Drop-down arrow button    Displays a list of your previous search text.    This list is saved with the file 
and is available from session to session.



Find button    Begins the search.    Depending on the search parameters, this button might be labeled 
"Collect All."



Replace box    Type here the text with which you want to replace the found text.    If you leave this box 
empty, Ecco will delete all instances of the found text when you choose the Replace button.



Replace button    Replaces the current instance of the found text with the text you specified.



Repl All button    Replaces all instances of the found text with the text you specified.



Scope    Specify the scope of your search.



Current View    Limits the search to the active view.



Entire File    Includes in the search all items in the file.    When you choose this option, the Find button 
changes to the Collect All button and makes the Replace and Repl All buttons unavailable.    All found 
items will be displayed in the Search Results view. The Replace and Repl All buttons will again be 
available.



Find Items Matching Filter    Finds only those items with criteria that match the specified filter.    You can 
use this to search for items with folder or column values, such as dates or specific text.    You can search 
for items matching filters without typing text in the Find box.    Select a named filter or select "Custom" to 
display the Use Custom Filter dialog box, in which you can specify parameters for your filter.    

If you are using the advanced features of Ecco Professional, filters will be available.    To use filters, from 
the Tools menu, choose Show Full Menus.



This dialog box is displayed by the Find command on the Edit menu.     The Find dialog box lets you 
specify options for finding items in Ecco.    When you first open it, the Find dialog box is displayed in a 
collapsed state.    To display the entire Find dialog box, click the Unfold button (>>).

Click an area of the dialog box to view more information.

If you are using the advanced features of Ecco Professional, the lower dialog box appears.    Otherwise 
the upper dialog box appears.



Find box    Type here the text you want to find.



Drop-down arrow button    Displays a list of your previous search requests.    This list is saved with the 
file and is available from session to session.



Unfold button (>>)    Expands and hides the Find dialog box.



Find button  Begins the search.    Depending on the search parameters, this button might be labeled 
"Collect All."



Scope    Specify the current view or the entire file as the scope of your search.



Current View    Limits the search to the active view.



Entire File    Includes in the search all items in the file.    



Find Items Matching Filter    Finds only those items with criteria that match the specified filter.    You can 
use this to search for items with folder or column values, such as dates or specific text.    You can search 
for items matching filters without typing text in the Find box.    Select a named filter or select "Custom" to 
display the Use Custom Filter dialog box, in which you can specify parameters for your filter.    

If you are using the advanced features of Ecco Professional, filters will be available.    To use filters, from 
the Tools menu choose Show Full Menus.    



Actions    Specify whether you want to find the next instance of the specified item, select all instances, or 
copy the found items to the Search Results view.



Find Next    Finds the next instance of the specified item.



Select All in View    Selects all the items in the active view that meet the search criteria.



Copy to Search Results view    Copies the found items to the Search Results view.    



Replace/Append    Specify whether you want Ecco to replace all the found items in the Search Results 
view with the newly found items or append the newly found items to the contents of the Search Results 
view.



This dialog box is displayed by choosing the Options button in the Print PhoneBook View dialog box.

Click an area of the dialog box to view more information.



Names & Sub-Item Options    Specify the items to be printed.    



Column Options    Specifies column printing parameters.    



Name Order    Prints first name before last name.



Page Breaks    Prints each letter on a new page.



Fonts    Print using the font and font size in the view or specify a custom font and font size.



This dialog box is displayed by the Print command on the File menu when the PhoneBook view is active.   
 The Print PhoneBook View dialog box lets you specify options for printing the PhoneBook view.

Click an area of the dialog box to view more information.



Print    Specifies whether you want to print the entire PhoneBook, all items currently in this view, or only 
selected items.    

To print entries in the order currently displayed, select the "All Items Currently in this View" option.    (You 
can sort your PhoneBook entries before printing.    First, display all entries in the PhoneBook view by 
choosing the Search button when the search edit box is empty.    Then, from the Advanced menu, choose 
Sort to sort the entries by field or column.)



Format    Select options for printing names, addresses, phone numbers, sub-items, and columns.



Name & Address Only    Prints only names and addresses.    Use this command to print mailing labels.



Name, Address & Phones    Prints names, addresses, and phone numbers.



Name, with Sub-Item/Column Options    Prints names, with the option of printing their associated sub-
items and columns.    You can specify additional printing parameters for this format in the PhoneBook Print
Options dialog box.    



Test    Prints one page of sample data in the selected format.



Page/Labels    Specifies the size of page you want to print.    Select a standard Avery form or "organizer" 
size, or select the "Custom" option to display the Custom Page Size dialog box, in which you can specify 
page dimensions.    



Margin in Inches    Specifies margins for the left, top, bottom, and right sides of the printed page.



Copies    Specifies the number of copies you want to print.



Options button    Displays the PhoneBook Print Options dialog box.    



This dialog box is displayed by choosing the Options button in the Print Calendar View dialog box.

Click an area of the dialog box to view more information.



Page Layouts    Specify page layout format for your Calendar.    Selecting both options prints out one 
copy of each layout format.



Summary Pages (no Sub-Items)    Prints time slots and Calendar items  for the selected day, week, or 
month.    Does not print sub-items or information in columns. If you've selected the "Month" option in the 
Print Calendar View dialog box, this option is replaced by "Month Grid" which prints your appointments for
the month in a grid-like format.



Month Grid    Prints your appointments for the month in a grid-like format.    Does not print Tickler items or
sub-items.    This option is available only if you've selected the "Month" option in the Print Calendar View 
dialog box.    



Detail Pages    Prints all items, including sub-items, for the selected day, week, or month.    Does not print 
empty time slots.



Section Options    Specifies whether you want to print the Appointment Section, Tickler Section, or both.



Appointment Section    Prints the Appointment Section.



Tickler Section    Prints the Tickler Section.



Detail Page Options    Specify the items to print and the column printing parameters.    



Fonts    Print using the font and font size in the view or specify a custom font and font size.



This dialog box is displayed by the Print command on the File menu when the Calendar view is active.    
The Print Calendar View dialog box lets you specify options for printing the Calendar view.

Click an area of the dialog box to view more information.



Format    Specifies a daily, weekly, or monthly view format, or specifies whether you want to print only the 
selected items and their sub-items.



Date Range    Specifies the range of dates you want to print.



Page Size    Specifies the size of the page you want to print.    Select a standard Avery form or "organizer"
size, or select the "Custom" option to display the Custom Page Size dialog box, in which you can specify 
page width and height.    



Margin in Inches    Specifies margins for the left, top, bottom, and right sides of the printed page.



Copies    Specifies the number of copies you want to print.



Options button    Displays the Calendar Print Options dialog box.    



This dialog box is displayed by the Print command on the File menu when an outline view is active.     
The Print Outline View dialog box lets you specify options for printing an outline view.

Click an area of the dialog box to view more information.



Items and Folders    Specifies the items and folders to be printed.



Print All Items    Prints all items in the view.



Print Selected & Subs Only    Prints only the selected items and their sub-items.



Print Items to Level    Prints the items to the indentation level you specify.



Skip Hidden Subs    Does not print the sub-items hidden within a collapsed outline.



Print Item Icons    Prints the folder icons and item bullets (the blue oval icon at the left of each item).



Columns    Specifies column printing parameters.



Print Columns    Prints the columns.



Skip minimized Columns    Does not print minimized columns. You can minimize a column by double-
clicking the column head.    



No.    of Cols on 1st Page    Specifies the number of columns you want printed on the first page.



Headers & Footers    Specifies the text you want printed in your header, at the top of each page, and text 
you want printed in the footer, at the bottom of each page.    



Title Text    Type here the text you want in your header.



Print Date    Specifies that the current date will be printed in the footer.    



Print Page Numbers    Specifies that the page number will be printed in the footer of each page.



Margin in Inches    Specifies margins for the left, top, bottom, and right sides of the printed page.



Copies    Specifies the number of copies you want to print.    



This dialog box is displayed when you choose <Create Set> in the Export PhoneBook dialog box.    

Click an area of the dialog box to view more information.



Choose Fields    Displays a list of the fields in the PhoneBook view.



Add button    Adds the selected field in the Choose Fields list to the Fields Chosen list.



Fields Chosen    Displays the list of fields you have chosen to export.



Remove Field button  Removes the selected field from the Fields Chosen list.



Add Field Set to Menu    Adds the field set to the Choose Field Set list in the Export PhoneBook dialog 
box.



Name    Type here a name for your field set.



Displays the Export PhoneBook dialog box, in which you can specify what information in the PhoneBook 
view you want to export. 

Click an area of the dialog box to view more information.



Items To Export    Specify whether you want to export the entire PhoneBook, items currently displayed in 
the view, or the selected items only.



Format    Displays several format options that allow you to export information for use in word-processing, 
spreadsheet, database, and other programs.



Mail Merge Header    Exports field names as the first line in the exported file.



Choose Field Set    Select from the list a field set, or select <Create Set> to display the Choose Field Set 
dialog box, in which you can choose a set of fields to export.    



Fields Chosen    Displays the columns that will be exported.



Remove Field button    Removes a field from the Fields Chosen list.    As a result the field column will not 
be exported.



Export to file    Type here the name of the file that will contain the exported information.



Browse button    Displays the File Export dialog box, in which you can specify an existing file to export to.



This dialog box is displayed when you choose <Create Set> in the Export Outline and Columns dialog 
box.

Click an area of the dialog box to view more information.



Choose Columns    Displays a list of the columns in the active view.



Add button    Adds the selected column in the Choose Columns list to the Columns Chosen list.



Columns Chosen    Displays the list of columns you have chosen to export.



Remove Col    Removes the selected column from the Columns Chosen list.



Add Column Set to Menu    Adds the column set to the Choose Column Set list in the Export Outline and
Columns dialog box.



Name    Type here a name for your column set.



This dialog box is displayed when you choose the Columns button in the Export Outline dialog box.    

Click an area of the dialog box to view more information.



Choose Column Set    Select from the list a column set, or select <Create Set> to display the Choose 
Column Set dialog box, in which you can choose a set of columns to export and create a named columns 
set.    



Columns Chosen    Displays a list of the columns in the chosen column set.



Remove Col    Removes the selected column from the Columns Chosen list.



Displays the Export Outline dialog box, in which you can specify what information in the active view you 
want to export. 

Click an area of the dialog box to view more information.



Items To Export    Specify whether you want to export all the items in the outline view, the selected items 
only, or the selected items and their sub-items.



Format    Displays several format options that allow you to export information for use in word-processing, 
spreadsheet, database, and other programs.    Select the Mail Merge Header option to export column 
names as the first line in the exported file.



Columns button    Displays the Export Outline and Columns dialog box, in which you can specify which 
columns you want to export.    



Export to file    Type here the name of the file to which you want to export.



Browse button    Displays the File Export dialog box, in which you can specify an existing file to export to.



This dialog box is displayed when you choose the Choose button in the Import into Current View dialog 
box.    Click an area of the dialog box to view more information.



Import Field    Displays a list of all field names or sample fields in the file you are importing.



Destination Column    For each field, displays the destination column.



Choose a Column    Choose from this list a destination column for the selected field.    If you do not want 
Ecco to import the selected field, choose <Ignore>.    To create a new column to import to, select a field 
name surrounded by angle brackets.

If you choose a <New Date Field>, imported items will be shown by default in the Calendar view on the 
dates imported into that column.    To override this, choose the Properties command from the Column 
menu after importing.



Sample buttons    Move you through the file one field at a time.



Rename Column    If you are creating a new column to import to, type a name for it here.



This dialog box is displayed by choosing the OK button in the File Import dialog box when importing a file 
into an outline view.

Click an area of the dialog box to view more information.



Insert imported items    Specify where in your outline you want to insert the imported information.



At bottom of outline    Places the imported information at the bottom of the outline.



After currently selected item    Places the imported information after and at the same level as, or after 
and subordinate to, the selected item in the active view.



Import file has columnar data    Specifies that the import file has data that you want to import into 
columns.



Create new columns using mail merge header    Select this option to create new columns based on 
names in the file's first record.



Use existing columns if matching names found    Select this option if you want Ecco to import to 
existing columns if names in the first record match existing column names.



Choose column for each field    Select this option if you want to choose a destination column for each 
field.



Choose button    Displays the Choose Columns for Import Fields dialog box, in which you can choose the
columns you want to import to.    



This dialog box is displayed when you choose the OK button in the File Import dialog box in the process 
of importing a file into the PhoneBook view. Click an area of the dialog box to view more information.



Field Name    Displays a list of all field names in the file you are importing.



Destination    For each field, displays the destination.



Choose a Destination    Choose from this list a destination for the selected field.    If you do not want 
Ecco to import the selected field, choose <Ignore>.    To create a new column to import to, select a field 
name surrounded by angle brackets.    



Sample buttons    Move you through the file one record at a time.



Rename New Field    If you are creating a new column to import to, type a name for it here.



This dialog box is displayed by the Import command on the File menu.    The File Import dialog box lets 
you specify which file you want to import to the active view.

Click an area of the dialog box to view more information.



File Name    Type here, or select from the list, the name of the file you want to import.



List Files of Type    Select the type of file you want to import.



Directories    Select a different directory if the file you want to import is not in the current directory.



Drives    Select from the list a different drive if the file you want to import is not on the current drive.



Network button    If you are on a network, choose this button to display the Connect Network Drive dialog
box, in which you can connect to a shared directory.



This dialog box is displayed by the Connection Status command on the File menu.     The Connection 
Status and Options dialog box displays the public file (.ECG) to which you are connected, and lets you 
disconnect from the public file.

Click an area of the dialog box to view more information.



Connected to public file    Displays the name of the Ecco public file to which you are connected.



Completely disconnect from public file    Disconnects you from the public file.



Disconnect, removing all public information from local file    Disconnects and removes all public 
information from your local file, including information that you have created and made public.



Disconnect, keeping local copies of public information    Disconnects and stores in your file all public 
information.    Reconnecting later to the public file will create duplicate copies of this information in your 
file.



This dialog box is displayed by the Connect to Public command on the File menu.     The Connect to 
Public File dialog box lets you specify networking options.    You can make information available to others 
on your network, or you can gain access to information that others on your network have created.

Click an area of the dialog box to view more information.



Connect this private file to:    Establishes connections between the active Ecco file and a new or 
existing Ecco public file. A public file is used for sharing information among members of a workgroup.



Existing Public File    Displays a dialog box, in which you specify the public file to which you want to 
connect the active file.



New Public File    Allows you to create a new public file.    Ecco displays a dialog box in which you can 
specify a name for the new public file to which you want to connect the active file.



File Menu

File Menu Overview
This menu includes the standard Windows commands for tasks such as opening new or existing files; 
closing, saving, and printing files; sending mail; and quitting the program.    The File menu also includes 
powerful Ecco commands for tasks such as importing, exporting, and sharing files and information.

New 

Opens a blank Ecco file based on the template DEFAULT.ECT.    To open a new file not based on any 
template, hold down the CTRL key and choose New.

Every Ecco file contains a Calendar view, a PhoneBook view, and up to 26 outline views. 

Open

Displays a dialog box, in which you select the Ecco file or template you want to open.    To open a new, 
untitled file based on an existing Ecco file, select the "Untitled" checkbox.    

Close File

Closes the active file.    If you have not saved changes to the file and if you have not selected the 
"Autosave on file close" option, Ecco prompts you to save your changes before closing the file.    

Save

Saves all changes in all views of the active file under its current name.    

Save As

Displays a dialog box, in which you specify the name under which you want to save the file.    

Send Mail

If you have an electronic-mail program supporting VIM (such as Lotus cc:Mail) or MAPI (such as Microsoft
Mail), this command opens the program and places the selected items and their subordinate items into a 
mail message.

Connect to Public

Displays the Connect to Public File dialog box, in which you can specify networking options.    You can 
make information available to others on your network, or you can gain access to information that others 
on your network have created.



When you choose this command, you may connect your local file to an Ecco public file.    Ecco public files 
(.ECG) have a file format and extension different from that of regular Ecco files (.ECO).    

Connection Status

Displays the Connection Status & Options dialog box, which displays the public file (.ECG) to which you 
are connected and lets you disconnect from the public file.

This command is available only if you have previously chosen the Connect to Public command from the 
File menu.    

Import

Displays the File Import dialog box, in which you can specify a file to import into the active view. Before 
choosing Import from the File menu, switch to the view to which you want to import.

You can import files in either of two formats, TXT (text) or CSV (comma-separated values). When you 
choose the OK button in the File Import dialog box, a second dialog box appears.    The elements of this 
dialog box differ, depending on the active view.    

After you choose OK in the File Import dialog box, the following dialog boxes may be displayed, 
depending upon the active view, and whether you choose to import specific information:

Active view Dialog box
PhoneBook Choose Fields for Import 

into PhoneBook

Outline Import into Current View

Outline Choose Columns for 
Import Fields

Export

Displays a dialog box specific to the active view.

Active View Dialog Box
Outline Export Outline

PhoneBook Export PhoneBook

After you choose OK in one of these dialog boxes, the following dialog boxes may be displayed, 
depending upon the active view, and whether you choose to export specific information:

Active view Dialog box
Outline Export Outline and 

Columns

Outline Choose Column Set

PhoneBook Choose Field Set



Print

Displays a dialog box specific to the active view.

Active View Dialog Box
Outline Print Outline View

Calendar Print Calendar View

PhoneBook Print PhoneBook View

If you choose the Options button in the Print Calendar View or Print PhoneBook View dialog boxes, the 
following dialog boxes appear.

Active view Dialog box
Calendar Calendar Print Options

PhoneBook PhoneBook Print Options

Printer Setup

Displays a dialog box, in which you can select a printer and specify printer options.

Exit

Quits the program and saves any changes if you have selected the "Autosave on file close" checkbox in 
the Ecco Preferences dialog box.    If you have not selected the "Autosave on file close" checkbox, Ecco 
prompts you to save any changes before quitting the program.    



Edit Menu

Edit Menu Overview
This menu includes commands for tasks such as editing text, finding and replacing text, and creating links
and embedded objects.

Undo

Undoes the previous editing or formatting action.

Cut

In general, this command cuts the selected information from the active view and copies it onto the 
Clipboard, from where it can be pasted into another location.

Cutting items or sub-items    Cuts the items from an Ecco file if the items and all of their sub-items have 
been added to only one folder.

Displays the Cut Items dialog box if the item or any of its sub-items exist in more than one view. Selecting 
the "From Folder: <folder name>" option deletes the item and its sub-items from the selected folder, but 
the items remain in all other folders to which they have been added.    Does not copy the cut items onto 
the Clipboard.    Selecting the "Cut entirely from file (all Views)" option deletes the item and its sub-items 
from all views in your Ecco file and adds them to the Clipboard.    

Cutting folders from an outline view    Cuts the selected folders from the active view only.    Does not 
copy the cut folders onto the Clipboard; the Paste command is not available.    Does not remove folders 
from the Folder window or any other view. 

Cutting folders from the Folder window    Cuts the selected folders and their subfolders from all views 
in your Ecco file.    You can't cut any of the default folders, such as PhoneBook and Appointments.    

If you are using the advanced features of Ecco Professional, folders will be available.    To use folders, 
from the Tools menu, choose Show Full Menus.    

Copy

Copies the selected information onto the Clipboard.    

Paste

Pastes the contents of the Clipboard into the location you specify with the insertion point.

Paste Special

Pastes the contents of the Clipboard as an OLE link or OLE object into the location you specify with the 
insertion point.    

Delete Items



In general, choosing this command deletes the selected items from the active view without copying them 
onto the Clipboard.

Items or sub-items are deleted from Ecco if the items and all of their sub-items have been added to only 
one folder.

The Delete Items dialog box appears if the items or any of their sub-items have been added to more than 
one folder.    Selecting the "Delete Items entirely from file (all Views)" option deletes the item and its sub-
items from all views in your Ecco file.    

If you are using the advanced features of Ecco Professional, folders will be available.    To use folders, 
from the Tools menu, choose Show Full Menus.    

Remove Folders

Removes the selected folders from the active outline view without copying them onto the Clipboard.    This
command does not remove any items from the folders.    It also does not remove the folders from any 
other view or from the Folder window.

You can't remove folders from the PhoneBook or Calendar views.

If you are using the advanced features of Ecco Professional, folders will be available.    

Find

Allows you to find information in the active view or gather information from an entire file into a Search 
Results view. When you first open it, the Find dialog box is displayed in a collapsed state.    

Find/Replace

Displays the Find and Replace dialog box, in which you can specify the text you want to find and the text 
with which you want to replace it.    

Find Next

Finds the next instance of the text you most recently searched for.    

Insert

Displays a menu, in which you can specify the line, tab, or object you want to insert.    

New Line

Begins a new line at the insertion point in the selected item. 

Tab



Inserts a tab at the insertion point.    

<Other Programs>

Lists the programs on your system from which you can insert OLE objects. 

OLE Links

Displays the Links dialog box, in which you can specify options that let you change or update existing 
OLE links in your file.    

Objects

Lets you modify the selected OLE object's size, or open the program in which the object was originally 
created and make changes to the object, without leaving Ecco.    When an object is selected, the 
command name changes to reflect the name of the program with which the object was created and 
indicates whether or not the object is linked.    

Minimize

Reduces the selected object to a minimized size.    

Adjusted Size

If the selected object is minimized or is in its original size, returns the object to its previous resized 
state.    

Original Size

If the selected object has been minimized or resized, returns it to the size it was when you first 
embedded it.    

Edit

Opens the program in which the selected object was created so you can edit it.    

Other
Displays other options provided by the program used to create the OLE object.    



View Menu

View Menu Overview
Commands on this menu switch you between the Ecco views, create and manage outline views, and 
make the active view public for use by others over a network.    

Calendar

Makes the Calendar view the active view. 

PhoneBook

Makes the PhoneBook view the active view. 

Outlines

Creates named outline views, manages existing outline views, or makes an existing outline the active 
view. 

New Outline

Displays the Create A New Outline View dialog box, in which you can create a new outline view. 

Manage

Displays the Manage Named Outlines dialog box, in which you rename or delete existing outline 
views or reorder them on the menu.    

<Outline Views>

Displays a list of outline views. Choosing an outline view makes that view the active view. 

Make Public

Makes the active outline view public. This command is valid only if you've previously made the Ecco file 
available by choosing the Connect to Public command from the File menu.    



Item Menu

Item Menu Overview
Commands on this menu let you insert, move, and display items in various ways and mark items as 
Done.

Add Item

Inserts a new item below the selected item.    

In the Folder window, choosing Add Item inserts a new, untitled folder after the selected folder.    
If you are using the advanced features of Ecco Professional, folders will be available.    To use folders, 
from the Tools menu, choose Show Full Menus.

Add Item Right

Inserts a new sub-item below and to the right of the currently selected item.    

In the Folder window, choosing this command inserts a new, untitled subfolder below and to the right of 
the selected folder.    
If you are using the advanced features of Ecco Professional, folders will be available.    To use folders, 
from the Tools menu, choose Show Full Menus.

Add Item Left

Inserts a new item below and to the left of the currently selected item.    

In the Folder window, choosing Add Item Left inserts a new, untitled folder below and to the left of the 
selected folder.    
If you are using the advanced features of Ecco Professional, folders will be available.    To use folders, 
from the Tools menu, choose Show Full Menus.

Show Levels

Displays the Show Levels dialog box, in which you can hide and expand your outline level by level by 
clicking the level number buttons.    

Show Sub-Items

Displays or hides sub-items of the selected items. 

Hide

Hides all sub-items of all selected items.    This command is available when selected items are 
expanded.    

Expand



Displays all sub-items that were displayed before the items were last hidden.    This command is 
available when selected items are collapsed. 

All Subs

Displays all sub-items of all selected items.    

1 Level Only

Displays one level of sub-items below each of the selected items.    

Move

Moves the selected items up, down, left, or right.    

Up

Moves the selected items and their sub-items up one position.    

Down

Moves the selected items and their sub-items down one position.    

Left

Moves the selected items and their sub-items left one level. 

Right

Moves the selected items and their sub-items right one level.    

Mark as Done

Marks the selected items or sub-items as done.    You can specify that To-Do's and other items shown in 
the Tickler section remain in the Calendar until they are marked done.    Choosing this command removes
such items from the Tickler section of the Calendar, even if the command is applied to the item within 
another view.

If you are using the advanced features of Ecco Professional, this command also adds items to the Done 
folder.    To use folders, from the Tools menu, choose Show Full Menus.    



Format Menu

Format Menu Overview
Commands on this menu format the text of items and outline levels and specify the type of outline labels 
you want to use.    

Character

Displays the Character dialog box, in which you can specify character formats or apply an outline style to 
previously formatted text.    

Font

Formats the selected text in the font you specify, for example, Helvetica or Times Roman.    Choose More 
to display more fonts.    If you hold down the CTRL key when you choose a font, Ecco applies the font to 
the outline styles of the selected items. 

Size

Formats the selected text in the point size you specify.    If you hold down the CTRL key when you choose 
a size, Ecco applies the size to the outline styles of the selected items. 

Style

Formats the selected text in the style you specify.    If you hold down the CTRL key when you choose a 
style, Ecco applies the style to the outline styles of the selected items. 

Color

Formats the selected text in the color you specify.    If you hold down the CTRL key when you choose a 
color, Ecco applies the color to the outline styles of the selected items. 

Text Touch-Ups

Displays a menu that allows you to create, edit, or apply a text touch-up style.    Text touch-up styles 
override outline styles. 

New

Displays the New Named Text Touch-Up dialog box, in which you can create a custom style for the 
selected text.    



Manage

Displays the Manage Text Touch-Ups dialog box, in which you can create a new style, rename or edit 
an existing style, delete a style, or reorder the list of custom styles.    

< Named Text Touch-Up>

Displays a list of existing text touch-ups. When you select a text touch-up from the list, Ecco applies it 
to the highlighted text.    

If you hold down the CTRL key while you choose the text touch-up, Ecco applies the attributes of the 
touch-up to the outline styles for the selected items.    

Outline Styles

Displays the Outline Styles dialog box, in which you define a text style (font, size, color, and style) for the 
selected levels in your outline.    

Outline Labels

Displays or hides outline labels and allows you to create new or edit existing outline labels.    This 
command is not available in either the Calendar view or the PhoneBook view. 

Show Labels

Shows or hides all labels in the outline.    

Skip Label

Skips the label for the selected items but resumes the labeling sequence with the next item.    

Restart Sequence

Restarts the labeling sequence beginning with the selected items.    

New

Displays the Outline Labels dialog box, in which you can create custom label formats (for example, I, 
II, III; 1, 2, 3; A, B, C) for selected outline levels. 

Manage

Displays the Manage Outline Labels dialog box, in which you can edit, delete, reorder, and rename 



existing outline labels.    You can also create a new outline label from this dialog box.    

<Named Outline Labels>

Any outline labels you've created are listed at the bottom of this menu.    Choose a name to apply a 
set of labels to the active view. The default named set of outline labels is called Simple Numeric 
Labels.    



Tools Menu

Tools Menu Overview
Commands on this menu let you show or hide the full menus and options (including the Advanced menu);
insert files and program names into Ecco; launch other programs from Ecco; manage alarms and tickler 
items; customize the tool bar specify Ecco default preferences, and display or hide the column grid, dialog
alerts, and the Shooter.

Show Full Menus

Allows you to use the advanced features of Ecco Professional.    When this command is checked, the 
Advanced menu appears on the main Ecco menu bar, filter and folder options are available, and the 
Column menu appears in all views. When full menus are activated, the Find, Replace, and New Outline 
dialog boxes have additional options.    

Get Disk Files

Inserts file, directory, or program names into Ecco.    

From File Manager

Opens the File Manager, from which you can insert references to one or more files, directories, or 
programs into Ecco by using the Shooter. 

Browse

Opens a dialog box, from which you can choose a file to which you want to insert a reference in Ecco.

Launch

When a filename is selected, choosing this command launches the program and opens the file.    When 
an executable file (which has an .EXE file extension) is selected, choosing this command launches the 
program.    

Alarms

Displays a menu with commands that let you create new alarms, review existing alarms, and edit existing 
alarms.    You use alarms to get advance warning for important events. 

Create New Alarm

Displays the Create an Alarm dialog box, in which you can create a simple alarm or a new named 
alarm.    This command is unavailable in the Calendar view, where alarms can be attached to items 



using the Calendar menu or the Date Settings dialog box. 

Review Alarms

Displays the Review Alarms dialog box, in which you can view upcoming alarms and delete those you
no longer want.    

Manage Named Alarms

Displays the Manage Named Alarms dialog box, in which you can create or edit named alarms, delete
existing named alarms, or reorder the list of named alarms.    

Ticklers

Displays the Show Item in Calendar Tickler Section dialog box, in which you can choose to display the 
currently selected item as a tickler item in the Tickler section of the Calendar. 

Tool Bar

Displays the Tool bar dialog box, in which you customize the tool bar display.    (You can also customize 
the tool bar by using the right mouse button to drag icons.) 

Preferences

Displays the Ecco Preferences dialog box, in which you can specify the settings you want to use 
whenever you work in Ecco.    

Display

Displays a menu that contains the following commands.

Column Grid

Displays or hides the column grid (vertical column lines) in the Column pane of the active view only.    

Restore Dialog Alerts

Restores any dialog box messages you previously turned off.    

Show Shooter



Toggles the display of the Shooter icon on and off.    Using the Shooter, you can insert, link, and embed 
objects and selected information from other programs to Ecco views or folders, from Ecco views to other 
programs, or between other programs.    Click the Shooter icon to display its menu.    



Advanced Menu

Advanced Menu Overview
Use these commands to display the Folder window, filter or sort the active view, select folders to display 
in an outline view, and view an item's folders.    You can also create forms that automate your work by 
adding items and their values to several folders at once.

If you are using the advanced features of Ecco Professional, this menu will be available.    To display this 
menu, from the Tools menu, choose Show Full Menus.

Show Folder Window

Displays and hides the Folder window. 

Sort

Displays the Sort Items dialog box, in which you can sort items or sub-items subordinate to the selected 
folders or items in the active view. 

Filters

Filters allow you to limit the display of items in the view to those items that meet the criteria you specify.    

Commands on this menu let you create a new filter, edit an existing one, ignore a filter and see all the 
information in a view, or apply an existing filter to a view.    

New

Displays the Filter Current View dialog box, in which you can create a filter and display specific 
information contained in the view.    After you create a new filter, it is applied to the active view. 

If you choose the Advanced button in the Filter Current View dialog box, Ecco displays the Create a 
New Filter dialog box, in which you can create advanced filters.    If you use the Create a New Filter 
dialog box to create the current filter, then when you subsequently choose New from the Filters menu,
Ecco displays the current filter in the same dialog box.

Manage

Displays the Manage Named Filters dialog box, in which you rename or delete existing named filters 
or reorder them on the menu.    

Ignore Filter

Ignores the applied filter and displays all information contained in the view.    When chosen again, this 



command restores the filter.    

<Named Filters>

Applies the filter to the active view, displaying only those items that match the filter.    

Outline Folders

Displays the Choose Outline Folders dialog box, in which you choose the folders whose items you want to
display in the view. To include a folder in the view, choose the folder name.    

Show Item Info

Displays the Show Item Info dialog box, in which you can view all folders to which the selected item has 
been added and all column values entered for the item, edit the folder values associated with the item, or 
delete the item.    

Add Item By Form

Creates new forms, manages existing forms, and lets you create new items and add them to folders 
without requiring you to first add them to a view. Use forms to quickly add items and associated folder 
values to several folders at one time.    

New Form

Displays the Create New Form dialog box, in which you can create a form. The forms created here 
can be used with the Add By Form, View By Form, and Apply By Form commands.    

Manage Forms

Displays the Manage Forms dialog box, in which you rename or delete existing forms or reorder them
on the menu.    

<Named Forms>

Displays a list of named forms.    Choosing a named form displays the Add By Form dialog box for that
form.    In this dialog box, you can specify options to create a new item and add it to Ecco by form, 
without having to first add them to any specific view.    

View Item By Form

Allows you to:



View and edit individual items by form.
See which of the form's folders and columns the item is in.
See each item's associated column values.
Navigate through the items in a view and see and edit their folders and column values in a form.   

Displays a list of existing forms.    When you select a form from the list, the View By Form dialog box is 
displayed.    In this dialog box, you can view and edit the selected item's folders, columns, and associated 
values for the form you chose.    You can also use the "Next Item" button in this dialog box to move 
sequentially through a view and see the form's folders, columns, and values for each item.    

Apply Form to Items

Displays a list of existing forms. When you select a form from the list, Ecco displays the Apply Form dialog
box, in which you can set column values and apply the chosen form to the currently selected items in the 
active view. Allows you to put multiple items into a set of folders or columns at one time and associate 
values for those items with each of the columns in the form.    

If you selected the "Don't display dialog" checkbox when you created the form, Ecco applies the default 
columns and values in the form to the selected items without displaying the Apply Form dialog box.    



Window Menu

Window Menu Overview
Use these commands to rearrange the display of windows on the screen, close all the open files, or make
a particular window or window pane active.    

Tile

Arranges the open windows side by side so that all of them are visible.    

Cascade

Arranges the open windows in an overlapping fashion so that the title bar of each is visible.    

Arrange Icons

Arranges Ecco icons in a row across the bottom of the main Ecco window.    You display an Ecco icon by 
minimizing an Ecco window.    

Close All

Closes all active files.    If you have not saved changes to the files, Ecco prompts you to save them before 
closing the files.    

Go To Pane

Switches you to different sections of the active window.    

Left <-> Right

Switches you to and activates the left or right pane and shows columns if they are not showing.    

Top <-> Bottom

Switches you to and activates the top or bottom pane and splits the window vertically if the bottom 
pane is not already open.    In the Calendar view, this command switches you between the Tickler 
section and the Appointment section. 

<Open Windows>
All open windows are listed at the bottom of this menu.    A checkmark appears before the name of the 
active window.    To make another window active, choose its name from the list.    



Help Menu

Help Menu Overview
This menu includes commands to view the Quick Tour of Ecco features, open the online User's Guide and
view specific Help topics, do a keyword search of the online User's Guide, or choose a command for 
which you want to view a Help topic.

Overview
Displays an interruptable online Quick Tour of Ecco features and functions.    

Contents
Displays a list of Help topics.    

Search
Displays the Search dialog box.    

Menu Help
Displays a "choose menu" cursor, with which you can choose the menu or command for which you want 
to see a Help topic.    

Shortcut Keys
Displays a list of keyboard shortcuts.    

Help on this View
Displays a Help topic on how to use the active view. 

Help on Ecco Folders
Displays a Help topic on how to use folders. 

About Ecco
Displays information about your version of Ecco.



 Non-Menu Bar Commands Overview

The commands in this section appear on menus that are in the Ecco program window but not on the 
menu bar.    The following menus are included in this section.

The Column menu (in the Column pane) 

The Calendar menu (in the Calendar view) 

The PhoneBook menu (in the PhoneBook view) 

The Folder menu (in the Folder window) 

The folder options pop-up menu (appears when you click folder names in the Folder window) 

The Shooter menu (appears when you click the Shooter icon) 



Column Menu

Column Menu Overview
If you are using the advanced features of Ecco Professional, the Column menu will be available.    
Otherwise, it will be replaced by the Show Columns and Hide Columns button.    

This drop-down menu is located in the upper right corner of every view window when the Column pane is 
closed and to the left of the Column pane when it is open.    This menu includes commands for hiding, 
displaying, inserting, or deleting columns; modifying column properties; naming, aligning, moving, or 
sizing columns; and making the contents of a column public.

Checkmarks and values in column cells on the right are always associated with items on the same line on
the left, just as spreadsheet cells are commonly associated with their titles.    When you move an item, the
values and checkmarks in columns move with the item.

Columns without headings (scratch columns) are specific to the view in which they appear.    When you 
add a heading to a column, Ecco automatically creates a new folder with the name of the supplied 
heading and adds it to the list in the Folder window. 

You can also add folder columns to show which of the items in a view are in that folder, to add columns 
from other views, and to show the values associated with the items in the view.    

Show Columns

Toggles the display of Column pane on or off.    

You can create many different types of columns in the Column pane, using the Insert Column command.   

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Column menu, from the Tools menu, choose Show Full Menus.
When full menus are not in effect, the Column menu is replaced by the Show Columns and Hide Columns
buttons.

Insert Column

Inserts the column type you specify.    The available column types are folder, text, number, checkmark, 
date, pop-up list, and Gantt. 

Columns without headings (scratch columns) are specific to the view in which they appear and are not 
associated with any folder. When you add a heading to a column, Ecco automatically creates a new folder
with the name of the supplied heading and adds it to the list in the Folder window. The column can then 
be added to any other view as a folder column, using the Insert Column: Folder command.    

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Column menu, from the Tools menu, choose Show Full Menus.

Folder

Displays the Insert Folder Columns dialog box, in which you choose one or more folders (or named 
columns from other views) to insert as columns.    

When you make multiple selections from this dialog box, Ecco creates a separate column for each folder 
you select.    
You can also insert a folder column by dragging a folder from the Folder window to the Column pane. 



Text

Inserts a column that allows you to type text into its cells.

Text is the default column type for scratch columns.    

Number

Inserts a column that allows you to type a number into its cells.    

CheckMark

Inserts a column that allows you to enter checkmarks (or other one-character symbols) into its cells.    
Clicking a cell toggles the checkmark on or off.    To change the checkmark symbol, use the 
Checkmark command on the Column menu.    

Date

Displays the Date Column Heading dialog box, in which you can type a heading to display in the 
column and create a new date column.    After you select a date column, you can enter, view, and edit 
dates in the cells of the column.    

Use the Column Properties command to specify the date format you want to use.     

Pop-Up List

Displays the Insert Pop-Up List Column dialog box, in which you can specify a pop-up list of values 
for the column.    For example, the pop-up list values for a column titled "Priorities" might include the 
values "High," "Medium," and "Low." You could click on any cell in the column and choose one of the 
priorities for the item on that line.    

The Insert Pop-Up List Column dialog box is identical to the Pop-Up List Column Values dialog box.    

Gantt

Displays the Create New Gantt Column dialog box, which allows you to create a Gantt chart column 
for the items in that view.    

Remove Column/Delete Column

Removes the selected column. If the column has a heading, the heading appears as the name of a folder 
in the Folder window. In this case, the Remove Column command appears on the menu.    You can 
redisplay this column and any values you have added by dragging it from the Folder window to the 
Column pane. If the column does not have a heading, the Delete Column command appears on the 
menu.    Choosing this command permanently deletes the column values.    

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Column menu, from the Tools menu, choose Show Full Menus.



Column Type

Lets you change the type of the values that can be entered and displayed in the column. 

For a description of the column types, see the Insert Column menu.    

Properties

Displays the Column Properties dialog box, in which you can specify properties for the selected column.    
The options in this dialog box change depending upon the type of column selected.    From this dialog 
box, you can change any of the settings of the available options.    

Column Type Options Available
Text Heading; Alignment; Width; 

"For each Item, cell displays"

Number Heading; Format; Alignment; Width;
"For each Item, cell displays"

Checkmark Heading; Checkmark; Alignment; 
Width; 
"For each Item, cell displays":

Date Format; Alignment; Defaults; Width

Pop-Up List Heading; Alignment; Values; Width; 
"For each Item, cell displays"

Gantt Displays a dialog box identical to 
the Create New Gantt Column 
dialog box.    

Heading    Type here the text you want to appear at the heading of the selected column.    When you add 
a heading to a column, Ecco automatically creates a new folder with that name and adds it to the list in 
the Folder window. 

Alignment    Specifies the alignment of the column's contents (left, right, or center).
Width    Displays the Column Width dialog box.    
For each item, cell displays    This is an advanced feature that you should only consider if you're already
familiar with the use of folders and columns.    
Format    Specifies the number format (for a Number column) or date format (for a Date column).    
Checkmark    Specifies the type of checkmark or symbol displayed in a checkmark column.
Defaults    Displays the Date Properties dialog box.    

Values    Displays the Pop-Up List Column Values dialog box.    
If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Column menu, from the Tools menu, choose Show Full Menus.

Heading

Type or edit the text you want to appear at the heading of the selected column. When you add a new 
heading to a column, Ecco automatically creates a new folder with that name and adds the new folder to 
the list in the Folder window. You can then insert it as a column into another view by dragging the folder 
into the Column pane or by choosing the Insert Column: Folder command.    When you change a column 



heading, you also change the folder name.    

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Column menu, from the Tools menu, choose Show Full Menus.

Format

Lets you specify the number format or date format of the selected column's contents.    This command is 
available only for Number columns and Date columns. 

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Column menu, from the Tools menu, choose Show Full Menus.

Checkmark

Lets you specify the type of symbol you want to display in the selected checkmark column. This command
is available only for checkmark columns.    

Alignment

Lets you specify the alignment of the selected column's contents (left, right, or centered).    

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Column menu, from the Tools menu, choose Show Full Menus.

Width

Displays the Column Width dialog box, in which you can specify the column width or minimize the column 
to a narrow width (to display a greater number of columns at one time).    

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Column menu, from the Tools menu, choose Show Full Menus.

Move Column

Lets you move a column, using the keyboard.    To move a column with the mouse, drag its heading to a 
new position.    

If you are using the advanced features of Ecco Professional, this menu will be available.    To display this 
menu, from the Tools menu, choose Show Full Menus.

Show Home Folder

Displays or hides the Home Folder column in the Column pane. The home folder is the folder in which the
item was first created.

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Column menu, from the Tools menu, choose Show Full Menus.

Make Public

Lets you make the contents of a specific column public for workgroup interaction by adding the column to 



a view in a public file (and in all local files attached to the public file).    This command is valid only if 
you've previously connected to a public file by choosing the Connect to Public command from the File 
menu.    



Calendar Menu

Calendar Menu Overview
This menu is located at the left side of the Calendar view and is available only in the Calendar view.

Commands on this menu let you add tickler items and appointments, make multiday appointments, 
schedule group meetings, and navigate through the Calendar.    

Add Tickler Item

Displays the Add Tickler Item dialog box, in which you can specify settings for the tickler item you are 
adding.    

Add Appt.    Item

Creates a new appointment item at the selected time.    

Add Multi-Day Appt

Displays the Add Multi-Day Appointment dialog box, in which you can specify the beginning and ending 
dates for a multiday appointment.    This dialog box is identical to the Edit Multi-Day Appointment dialog 
box.    Multiday appointments are shown in the Tickler section, and they appear in the Busybar in red.    

Group Scheduling

Available only in the workgroup version of Ecco (Ecco for Workgroups).

Displays the Schedule Group Meeting with Others dialog box, in which you can schedule a meeting for 
yourself and for members of your workgroup.    Once you've scheduled a group meeting, it appears in the 
Calendar view of each of the meeting's participants.

Time, Date, Alarm, etc.

Displays the Date Settings dialog box for the selected item.    This command is available only if the 
selected item is an appointment or tickler item. 

For multiday appointments, this command displays the Edit Multi-Day Appointment dialog box, identical to
the Add Multi-Day Appointment dialog box.    

Add Outline Note

Adds to the selected item a sub-item, which you can use to record notes.    

Navigate



Moves the calendar display to the previous or next day, month, or year.    

Use with PhoneBook

Opens the PhoneBook view and arranges the windows side by side so that both the PhoneBook view and
the Calendar view are visible.    You can drag any name in the PhoneBook to the Calendar to 
automatically create an appointment. 



PhoneBook Menu

PhoneBook Menu Overview
This menu is located at the upper left side of the PhoneBook view and is available only in the PhoneBook 
view.    

Commands on this menu let you create, edit, delete, and add notes to PhoneBook items; search your 
PhoneBook; and autodial numbers.    

New PhoneBook Item

Lets you enter information for a new PhoneBook item and add it to the PhoneBook.    Opens the 
PhoneBook's entry form if it is closed.    If it is open and a PhoneBook entry is already selected, this 
command clears the entry form.    

Use PhoneBook Form

Opens the PhoneBook's entry form if it is closed and displays the contents of the Name field of the 
selected PhoneBook item. 

Add Outline Note

Adds to the selected item. a sub-item, which you can use to record notes.    

Search 1st and Last Name

Searches based on the letter tabs or text entered in the PhoneBook search box and will find either of the 
first two words in the Name field (the item text).    

Enable Company Search

When this command is checked, clicking a letter tab or the Search button displays a pop-up menu that 
allows you to search by name, company, or column of your choice.    

Dial phone

Displays the Dialer/Call Logger dialog box, in which you can dial or log a phone call.    

Use with Calendar

Opens the Calendar view and arranges the windows side by side so that both the PhoneBook view and 
the Calendar view are visible.    



Folder Menu

Folder Menu Overview
If you are using the advanced features of Ecco Professional, this menu will be available.    To display this 
menu, from the Tools menu, choose Show Full Menus.

The folder menu appears in the upper right corner of the Folder window.

Commands on this menu let you edit folders; add items to folders; create new folders; assign values to 
folders; change default properties; delete folders; assign folders using the keyboard; and make folders 
public. 

Folders are the basic organizational container for your information, used for organizing, collecting, and 
cross-referencing items.    Every item goes into a folder, but an item can exist in many folders at one time. 
You can view folders in the Folder window, view the contents of any folder in an outline view, and you can 
insert and view folders as folder columns in the Column pane of any view.    

Assign Folders

After you choose this command, clicking a folder name opens the folder options pop-up menu. 

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder menu, from the Tools menu, choose Show Full Menus, then choose Show Folder Window from
the Advanced menu.

Edit Folders

After you choose this command, you can use the Folder window to rename folders, reorganize the folder 
outline, add new folders, view a folder type, change default properties, delete folders, or make folders 
public. 

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder menu, from the Tools menu, choose Show Full Menus, then choose Show Folder Window from
the Advanced menu.

New Folder

Inserts a new folder after the selected folder in the Folder window.    (Alternatively, you can insert a new 
folder by pressing the ENTER key.) 

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder menu, from the Tools menu, choose Show Full Menus, then choose Show Folder Window from
the Advanced menu.

Folder Type

Lets you view or change the type of the selected folder. If a folder currently contains items, you cannot 
change the folder's type.    Also, you can't change the type of any default folder, such as PhoneBook or 
Appointments.    Folder types allow you to associate a checkmark, text, numbers, or dates with items 
when you add the items to folders.    

This command is available only when you have previously chosen the Edit Folders command.



If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder menu, from the Tools menu, choose Show Full Menus, then choose Show Folder Window from
the Advanced menu.

Text

Makes the selected folder a text folder, allowing you to associate additional text with each item you 
add to the folder.    

Number

Makes the selected folder a number folder, which allows you to associate a number with each item 
you add to the folder.    

CheckMark

Makes the selected folder a checkmark folder, which allows you to associate a checkmark with each 
item you add to the folder (rather than associating a number, text, or a date).    Checkmark is the 
default folder type.    

Date

Makes the selected folder a date folder, which allows you to associate a date and time with each item 
you add to the folder.    Items added to a date folder automatically appear in the Calendar on the 
appropriate date and time.    

Pop-Up List

Displays the Pop-Up List Column Values dialog box, in which you can specify a pop-up list of values.   
When you add an item to a pop-up list folder, you can associate one of the values in the pop-up list 
with the item.    

Properties

This command is available only for number folders, date folders, and pop-up list folders.

If a number folder is selected, this command displays the Number Properties dialog box, in which you can
select a number format.

If a date folder is selected, this command displays the Date Properties dialog box, in which you can 
specify properties for the selected date folder.    If you often set alarms, or if you like to display tickler 
items a particular number of days before an appointment, you can change the default settings to the 
settings you use most often.    

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder menu, from the Tools menu, choose Show Full Menus, then choose Show Folder Window from
the Advanced menu.

Delete Folder



Removes the selected folders and their subfolders from all views and the Folder window, without copying 
them onto the Clipboard.    Removes items from the folders without removing items from the file.    

Because any item can appear in many folders, deleting a folder does not delete the items it contains.    
You can delete items in any folder by displaying the folder in a view and deleting items from the view.    
You can also search for any items and collect them in the Search Results folder, using the Find 
command.

You can't remove any of the default folders, such as PhoneBook and Appointments, however.

This command is available only when you have previously chosen the Edit Folders command.    

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder menu, from the Tools menu, choose Show Full Menus, then choose Show Folder Window from
the Advanced menu.

Assign by Keys

Allows you to use the keyboard in the Folder window.    When you choose this command, the folder most 
recently selected in the Folder window changes to black.    You can move the highlight with the up and 
down arrow keys.    Press the left arrow key to hide subfolders, press the right arrow key to expand 
subfolders, and press the SPACEBAR or the ENTER key to display the folder options pop-up menu. 

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder menu, from the Tools menu, choose Show Full Menus, then choose Show Folder Window from
the Advanced menu.

Make Public

Makes the selected folder public for use by others over a network.    

This command is valid only if you've previously connected to a public file by choosing the Connect to 
Public command from the File menu.    



Folder Options Pop-up Menu

Folder Options Pop-up Menu Overview
If you are using the advanced features of Ecco Professional, this menu will be available.    To display this 
menu, from the Tools menu, choose Show Full Menus.

This menu pops up when you choose the name of a folder in the Folder window (and when you have 
previously chosen the Assign Folders command from the Folders menu).    

Commands on this menu let you add items to folders, remove items from folders, show or edit the values 
associated with selected items in a given folder, show the folder's items in the active outline view, and 
insert a folder column into the active view. 

Add Items to Folder(s)
Adds the selected items in the active view to the selected folder or folders in the Folder window. To add 
items to multiple adjacent folders, drag the mouse pointer down the list of folder names.    If you select 
multiple folders that have values (folders of any type other than checkmark), the Specify Folders and 
Column Values dialog box appears, in which you can associate a value with the items in each folder.    

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder window, from the Tools menu, choose Show Full Menus, then choose Show Folder Window 
from the Advanced menu.

Remove Items from Folder
Removes the selected items and their associated values from the folder. or column. 

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder window, from the Tools menu, choose Show Full Menus, then choose Show Folder Window 
from the Advanced menu.

Show/Edit Values
Displays a value edit box, in which you can change the folder values associated with the selected items in
the folder. or column. These options are available only for column or folder types that have values 
associated with them (all types other than checkmark).    

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder window, from the Tools menu, choose Show Full Menus, then choose Show Folder Window 
from the Advanced menu.

Show Folder's Items
Displays the folder and its items in the active outline view.    This command is available only in outline 
views. 

If you are using the advanced features of Ecco Professional, this command will be available.    To display 
the Folder window, from the Tools menu, choose Show Full Menus, then choose Show Folder Window 
from the Advanced menu.

Replace View's Folders
Replaces the folders in the active outline view with the folders you have selected.    The items in these
folders will be displayed in the view.    

Add Folder to View



Adds the folders you have selected to the bottom of the active outline view.    The items in these 
folders will be displayed in the view.    Alternatively, you can add folders to a view by dragging them 
from the Folder window into the outline view.    

Insert Folder Column
Inserts a folder column that shows a check (for checkmark folders) or a column value (for folders that 
have a type other than checkmark) for each item that is in the selected folder.    The checkmark or 
value appears in the column, on the same line as the item.    

Alternatively, you can add folder columns to a view by dragging folders from the Folder window into 
the Column pane of any active view.    



Shooter Menu

Shooter Menu Overview
Using Shooter menu commands, you can send, or "shoot," selected information from other programs to 
Ecco views or folders, from Ecco views to other programs, or between other programs.    Click the Shooter
icon to display its menu.

Depending upon the preference you have selected, Ecco might or might not display the Send Text 
Selection As dialog box or the Send Graphics Selection As dialog box before sending your information.    
The only difference between these dialog boxes is that the Send Graphics Selection As dialog box does 
not have an Editable Text option.    

When the information has been sent, a small "Item Sent" message window appears briefly next to your 
Shooter icon.    

Active View
Sends the selection to the active view or to the most recent Ecco view. 

Calendar
Sends the selection to the Calendar view. The Date Settings dialog box appears, in which you can set 
date and time options before sending the selection.    If no time is specified, the selection is sent to the 
Tickler section of the Calendar.    If a time is specified, the selection is sent to the Appointment section. 

Folders
Displays the Shooter tool bar and the Folder window (which contains a list of all the folders in your Ecco 
file).    Choose the folders to which you want to send the selection.    To close the window, double-click the 
Shooter icon or, from the Shooter menu, choose the Close Folders command.    

If you are using the advanced features of Ecco Professional, folders will be available.    To use folders, 
from the Tools menu, choose Show Full Menus.

Relative to Last
Sends the selection relative to the last selection you sent.    

Same Level As
Sends the selection to the same outline level as the previous selection you sent.    

To Right Of
Sends the selection to the right of (subordinate to) the previous selection you sent (as a sub-item).    

To Left Of
Sends the selection to the left of (superior to) the previous selection you sent.    

<Other Program>
Lists the active files in the other Windows programs that are currently running, from which you can 
choose where to send your selection.    If you choose this command while Ecco is active, the command 
inserts the text into and switches you to the program you choose.    



Show
Specify the display of the Shooter and its icon, the Shooter tool bar and the Folder window. 

Icon Only
Displays only the Shooter icon.    

Tools
Displays the Shooter tool bar.    

Tools and Folder
Displays the Shooter tool bar and the Folder window.    

If you are using the advanced features of Ecco Professional, folders will be available.    To use folders, 
from the Tools menu, choose Show Full Menus.

Hide Shooter
Hides the Shooter icon from view.    To redisplay the Shooter, from the Tools menu (in Ecco), choose 
Show Shooter.    

Preferences
Changes the default Shooter settings.    

Choose Ecco File
Selects the Ecco file to which you want to send information.    Choosing Open Another displays the 
File Open dialog box, from which you can select other Ecco files.    All open Ecco files are listed at the 
bottom of this menu.    

Send Text As
Changes the default settings for sending text as editable text, OLE linked text, or an OLE embedded 
object, and changes the default setting to display or hide the Send Text Selection As dialog box 
before sending text.    

Send Graphics As
Changes the default settings for sending graphics as OLE linked objects or OLE embedded objects 
and changes the default setting to display or hide the Send Graphics Selection As dialog box before 
sending text.    

Add By Form
Displays a list of existing forms that you can apply to the current selection.    

If you are using the advanced features of Ecco Professional, forms will be available.    To use forms, from 
the Tools menu, choose Show Full Menus.

<Named Forms>
Choosing a form from this list applies the form to the selection.    

Go To Ecco
Switches you to the active view in Ecco.    



Ecco Shooter Help
Opens online Help for the Shooter.    



Date Settings Commands Overview

The commands in this section appear on menus that are available from the buttons in the Date Settings 
dialog box. 



Alarms Menu

Alarms Menu Overview
Commands on this menu let you create a custom alarm. You use alarms to get advance warning for 
important events. 

None
Removes the alarm from the selected item. 

Custom
Displays the Alarms dialog box, in which you can specify parameters for a new alarm for the selected 
item. 

<Named Alarms>
Displays the list of named alarms. The default named alarm is Simple Alarm.    



Recur Menu

Recur Menu Overview
The Recur button in the Date Settings dialog box displays the Recur menu.    From this menu, you can 
create a custom recurring event or a standard recurring event, or you can change an existing recurring 
event into a non-recurring event.    

Non-Recurring
Removes the recurring event attributes from an item. 

Custom
Displays the Recurring Event dialog box, in which you can create a custom recurring event.    

Every Day
Sets the event to recur daily.    

Every Mon thru Fri
Sets the event to recur every weekday.    

<Date-Specific Options>
Sets the event to recur at an interval based on the selected item's date.    



For more information, see Opening a File.



For more information, see Opening a File.



For more information, see Closing Files and Exiting Ecco.



For more information, see Saving an Ecco File.



For more information, see Saving an Ecco File.



For more information, see What is a Public File?



For more information, see Importing to the PhoneBook and Importing to Other Ecco Views.



For more information, see The PhoneBook Print Options Dialog Box.



For more information, see Saving an Ecco File.



For more information, see Deleting Items.



For more information, see Understanding Folders.



For more information, see Linking and Embedding OLE Objects.



For more information, see Deleting Items.



For more information, see Understanding Folders.



For more information, see Removing Folders from an Outline View.



For more information, see About Finding Items.



For more information, see Finding and Replacing.



For more information, see About Finding Items.



For more information, see Adding Items to an Outline.



For more information, see Adding Items to an Outline.



For more information, see Linking and Embedding OLE Objects.



For more information, see Editing OLE Links.



For more information, see Editing Embedded Objects.



For more information, see Resizing Linked or Embedded Objects.
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For more information, see Resizing Linked or Embedded Objects.



For more information, see Editing Embedded Objects.



For more information, see Linking and Embedding OLE Objects.



For more information, see About the Calendar View.



For more information, see About the PhoneBook View.



For more information, see About Outlining.



For more information, see Creating New Outlines.



For more information, see Managing Outlines.



For more information, see Viewing an Outline.



For more information, see Sharing Views.



For more information, see Adding Items to an Outline.



For more information, see Creating Folders.



For more information, see Adding Items to an Outline.



For more information, see Creating Folders.



For more information, see Adding Items to an Outline.



For more information, see Creating Folders.



For more information, see Viewing an Outline.
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For more information, see Viewing an Outline.



For more information, see Viewing an Outline.



For more information, see Promoting, Demoting, and Moving One or More Items.



For more information, see Promoting, Demoting, and Moving One or More Items.



For more information, see Promoting, Demoting, and Moving One or More Items.



For more information, see Promoting, Demoting, and Moving One or More Items.



For more information, see Promoting, Demoting, and Moving One or More Items.



For more information, see About Folder Columns.



For more information, see About Formatting.



For more information, see Character Formatting.



For more information, see Character Formatting.



For more information, see Character Formatting.



For more information, see Character Formatting.



For more information, see Character Formatting.



For more information, see About Text Touch-Ups.



For more information, see Creating Text Touch-Ups.



For more information, see Managing Text Touch-Ups.



For more information, see Applying Text Touch-Ups.



For more information, see Outline Styles.



For more information, see Outline Styles.



For more information, see About Outline Labels.



For more information, see Displaying Outline Labels.



For more information, see Displaying Outline Labels.



For more information, see Displaying Outline Labels.



For more information, see Creating Outline Labels.



For more information, see About Outline Labels.



For more information, see About Outline Labels.



For more information, see Advanced Menu Overview.



For more information, see Working with Disk Files.



For more information, see Inserting Files and Directory References into Ecco.



For more information, see Inserting Files and Directory References into Ecco.



For more information, see Launching Other Programs from Ecco.



For more information, see Using Alarms.



For more information, see Setting Simple Alarms.



For more information, see Reviewing Alarms.



For more information, see Managing Named Alarms.



For more information, see Introduction to Ticklers.



For more information, see Tool Bar Features.



For more information, see Displaying the Shooter.



For more information, see The Folder Window.



For more information, see Sorting Items in a View.



For more information, see About Filters.



For more information, see Creating Filters.



For more information, see Managing Filters.



For more information, see Applying Filters.



For more information, see Using Named Filters.



For more information, see About Folders in Outline Views.



For more information, see Viewing an Item's Folders.



For more information, see About Forms.



For more information, see Creating Forms.



For more information, see Managing Multiple Forms.



For more information, see Adding Items by Form.



For a better understanding of folder values, see About Folder Values.



For more information, see Viewing Items by Form.



For more information, see Applying Forms to Items.



For more information , see Managing Multiple Windows.



For more information, see Managing Multiple Windows.



For more information, see Managing Multiple Windows.



For more information, see Closing Files and Exiting Ecco.



For more information, see Managing Multiple Windows.



For more information, see Managing Multiple Windows.



For more information, see Managing Multiple Windows.



For more information, see Managing Multiple Windows.



For more information, see Ecco User's Guide Contents.



For more information, see Keyboard Shortcuts.



For more information about outlining, see About Outlining.

For more information about the Calendar view, see About the Calendar View.

For more information about the PhoneBook view, see About the PhoneBook View.



For more information, see Understanding Folders.



For more information, see Column Menu Overview.



For more information, see Calendar Menu Overview.



For more information, see PhoneBook Menu Overview.



For more information, see Folder Menu Overview.



For more information, see Folder Options Pop-up Menu Overview.



For more information, see Shooter Menu Overview.



For more information, see About Folders.



For more information, see Introduction to Columns.



For more information, see Adjusting the Column Pane Display.



For more information, see Insert Column.



For more information, see Inserting Columns.



For a better understanding of the basic relationship between columns and folders, see About Folder 
Columns.



For more information, see Using the Same Column in Multiple Views.



For more information, see About Folder Columns.



For more information, see Text Columns.



For more information, see Number Columns.



For more information, see Checkmark Columns.



For more information, see Date Columns.



For more information, see Properties.



For more information, see Pop-up List Columns.



For more information, see The Pop-Up List Column Values Dialog Box.



For more information, see Using Gantt Columns.



For more information, see Deleting or Removing Columns.



For more information, see About Folder Columns.



For more information, see Insert Column.



For more information, see Customizing a Column's Display.



For more information, see About Folder Columns.



For more information, see The Column Width Dialog Box.



This option is only available when the selected column has a heading other than "A," "B," "C," etc.    
Select the first radio button ("Cell displays checkmark or value") for the normal entry of values into 
columns.    Note that if you've supplied a heading for this column, the column heading automatically 
appears as the name of a folder in the Folder window and is known as a folder column. If this first radio 
button is selected, then entering a value into a cell in this column adds that value and the item on the 
same line to the folder.    For more information, see About Folder Columns.

Select the second radio button ("Cell displays subfolders of <folder column name> that contain item") to 
make this column a multiple folder column.    Remember that because this column has a heading, it 
appears as a folder in the Folder window.    Like any other folder, this folder can have subfolders.    
Multiple folder columns display in each cell any of those subfolders that contain the item on the same line.
For more information, see Displaying Multiple Folders in a Column.

When you click a cell in this column, a scrolling edit box appears, showing all the subfolders and 
indicating which of those folders contain the item on that line.    You can use this edit box to add (or 
remove) the item to any of these subfolders.    For more information, see Editing Multiple Folders in a 
Column.



For more information, see The Date Properties Dialog Box.



For more information, see The Pop-Up List Column Values Dialog Box.



For more information, see Adding or Changing Column Headings and About Folder Columns.



For more information, see Customizing a Column's Display.



For more information, see Checkmark Columns.



For more information, see Customizing a Column's Display.



For more information, see Customizing a Column's Display.



For more information, see Adjusting the Column Pane Display.



For more information, see Sharing Columns.



For more information, see About the Calendar View.



For more information, see Ticklers: To-Do's and What's Ahead.



For more information, see Scheduling New Appointments.



For more information, see Scheduling Multi-Day Appointments.



For more information, see The Date Settings Dialog Box.



For more information, see Add Multi-Day Appt.



For more information, see Adding Outline Notes to an Appointment.



For more information, see Viewing Dates and Appointments.



For more information, see Scheduling Appointments Using the PhoneBook or Using the PhoneBook with 
the Calendar.



For more information, see About the PhoneBook View.



For more information , see Entering PhoneBook View Information.



For more information, see Using the PhoneBook View Entry Form.



For more information, see Adding Outline Notes to an Entry.



For more information, see Finding PhoneBook Information.



For more information, see Finding PhoneBook Information.



For more information, see Dialing and Logging Calls.



For more information, see Scheduling Appointments Using the PhoneBook or Using the PhoneBook with 
the Calendar.



For more information, see About Folders.



For more information, see Folder Options Pop-up Menu Overview.



For more information, see The Folder Window.



For more information, see Creating Folders.



For more information about column types, folder types, and folder columns, see About Folder Columns or 
About Column Types.



For more information about text folders and text columns, see Text Columns.



For more information about number folders and number columns, see Number Columns.



For more information about checkmark folders and checkmark columns, see Checkmark Columns.



For more information about date folders and date columns, see Date Columns.



For more information about pop-up list folders and pop-up list columns, see Pop-up List Columns.



For more information, see Assigning Date Properties.



For more information, see Deleting Folders.



For more information, see Organizing the Folders in the Folder Window.



For more information, see Sharing Folders.



For more information, see Adding an Item to Additional Folders.



For more information, see Removing Items Using the Folder Window.



For more information, see Viewing, Editing, and Deleting Values in Folders.



For more information, see Adding Folders to an Outline View.



For more information, see Adding Folders to an Outline View.



For more information, see Adding Folders to an Outline View.



For more information, see About Folder Columns.



The Shooter menu



The folder options pop-up menu



For more information, see The Shooter: Sending Information to and from Ecco.



For more information, see Sending Information to Ecco.



For more information, see Sending Information to Ecco.



For more information, see Sending Information to Ecco.



For more information, see Sending Information to Ecco.



For more information, see Sending Information to Ecco.



For more information, see Sending Information to Ecco.



For more information, see Sending Information to Ecco.



For more information, see Sending Information Between Non-Ecco Programs.



For more information, see Displaying the Shooter.



For more information, see Displaying the Shooter.



For more information, see Displaying the Shooter.



For more information, see Displaying the Shooter.



For more information, see Displaying the Shooter.



For more information, see Setting Shooter Preferences.



For more information, see Setting Shooter Preferences.



For more information, see Setting Shooter Preferences.



For more information, see Setting Shooter Preferences.



For more information, see Adding Items by Form.



For more information, see Adding Items by Form.



For more information, see The Shooter: Sending Information to and from Ecco.



For more information, see The Date Settings Dialog Box.



For more information, see Using Alarms.



The Alarms menu



For more information, see Canceling an Alarm.



For more information, see Setting Custom Alarms in the Calendar View.



For more information, see Setting Custom Alarms in the Calendar View.



For more information, see Using Recurring Events.



The Recur menu



For more information, see Canceling Recurring Events.



For more information, see Creating Recurring Events.



For more information, see Creating Recurring Events.



For more information, see Creating Recurring Events.



For more information, see Creating Recurring Events.



For a better understanding of folder values, see About Folder Values.



For a better understanding of folder values, see About Folder Values.



For a better understanding of folder values, see About Folder Values.



For a better understanding of folder values, see About Folder Values.



For more information, see Connecting to a Public File.



For more information, see Connection Status.



For more information, see Print.



For more information, see Print.



For more information, see Print.



For more information, see Searching the Active View for Items.



For more information, see Finding and Replacing.



For more information, see About Filters.



For more information, see About Filters.



For more information, see Updating Links.



For more information, see Creating New Outlines.



For more information, see The Choose Outline Folders Dialog Box.



For more information, see About Folders in Outline Views.



For more information, see Managing Outlines.



For more information, see Viewing an Outline.



For more information, see Character Formatting.



For more information, see Outline Styles.



For more information, see Creating Text Touch-Ups.



For more information, see Managing Text Touch-Ups.



For more information, see The New Named Text Touch-Up Dialog Box.



For more information, see Outline Styles.



For more information, see Creating Outline Labels.



For more information, see Outline Labels.



For more information, see The Outline Labels Dialog Box.



For more information, see Setting Simple Alarms.



For more information, see The Alarms Dialog Box.



For more information, see The Manage Named Alarms Dialog Box.



For more information, see Setting Custom Alarms for Any Item.



For more information, see Reviewing Alarms.



For more information, see Managing Named Alarms.



For more information, see The Alarms Dialog Box.



For more information, see Ticklers.



For more information, see Mark as Done.



For more information, see Understanding Folders.



For more information, see Displaying or Hiding the Tool Bar.



For more information, see Preferences.



For more information, see Sorting Items in a View.



For more information, see Creating Filters.



For more information, see The Create a New Filter Dialog Box.



For more information, see Advanced Filters.



For more information, see Managing Filters.



For more information, see The Create a New Filter Dialog Box.



For more information, see Creating a New Outline View.



For more information, see Viewing an Item's Folders.



For more information, see Creating Forms.



For more information, see Apply Form to Items.



For more information, see Managing Multiple Forms.



For more information, see The Create New Form Dialog Box.



For more information, see Sharing Forms.



For more information, see Adding Items by Form.



For more information, see Viewing Items by Form.



For more information, see Applying Forms to Items.



For more information, see Insert Column.



For more information, see The Create New Gantt Column Dialog Box.



For more information, see Width.



For more information, see Creating a To-Do List.



For more information, see Date Columns.



For more information, see Dialing.



For more information, see Printing Values in Columns.



For more information, see Assigning a Type to a Folder.



For more information, see Assigning Date Properties.



For more information, see Adding Items and Values to Folders.



For more information, see About Folder Values.



For more information, see The Shooter: Sending Information to and from Ecco.



For more information, see Introduction to Linking and Embedding.



For more information, see Preferences.



For more information, see Specifying Alarm Actions.



For more information, see Setting Custom Alarms in the Calendar View.



For more information, see Creating Recurring Events.



For more information, see Creating a Gantt Column.



For more information, see Exporting from an Outline View.



For more information, see Exporting from the PhoneBook View.



For more information, see Printing an Outline.



For more information, see Printing Your Schedule.



For more information, see Printing Your PhoneBook Entries.



For more information, see What is a Public File?



For more information, see Printing Your PhoneBook Entries.



For more information, see Print Outline View Dialog Box.



For more information, see Print Outline View Dialog Box.



For more information, see Print Outline View Dialog Box.



For more information, see The Export Outline and Columns Dialog Box.



For more information, see The Choose Columns for Import Fields Dialog Box.



For more information, see The Choose Column Set Dialog Box.



For more information, see The Choose Field Set Dialog Box.



For more information, see The Calendar Print Options Dialog Box.



Keyboard Shortcuts

Click a book to display the corresponding shortcut keys.
            The File Menu  
            The Edit Menu  
            The Format Menu  
            The Item Menu  
            Paragraphs and Tabs  
            Outline Style Formatting  
            The Calendar View  
            The PhoneBook View  
            The Tool Bar  
            Moving the Cursor  
            Working with Windows  



File Menu
To choose Press

Open new file 
without templates

SHIFT + New 
or CTRL + New

Open CTRL + O

Save CTRL + S

Print CTRL + P

Exit ALT + X

Edit Menu
To choose Press

Undo CTRL + Z

Cut CTRL + X

Copy CTRL + C

Paste CTRL + V

Delete Items CTRL + D

Find CTRL + F

Find Next CTRL + N

Insert new line SHIFT + ENTER

Insert tab CTRL + T

Format Menu
To choose Press

Character CTRL + K

Plain style CTRL + SPACEBAR



Bold style CTRL + B

Italic style CTRL + I

Underline style CTRL + U

Outline styles CTRL + Y

Outlining
To choose Press

Add item CTRL + ENTER

Add item right CTRL + R

Add item left CTRL + L

Show levels dialog box CTRL + W

Show levels CTRL + 1...9

Collapse (hide) sub 
items

CTRL + H

Expand sub items CTRL + E

Mark item as done CTRL + M

Move items right TAB 
or ALT + RIGHT ARROW

Move items left SHIFT + TAB 
or ALT + LEFT ARROW

Move items up ALT + UP ARROW

Move items down ALT + DOWN ARROW

Show all sub-items CTRL + G
or ALT + double-click

Show one level of sub-
items

CTRL + J
or CTRL + double-click

Begin a new line in the
same item

SHIFT + ENTER

Paragraphs and Tabs



To choose Press

Begin a new line in 
the same cell of a 
text column

SHIFT + ENTER

Insert a tab in an 
item

CTRL + T

Outline Style Formatting
Result Press

Apply any Format menu 
command or tool bar button 
to the outline style for 
currently selected levels

Press CTRL while 
choosing the 
command or button

The Calendar View
To choose Press

Add outline note ENTER

Open appointment edit
box for Calendar items

F2

Go to specified date F4

Go to previous year F5

Go to next year F6

Go to previous month F7

Go to next month F8

Go to previous day F9

Go to next day F10

Toggle between 
columns

F11

Toggle ticklers and 
appointments

F12

Toggle graphical views SHIFT + F10



Go to today ALT + G

Add outline note CRTL + R

The PhoneBook View
To choose Press

Use PhoneBook data 
entry form

F2

New PhoneBook entry F3

Search ALT + S

Search for next ALT + N

Add outline note CRTL + R

The Tool Bar

The repeat box (at top right of the tool bar) holds a history of recent menu choices.    Use the right mouse 
button to drag icons to the tool bar.

Result Press
Show or hide tool bar Click button on status

bar (left of date and 
time)

Move tool bar icons Click right mouse 
button and drag

Insert or remove 
spaces between icons

SHIFT + click right 
mouse button

Move tool bar icon 
groups

CTRL + click right 
mouse button

Moving the Cursor

You can extend your selection by holding down the SHIFT key with any of the following key combinations.

To choose Press

One character LEFT ARROW 
or RIGHT ARROW



One word CTRL + LEFT ARROW 
or RIGHT ARROW

End of line END

Beginning of line HOME

Beginning of previous 
line

HOME, HOME

End of next line END, END

Beginning of view CTRL + HOME

End of view CTRL + END

Working with Windows
To choose Press

Switch to left or right 
pane

F11

Switch to top or bottom
pane

F12

Next window CTRL + F6

Close window CTRL + F4

Scroll to top of view CTRL + HOME

Scroll to bottom of 
view

CTRL + END



Alarm Error

Explanation: In order to play a sound to accompany your alarm, you must have installed a sound card on
your computer, or software that allows you to use your computer's speaker to play sounds.    A sound 
driver capable of playing waveform (.WAV) audio files comes with the sound card or the software.    You 
must also specify an existing .WAV file.    

Action: Check the installation of the sound driver and ensure that your .WAV file has not been corrupted.  
Then enter the file name again in the Alarm dialog box.



Can't Play Sound 

Explanation: In order to play a sound to accompany your alarm, you must have installed a sound card on
your computer, or software that allows you to use your computer's speaker to play sounds.    A sound 
driver capable of playing waveform (.WAV) audio files comes with the sound card or the software.    You 
must also specify an existing .WAV file.    

Action: Check the installation of the sound driver and ensure that your .WAV file has not been corrupted.  
Then enter the file name again in the Alarm dialog box.



Choose File for Alarms 

Explanation: All of your Ecco alarms are stored in one database.    This message warns you that the 
second file you are creating by choosing the Save As command will create a duplicate of the alarm in the 
first file.

Action: You have the following choices:

To move the alarm to the new file, choose the New File button.
To leave the alarm in the file in which it was originally created, choose the Old File button.
To keep the alarm in both files, choose the Cancel button.
To cancel the alert without saving the new file, from the system menu, choose Close.



Appointment Conflict

Explanation: This message warns you that your recurring appointment conflicts with holidays/weekends. 
The holidays it conflicts with are listed in the list box.    

Action: This message is only for your information.    Ecco does not prevent you from scheduling 
appointments on holidays or weekends.



Delete Recurring Events

Explanation: The item you are attempting to delete is a recurring event.    You have previously added this 
item to folders other than the Appointment folder.    

Action: You have three options:

Choose "Delete all recurrences" to delete all recurrences of the event from the Appointment 
section without deleting the item from other folders or views.

Choose "Delete selected recurrences only" to delete the selected recurrences of the event from 
the Appointment section without deleting other recurrences, and without deleting the item from other 
folders or views.

Choose "Delete entirely from file (all Views)" to delete the item from all folders and views.



Context Parents

Explanation: This message is for your information only.    It appears when you add a sub-item, but not its 
parent item, to a folder in addition to the one in which it was originally entered.    

Action: If you understand the concept of context parents, check the option, "Don't display this message 
again."



Cut Recurring Events

Explanation: You are attempting to cut an instance of a recurring event.    

Action: Select an option indicating whether you want to cut only the selected occurrence of the event or 
all occurrences of the event and then choose the OK button.    If you want to change the date or time 
rather than cut the event, choose the Cancel button.    Then use the Date Settings dialog box to change 
the date or time, either for a single occurrence or for all occurrences of the event.



Delete Column

Explanation: This is a warning that the values entered in the column you are about to remove will be 
deleted along with the column.    The items that have values in the column will continue to exist, but the 
values will be discarded.

Action: Choose OK to delete the column and the values displayed in the column, or choose Cancel to 
avoid deleting the column and values.



Context Parents

Explanation: This message is for your information only.    It appears when you apply a filter whose criteria
are met by sub-items, but not parent items.    

Action: If you understand the concept of context parents, check the option, "Don't display this message 
again." Then choose the OK button.



New Column

Explanation: You are attempting to make the selected column public but the network is not available.

Action: To make the column public, first establish an open connection to network location of the public 
file, and then use the Make Public command from the View menu.



Publish OLE Links

Explanation: You are making a view or a column public that contains OLE links, as shown in the list box.  

Action: Make sure the files in the list box can be accessed by the other members of your workgroup so 
that they can edit the files when necessary.    To do this, change the directory of the linked files to a 
network directory.    Then, in Ecco, choose the OLE Links command from the Edit menu.    In the Links 
dialog box, choose Change Links and change the the directory to the network directory.



New Column

Explanation: When you insert a new column in a public view, Ecco allows you to choose whether to 
make that column public or private.

Action: Choose the Private button to keep the column private.    Choose Public to make the column 
public.    If you choose private you can later make the column public by choosing the Make Public 
command from the Column menu.



For more information about alarms, see Specifying Alarm Actions.



For more information about alarms, see Specifying Alarm Actions.



For more information about alarms, see Specifying Alarm Actions.



For more information about Alarms, see Using Alarms.



For more information about changing recurring events, see Changing Recurring Events.



For more information, see Scheduling New Appointments.



For more information, see Creating Recurring Events.



For more information, see Creating Recurring Events.



For more information, see Scheduling Appointments Using the PhoneBook.



For more information, see Using the PhoneBook with the Calendar.



For more information, see Canceling Recurring Events.



For more information, see Canceling Recurring Events.



For more information, see Changing Recurring Events.



For more information, see Deleting Folders.



For more information, see Removing Folders from an Outline View.



For more information, see Deleting Items.



For more information, see Deleting Items.



For more information about context parents, see Understanding Context Parents.



For more information, see Removing Items from Folders.



For more information, see Deleting Items.



For more information, see Deleting Items.



For more information, see Deleting Items.



For more information, see Deleting Items.



For more information, see Canceling Recurring Events.



For more information, see Deleting or Removing Columns.



For more information about filters, see Applying Filters.    For more information about context parents, see 
Understanding Context Parents.



For more information about filters, see Advanced Filters.



For more information, see Importing and Exporting.



For more information, see Importing and Exporting.



For more information, see Importing and Exporting.



For more information, see Launching Other Programs from Ecco.



For more information, see Sharing Columns.



For more information about changing links, see Changing Links.



For more information about sharing columns, see Sharing Columns.



Active view
Add
Advanced features
Advanced menu
Alarm
Alert box
Alignment
Appointment
Appointment section
Attribute
Busybar
Busybar block
Calendar view
Calendar/PhoneBook button
Call logger 
Cascading menu
Checkmark column or folder
Close box button
Collapse
Column
Column grid
Column heading
Column menu
Column pane
Comma-separated values
Context parent
CSV
Cumulative label
Date column or folder
Date Settings dialog box
Day, Week, and Month buttons
Ecco for Workgroups
Embed
ENT (Enter) button
ESC (Escape) button 
Event
Export
Filter
Folder
Folder button 
Folder column
Folder options pop-up menu
Folder value
Folder window
Form
Gantt column
Group meeting
Home folder
Import
Item
Item bullet
Label
Letter tab
Level



Link
Make Public
Margin line
Minimized column
Multiple-folder column
Navigator
Number column or folder
OLE link
OLE object
Outline label
Outline note
Outline style
Outline view
Parent item
Phone dialer
PhoneBook entry form
PhoneBook view
Pop-up list column or folder
Public
Public file
Recurring event
Repeat box
Scratch column
Search Results view
Share bar
Shooter
Status bar
Status column
Subfolder
Sub-item 
Telephone button
Template
Text column or folder
Text touch-up
Tickler item
Tickler section
Tool bar
Top-level item
Value
Value edit box
View
Workgroup
Zoom button 



Active view
The Ecco view in which the next action will occur.    The active view's title bar is highlighted.    



Add
To collect like items together by dragging them into folders, thereby adding them to the folders.    When 
you drag an item from any view into a folder in the Folder window, the item remains in the original view as
well.



Advanced features
Features of Ecco Professional that allow you to collect and cross-reference items in folders and to 
accomplish other advanced management tasks.

To use the advanced features of Ecco Professional, from the Tools menu, choose Show Full Menus.



Advanced menu
Allows you to use advanced features of Ecco Professional.    To display this menu, from the Tools menu, 
choose Show Full Menus.    Ecco Professional will display the Advanced menu on the menu bar and the 
Column menu in each view.



Alarm

An Ecco feature that lets you display a message or trigger an action associated with an event. You can 
set an alarm to go off at the time of the event; minutes, hours, days, or weeks before or after the event; or
any combination of those settings.    You can also set alarms to display dialog messages, play sounds, 
and launch documents or batch files.    



Alert box
A warning that you're trying to do something Ecco can't do, or that you're about to delete information from 
your Ecco file.



Alignment
The horizontal arrangement of text within the width of a column. You can align information in columns by 
centering, left-aligning, or right-aligning it.    



Appointment
An item you type into the Appointments section of the Calendar view. Other items that are associated with
a time value are also appointments and appear in the Appointments section.    



Appointment section
The area of the Calendar view in which you schedule, view, and edit appointments. 



Attribute
A formatting characteristic applied to text.    Character style, such as bold or italic; font, such as Helvetica 
or Times Roman; point size; and color are all examples of formatting attributes.



Busybar
The vertical bar at the far left side of the Calendar view window that shows you at a glance your 
scheduled appointments. Use the Busybar to change the time and duration of appointments.    See also 
Busybar block. 



Busybar block

The block in the Busybar that shows the time and the duration of each scheduled appointment. You can 
drag a Busybar block to change the time and duration of an appointment.



Calendar view
In the Calendar view you can schedule appointments, remind yourself of upcoming meetings, set alarms, 
and add tickler items for important engagements.    If you're using the workgroup version of Ecco (Ecco for
Workgroups), you can schedule group meetings. 



Calendar/PhoneBook button

The button in the upper right corner of both the PhoneBook view and the Calendar view that you choose 
to display the two views side-by-side.    Drag any name from the PhoneBook to any day or time in the 
Calendar to automatically make an appointment.    



Call logger 
A PhoneBook view feature that logs the time, date, and duration of your calls and stores the information in
the Phone Log column.  See also Telephone button. 



Cascading menu
A menu that opens from another menu when you choose a command.



Checkmark column or folder

A type of column or folder that displays checkmark values.    For example, you might use a checkmark 
column to mark an item as personal.    A checkmark folder is the default folder type.    



Close box button

The button in the upper left corner of the Folder window and the PhoneBook entry form that you choose 
to close the window or entry form.



Collapse
To hide an item's sub-items. Do this by double-clicking an item bullet, or by choosing Show Sub-Items 
from the Item menu and then choosing Hide.    



Column
A spreadsheet-style display that contains specific information about items. Column values can be text, 
numbers, checkmarks, dates,  pop-up lists, or Gantt charts.

A column with a heading can be displayed in any Ecco view, and can display folder values associated 
with a folder of the same name.    Columns without headings appear only in the view in which they were 
created.    



Column grid
The set of lines separating columns and rows in the Column pane that make it easier to read your 
information.    You can display and hide the column grid by choosing the Display command, and then 
choosing Column Grid from the Tools menu.



Column heading
The name you assign to a column by choosing the Heading command on the Column menu. When you 
assign a heading to a column, Ecco automatically makes the column into a new folder (with the same 
name) and adds it to the list of folders in the Folder window under the "New Columns" folder.    You can 
insert a named column into another view by dragging its folder into the Column pane of that view.    



Column menu
The menu that allows you to use the advanced column features of Ecco Professional.    To display this 
menu, from the Tools menu, choose Show Full Menus.    Ecco Professional will display the Column menu 
in each view and the Advanced menu on the menu bar.    



Column pane
An area of each view in which you can display specific information about items. You can create columns 
that display text, numbers, checkmarks, dates, Gantt charts, and folder values. 



Comma-separated values
A text file format that includes columnar data surrounded by quotation marks and separated by commas, 
for example: "James Monroe", "212-555-6423", "1234 Any Street".



Context parent

Green-shaded items that would not ordinally appear in a particular outline view, but are included to 
provide context.    



CSV
See Comma separated values.



Cumulative label

A series of numbers and letters to the left of an item in an outline view. For example, a cumulative fourth-
level outline label might display "1.A.1.a." whereas a non-cumulative fourth-level label would display only 
"a." Used primarily to track item levels in long documents.    



Date column or folder
A type of column or folder that lets you associate a date with each item you add to the folder.    When you 
enter a date into a date column, you are both supplying a date for the item on the corresponding line and 
adding that item to the folder whose name appears as the heading of that column.    Unless you specify 
otherwise, items with dates appear in the Tickler section of the Calendar view.    



Date Settings dialog box

The dialog box in which you can change the time and date of appointments. as well as set tickler item 
options, alarms, and recurring events. If you are using Ecco for Workgroups, you can schedule group 
meetings.    To display the Date Settings dialog box when the Calendar view is active, click an existing 
appointment time.    



Day, Week, and Month buttons

Buttons at the far left of the Navigator that, when clicked, switch you between day, week, and month 
displays of your schedule.    Located in the Calendar view. 



Ecco for Workgroups
A workgroup version of Ecco that provides group scheduling and Calendar sharing.    Both Ecco 
Professional and Ecco for Workgroups provide multiuser outlining for activity management.    Ecco for 
Workgroups can be purchased separately.



Embed
See OLE object.



ENT (Enter) button

A button that, when chosen, enters the specified action and closes the value edit box.



ESC (Escape) button 

Button that, when chosen, cancels the specified action and closes the value edit box.



Event
An appointment, group meeting, or item that has a date associated with it.    You can set alarms for events
or set an event to recur at specified intervals.    



Export
To save the active view as a file for use in other programs.    



Filter
An advanced feature of Ecco Professional that limits the items displayed in a view according to user-
definable column (or folder) criteria.    For example, if you created a column titled "Priority," you could use 
a filter to display in the view only the items with a priority of "high." 



Folder

Folders are containers of items used to collect and cross-reference related items.    Whenever you create 
items in any of Ecco's views, you are actually adding them to a folder.    For example, when you create an 
appointment in the Calendar, Ecco automatically adds that appointment item to a folder named 
"Appointments." Similarly, whenever you add a name to your PhoneBook, Ecco automatically adds that 
name to the PhoneBook folder.

You can also drag any item to any number of additional folders in the Folder window. When you 
do so, the item remains in its original location as well.

You can see the items in any folder by dragging it into any outline view.    



Folder button 

A button to the left of a folder in the Folder window that, when chosen, displays the folder options pop-up 
menu.    Using this menu, you can add selected items to folders, remove selected items from folders, see 
or edit folder values associated with selected items, show a folder in an outline view, or insert a folder into
a column. A checkmark on a folder button indicates that the selected items in the active view have been 
added to the corresponding folder.    



Folder column
A folder column is a column associated with a folder (that is, its heading appears as the name of a folder 
in the folder window).    Use folder columns to:

See which items in the view are in a particular folder.
Display any column in multiple views.

 



Folder options pop-up menu
Using this menu, you can add selected items to folders, remove selected items from folders, see or edit 
folder values associated with selected items, show a folder in an outline view, or insert a folder into a 
column. 



Folder value
A folder can store a value with each item it contains.    A folder value gives you a way to associate an 
additional piece of information with each item.    Because an item can be added to many different folders, 
each item can have many different values associated with it.    This is analogous to the many different 
column values that can be associated with each item in a view. 



Folder window
A window on the right side of the main Ecco window that displays your folders. Use the Folder window to:

Add new folders.
Edit existing folders.
View folder types.
Change folder preferences.
Add items to folders.
Remove items from folders.
Choose folders whose items you want displayed in an outline view.
Insert a folder into a column.



Form
A set of folders or columns and corresponding values. By applying a form to an item, you can include the 
item in several folders at once and associate a value with it in each column.    



Gantt column
A column type.    Lets you create Gantt charts in any column in any view. Gantt charts are bar charts that 
display task or project start and finish dates and durations.    



Group meeting

Available only in Ecco for Workgroups.

An appointment that involves several workgroup users.    Ecco shows you when workgroup users have 
appointments scheduled and when they have free time, allowing you to schedule group meetings.    



Home folder
The folder in which an item originated.    For example, the home folder for an item first entered in the 
PhoneBook view is the PhoneBook folder.    You can display home folders in the Column pane.



Import
To bring a tab-separated file or CSV (comma separated values) file from another program into Ecco.    You
import into the active view. 



Item
The primary unit of information in Ecco.    Each item is a distinct element and has a blue item bullet to its 
left.    Items can have values (dates, numbers, and text) associated with them and may have parent items 
or sub-items, which are themselves items.



Item bullet

The icon at the left of an item that can be used like a handle to move the item up, down, left, or right.    
Double-clicking an item bullet expands or hides the item's sub-items. A black triangle at the lower right 
corner of an item bullet indicates the item is collapsed and its sub-items are hidden.



Label
See outline label.



Letter tab

The letters on the left side of the PhoneBook view window.    You choose a letter tab to display all items 
beginning with that letter.    



Level
The relative horizontal position of an item in an outline.



Link
See OLE link.



Make Public
An option that, when chosen, makes an folder, column, or form available for use by others in a workgroup.
This option is available only if you've previously connected to an Ecco public file. 



Margin line
The vertical line that forms the right margin for the items in each view. You can use the handle at the top 
of the right side of the margin line to change the word-wrap and right margin for each view.    



Minimized column
A column that has been narrowed.    Minimized columns let you view more columns at once or hide the 
information in columns you don't currently need to see.    You can skip (choose not to print) minimized 
columns when you issue a print command.    To minimize or restore a column, double-click the heading or 
letter at the top of the column.    



Multiple-folder column

A folder column that displays in each cell a group of folders to which the item on the corresponding line 
has been added.    These folders must be subfolders of the folder whose name appears in the column 
heading.    



Navigator
A control in the Calendar view that lets you move forward and backward by month, day, or year.    



Number column or folder
A type of column or folder that lets you associate a number with each item. A number column can be used
to display a number value for each item in a view. 



OLE link
A dynamic link between the data in an Ecco file and a file that contains the same data in another program.
Changes to the file in the other program are reflected in the data linked to it (the data in the Ecco file).    If 
the Ecco file is open, the data in the Ecco file is automatically updated.    If the Ecco file is closed, the next
time you open it, you will be asked whether you want to update the linked data.    



OLE object
An embedded object in an Ecco file.    Double-click an embedded object to open the program in which the 
object was originally created.    You can thereby edit or make changes to the object without leaving Ecco 
or affecting the original source file.    



Outline label
The number or letter to the left of an item bullet in an outline view. 



Outline note
An outline item added to a PhoneBook entry or Calendar item.    To create an outline note, select the item 
for which you want to create an outline note, and then press the ENTER key.    Press ENTER again to create 
more notes.    Use the TAB key to indent items and SHIFT+TAB to promote them.    Double-click any item 
bullet to collapse or expand an item's sub-items.    



Outline style
A set of character-formatting attributes that apply to a particular level of item in a view.    Using different 
outline styles for each level makes it easier to differentiate between your outline levels.    



Outline view
A window showing one or more folders and the items in them.    Each item in an outline can be 
repositioned to a different level of indentation to express major and minor points.    Items can be expanded
or collapsed to hide subordinate levels.    



Parent item
An item that has another item subordinate to it.    The subordinate item is called a sub-item.



Phone dialer
A PhoneBook view feature that dials a phone number for you.     See also Telephone button. 



PhoneBook entry form
An entry form in the PhoneBook view in which you add new or modify existing PhoneBook items. 



PhoneBook view
Use the PhoneBook view to store phone numbers, addresses, and other information about your friends, 
clients, business contacts, and others.    



Pop-up list column or folder

A type of column or folder that lets you associate user-defined values with each item. For example, a pop-
up list for a column or folder titled "Priority" might include the values "High," "Medium," and "Low." When 
you select a cell in the "Priority" column, you can quickly associate the degree of priority with the item on 
the corresponding line.    



Public
A term describing a file, outline view, folder, column, or form that has been made accessible to others in a 
workgroup. See also Make Public. 



Public file
An Ecco file (with the file extension .ECG) that allows workgroup users to share information over the 
network.    



Recurring event

An event that occurs at regular intervals.    For example, if you have staff meetings every Wednesday 
morning, you could set a recurring event in the Calendar view so that Ecco schedules your meetings on 
Wednesday of each week.    You can also make alarms and to-do's recurring.    



Repeat box

The box in the upper right corner of the Ecco program window when the tool bar is displayed that displays
the icon representing the command last chosen.    You can repeat a command by clicking the icon with the
left mouse button.    You can customize your tool bar by clicking the icon in the repeat box with the right 
mouse button and dragging the icon onto the tool bar.    



Scratch column
A column without a heading.    Columns without headings are designated A through AX until given a 
heading.    Unlike folder columns (columns with headings), scratch columns appear only in the view in 
which they are created.    Scratch columns can be of the following type: text, number, pop-up list, and 
Gantt. See also column heading. 



Search Results view
The Ecco view that displays the results of a search.    



Share bar
The blue bar above an item bullet or inside a folder icon that indicates the item or folder has been made 
public.    



Shooter

A tool that sends information from other programs to Ecco, from Ecco to other programs, or between two 
other programs.    Using the Shooter, you can insert, link, and embed objects and selected information 
from other programs to or in Ecco views or folders, from Ecco views to other programs, or between other 
programs.    Click the Shooter icon to display its menu.    



Status bar
The bar at the bottom of the Ecco program window that displays the date, the time, and messages to help
you use Ecco, such as information about the selected command.    



Status column
The column in the Calendar view that lies between the Busybar and the Calendar items. It shows whether
an appointment is recurring and whether an alarm or group meeting has been set.    



Subfolder
A folder that is subordinate to another folder in the Folder window. In other words, a folder that is below 
and to the right of another folder.    



Sub-item 
An item that is subordinate to another item.    In other words, an item below and to the right of another 
item.    See also parent item.



Telephone button

A button located in the PhoneBook view tool bar that, when chosen, displays the Dialer/Call Logger dialog
box.    



Template
A preformatted Ecco file that may contain folders, columns, forms, and filters to help you become 
productive quickly.    Ecco comes with a variety of templates to help you get started.    Templates have the 
file extension .ECT.    



Text column or folder
A type of column or folder that lets you enter or display text for each item in a view. Using a text column, 
you can associate additional text, or notes, with each item.    



Text touch-up
A group of character-formatting attributes that you name and store.    Apply text touch-ups to a range of 
selected text to override outline styles. 



Tickler item

A note, reminder, or appointment displayed in the Tickler section of the Calendar view that "tickles," or 
jogs, your memory.    



Tickler section
Area of the Calendar view in which reminders that "tickle" your memory tasks you need to do or 
upcoming appointments you need to prepare for

are displayed.    



Tool bar
An Ecco feature that gives you quick access to frequently used commands.    The tool bar can be 
displayed across the upper part of the Ecco program window, Ecco views, and the Shooter. 



Top-level item
An item located at the highest (left-most) level of an outline.    When you type top-level items in an outline 
view, they are automatically added to the folder.



Value
A number, date, or additional text associated with an item. You can associate any number of values with 
an item by entering those values into any number of columns. 



Value edit box

A pop-up box in which you enter or edit text, numbers, dates, appointments, and pop-up list values. The 
value you enter is associated with the selected item or items.    



View
A window displaying the Calendar, the PhoneBook, or an entire outline.    Every Ecco file contains a 
Calendar view, a PhoneBook, and any number of named outline views. 



Workgroup
A group of people whose computers are connected by a network.    



Zoom button 

The small arrows in the corner of each section of the view. Clicking the zoom button instantly expands the
section to its maximum size while hiding the adjacent section.    Clicking it again restores the sections to 
their original state.    Zoom buttons are available only if you are using the advanced features of Ecco 
Professional.    



For more information about views, see Ecco Views.



For more information, see Using Alarms.



For more information, see Customizing a Column's Display.



For more information, see Creating and Managing Appointments.



For more information, see The Calendar View Window.



For more information, see The Calendar View Window.



For more information, see The Calendar View Window.



For more information, see The Calendar View Window.



For more information, see The Dialer/Call Logger Dialog Box.



For more information, see Checkmark Columns.



For more information, see Viewing an Outline.



For more information, see Introduction to Columns.



For more information, see Adding or Changing Column Headings.



For more information, see Introduction to Columns.



For more information, see The Column Pane.



For more information, see Understanding Context Parents.



For more information, see About Outline Labels.



For more information, see Date Columns.



For more information, see The Date Settings Dialog Box.



For more information, see Displaying Your Schedule by Day, Week, or Month.



For more information, see Importing and Exporting.



For more information, see About Filters.



For a complete understanding of folders, see Understanding Folders.



For more information about folder columns, see About Folder Columns.



For more information, see Folder Options Pop-up Menu Overview.



For a complete understanding of folder values, see About Folder Values.



For more information, see The Folder Window.



For more information, see About Forms.



For more information, see Using Gantt Columns.



For more information, see Importing to the PhoneBook and Importing to Other Ecco Views.



For more information, see Finding PhoneBook Information.



For more information, see Sharing Views, Columns, Folders, and Forms.



For more information, see The Ecco Program Window.



For more information, see Adjusting the Column Pane Display.



For more information, see Displaying Multiple Folder Values in a Column and Editing Multiple Folder 
Values in a Column.



For more information, see Using the Navigator to Move to a Date.



For more information, see Number Columns.



For more information, see Linking and Embedding OLE Objects.



For more information, see Linking and Embedding OLE Objects.



For more information, see Labeling an Outline.



For more information, see Adding Outline Notes to an Appointment or Adding Outline Notes to an Entry.



For more information, see Outline Styles.



For more information, see The Outline View Window.



For more information, see Dialing.



For more information, see The PhoneBook View Window.



For more information, see The PhoneBook View Window.



For more information, see Pop-up List Columns.



For more information, see What is a Public File? and Introduction to Sharing.



For more information, see What is a Public File?



For more information, see Using Recurring Events.



For more information, see Adding Buttons to the Tool Bar on the Fly.



For more information about scratch columns, see About Column Types.



For more information, see Using the Search Results View.



For more information, see Introduction to Sharing.



For more information, see Introduction to the Shooter.



For more information, see The Ecco Program Window.



For more information, see The Calendar View Window.



For more information, see The Dialer/Call Logger Dialog Box.



For more information, see Opening a File.



For more information, see Text Columns.



For more information, see About Text Touch-Ups.



For more information, see Introduction to Ticklers.



For more information, see The Calendar View Window.



For more information, see The Tool Bar.



For more information, see Introduction to Columns and Values.



For more information, see Editing and Deleting Values in Columns.



For more information, see Ecco Views.



For more information, see About Workgroup Computing.



For more information, see The Ecco Program Window (with Full Menus).




